Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 20:51
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to change network proxy settings in Puppy and Chrome?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
rameshiyer

Joined: 17 Sep 2009
Posts: 231
Location: Calicut, Kerala, India

PostPosted: Tue 10 Nov 2009, 06:17    Post subject:  How to change network proxy settings in Puppy and Chrome?  

I am getting internet connection through http proxy. Due to this, I am not able to install additional packages through Puppy Package Manager. PPM is working only Direct access to Internet/ISP. Also I have managed to install Google Chrome. In which Change Proxy setting is not possible. While trying to set up Proxy setting in Google Chrome Browser, I am getting following message.
http://code.google.com/p/chromium/wiki/LinuxProxyConfig.
How to set up "http proxy "in Puppy as well as in Google Chrome Browser
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger 
aragon

Joined: 15 Oct 2007
Posts: 1696
Location: Germany

PostPosted: Tue 10 Nov 2009, 07:04    Post subject: Re: Network Proxy Setting
Subject description: HTTP Proxy setting
 

rameshiyer,

please try the following in this order, because i think you don't need part 2 in this way round.

Quote:
Also I have managed to install Google Chrome. In which Change Proxy setting is not possible. While trying to set up Proxy setting in Google Chrome Browser, I am getting following message.
http://code.google.com/p/chromium/wiki/LinuxProxyConfig.
How to set up "http proxy "in Puppy as well as in Google Chrome Browser

open the file
Code:
/etc/rc.d/rc.local

and add the lines
Code:
export http_proxy="YOUR_PROXY"
export HTTP_PROXY="YOUR_PROXY"
export https_proxy="YOUR_PROXY"
export HTTPS_PROXY="YOUR_PROXY"

save the file and reboot. with
Code:
echo $http_proxy

and so on you could check from within a terminal, if the variables are now setup correctly. Chrome should now work. please also test ppm at this stage. in my opinion it also should work now (it's from memory, i'm not in puppy right now).

only if ppm still doesn't work do the following.

rameshiyer wrote:
I am getting internet connection through http proxy. Due to this, I am not able to install additional packages through Puppy Package Manager. PPM is working only Direct access to Internet/ISP.

ppm uses wget to download the files. to configure wget for your proxy there are 2 possibilities:
a) change default settings
/etc/wgetrc is the default-rc-file. open it in a editor. there are two points to change (and activate), the proxy-adress and use_proxy (please simple search for them). be aware to also delete the '#'. save the file. you should now be able to install directly with ppm.
b) setup user settings
copy the file /etc/wgetrc to /root and rename it to .wgetrc. after that apply the same settings as in a).

if you have problems, please post.

aragon

_________________
PUPPY SEARCH: http://wellminded.com/puppy/pupsearch.html
Back to top
View user's profile Send private message 
rameshiyer

Joined: 17 Sep 2009
Posts: 231
Location: Calicut, Kerala, India

PostPosted: Wed 11 Nov 2009, 04:41    Post subject: Proxy Settings in Puppy
Subject description: Puppy Packet Manager & Chrome
 

Dear Aragon

Thank you for the help. I am glad to inform you that now I am able to install from Puppy Package Manager after providing Http Proxy setting and User name and Password in /etc/wgetrc. However, I am still not able to browse Google Chrome and not able to access the Network Proxy setting in Google Chrome (option - under the hood of chrome). I also provided the proxy setting in /etc/rc.d/rc.local. However, PPM starts working only after adding Http Proxy setting in etc/wgetrc file. ( my Puppy works in Full Hard Disk -sda8 - with Grub Boot ) . My pending problem - how to browse through Google Chrome or enable Proxy setting in Google Chrome.
Looking forward further help
Thanking you once again.
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger 
aragon

Joined: 15 Oct 2007
Posts: 1696
Location: Germany

PostPosted: Wed 11 Nov 2009, 08:13    Post subject:  

rameshiyer
i've just tested it, for me http_proxy works with chrome, but i don't need username/password for my proxy.

are you shure, you entered your data in the correct way? in my oppinion this should be
Quote:
http://user:password@server:port


to test it open a terminal and do

Code:
export http_proxy="http://user:password@server:port"

with your setting. then start chrome from this terminal. with a little trial and error you might get the correct syntax.

with that you should be able to setup as in my first post.

or you could simply write al little wrapper-script to start chrome. example:

Code:
#!/bin/sh
export http_proxy="http://Proxy:80" #Fill in your data
export https_proxy="http://Proxy:80" #Fill in your data
google-chrome #or whatever the startcommand for your package is
exit


save this in your path e.g. in /usr/local/bin as start-chrome, make it executable. if you start it with start-chrome now, it should work.

aragon

_________________
PUPPY SEARCH: http://wellminded.com/puppy/pupsearch.html
Back to top
View user's profile Send private message 
rameshiyer

Joined: 17 Sep 2009
Posts: 231
Location: Calicut, Kerala, India

PostPosted: Thu 12 Nov 2009, 06:36    Post subject: HTTP Proxy Setting
Subject description: Now Google Chrome Works through Batch File execution
 

Thank you for the continued support for solving my problem. In this regard, you may please note that though I am not a programmer, I managed to put the Google Chrome into working condition as per your guidance and suggestion. I have provided following commands in Console/terminal as detailed by you :-export http_proxy :”http://200.200.200.5:6588”export https_proxy:http://200.200.200.5:6588”then typed google-chrome. At this stage, Google chrome Browser started and while entering the website address, the authroisation for Proxy came up, I have entered the user name and password for proxy. To my surprise, I was able to browse through Google Chrome without any other problem! Thank you very much. I feel Google chrome is faster than others in Puppy Linux. It even supports local language site without any problem. I browsed many local language newspaper site, it provides lightning fast access!!. As per your suggestion, I have created a file and made executable and put on Desktop and set Icon of Google Chrome. It works when clicking Icon. !! Credit goes to U, Sir.However, from academic point, I would like to point out to you one problem which is still not solved in Google Chrome ie. Built in Proxy setting in Google Chrome ( option – under the hood). It is not necessary to me because I am now able to use Chrome. It may be due to some built it problem of Google Chrome ? Puppy Package ManagerAs per your guidance, I have edited the wgetrc file as follows :

http_proxy = http://200.200.200.5:6588
ftp_proxy = http://200.200.200.5:6588
Proxy_user = xxx
Proxy-passwd = xxxxxx

After saving this setting , I was able to update and install the new software through Puppy Package Manager. !!!. However, this has not solved the problem of Google Chrome mentioned in earlier occasion.
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger 
Skipper

Joined: 22 Apr 2007
Posts: 23

PostPosted: Wed 07 Dec 2011, 19:09    Post subject:  

A little thing: it is not "Proxy-passwd" but "proxy_password".
And "proxy_user", without uppercase.

In my case, even using the last builtin proxy manager of Lucid Puppy, and without it, I'm unable to authenticate for the proxy. Error 407. May be a proxy's configuration?
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Thu 08 Dec 2011, 06:20    Post subject:  

What Puppy are you using?

Recent puppies have /usr/local/simple_network_setup/proxy-setup, which is launched via a button in the Internet Connection Wizard (click 'connect' icon on desktop).

This includes Wary, Racy, Slacko, many others.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Skipper

Joined: 22 Apr 2007
Posts: 23

PostPosted: Mon 12 Dec 2011, 16:19    Post subject:  

BarryK wrote:
What Puppy are you using?

Recent puppies have /usr/local/simple_network_setup/proxy-setup, which is launched via a button in the Internet Connection Wizard (click 'connect' icon on desktop).

This includes Wary, Racy, Slacko, many others.

Nice to read you, Barry! Genius!

Lupu-528.

I remembered that even on a Windows machine, I was unable to connect mplayer or any other console application, trough the proxy. It seems that some setups on the proxy's side is allowing only browsers to connect to the internet.

So, modify "/usr/local/bin/defaultbrowser" did the trick. Just like this:
Code:
exec iron --proxy-server=nvisacc:8080 "$@"

And Iron ask for user and password, and connects!

Sorry for the lost of time, but may be also you are suffering like me because of an irremediable proxy restriction.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0638s ][ Queries: 12 (0.0044s) ][ GZIP on ]