Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 28 Aug 2014, 23:31
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Where is the wpa supplicant?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
davidknibb

Joined: 03 Aug 2006
Posts: 22

PostPosted: Mon 07 Aug 2006, 15:16    Post subject:  Where is the wpa supplicant?  

Puppy 2.02
Hard Disk Install
HP XE2 machine

Another question that will no doubt make me blush with shame when I see the answer.
I'm trying to get WPA to work with my network card.

Now it works fine if I turn off encryption from the router, and also with WEP encryption.

But it seems that to get it singing with WPA I need wpa_supplicant.

And her's the bit to make me blush. I cannot find anyplace from where to download it.

I've looked at all the Install options given - but I guess I'm just blind to the obvious.

So please - where on earth is it ??

Thanks

David
Back to top
View user's profile Send private message 
PaulBx1

Joined: 16 Jun 2006
Posts: 2308
Location: Wyoming, USA

PostPosted: Mon 07 Aug 2006, 15:26    Post subject:  

http://www.dotpups.de/dotpups/Wifi/wireless-drivers/

Nothing to be embarrassed about. It ain't exactly self-evident.
Back to top
View user's profile Send private message 
davidknibb

Joined: 03 Aug 2006
Posts: 22

PostPosted: Mon 07 Aug 2006, 15:41    Post subject:  

Thanks indeed

David
Back to top
View user's profile Send private message 
opticalc

Joined: 20 Jul 2006
Posts: 1

PostPosted: Tue 15 Aug 2006, 15:00    Post subject:  

OK since the original problem is fixed, ill hijack the thread:

I have puppy 2.01 installed, and have loaded the firmware for the ipw2200, which shows up as eth1.

WPA-TKIP works fine with my winxp client, so I know the router is working fine.

I cannot seem to get the wpa-tkip working in puppy though. I have installed the wpa_supplciant but cannot seem to get it working. Here is my debugged output:

(i have also tried (with no success) bypassing the encryption in the config file with wpa_passphrase)

wpa_supplicant -i eth1 -D ipw -c /etc/wpa_supplicant.conf -dd


Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'ipw' ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
Line: 2 - start of a new network block
ssid - hexdump_ascii(len=4):
62 79 72 64 byrd
proto: 0x1
key_mgmt: 0x2
group: 0x8
pairwise: 0x8
PSK - hexdump(len=32): [REMOVED]
Priority group 0
id=0 ssid='byrd'
Initializing interface (2) 'eth1'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_ipw_init is called
SIOCGIWRANGE: WE(compiled)=19 WE(source)=16 enc_capa=0x0
capabilities: key_mgmt 0x0 enc 0x3
Own MAC address: 00:13:ce:26:4d:54
wpa_driver_ipw_set_wpa: enabled=1
wpa_driver_ipw_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
Failed to set encryption.
wpa_driver_ipw_set_countermeasures: enabled=0
wpa_driver_ipw_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Added interface eth1
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Scan timeout - try to get results
Received 804 bytes of scan results (4 BSSes)
Scan results: 4
Selecting BSS from priority group 0
0: 00:0f:cc:0b:a4:24 ssid='byrd' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
selected based on WPA IE
Trying to associate with 00:0f:cc:0b:a4:24 (SSID='byrd' freq=0 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
wpa_driver_ipw_set_auth_alg: auth_alg=0x1
WPA: using IEEE 802.11i/D3.0
WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2
WPA: set AP WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
WPA: clearing AP RSN IE
WPA: using GTK TKIP
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
No keys have been configured - skip key clearing
wpa_driver_ipw_set_drop_unencrypted: enabled=1
State: SCANNING -> ASSOCIATING
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8b1a len=13
Authentication with 00:00:00:00:00:00 timed out.
Added BSSID 00:00:00:00:00:00 into blacklist
State: ASSOCIATING -> DISCONNECTED
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Setting scan request: 0 sec 0 usec
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Scan timeout - try to get results
Received 802 bytes of scan results (4 BSSes)
Scan results: 4
Selecting BSS from priority group 0
0: 00:0f:cc:0b:a4:24 ssid='byrd' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
selected based on WPA IE
Trying to associate with 00:0f:cc:0b:a4:24 (SSID='byrd' freq=0 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
wpa_driver_ipw_set_auth_alg: auth_alg=0x1
WPA: using IEEE 802.11i/D3.0
WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2
WPA: set AP WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
WPA: clearing AP RSN IE
WPA: using GTK TKIP
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
No keys have been configured - skip key clearing
wpa_driver_ipw_set_drop_unencrypted: enabled=1
State: SCANNING -> ASSOCIATING
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8b1a len=13
CTRL-EVENT-TERMINATING - signal 2 received
Removing interface eth1
State: ASSOCIATING -> DISCONNECTED
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_ipw_set_wpa: enabled=0
wpa_driver_ipw_set_drop_unencrypted: enabled=0
wpa_driver_ipw_set_countermeasures: enabled=0
No keys have been configured - skip key clearing
Removed BSSID 00:00:00:00:00:00 from blacklist (clear)
Cancelling scan request


if anyone has gotten thiers to work please let me know how
Back to top
View user's profile Send private message 
PaulBx1

Joined: 16 Jun 2006
Posts: 2308
Location: Wyoming, USA

PostPosted: Tue 15 Aug 2006, 16:35    Post subject:  

Usually folks try to get it running with encryption turned off first, just to make sure that part of it works. Have you tried that?

Show us what you have in wpa_supplicant.conf (obscure the key if you want).
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0581s ][ Queries: 11 (0.0029s) ][ GZIP on ]