Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 02 Aug 2015, 14:32
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
How to use BCM43224 802.11a/b/g/n in Tahr PAE?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
sheldonisaac

Joined: 21 Jun 2009
Posts: 505
Location: Philadelphia, PA

PostPosted: Thu 04 Jun 2015, 10:49    Post subject:  How to use BCM43224 802.11a/b/g/n in Tahr PAE?  

I just started using Tahrpup 6.02 with a new 4.0.4 kernel

Problems with wireless.

I copied this from the output of
Code:
lspci -nnk | more

02:00.0 Network controller [0280]: Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)
Subsystem: Dell Wireless 1520 Half-size Mini PCIe Card [1028:000e]


Code:
 dmesg | grep -i wl
Quote:

wl: version magic '3.14.20 SMP mod_unload modversions 686 ' should be '4.0.4-tahr_PAE-32-pae SMP mod_unload 586 '

Is the reason that the module wasn't compiled under the current kernel?

Please excuse my ignorance.
Code:
uname -a
Quote:

Linux puppypc992 4.0.4-tahr_PAE-32-pae #1 SMP Sun May 24 22:26:45 BST 2015 i686 i686 i686 GNU/Linux
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11508
Location: Arizona USA

PostPosted: Thu 04 Jun 2015, 16:08    Post subject:  

If the module was compiled for a different kernel, it won't work.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1884
Location: Worcestershire, UK

PostPosted: Fri 05 Jun 2015, 02:26    Post subject:  

You are trying to use the wl driver made for k3.14.20 on k4.0.4 - this won't work sadly.

This is one of the drawbacks of how easy it is now to change kernel - drivers outside of the kernel package don't get updated at the same time.

Quickpet does not know you have changed kernel so continues to offer the drivers for the original base kernel.

I have compiled the wl driver for k4.0.4 but have not packaged it up as a .pet until I knew what 666philb's plans were for the k4.0.4 kernel.

Cheers
peebee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
sheldonisaac

Joined: 21 Jun 2009
Posts: 505
Location: Philadelphia, PA

PostPosted: Fri 05 Jun 2015, 06:30    Post subject: Kernel madness  

peebee (in part) wrote:
You are trying to use the wl driver made for k3.14.20 on k4.0.4 - this won't work sadly.

This is one of the drawbacks of how easy it is now to change kernel - drivers outside of the kernel package don't get updated at the same time.

I have compiled the wl driver for k4.0.4 but have not packaged it up as a .pet until I knew what 666philb's plans were for the k4.0.4 kernel.

Oh, thank you, peebee.

Kind of what Flash said.

Well, now that I know, I can stop struggling with it, and be patient.

Does anyone know where I can see the advantages of this new kernel? I'm on a Dell Latitude E6410 laptop, about 5? years old, with an I5 processor; if that has any relevance.

Thanks again,
Sheldon
(posting from Opera 12.16 under LuPu 5.87)

_________________
Dell E6410: LuPu Super 2 & various Puppys; Dell D610: Windows XP, Puppy Linux 5.2, Carolite
Intel D865GBF: Windows XP, Puppy Linux 5.2
Acer Aspire One: Windows XP, Puppy Linux 5.2; ASUS P5A: MS-Windows 98SE, Puppy Linux 2.14X
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0725s ][ Queries: 11 (0.0081s) ][ GZIP on ]