Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 06:31
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Flash 4 Linux
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Author Message
phantrongnghia


Joined: 24 Apr 2006
Posts: 205
Location: Hanoi,Vietnam

PostPosted: Sun 06 Aug 2006, 04:01    Post subject:  Flash 4 Linux  

Hi !
For a long time, i found this tool, it is good for design Macromedia Flash in Linux
It is f4l (Flash for Linux)
I made the dotpups:

f4l.pup - 0.36MB

It is very small, and worked on my system
But the text in toolbar display very small:



I do not know why ? We need to install gtk-2.8 ?

Thanks
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 06 Aug 2006, 04:42    Post subject:  

Looks good Smile

- this is what I got when trying to run

anyone else?

Quote:
sh-3.1# ./run-f4l
f4l: error while loading shared libraries: libqt-mt.so.3: cannot open shared obj ect file: No such file or directory
sh-3.1#

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 06 Aug 2006, 04:45    Post subject:  

I did not try it myself yet, but here is a mirror:
http://dotpups.de/dotpups/Shockwave/f4l.pup (380 kb).

Lobster, you must install Qt-3.3.4 with Pupget.
In megapup Qt is already included.

Mark
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 06 Aug 2006, 04:50    Post subject:  

you can set the fontsize maybe like this:
Install with Pupget "scribus".
In the options, choose a font and colors you like.
This will update /root/.qt/qtrc I think, these settings then should be available in other QT-applications like f4l, too.

Mark
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 06 Aug 2006, 09:44    Post subject:  

thanks Mark - installed QT - now get this (still no run)

Code:
sh-3.1# ./run-f4l
f4l: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by f4l)

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
phantrongnghia


Joined: 24 Apr 2006
Posts: 205
Location: Hanoi,Vietnam

PostPosted: Sun 06 Aug 2006, 09:56    Post subject:  

Lobster: Try install libstdc++.so.6 with Dotpups Downloader

Thanks
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 06 Aug 2006, 11:04    Post subject:  

OK installed (and it is there) - same message

sh-3.1# ./run-f4l
f4l: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required
by f4l)

Rolling Eyes

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
phantrongnghia


Joined: 24 Apr 2006
Posts: 205
Location: Hanoi,Vietnam

PostPosted: Sun 06 Aug 2006, 19:42    Post subject:  

My sysytem do not hace this file in /usr/lib ?
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Tue 08 Aug 2006, 11:25    Post subject:  

I'll try this in Grafpup when I get a chance.
Back to top
View user's profile Send private message AIM Address 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Mon 02 Oct 2006, 00:22    Post subject:  

f4l: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by f4l)
Back to top
View user's profile Send private message AIM Address 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 02 Oct 2006, 10:29    Post subject:  

In 2.10 it works.
Mark
Back to top
View user's profile Send private message Visit poster's website 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Mon 02 Oct 2006, 15:58    Post subject:  

Any way to get it working in Grafpup?
Back to top
View user's profile Send private message AIM Address 
klhrevolutionist


Joined: 08 Jun 2005
Posts: 1124

PostPosted: Mon 02 Oct 2006, 16:15    Post subject:  

My question of the day !

If one had wine installed + Flash for windows

Could'nt you symlink to that ?

_________________
Heaven is on the way, until then let's get the truth out!
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 02 Oct 2006, 21:19    Post subject:  

Quote:
/usr/lib/libstdc++.so.6


The dotpup from GuestToo (dotpup-downloader) installs to /root/my-applications/lib.

But f4l uses the one in /usr/lib

So try this:
edit
/usr/local/f4l/run-f4l

Add 1 line, so that it looks like this:
Code:
#!/bin/bash

export LD_LIBRARY_PATH=/root/my-applications/lib:$LD_LIBRARY_PATH

f4l&


This should force it to use libstdc++ from GuestToo, that works for me.


Or try this dotpup, it includes this lib in a subfolder and uses it with the same method:
http://dotpups.de/tests/f4l.pup
Mark
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 02 Oct 2006, 21:32    Post subject:  

klh, do you mean to use the windows-flash in Linux-browsers?
No, this does not work.
The new beta of crossover (commercial wine) uses a "wrapper" that can use Flash 9 from crossover in Linux-browsers.
But I was not able to get crossover working, so no success playing around with it.
The beta is time-limited to 60 days.

The only way I got flash 9 working is by using a windows-webbrowser (Opera 9):
http://www.murga.org/~puppy/viewtopic.php?t=11458

Mark
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0571s ][ Queries: 11 (0.0048s) ][ GZIP on ]