Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 19 Nov 2019, 10:16
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
BIT METER OS 0.7.6 (stable) & 0.8.0 (experimental)
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 15 [223 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 13, 14, 15 Next
Author Message
Geoffrey


Joined: 30 May 2010
Posts: 2377
Location: Queensland

PostPosted: Wed 13 May 2015, 00:45    Post subject:  

Here is bitmeteros-0.8.0-i386.pet.

I've included a pinstall.sh that creates the needed libpcap.so.0.8 symbolic link,

Copies /var/lib/bitmeter/bitmeter.db.new to /var/lib/bitmeter/bitmeter.db, was mentioned the database wasn't being created.

Runs the bitmeterweb start and bitmeter start

I'm guessing it should work in any pup

As always, use at your own peril Wink

Edit: re-uploaded, changed so opens default browser created bitmeter.png so the icon shows in the menu with jwm, don't seem to like .ico.

Tested with Racy 5.2.9, Tahr 1.6.0.2, Wary 5.5, all work OOTB.

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 11281

PostPosted: Wed 13 May 2015, 03:45    Post subject:  

Ok quick test of the 0.8.0 pet....

libpcap is a funny one.... perhaps the older bitmeter had it statically compiled in since it seems to provide functions that are needed for monitoring...or perhaps there were too many to duplicated in the end Smile

As it happens 4.12 (thought I would test on that again) does not have it...debian etch provided the goods and even that has 0.8 as a symlink to 0.9.5! Actually Lucid does not have it (libpcap) either.

Ok those debian start up scipts will not work on 4.12 and lucid (and others?)...so tested from command line.
All works just fine so no problem there.
4.12 might not be considered but Lucid does still have quite a user base here.

Interestingly enough there is no log file generated that I can see...and since that seemed to be related to the problems I was having I will take that as a good thing Smile.

II also did not see any problems with the 0.8.0 build...the coding of the guy seems solid and yes the web inteface has those nice extras Smile

Just some feedback.

mike
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 11281

PostPosted: Wed 13 May 2015, 04:44    Post subject:  

Just noticed the pet has everything as root.

The older package had all files as 1000:1000 ownership (actually on 4.12 it comes up as ftp:ftp and it behaved) which I am sure helped confuse matters so hopefully being all root makes life easier.

Mike
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Wed 13 May 2015, 06:29    Post subject:  

BM080 installed to 2 32bit PUP distros; namely X-Slacko2.1 and Puppex6.0.

In each case, it shows in the Menu>Network>BitMeter OS... Launching from the menu does not present itself in the browser. On X-Slacko's menu, it has an icon, but on Puppex, it does not.

What can I present which would be helpful?

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2377
Location: Queensland

PostPosted: Wed 13 May 2015, 07:19    Post subject:  

gcmartin wrote:
BM080 installed to 2 32bit PUP distros; namely X-Slacko2.1 and Puppex6.0.

In each case, it shows in the Menu>Network>BitMeter OS... Launching from the menu does not present itself in the browser. On X-Slacko's menu, it has an icon, but on Puppex, it does not.

What can I present which would be helpful?


ldd shows these library files
Code:
ldd bmcapture
   libpcap.so.0.8 => /usr/lib/libpcap.so.0.8 (0xb7753000)
   libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0xb769e000)
   libm.so.6 => /lib/libm.so.6 (0xb7651000)
   libc.so.6 => /lib/libc.so.6 (0xb749b000)
   libpthread.so.0 => /lib/libpthread.so.0 (0xb747f000)
   libdl.so.2 => /lib/libdl.so.2 (0xb747a000)
   /lib/ld-linux.so.2 (0xb7780000)


Check the task manager, bmcaputure and bmws should be running

I've had the pet work on X-slacko 3 which is slacko 5.9.3 don't know what Puppex's window manager is?

The bitmeterweb.desktop I edited so the icon is a png instead of a ico, it should now show in any menu

Code:
[Desktop Entry]
Name=BitMeter OS Web Interface
GenericName=Bandwidth Monitor
Comment=Monitor your network speed using a web browser
Exec=/var/lib/bitmeter/runweb.sh
Type=Application
Icon=/var/www/bitmeter/bitmeter.png
Categories=Network;


You may have downloaded before I fixed the icon and changed the runweb.sh script, it now opens the default browser, download the pet again and try it.

You can try http://localhost:2605 in a browser and see if it's working

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Wed 13 May 2015, 14:08    Post subject:  

Thanks @Geoffrey. I will download and replace 080.
Code:
URL ===> localhost:260
Works, prior to replacing.

I noticed that the utilty implies, by its name, a 32bit usage. Will there be a separate utility for 64bit PUPs or will the 32bit morph into 64bit as well?

Thanks for this very good tool for home data management use. And, thanks to everyone for addressing this understanding.

Edited: Replacing with the latest has resolved the issues reported earlier. Thx, again, Geoffrey! Cool

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile

Last edited by gcmartin on Wed 13 May 2015, 15:36; edited 1 time in total
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 5553
Location: King's Lynn, UK.

PostPosted: Wed 13 May 2015, 15:13    Post subject:  

My, you have all been busy bees while I've been to the seaside today....!

@Geoffrey:-

Goodness me; I shall to have to turn my back on things a bit more often if this is what happens in my absence...! Laughing That's marvellous, Geoff. How certain are we that this will run OK in the Pups you've tried it in?

@ gcmartin:-

As stated in the original post, there are 64-bit versions of both 0.7.6 AND 0.8.0. However, obviously no development work will go on with those if nobody's yet tried them. We need testers for the 64-bit versions. Install them (taking all necessary precautions, of course) from the .deb file; note what happens.....then give us all some feedback! That's what's needed.

What work has been done so far is all on 32-bit 'Pups', for the simple reason, I expect, that there's more of them in general use by the community. That in turn, is also for the simple reason that 64-bit came along after 32-bit; so in terms of what elderly hardware is in use, I think there would naturally be a higher proportion of 32-bit systems. As stated, I'm NOT a programmer, or 'coder'. I did, however, bring this to the community's notice because I genuinely believe that it does have a place for many Puppy users.

I don't have any 64-bit Pups myself to try them out in. Although I have a 64-bit system (AMD Athlon 64 X2 3800+), I've always preferred to run 32-bit Puppies, for the simple reason that they run so fast.....and I'm not too keen on the likes of FatDog, et al. That's not to say that kirk & jamesbond haven't done some absolutely marvelous work with them; it's just not my cup of tea. I've tried FatDog 700 in the past; didn't get on too well with it....

I am, however, considering giving Slacko64 a try, so.....we'll see.

Anyway, it's just my bit to contribute to the community, since I enjoy Puppy so much. The 'dev' work, however, will of necessity have to come from other interested parties...who know what they're doing! (I don't mind admitting I'm very much a 'noob' at present.) Oscar, Geoffrey & mikeb have done some sterling work on this already.....


Regards,

Mike. Smile

_________________
MY 'PUPPY' PACKAGES


Last edited by Mike Walsh on Wed 13 May 2015, 17:15; edited 3 times in total
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2377
Location: Queensland

PostPosted: Wed 13 May 2015, 16:19    Post subject:  

mikeb wrote:
Just noticed the pet has everything as root.


That's my fault, I had a mishap with the properties on the drive, it don't seem to have been detrimental.
I might make another and see if it works the same with the ftp ownership, though maybe better to let sleeping dogs lie.


gcmartin wrote:
Will there be a separate utility for 64bit PUPs or will the 32bit morph into 64bit as well?


Only if someone with a 64bit version of Puppy packages the bitmeteros_0.8.0-amd64.deb, I don't have a 64bit version to try it on.

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 11281

PostPosted: Wed 13 May 2015, 16:28    Post subject:  

yes let the dogs lie... I was actually wanting to make it all root anyway.
Sometimes i find packages with odd permissions and sometimes it causes problems...in this case i suspect its not intentional or necessary.

Well all good progress Smile

been fiddling with Thunar of all things so left this on the side for a little anyway.

mike
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2377
Location: Queensland

PostPosted: Wed 13 May 2015, 18:11    Post subject:  

Mike Walsh wrote:
How certain are we that this will run OK in the Pups you've tried it in?


I think it should work ok, they were booted with no save file, installed the pet, run bitmeter from the menu and worked without a hitch.

I packaged the 64 bit version for gcmartin to test, changed all the files to "root" ownership, waiting a report

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Wed 13 May 2015, 19:06    Post subject:  

Tested results
Installed with no reports of issues to LxPUP64 and on an old nonsupported version of PUPPY Chubby. Both showed the Menu>Network>BM as seen in 32bit, and both would launch the browser to localhost:... But, in each case, the browser port would not open to BM's local page port 2605.

Edit: Lighthouse and its derivatives (Chubby is one of them) will install a ".deb" file. The deb works where the pet did not launch.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile

Last edited by gcmartin on Wed 13 May 2015, 19:27; edited 2 times in total
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2377
Location: Queensland

PostPosted: Wed 13 May 2015, 19:19    Post subject:  

@gcmartin

I'll download a 64 bit wary and get it working on that, stay tuned Wink

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2377
Location: Queensland

PostPosted: Wed 13 May 2015, 19:57    Post subject:
Subject description: bitmeteros-0.8.0-amd64 running in wary64-6.99
 

@gcmartin

I'm posting from wary64-6.99, bitmeteros-0.8.0-amd64.pet is working ok for me.

Quote:
Edit: Lighthouse and its derivatives (Chubby is one of them) will install a ".deb" file. The deb works where the pet did not launch.


Did not launch? from the menu or the pet didn't install? well if the deb works just use it or make a unedited pet from it.
capture3483.png
 Description   bitmeteros-0.8.0-amd64 running in wary64-6.99
 Filesize   50.68 KB
 Viewed   333 Time(s)

capture3483.png


_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Wed 13 May 2015, 21:21    Post subject:  

The PET installs with no message of any issues on both systems. And, Menu items are created in Network.
GCMartin wrote:
... The deb works where the pet did not launch.
I apologize as this can mislead. To rephrase: The deb allows the browser to spawn to port properly where the pet did not spawn a browser which connects to the port. The PET's browser tab shows page not found while the DEB's browser tab in Chubby launches the tab as expected when started.

Also, on Chubby (when the DEB is used), I can search and find BM while on LxPUP64 I cannot find the BM task
Code:
pidof bmcapture
after Menu launch, even though a tab (which doesnt connect ) spawns on the LxPUP64 browser. Thus, something is causing it to fail when the PET is used.

I will try another 64bit PUP; namely EmSee's Ultra.

Edit1:
I found my EmSee Sugar DVD and booted it. After FirstRUN, I insure WAN was active and installed the PET. Same as before on the 2 other 64bit PUPs.
P.S. No firewall active at any time during any of these tests on the PCs.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile

Last edited by gcmartin on Wed 13 May 2015, 22:14; edited 3 times in total
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2377
Location: Queensland

PostPosted: Wed 13 May 2015, 21:50    Post subject:  

gcmartin, I'm downloading LxPup64-15.03.01-hybrid, hopefully it will work, if not I'll sort it out, it could be the ownership I changed Confused , I'm sure I can make it work, here's hoping Wink .
_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 15 [223 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 13, 14, 15 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0682s ][ Queries: 12 (0.0141s) ][ GZIP on ]