Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 02 Aug 2015, 04:37
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Slacko 5.6 does not see Android smartphone
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Wed 06 May 2015, 00:54    Post subject:  Slacko 5.6 does not see Android smartphone
Subject description: Kitkat
 

When I connect an Android KitKat smartphone to Dell desktop by simple USB cable, I am prompted to install software. Is this software for Android or for the desktop (presumably running Windows)? Although the 32 GB external drive is mounted in the smartphone, no icon appears on Slacko desktop. How to proceed?
Last edited by nubc on Wed 06 May 2015, 08:15; edited 1 time in total
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 5301
Location: World_Hub

PostPosted: Wed 06 May 2015, 06:48    Post subject:  

You're looking for go-mtpfs >> http://www.murga-linux.com/puppy/viewtopic.php?t=91833
_________________
>>> Great minds discuss ideas; Average minds discuss events; Small minds discuss people. <<<
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Sat 09 May 2015, 16:45    Post subject:  

I installed the go-mtpfs dotpet without rebooting. The program did not mount at first, then when it did mount, I didn't get the prompt back (so I couldn't unmount the drive). So I shut down the phone, and, as you can see, the program is stuck trying to perform some operation. Any ideas what is going on?
Code:
# cd /mnt
# ls
cdrom  dvd    floppy  msdos      ram0  sda2  sdc1  swap
data   flash  home    MTPdevice  ram1  sdb2  sdd1  zip
# go-mtpfs MTPdevice
2015/05/09 16:34:10 detect failed: no MTP devices found
# cd /mnt
# ls
cdrom  dvd    floppy  msdos      ram0  sda2  sdc1  swap
data   flash  home    MTPdevice  ram1  sdb2  sdd1  zip
# cd /MTPdevice
bash: cd: /MTPdevice: No such file or directory
# cd MTPdevice
# ls
# go-mtpfs MTPdevice
/bin/fusermount: failed to access mountpoint /mnt/MTPdevice/MTPdevice: No such file or directory
2015/05/09 16:37:10 mount failed: fusermount exited with code 256
# fusermount -u MTPdevice
fusermount: /mnt/MTPdevice/MTPdevice not mounted
# ls
# cd /mnt
# ls
cdrom  dvd    floppy  msdos      ram0  sda2  sdc1  swap
data   flash  home    MTPdevice  ram1  sdb2  sdd1  zip
# go-mtpfs MTPdevice
2015/05/09 16:38:30 starting FUSE 70ad1f3 (2013-02-24 20:42:03 +0100)


fusermount -u MTPdevice
2015/05/09 16:41:04 fatal error LIBUSB_ERROR_NO_DEVICE; closing connection.
2015/05/09 16:41:04 GetStorageInfo 10001: LIBUSB_ERROR_NO_DEVICE
2015/05/09 16:41:04 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:41:14 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:41:14 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:41:24 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:41:24 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:41:34 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:41:34 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:41:44 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:41:44 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:41:54 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:41:54 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:04 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:04 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:14 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:14 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:24 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:24 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:34 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:34 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:44 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:44 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:54 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:42:54 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:43:04 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:43:04 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:43:14 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:43:14 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:43:24 GetStorageInfo 10001: mtp: cannot run operation GetStorageInfo, device is not open
2015/05/09 16:43:24 GetStorageInfo 20001: mtp: cannot run operation GetStorageInfo, device is not open

EDIT: I see what I did wrong, I should have restarted the Puppy computer after installation. I put the USB back in the phone and got a dialog with Android to "Install PC programs: Install PC programs required when connected to computer--" I wonder what programs are being recommended. The programs shouldn't be Windows-specific if they're gonna install on KitKat Android.
Question: Should I install these suggested programs?

EDIT2: Android wants to install programs on the Puppy PC. Allow this?
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Sat 09 May 2015, 17:27    Post subject:  

Okay, I restarted the computer, went to /mnt/MTPdevice/ and found the expected drives. However, when I view properties of the 32 GB micro SD card, it shows "0 MB", even though there are 3 folders there. When I view properties of the internal storage, it shows "0 MB", although there is a lotta stuff on this drive.

It occurs to me that I must restrict my search to mp3 files. Does Android have a resident player for YT-based mp4 files?

After mounting the MTPdevice, I tried to create a directory on the microSD and got the error:
Code:
mkdir: Function not implemented

I pull the USB from the phone, and now the go-mtpfs program is endlessly looking for the device, as it did before. How do I kill this searching.

EDIT: I killed go-mtpfs with resident Pprocess 2.3.2. Anything else I should terminate? (eg, busybox)
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Sat 09 May 2015, 18:28    Post subject:  

Well, I connected the phone to Windows XP, and Windows asked to go out on the internet to find a driver. This failed. Meanwhile, I went into Android settings to install USB connection software. This proceeded to a point where Windows popped up a dialog saying that it ain't gonna work. Meanwhile, the software initiated from LG phone was making progress, and asked for a Restart. After reboot, things weren't quite right, so I went into Android settings and instigated the installation of LG-specific software, after which the phone showed up in Windows Explorer much like a thumb drive. I created several folders on the microSD drive.

Great, I got it to work in Windows XP. Only problem is, my data is not on my Windows box, it's on my Slacko 5.6 box.

Question: Is this smartphone able to install essential MTPdevice software, including the LG-specific software, on a Slacko 5.6 system?
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Sat 09 May 2015, 18:52    Post subject:  

Connecting to the Slacko box, I ran the go-mtpfs command and the SD card data appeared. I successfully created a directory with ROX. BUT, properties of directories and folders seem to be fixed at "0 MB", including the 'internal storage' directory which contains Android and apps.

01micko's suggestion to press CTRL+C to stop the searching works, then you can unmount with 'fusermount -u MTPdevice'. Uh-oh, remounted MTPdevice doesn't show files after using CTRL+C.

Restarting Xserver did not recover functionality. I had to Restart computer before the go-mtpfs command would work again. Oh well, then don't use CTRL+C to stop the runaway search.

Last edited by nubc on Sun 10 May 2015, 00:30; edited 1 time in total
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Sat 09 May 2015, 23:33    Post subject:  

I fell asleep for a while, and an hour later the MTPdevice folder in /mnt shows an error condition, yellow triangle with exclamation mark. In Properties, says Error: Transport endpoint not connected. I would like to clear this error without rebooting. Any suggestions?

EDIT: Restarted the computer, condition cleared.

Why I am still hanging on to this topic is that I would like to formulate a stepwise procedure to mount and unmount the phone, without having to restart computer.

Here is my best guess:
________________________________________________________________________

1 cd /mnt

2 go-mtpfs MTPdevice
[After successful mounting, there is no command prompt available.]

3 After finishing work, Terminate 'go-mtpfs MTPdevice' in Pprocess
[After terminating process, command prompt becomes available again.]

4 fusermount -u MTPdevice
________________________________________________________________________

Menu > System > Pprocess

I tested and found that step 4 is necessary, After step 4 I can mount the device again (starting at step 2) without an issue and without rebooting, which is the goal.

If you try to mount the device and get a message that device is not present, it is likely that the USB connection on the phone is set to "Charge phone". Change this setting to "Media sync (MTP)" and the error condition will probably clear.

If after a few days you try to mount the device but it won't mount, run step 4, fusermount -u MTPdevice, then start over. Reboot if nothing else works.

Last edited by nubc on Sat 11 Jul 2015, 20:09; edited 6 times in total
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 2598
Location: wales

PostPosted: Sun 10 May 2015, 03:39    Post subject:  

have you tried connecting the phone as mass storage instead of mtp?
when the phone it's plugged into a computer... puconnects the menu from the top of the screen and there should be an option to change how it connects.

after connecting as mass storage, if the partitions icons don't appear.. try pmount

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Sun 10 May 2015, 16:17    Post subject:  

666philb, I don't see the option to connect as mass storage. Nothing shows up in pmount after connection. In phone's options on how to connect by USB, there is an unidentified button to click, which prompts user to Install PC programs required when connected to computer. As this is software for the PC, I repeat my previous inquiry as to whether these programs are intended for Windows. Is Android smart enough to install programs on a Linux box? Dubious.

Quote:
when the phone it's plugged into a computer... puconnects the menu from the top of the screen and there should be an option to change how it connects.

Can you rewrite that sentence, can't understand, especially the word, puconnects.

Last edited by nubc on Mon 11 May 2015, 01:36; edited 1 time in total
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 5301
Location: World_Hub

PostPosted: Sun 10 May 2015, 17:04    Post subject:  

Personally, the mtp script doesn't work for me. I instead have to manually mount my device. If they haven't worked for you, give this package a spin.
_________________
>>> Great minds discuss ideas; Average minds discuss events; Small minds discuss people. <<<
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Sun 10 May 2015, 17:46    Post subject:  

I just moved 36 mp3 files to the phone through MTP connection, following the step-wise procedure above. Enjoying the music now. Even with that many files, properties stills shows "0 MB".
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Sun 07 Jun 2015, 01:40    Post subject:  

I created a folder named 'mp3' and things worked fine. Then I created a folder named 'mp4' for YT videos, and confusion began. I transferred 50 YT music vids to 'mp4', but after I unmounted the smartphone from the computer, the filing system went funky. Only one or two files were in 'mp4'. Now the YT vids are in the section named 'Video' in Android's file system. Inside Video, there are two redundant folders named 'All videos' (colored blue) and the folder I created, 'mp4'. There are 5 general sections of the Android file manager, namely, All Files, Music, Video, Image, Document. (There is also a section named Dropbox under Cloud Storage.) The 5 main sections do not appear when opened on the computer with ROX filer. In Android there are 2 folders named 'mp4', one located in Music and one in Video. The 'mp4' folder in Music contains only a few files. Most of the YT mp4's I transferred are in the 'mp4' folder in Video. However, big problem, after I remount the MTP device, the 'mp4' folder that appears in ROX is nearly empty, and I have yet to locate maybe 50 YT mp4 files that I transferred to the SD card. When I click the folder mp4, ROX shows the contents of 'mp3', all mp3 files. ROX does not show the Android sections named 'All Music' and 'All Videos' when viewing the SD card. So I can't view the YT vids that I previously transferred to SD card. Did Android store these vids on the internal storage drive?

EDIT: I reluctantly rebooted, and now I can see the YT vids in 'mp4' folder.
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Sun 07 Jun 2015, 13:58    Post subject:  

There is a player for mp3 files that plays music continuously. Is there an app that will play mp4 files continuously? How must I organize mp4 files for continuous playback from SD card?

When I open the 'mp4 vids' folder with ROX, I get an error message
Code:
Error scanning '/mnt/MTPdevice/SD card/mp4 vids':
Can't stat directory: no such file or directory

"Can't stat directory" what does this mean? I can probably get rid of this error if I reboot, but it's still a problem because there's a difference between the ways Puppy and Android organize files. I wonder if this issue will improve after I unlock my phone.

Surprises:
1 Adblock Plus add-on will not install on Firefox for Android. I guess it won't install until I unlock my phone?
2 The Yahoo Mail app for Android has no log off. One must delete the account to log off. Or navigate to yahoo.com to log off (not verified because I uninstalled the app).
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 5301
Location: World_Hub

PostPosted: Mon 08 Jun 2015, 07:26    Post subject:  

In my experience, Linux utilities are buggy @ best and anything but consistent.

You'd..
  • a) Be better off with an Android based file manager/explorer.
And..
  • b) To post your questions on an appropriate Android forum.

_________________
>>> Great minds discuss ideas; Average minds discuss events; Small minds discuss people. <<<
Back to top
View user's profile Send private message 
nubc


Joined: 23 Jan 2007
Posts: 1230
Location: USA

PostPosted: Tue 09 Jun 2015, 10:12    Post subject:  

Semme wrote:
In my experience, Linux utilities are buggy @ best and anything but consistent.
You'd..
  • a) Be better off with an Android based file manager/explorer.
And..
  • b) To post your questions on an appropriate Android forum.

On the smartphone side I am using an Android-based file manager, which sees things differently from Linux ROX. If I go to an "appropriate" Android forum, I am certain that very few helpers will know how to transfer files from an obscure distribution of Linux (Puppy Slacko). I would probably have better luck on an Ubuntu forum. I don't like being cutting edge because I hate being the guinea pig. I like being about 5 years behind, so everything is already figured out and documented, with no need to re-invent the wheel. Are you telling me that on an ubergeek forum like Puppy, nobody has transferred music files from PC to an Android smartphone?

And, yes, I see the big, pink, polka dotted elephant in the room. This transfer operation probably goes very smoothly between Android and a Windows box. Geez, why didn't I think of that? Oh, it only works with Windows 8, or just get an iPhone and a Mac box, to put a stop to all this tinkering.

As a strategy, I probably will put an extra step in this task. I will put the music files on a thumb drive, insert into Windows box, then connect smartphone to Windows box (installing all the good connection software), and thereby use Windows Explorer to make the transfers. The Google God probably wants it done this way, anyhow.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1462s ][ Queries: 11 (0.0095s) ][ GZIP on ]