Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 19 Nov 2017, 10:39
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jpilot Lucid 5.28
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Author Message
paule

Joined: 15 Jul 2007
Posts: 79

PostPosted: Sun 26 Apr 2015, 20:28    Post subject:  Jpilot Lucid 5.28  

Has anyone compiled Jpilot to work with Lucid 5.28. The available pets work with puppy 4.31 but not 5.28. Any assistance would be greatly appreciated.

cheers, Paul
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Sun 26 Apr 2015, 20:48    Post subject:  

Hi, Paul.

Judging from the screen shots at the Jpilot site, your Jpilot looks a lot like
osmo. Have you tried osmo? (osmo is included by default on every Puppy.)

BFN.

musher0

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
paule

Joined: 15 Jul 2007
Posts: 79

PostPosted: Sun 26 Apr 2015, 20:53    Post subject:  

musher0 wrote:
Hi, Paul.

Judging from the screen shots at the Jpilot site, your Jpilot looks a lot like
osmo. Have you tried osmo? (osmo is included by default on every Puppy.)

BFN.

musher0


Thanks for the reply. I use jpilot on a number of computers and operating systems including some palm devices, so really need this. Unfortunately I don't have the skills to compile packages myself.

Thanks again for the reply.

cheers, Paul
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Sun 26 Apr 2015, 21:08    Post subject:  

Hi, Paul.

I see. So it's a transversal thing, eh? All your machines use jPilot.

Have you got the URL for the 4.31 pet? Not promising anything, but I'll
see what I can do. Maybe it's just a missing library.

Also, there's this page with all manner of pre-compiled packages for jPilot:
http://pkgs.org/search/jpilot I'd suggest the first (Alt Sysyphus)
or the last (Ubuntu Lucid) for a Puppy 5.2.8. The others are likely too
recent.

I'd try recompiling the latest version from source, but the download page
from jPilot itself seems down at the moment. Can you check if
http://www.jpilot.org/download.htm is active from where you
are? Thanks.

BFN.

musher0

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
paule

Joined: 15 Jul 2007
Posts: 79

PostPosted: Sun 26 Apr 2015, 21:13    Post subject:  

musher0 wrote:
Hi, Paul.

I see. So it's a transversal thing, eh? All your machines use jPilot.

Have you got the URL for the 4.31 pet? Not promising anything, but I'll
see what I can do. Maybe it's just a missing library.

Also, there's this page with all manner of pre-compiled packages for jPilot:
http://pkgs.org/search/jpilot I'd suggest the first (Alt Sysyphus)
or the last (Ubuntu Lucid) for a Puppy 5.2.8. The others are likely too
recent.

I'd try recompiling the latest version from source, but the download page
from jPilot itself seems down at the moment. Can you check if
http://www.jpilot.org/download.htm is active from where you
are? Thanks.

BFN.

musher0


Here is the URL for the jpilot.pet I have used before:

http://www.murga-linux.com/puppy/viewtopic.php?t=29857

I cannot access the download page for jpilot at this time either.

Really appreciate the help.

cheers, Paul
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Sun 26 Apr 2015, 21:23    Post subject:  

Hi.

I managed to put together a pet from the pre-compiled stuff I mentioned. I
got it working on Puppy Precise 5.4.3.

It needed the pisock and the bluetooth libs.

Give me a minute so I can upload it somewhere, and then you can test it
on your Lucid Pup.

Back in a minute.

musher0

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Sun 26 Apr 2015, 21:31    Post subject:  

Try this ? http://tinyurl.com/nrur96k
It's only jPilot version 0.99, though.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
paule

Joined: 15 Jul 2007
Posts: 79

PostPosted: Sun 26 Apr 2015, 21:35    Post subject:  

musher0 wrote:
Try this ? http://tinyurl.com/nrur96k
It's only jPilot version 0.99, though.


When I try to run it after installation I get this error message:

jpilot: /lib/libc.so.6: version `GLIBC_2.15' not found (required by jpilot)


cheers, Paul
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Sun 26 Apr 2015, 22:18    Post subject:  

Hm...

Again, I'd accomodate you, but we have a couple of serious problems...

I don't have a Lucid Pup on this computer to compile jpilot on with an
original Glbc "less-than-2.15", plus...

I don't have a source file of jpilot to compile... Not funny. Sad

Long story short: if we don't have a compilation of jpilot that's compatible
with your lupu's Glbc version, we're stumped. So...

The way to go for you to go from here, would be to install a more recent
Pup, such as Upup-raring-3.9.9.2, or a Puppy Precise 5.4.3 or later.

And then re-try the jpilot pet above... or the one below... because...

In the meantime I had assembled another pet of jpilot for version 1.18.1.
http://tinyurl.com/ocejctw Shucks. Smile

This newer pet has the locales separately, so if you're English-speaking,
you don't need to install the "NLS" pet included in the zip archive.

BFN.

musher0
~~~~~~~~
P.S. I just downloaded rerwin's lupusuper4-5.2.8.7 with kernel 3.9.9
(pretty much the same as the kernel used by pemasu for his
Upup-raring-3.9.9.2). I'll try the jpilot-1.81 package on that to see
what happens.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
paule

Joined: 15 Jul 2007
Posts: 79

PostPosted: Sun 26 Apr 2015, 22:26    Post subject:  

musher0 wrote:
Hm...

Again, I'd accomodate you, but we have a couple of serious problems...

I don't have a Lucid Pup on this computer to compile jpilot on with an
original Glbc "less-than-2.15", plus...

I don't have a source file of jpilot to compile... Not funny. Sad

Long story short: if we don't have a compilation of jpilot that's compatible
with your lupu's Glbc version, we're stumped. So...

The way to go for you to go from here, would be to install a more recent
Pup, such as Upup-raring-3.9.9.2, or a Puppy Precise 5.4.3 or later.

And then re-try the jpilot pet above... or the one below... because...

In the meantime I had assembled another pet of jpilot for version 1.18.1.
http://tinyurl.com/ocejctw Shucks. Smile

This newer pet has the locales separately, so if you're English-speaking,
you don't need to install the "NLS" pet included in the zip archive.

BFN.

musher0
~~~~~~~~
P.S. I just downloaded rerwin's lupusuper4-5.2.8.7 with kernel 3.9.9
(pretty much the same as the kernel used by pemasu for his
Upup-raring-3.9.9.2). I'll try the jpilot-1.81 package on that to see
what happens.


Really appreciate all the effort. Unfortunately 5.28 is the latest version I can run on this laptop. I downloaded the .zip file (just realized that was intended) and the 1.81 works just fine. Thanks very much and sorry for my misunderstanding.

cheers, Paul
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 923
Location: El Salvador

PostPosted: Mon 27 Apr 2015, 00:03    Post subject: Maybe help this  

Compiled in 5.7.1 retro-precise remaster(Pupjibaro 1.0.4)
jpilot-1.8.2.pet
https://copy.com/oH0R3G09YhkqrDzu
6e396752974f8fe53a616d1e577b6fc3 1917K
pilot_link-0.12.5.pet
https://copy.com/Gwwe6JgTfEMkoJJP
c5fd3ec99dbb2a94c2c11f55e9c4fad7 670K
This was for pilot-link
Quote:
Options detected/selected
-------------------------.
pilot-link version...... : 0.12.5
libpisock version....... : 9.0.2
libpisync version....... : 1.0.3
Build for host.......... : i686-pc-linux-gnu
Extra Warnings.......... : no
Direct USB support...... : yes, Linux
BlueZ support........... : yes
Thread-safe libpisock... : no
ElectricFence checks.... : no
CPPFLAGS................ :
CFLAGS.................. : -g2 -Wall

Userland Tools
-------------------------.
Build userland tools.... : no
Support for popt........ : none
Readline support........ : none
PNG support............. : no

Internal Language Support
-------------------------.
Iconv support........... : yes

External Language Support
-------------------------.
TCL support............. : false
Java support............ : false
Python support.......... : true 2.7
Perl support............ : false

this for jpilot
Quote:
This package is configured for the following features:
------------------------------------------------------
Compiling with plugin support.......... yes
Compiling with private record support.. yes
Compiling with Datebk support.......... yes
Compiling with Manana support.......... yes
Compiling with Prometheon support...... no
Compiling Expense plugin............... yes
Compiling SyncTime plugin.............. yes
Compiling KeyRing plugin............... yes
Compiling dialer add-on................ yes
Cryptographic library.................. libgcrypt
GTK-2 support.......................... yes
Stock buttons (icons on buttons in GUI) yes
NLS support (foreign languages)........ yes
Compiler Options....................... -g -O2
Prefix directory....................... /usr
pilot-link headers..................... /usr/include
USB support enabled.................... yes
pilot-link version found............... 0.12.5

Now type make to compile

_________________
My blog | | Github


Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Mon 27 Apr 2015, 01:24    Post subject:  

Hi, Paul.

I'm surprised that v. 1.8.1 would work fine on your setup, but if you say so...

Actually, I installed rerwin's SuperLupu 5.2.8.7 mentioned above, and its
Glibc version has remained at 2.11, so it was a no go for my jPilot 1.8.1
package.

If I could access the source code for the most recent jPilot, I could try to
compile it over lupu 5.2.8, but the jpilot download site seems to be down
at the moment.

Maybe we retry later, ok?

@nilsonmarales: Thanks for the additional stuff.

BFN.

musher0

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
paule

Joined: 15 Jul 2007
Posts: 79

PostPosted: Mon 27 Apr 2015, 10:52    Post subject:  

Musher0 and nilsonmarales, thank you both very much.

cheers, Paul
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Mon 27 Apr 2015, 13:08    Post subject:  

@nilson: What is the glibc version for your pupjibaro built with precise-retro,
please? Thanks in advance. I might try your jPilot version 1.8.2 on some of
my pups.

@paul: thanks for the discovery of this useful PIM.

BFN.

musher0

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 923
Location: El Salvador

PostPosted: Mon 27 Apr 2015, 17:51    Post subject:  

@musher0
ldd --version
ldd (Ubuntu EGLIBC 2.15-0ubuntu10.4) 2.15
Copyright (C) 2012 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.
Cheers.

_________________
My blog | | Github


Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0698s ][ Queries: 12 (0.0043s) ][ GZIP on ]