Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 14:36
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Announcements
CUPS printing - installation script - update 13SEP06
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 14 [197 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 12, 13, 14 Next
Author Message
vanchutr

Joined: 05 Aug 2006
Posts: 427

PostPosted: Sat 05 Aug 2006, 22:54    Post subject: CUPS installer  

Dear Pakt;
I'd installer successfully the CUPS by your instructions.
But I could'nt print the test page.
I use the EPSON EPL 5800L connected in parallel port.
Your instructions about 'how to install the CUPS with printer on parallel port or USB port' is very clear and easy to understand. Thank you.
I use the version Puppy 2.01 (installed on HDD)
Back to top
View user's profile Send private message 
can8v

Joined: 15 Jul 2006
Posts: 584
Location: Yuba City, CA

PostPosted: Sun 06 Aug 2006, 01:49    Post subject:  

Buteman wrote:
Hi,
Further checking has shown that printing works from seamonkey if I choose the correct printer from the list presented but does not work from abiword, leafpad etc.
Still puzzeled.
norm

I have yet to try this script out, but I did use Rarsa's scripts to get CUPS up and running. I thought I had the same problem that you had, but as it turns out all I had to do was click print in Abi Word, leafpad etc... I was tricked into thinking that it wouldn't work, because when I would use the file pull down menu to select print, then look for my printer in the list of available printer it wasn't there. Since I couldn't select my printer I assumed it wouldn't work, but then someone pointed out all I needed to do was click print anyway, and then CUPS would filter it and print it with the default CUPS printer.
I hope this solves your problem, but I still don't have any idea why some programs will let me select which printer I want to use and other I have to print on the CUPS default printer, and the only way to change printers is to change the CUPS default printer in the html interface tool. Perhaps that is the subject of another thread though.
Good luck,
-Jason
Back to top
View user's profile Send private message Visit poster's website 
can8v

Joined: 15 Jul 2006
Posts: 584
Location: Yuba City, CA

PostPosted: Sun 06 Aug 2006, 02:06    Post subject: IrDA  

I would like to test this new install script over an IrDA port. I haven't been able get this working with the files from Slackware 10.1, but who knows this is 10.2 now right. I have a HP DeskJet 450 I have been able to get it working over USB and Parallel with the script Rarsa provided, I was wondering if I should uninstall the current version of CUPS installed before I run your script or will it simply overwrite any necessary files?
-Jason
Back to top
View user's profile Send private message Visit poster's website 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Sun 06 Aug 2006, 03:30    Post subject: Re: CUPS installer  

vanchutr wrote:
Dear Pakt;
I'd installer successfully the CUPS by your instructions.
But I could'nt print the test page.
I use the EPSON EPL 5800L connected in parallel port.
I use the version Puppy 2.01 (installed on HDD)

vanchutr, could you attach your cups error log to a post?

Pack the error log file:

# tar -czf errorlog.tar.gz /var/log/cups/error_log

Then attach file errorlog.tar.gz to a new forum post so we can examine it.
Back to top
View user's profile Send private message 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Sun 06 Aug 2006, 04:19    Post subject:  

Buteman wrote:
Hi,
Further checking has shown that printing works from seamonkey if I choose the correct printer from the list presented but does not work from abiword, leafpad etc.
Still puzzeled.
norm

Ok, I think I have at least a partial answer. I've connected my parallel port printer to a second PC running Puppy 2.02 in my network. Then from my first PC running Puppy 1.07 with CUPS installed (and normally printing through a wireless gateway printer server), I open AbiWord with a text document, click on File -> Print... -> 'Location: Custom' I changed 'lpr' to 'lp -d HL1030@192.168.0.191' (the name I gave my printer@the IP-address of the second PC). The text file printed successfully!

(See attached image)

EDIT: This also worked from GSview

Hope this works for you.
Paul
abiword_network_printing.jpg
 Description   
 Filesize   33.18 KB
 Viewed   1216 Time(s)

abiword_network_printing.jpg


Last edited by pakt on Sun 06 Aug 2006, 04:42; edited 1 time in total
Back to top
View user's profile Send private message 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Sun 06 Aug 2006, 04:37    Post subject: Re: IrDA  

can8v wrote:
I would like to test this new install script over an IrDA port. I haven't been able get this working with the files from Slackware 10.1, but who knows this is 10.2 now right. I have a HP DeskJet 450 I have been able to get it working over USB and Parallel with the script Rarsa provided, I was wondering if I should uninstall the current version of CUPS installed before I run your script or will it simply overwrite any necessary files?
-Jason

Actually the only file that was updated between 10.1 and 10.2 was espgs-xxx. I then added gimp-print-xxx, so running my script *should* just update & add to your original files. You might make a backup first just to be on the safe side.

Please let us know if you get IrDA printing to work, and if so, how you did it Wink
Back to top
View user's profile Send private message 
vanchutr

Joined: 05 Aug 2006
Posts: 427

PostPosted: Sun 06 Aug 2006, 08:29    Post subject: Print CUPS  

Dear Pakt
I provide some informations with after my installation Epson 5800L Printer.

In consol (Terminal) I lauch the command:
# lp testfile.txt
ang got the message:
request id is Epson-EPL-5800L-epl5800l-4 (1 file(s))
But nothing comes into my Printer.

# lp stat -p-d
that give:
printer Epson-EPL-5800L-epl5800l is idle, enable since Jan 01:00:00 system default destination: EpsonEPL-5800L-epl5800l

# lp -d Epson-EPL-5800L-epl5800l -0 testfile.txt
that give:
lp: unable to print file: client-error-not-found

Do that mean: I'd installed succesfully my Epson Printer?
I trap what error that don't allowed me to print with my Printer?
(Sorry about my bad english)
Thank a lots
Back to top
View user's profile Send private message 
vanchutr

Joined: 05 Aug 2006
Posts: 427

PostPosted: Sun 06 Aug 2006, 08:44    Post subject: error-log  

Dear Pakt,
I send you the contents of /var/log/cups/error_log
I [04/Aug/2006:23:42:30 +0800] Listening to 0:631
I [04/Aug/2006:23:42:30 +0800] Loaded configuration file "/etc/cups/cupsd.conf"
I [04/Aug/2006:23:42:30 +0800] Configured for up to 100 clients.
I [04/Aug/2006:23:42:30 +0800] Allowing up to 100 client connections per host.
I [04/Aug/2006:23:42:30 +0800] Full reload is required.
I [04/Aug/2006:23:42:30 +0800] LoadPPDs: Read "/etc/cups/ppds.dat", 16 PPDs...
I [04/Aug/2006:23:42:30 +0800] LoadPPDs: Wrote "/etc/cups/ppds.dat", 561 PPDs...
I [04/Aug/2006:23:42:30 +0800] Full reload complete.
I [04/Aug/2006:23:55:42 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=8392)
I [04/Aug/2006:23:56:01 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=8471)
I [04/Aug/2006:23:56:42 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=8633)
I [04/Aug/2006:23:57:01 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=8711)
I [04/Aug/2006:23:57:26 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=8824)
I [04/Aug/2006:23:57:37 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=8853)
I [05/Aug/2006:00:07:53 +0800] Scheduler shutting down normally.
I [05/Aug/2006:01:25:25 +0800] Listening to 0:631
I [05/Aug/2006:01:25:25 +0800] Loaded configuration file "/etc/cups/cupsd.conf"
I [05/Aug/2006:01:25:25 +0800] Configured for up to 100 clients.
I [05/Aug/2006:01:25:25 +0800] Allowing up to 100 client connections per host.
I [05/Aug/2006:01:25:25 +0800] Full reload is required.
I [05/Aug/2006:01:25:25 +0800] LoadPPDs: Read "/etc/cups/ppds.dat", 561 PPDs...
I [05/Aug/2006:01:25:25 +0800] LoadPPDs: No new or changed PPDs...
I [05/Aug/2006:01:25:25 +0800] Full reload complete.
I [05/Aug/2006:01:37:38 +0800] Listening to 0:631
I [05/Aug/2006:01:37:38 +0800] Loaded configuration file "/etc/cups/cupsd.conf"
I [05/Aug/2006:01:37:38 +0800] Configured for up to 100 clients.
I [05/Aug/2006:01:37:38 +0800] Allowing up to 100 client connections per host.
I [05/Aug/2006:01:37:38 +0800] Full reload is required.
I [05/Aug/2006:01:37:39 +0800] LoadPPDs: Read "/etc/cups/ppds.dat", 16 PPDs...
I [05/Aug/2006:01:37:39 +0800] LoadPPDs: Wrote "/etc/cups/ppds.dat", 562 PPDs...
I [05/Aug/2006:01:37:39 +0800] Full reload complete.
I [05/Aug/2006:01:38:58 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=3845)
I [05/Aug/2006:01:39:03 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=3874)
I [05/Aug/2006:01:40:09 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=4117)
I [05/Aug/2006:01:40:21 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=4167)
I [05/Aug/2006:01:40:30 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=4218)
I [05/Aug/2006:01:42:03 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=4584)
I [05/Aug/2006:01:42:03 +0800] Setting Epson-EPL-5800L-epl5800l device-uri to "parallel:/dev/lp0" (was "file:/dev/null".)
I [05/Aug/2006:01:42:03 +0800] Setting Epson-EPL-5800L-epl5800l printer-is-accepting-jobs to 1 (was 0.)
I [05/Aug/2006:01:42:03 +0800] Setting Epson-EPL-5800L-epl5800l printer-state to 3 (was 5.)
I [05/Aug/2006:01:42:03 +0800] Saving printers.conf...
I [05/Aug/2006:01:42:03 +0800] New printer 'Epson-EPL-5800L-epl5800l' added by ''.
I [05/Aug/2006:01:42:39 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=4726)
I [05/Aug/2006:01:42:49 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=4776)
I [05/Aug/2006:01:43:20 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=4896)
I [05/Aug/2006:01:43:21 +0800] Saving printers.conf...
I [05/Aug/2006:01:43:21 +0800] Printer 'Epson-EPL-5800L-epl5800l' modified by ''.
I [05/Aug/2006:01:43:28 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=4918)
I [05/Aug/2006:01:43:41 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=4968)
I [05/Aug/2006:01:43:41 +0800] Saving printers.conf...
I [05/Aug/2006:01:43:41 +0800] Printer 'Epson-EPL-5800L-epl5800l' rejecting jobs ('').
I [05/Aug/2006:01:43:48 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=4997)
I [05/Aug/2006:01:44:02 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5068)
I [05/Aug/2006:01:44:02 +0800] print_job: destination 'Epson-EPL-5800L-epl5800l' is not accepting jobs.
I [05/Aug/2006:01:44:13 +0800] Started "/usr/lib/cups/cgi-bin/jobs.cgi" (pid=5111)
I [05/Aug/2006:01:44:16 +0800] Started "/usr/lib/cups/cgi-bin/jobs.cgi" (pid=5119)
I [05/Aug/2006:01:44:26 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5162)
I [05/Aug/2006:01:44:41 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5212)
I [05/Aug/2006:01:44:41 +0800] Saving printers.conf...
I [05/Aug/2006:01:44:41 +0800] Printer 'Epson-EPL-5800L-epl5800l' stopped by ''.
I [05/Aug/2006:01:44:52 +0800] Started "/usr/lib/cups/cgi-bin/jobs.cgi" (pid=5262)
I [05/Aug/2006:01:45:00 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5317)
I [05/Aug/2006:01:45:07 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5341)
I [05/Aug/2006:01:45:30 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5420)
I [05/Aug/2006:01:45:31 +0800] Saving printers.conf...
I [05/Aug/2006:01:45:31 +0800] Printer 'Epson-EPL-5800L-epl5800l' modified by ''.
I [05/Aug/2006:01:45:36 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5442)
I [05/Aug/2006:01:45:40 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5464)
I [05/Aug/2006:01:45:40 +0800] print_job: destination 'Epson-EPL-5800L-epl5800l' is not accepting jobs.
I [05/Aug/2006:01:45:50 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5514)
I [05/Aug/2006:01:46:04 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5564)
I [05/Aug/2006:01:46:11 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5586)
I [05/Aug/2006:01:46:54 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5755)
I [05/Aug/2006:01:46:55 +0800] Saving printers.conf...
I [05/Aug/2006:01:46:55 +0800] Printer 'Epson-EPL-5800L-epl5800l' modified by ''.
I [05/Aug/2006:01:47:01 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5784)
I [05/Aug/2006:01:47:16 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5855)
I [05/Aug/2006:01:47:24 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5877)
I [05/Aug/2006:01:47:25 +0800] Saving printers.conf...
I [05/Aug/2006:01:47:25 +0800] Printer 'Epson-EPL-5800L-epl5800l' modified by ''.
I [05/Aug/2006:01:47:29 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5906)
I [05/Aug/2006:01:47:40 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5949)
I [05/Aug/2006:01:47:40 +0800] Saving printers.conf...
I [05/Aug/2006:01:47:40 +0800] Printer 'Epson-EPL-5800L-epl5800l' now accepting jobs ('').
I [05/Aug/2006:01:47:46 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5978)
I [05/Aug/2006:01:48:01 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=6028)
I [05/Aug/2006:01:48:01 +0800] Saving printers.conf...
I [05/Aug/2006:01:48:01 +0800] Printer 'Epson-EPL-5800L-epl5800l' started by ''.
I [05/Aug/2006:01:48:14 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=6078)
I [05/Aug/2006:01:48:18 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=6100)
I [05/Aug/2006:01:48:18 +0800] Adding start banner page "none" to job 1.
I [05/Aug/2006:01:48:18 +0800] Adding end banner page "none" to job 1.
I [05/Aug/2006:01:48:18 +0800] Job 1 queued on 'Epson-EPL-5800L-epl5800l' by ''.
I [05/Aug/2006:01:48:18 +0800] Started filter /usr/lib/cups/filter/pstops (PID 6101) for job 1.
I [05/Aug/2006:01:48:18 +0800] Started filter /usr/lib/cups/filter/foomatic-rip (PID 6102) for job 1.
I [05/Aug/2006:01:48:18 +0800] Started backend /usr/lib/cups/backend/parallel (PID 6103) for job 1.
E [05/Aug/2006:01:48:18 +0800] PID 6102 stopped with status 3!
I [05/Aug/2006:01:48:18 +0800] Hint: Try setting the LogLevel to "debug" to find out more.
I [05/Aug/2006:01:49:05 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=6325)
I [05/Aug/2006:01:49:21 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=6375)
I [05/Aug/2006:01:49:22 +0800] Saving printers.conf...
I [05/Aug/2006:01:49:22 +0800] Printer 'Epson-EPL-5800L-epl5800l' modified by ''.
I [05/Aug/2006:01:49:26 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=6397)
I [05/Aug/2006:01:49:36 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=6447)
I [05/Aug/2006:01:49:36 +0800] Adding start banner page "none" to job 2.
I [05/Aug/2006:01:49:36 +0800] Adding end banner page "none" to job 2.
I [05/Aug/2006:01:49:36 +0800] Job 2 queued on 'Epson-EPL-5800L-epl5800l' by ''.
I [05/Aug/2006:01:49:36 +0800] Started filter /usr/lib/cups/filter/pstops (PID 6448) for job 2.
I [05/Aug/2006:01:49:36 +0800] Started filter /usr/lib/cups/filter/foomatic-rip (PID 6449) for job 2.
I [05/Aug/2006:01:49:36 +0800] Started backend /usr/lib/cups/backend/parallel (PID 6450) for job 2.
E [05/Aug/2006:01:49:36 +0800] PID 6449 stopped with status 3!
I [05/Aug/2006:01:49:36 +0800] Hint: Try setting the LogLevel to "debug" to find out more.
I [05/Aug/2006:01:49:56 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=6525)
I [05/Aug/2006:01:49:56 +0800] Saving printers.conf...
I [05/Aug/2006:01:49:56 +0800] Saving classes.conf...
I [05/Aug/2006:01:49:56 +0800] Default destination set to 'Epson-EPL-5800L-epl5800l' by ''.
I [05/Aug/2006:01:50:23 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=6653)
I [05/Aug/2006:02:03:07 +0800] Scheduler shutting down normally.
I [05/Aug/2006:17:00:55 +0800] Listening to 0:631
I [05/Aug/2006:17:00:55 +0800] Loaded configuration file "/etc/cups/cupsd.conf"
I [05/Aug/2006:17:00:55 +0800] Configured for up to 100 clients.
I [05/Aug/2006:17:00:55 +0800] Allowing up to 100 client connections per host.
I [05/Aug/2006:17:00:55 +0800] Full reload is required.
I [05/Aug/2006:17:00:55 +0800] LoadPPDs: Read "/etc/cups/ppds.dat", 562 PPDs...
I [05/Aug/2006:17:00:55 +0800] LoadPPDs: No new or changed PPDs...
I [05/Aug/2006:17:00:55 +0800] Full reload complete.
I [05/Aug/2006:17:11:06 +0800] Scheduler shutting down normally.
I [06/Aug/2006:01:12:03 +0800] Listening to 0:631
I [06/Aug/2006:01:12:03 +0800] Loaded configuration file "/etc/cups/cupsd.conf"
I [06/Aug/2006:01:12:03 +0800] Configured for up to 100 clients.
I [06/Aug/2006:01:12:03 +0800] Allowing up to 100 client connections per host.
I [06/Aug/2006:01:12:03 +0800] Full reload is required.
I [06/Aug/2006:01:12:03 +0800] LoadPPDs: Read "/etc/cups/ppds.dat", 562 PPDs...
I [06/Aug/2006:01:12:03 +0800] LoadPPDs: No new or changed PPDs...
I [06/Aug/2006:01:12:03 +0800] Full reload complete.
I [06/Aug/2006:01:18:01 +0800] Adding start banner page "none" to job 3.
I [06/Aug/2006:01:18:01 +0800] Adding end banner page "none" to job 3.
I [06/Aug/2006:01:18:01 +0800] Job 3 queued on 'Epson-EPL-5800L-epl5800l' by 'root'.
I [06/Aug/2006:01:18:01 +0800] Started filter /usr/lib/cups/filter/texttops (PID 2361) for job 3.
I [06/Aug/2006:01:18:01 +0800] Started filter /usr/lib/cups/filter/pstops (PID 2362) for job 3.
I [06/Aug/2006:01:18:01 +0800] Started filter /usr/lib/cups/filter/foomatic-rip (PID 2363) for job 3.
I [06/Aug/2006:01:18:01 +0800] Started backend /usr/lib/cups/backend/parallel (PID 2364) for job 3.
E [06/Aug/2006:01:18:01 +0800] PID 2363 stopped with status 3!
I [06/Aug/2006:01:18:01 +0800] Hint: Try setting the LogLevel to "debug" to find out more.
I [06/Aug/2006:01:18:56 +0800] Adding start banner page "none" to job 4.
I [06/Aug/2006:01:18:56 +0800] Adding end banner page "none" to job 4.
I [06/Aug/2006:01:18:56 +0800] Job 4 queued on 'Epson-EPL-5800L-epl5800l' by 'root'.
I [06/Aug/2006:01:18:56 +0800] Started filter /usr/lib/cups/filter/texttops (PID 2456) for job 4.
I [06/Aug/2006:01:18:56 +0800] Started filter /usr/lib/cups/filter/pstops (PID 2457) for job 4.
I [06/Aug/2006:01:18:56 +0800] Started filter /usr/lib/cups/filter/foomatic-rip (PID 2458) for job 4.
I [06/Aug/2006:01:18:56 +0800] Started backend /usr/lib/cups/backend/parallel (PID 2459) for job 4.
E [06/Aug/2006:01:18:56 +0800] PID 2458 stopped with status 3!
I [06/Aug/2006:01:18:56 +0800] Hint: Try setting the LogLevel to "debug" to find out more.
E [06/Aug/2006:01:23:32 +0800] print_job: resource name '/printers/Epson-EPL-5800L-epl5800l-4' no good!
I [06/Aug/2006:01:24:44 +0800] Adding start banner page "none" to job 5.
I [06/Aug/2006:01:24:44 +0800] Adding end banner page "none" to job 5.
I [06/Aug/2006:01:24:44 +0800] Job 5 queued on 'Epson-EPL-5800L-epl5800l' by 'root'.
I [06/Aug/2006:01:24:44 +0800] Started filter /usr/lib/cups/filter/texttops (PID 3283) for job 5.
I [06/Aug/2006:01:24:44 +0800] Started filter /usr/lib/cups/filter/pstops (PID 3284) for job 5.
I [06/Aug/2006:01:24:44 +0800] Started filter /usr/lib/cups/filter/foomatic-rip (PID 3285) for job 5.
I [06/Aug/2006:01:24:44 +0800] Started backend /usr/lib/cups/backend/parallel (PID 3286) for job 5.
E [06/Aug/2006:01:24:44 +0800] PID 3285 stopped with status 3!
I [06/Aug/2006:01:24:44 +0800] Hint: Try setting the LogLevel to "debug" to find out more.
I [06/Aug/2006:01:29:01 +0800] Adding start banner page "none" to job 6.
I [06/Aug/2006:01:29:01 +0800] Adding end banner page "none" to job 6.
I [06/Aug/2006:01:29:01 +0800] Job 6 queued on 'Epson-EPL-5800L-epl5800l' by 'root'.
I [06/Aug/2006:01:29:01 +0800] Started backend /usr/lib/cups/backend/parallel (PID 4316) for job 6.
E [06/Aug/2006:01:30:22 +0800] print_job: resource name '/printers/Epson-EPL-5800L-epl5800l-0' no good!
I [06/Aug/2006:01:33:17 +0800] Started "/usr/lib/cups/cgi-bin/jobs.cgi" (pid=5347)
I [06/Aug/2006:01:33:26 +0800] Started "/usr/lib/cups/cgi-bin/classes.cgi" (pid=5376)
I [06/Aug/2006:01:33:31 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=5398)
I [06/Aug/2006:01:33:37 +0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5420)
I [06/Aug/2006:01:34:45 +0800] Scheduler shutting down normally.
I [06/Aug/2006:04:14:17 +0800] Listening to 0:631
I [06/Aug/2006:04:14:17 +0800] Loaded configuration file "/etc/cups/cupsd.conf"
I [06/Aug/2006:04:14:17 +0800] Configured for up to 100 clients.
I [06/Aug/2006:04:14:17 +0800] Allowing up to 100 client connections per host.
I [06/Aug/2006:04:14:17 +0800] Full reload is required.
I [06/Aug/2006:04:14:17 +0800] LoadPPDs: Read "/etc/cups/ppds.dat", 562 PPDs...
I [06/Aug/2006:04:14:17 +0800] LoadPPDs: No new or changed PPDs...
I [06/Aug/2006:04:14:17 +0800] Full reload complete.
I [06/Aug/2006:04:30:10 +0800] Scheduler shutting down normally.
I [06/Aug/2006:05:32:55 +0800] Listening to 0:631
I [06/Aug/2006:05:32:55 +0800] Loaded configuration file "/etc/cups/cupsd.conf"
I [06/Aug/2006:05:32:55 +0800] Configured for up to 100 clients.
I [06/Aug/2006:05:32:55 +0800] Allowing up to 100 client connections per host.
I [06/Aug/2006:05:32:55 +0800] Full reload is required.
I [06/Aug/2006:05:32:55 +0800] LoadPPDs: Read "/etc/cups/ppds.dat", 562 PPDs...
I [06/Aug/2006:05:32:55 +0800] LoadPPDs: No new or changed PPDs...
I [06/Aug/2006:05:32:55 +0800] Full reload complete.
errorlog.tar.gz
Description 
gz

 Download 
Filename  errorlog.tar.gz 
Filesize  1.98 KB 
Downloaded  371 Time(s) 
Back to top
View user's profile Send private message 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Sun 06 Aug 2006, 09:25    Post subject: Re: error-log  

vanchutr, thanks for the file, but please just attach it to the post next time - don't print it out. It takes too much space!

You need to change the detail level of the log file. Please do the following:

1. Edit /etc/cups/cupsd.conf and change the line that says "LogLevel info" to "LogLevel debug" and save the file.

2. Delete /var/log/cups/error_log

3. Re-start CUPS:

# /etc/rc.d/rc.cups start

4. Now try to print again, then pack the new error log file:

# tar -czf errorlog.tar.gz /var/log/cups/error_log

and attach file errorlog.tar.gz to a new forum post. Don't print it out!
Back to top
View user's profile Send private message 
vanchutr

Joined: 05 Aug 2006
Posts: 427

PostPosted: Sun 06 Aug 2006, 10:06    Post subject: Printing with CUPS  

Dear Pakt,
I send to you the /var/log/cups/error_log (attached .gz file)
errorlog.tar.gz
Description 
gz

 Download 
Filename  errorlog.tar.gz 
Filesize  3.87 KB 
Downloaded  375 Time(s) 
Back to top
View user's profile Send private message 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Sun 06 Aug 2006, 10:39    Post subject:  

vanchutr, the problem seems to here in the error log:
Quote:
D [06/Aug/2006:06:59:14 +0800] [Job 7] renderer command: gs -q -dBATCH -dSAFER -dNOPAUSE -sProcessColorModel=DeviceGray -dBitsPerSample=1 -sDEVICE=ijs -sIjsServer=ijs_server_epsonepl -dIjsUseOutputFD -sDeviceManufacturer=Epson -sDeviceModel=EPL5800L -sIjsParams="EplFlowControl=off,EplDpi=Class600,EplDensity=3,EplRitech=on,EplTonerSave=off," -sOutputFile=- -
D [06/Aug/2006:06:59:14 +0800] [Job 7]
D [06/Aug/2006:06:59:14 +0800] [Job 7] Closing renderer
D [06/Aug/2006:06:59:15 +0800] [Job 7] sh: ijs_server_epsonepl: command not found
D [06/Aug/2006:06:59:15 +0800] [Job 7] ESP Ghostscript 815.00: Can't start ijs server "ijs_server_epsonepl"

I checked on the net and found this on the ubuntu forum:
Quote:

Re: ijs_server_epsonepl not found from Denis Jacquerye at 2006-06-06 21:14:37 UTC

ijs_server_epsonepl was still not installed after I dist-upgraded to dapper.

What package contains it?
Re: ijs_server_epsonepl not found from Denis Jacquerye at 2006-06-06 21:39:58 UTC

I could not find any package with the ijs_server_epsonepl.
http://packages.ubuntu.com/cgi-bin/search_contents.pl?word=epsonepl&searchmode=searchword&case=insensitive&version=dapper&arch=i386

The file can be compiled from the Epson EPL-5x00L/EPL-6x00L Printer driver package
http://sourceforge.net/projects/epsonepl/

The cupsys PPD file calls gs with the -sIjsServer argument set to ijs_server_epsonepl but no package installs it.
Re: ijs_server_epsonepl not found from Ali Afshar at 2006-07-14 20:00:08 UTC

I can confirm that compiling http://sourceforge.net/projects/epsonepl/ and copying the resulting executable ijs_server_epsonepl to /usr/bin makes everything work perfectly.

Should this package be in Ubuntu somewhere?

It seems a file called 'ijs_server_epsonepl' is needed to make your printer work. I couldn't find it in the CUPS files.

Sorry, but I cannot help you more than this. Maybe someone else has a suggestion?
Back to top
View user's profile Send private message 
Buteman


Joined: 24 Jul 2006
Posts: 16
Location: Bute - Scotland

PostPosted: Sun 06 Aug 2006, 10:56    Post subject:  

Ok, I think I have at least a partial answer. I've connected my parallel port printer to a second PC running Puppy 2.02 in my network. Then from my first PC running Puppy 1.07 with CUPS installed (and normally printing through a wireless gateway printer server), I open AbiWord with a text document, click on File -> Print... -> 'Location: Custom' I changed 'lpr' to 'lp -d HL1030@192.168.0.191' (the name I gave my printer@the IP-address of the second PC). The text file printed successfully!
Hope this works for you.
Paul[/quote]

Thanks Paul,
This worked for abiword.
Any idea how to make this the default instead of having to type it in for every document?
tia,
Norm
Back to top
View user's profile Send private message 
vanchutr

Joined: 05 Aug 2006
Posts: 427

PostPosted: Sun 06 Aug 2006, 11:07    Post subject: install CUPS  

Dear Pakt,
Anyway, I must say thank you.
I will try the 'eps...ijs' deal with your comments.
Back to top
View user's profile Send private message 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Sun 06 Aug 2006, 11:16    Post subject:  

Buteman wrote:

Any idea how to make this the default instead of having to type it in for every document?

Found this on the net: http://cfm.gs.washington.edu/printing/cups/

'lpq' will show your default printer:
Code:
# lpq
HL1030 is not ready
Rank    Owner   Job     File(s)                         Total Size
1st     root    1       gsvxeDwRpm                      105472 bytes

Change the default printer like this:
Code:
# lpoptions -d HL1030@192.168.0.191

Now lpq shows:
Code:
# lpq
HL1030@192.168.0.191 is ready
no entries

Leave the AbiWord printer setting to 'lpr' and it will print to the new default printer. I tried it and it works.

This should work for all applications.

EDIT: I don't know if the change survives a re-boot. You may have to put the command in /etc/rc.d/rc.local so it executes every time you boot-up.
Back to top
View user's profile Send private message 
vanchutr

Joined: 05 Aug 2006
Posts: 427

PostPosted: Mon 07 Aug 2006, 08:59    Post subject: CUPS with Printer Epson EPL 5800L  

Dear Pakt,
You said:
'It seems a file called 'ijs_server_epsonepl' is needed to make your printer work. I couldn't find it in the CUPS files.'
That's exact. I follow your comments and instructions to install my Epson Printer. Now I can work with my PuppyLinux with Printer Epson in parallel port.
Thank you a lot.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 14 [197 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 12, 13, 14 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Announcements
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1528s ][ Queries: 12 (0.0089s) ][ GZIP on ]