Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 27 Mar 2015, 17:09
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
VLC 2.1.0 starting issue on slacko puppy 5.7
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
Greg1956

Joined: 18 Mar 2015
Posts: 7

PostPosted: Thu 19 Mar 2015, 23:10    Post subject:  VLC 2.1.0 starting issue on slacko puppy 5.7
Subject description: VLC doesn't appear to start from menu
 

Hi all,

after installing VLC onto Puppy 5.7, I'm not able to to get it to start/open from the menu.

It appears to have all its dependencies

any help would be appreciated

thanks
Greg
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5903
Location: Charleston S.C. USA

PostPosted: Fri 20 Mar 2015, 04:11    Post subject:  

How did you install VLC?
Details?

Any error messages if you try to run it from the console?

Open a console (terminal)
Code:
vlc

Hit enter.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Greg1956

Joined: 18 Mar 2015
Posts: 7

PostPosted: Fri 20 Mar 2015, 07:30    Post subject:  

here is the output of running vlc in Terminal

[0x80f8df8] main interface error: corrupt module: /usr/lib/vlc/plugins/control/libdbus_plugin.so
[0x80f8df8] main interface error: no suitable interface module
[0x804e3f8] main libvlc error: interface "dbus,none" initialization failed
[0x804e3f8] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x80f8df8] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[0x80f8df8] skins2 interface error: cannot instantiate qt4 dialogs provider
[0x80fe880] filesystem access error: cannot open file /root/2 (No such file or directory)
[0x80fe880] main access error: File reading failed
[0x80fe880] main access error: VLC could not open the file "/root/2" (No such file or directory).
[0xb6b005d0] main input error: open of `file:///root/2' failed
[0xb6b005d0] main input error: Your input can't be opened
[0xb6b005d0] main input error: VLC is unable to open the MRL 'file:///root/2'. Check the log for details.
[0x80f8df8] [cli] lua interface: Listening on host "*console".
VLC media player 2.1.0 Rincewind
Command Line Interface initialized. Type `help' for help.

thanks
Greg
Back to top
View user's profile Send private message 
Greg1956

Joined: 18 Mar 2015
Posts: 7

PostPosted: Fri 20 Mar 2015, 07:36    Post subject:  

Sorry missed some info,

I had installed VLC via the Package manager with no success, so uninstalled it and downloaded the PET via Firefox, then ran the PET

Greg
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 9930

PostPosted: Fri 20 Mar 2015, 08:15    Post subject:  

No qt4 it seems...dbus may or may not be related ...never seen corrupt before...most odd.

mike
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 980
Location: London, England

PostPosted: Fri 20 Mar 2015, 08:33    Post subject: Re: VLC 2.1.0 starting issue on slacko puppy 5.7
Subject description: VLC doesn't appear to start from menu
 

Greg1956 wrote:
It appears to have all its dependencies

As Mike says, looks like you have not installed Qt which is the main dependency it needs. That VLC does run in Slacko 5.7 and I have got a modified version of it with the needed Qt libs added to make it install-and-go. I can upload that for you if you want to grab it. There may be something better or more recent somewhere though.

_________________
Oscar in England

Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 9930

PostPosted: Fri 20 Mar 2015, 08:35    Post subject:  

better is definately a matter of opinion Smile

but more to the point any idea what version of qt4 is required for vlc 2.1.0 ?

mike
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 966
Location: lincoln

PostPosted: Fri 20 Mar 2015, 08:39    Post subject:  

this is the one I use to use on my slacko install

http://distro.ibiblio.org/puppylinux/pet_packages-slacko/qt-everywhere-opensource-src-4.7.3-i686.pet

Smile
Back to top
View user's profile Send private message Visit poster's website 
mikeb


Joined: 23 Nov 2006
Posts: 9930

PostPosted: Fri 20 Mar 2015, 08:43    Post subject:  

ok...a later one here
https://www.dropbox.com/s/6xq9lzssq5mztis/QT4-4.8.6-Lucid_sfs4.sfs?dl=1

vlc will not actually need half the stuff in there... a quick ldd could allow taking out just the required ones.

mike
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 980
Location: London, England

PostPosted: Fri 20 Mar 2015, 09:09    Post subject:  

You would just need to use the Qt version that is associated with those Slackware 14.0 Slackos. In fact VLC only needs libQtCore and libQtGui but then depeding on how the Qt has been compiled you might need to throw in deps of the deps. With 01micko's Qt though you just need those two. What I did was fish them out, throw them in a private directory and use patchelf to set the rpath of the gui plugin to link to them.
_________________
Oscar in England

Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 9930

PostPosted: Fri 20 Mar 2015, 09:14    Post subject:  

would it be too much to suggest that the puppy vlc package maker actually include those 2 libs?,,,, and a non broken dbus?

I do it with sfs that need such as qt and wxwidgets...for that load and run feel to life Smile

mike
Back to top
View user's profile Send private message 
Greg1956

Joined: 18 Mar 2015
Posts: 7

PostPosted: Fri 20 Mar 2015, 17:11    Post subject:  

thanks guys,

I'll install QT4 via package manager and report back

thanks
Greg
Back to top
View user's profile Send private message 
Greg1956

Joined: 18 Mar 2015
Posts: 7

PostPosted: Fri 20 Mar 2015, 18:45    Post subject:  

Hi all,

found a lot of packages with QT4 as the description. so left that alone
Unistalled vlc 2.1.0

reinstalled vlc 2.1, checks for dependencies, 15mins later still locked
restart
uninstall vlc

run QT4 everywhere PET, it is in

reinstalled vlc 2.1, checks for dependencies, 15mins later still locked
restart
uninstall vlc

restart
it also says it has vlc 2.0.6 as well, unable to uninstall this

running from menu = nothing
running from terminal gives these errors

vlc 2.0.6
main libvlc error : option http-user-agent does not exist
main interface error : corrupt module: /usr/lib/vlc/plugins/gui/libqt_plugin.so

what else can you suggest??

thanks
Greg
Back to top
View user's profile Send private message 
Greg1956

Joined: 18 Mar 2015
Posts: 7

PostPosted: Today, at 02:51    Post subject:  

Hi all,

In the end I have reinstalled puppy 5.7, and have not installed vlc at all.

Each installation ended up as corrupt or missing dependencies, are the any other media players suitable for Puppy?

Thanks
Greg
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 9930

PostPosted: Today, at 06:21    Post subject:  

Well shame you seem to only find broken packages for this.

Gmplayer I usually use ...its has skins , can be built statically and uses gtk2 so non of this ridiculous dependency crap. You probably have the gnome-mplayer front end...again a bag of doggie doo...I believe its finally been dropped in tahr.

If its any use here is a gmplayer build..not the latest but will give you an idea for a quick test and some skins.
https://www.dropbox.com/s/l0morcz9fl3fx34/Mplayer-2010-rc4-test_sfs4.sfs?dl=1

smplayer is quite nice too... but you need qt4 again.

mike
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0915s ][ Queries: 11 (0.0083s) ][ GZIP on ]