Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 01 Mar 2015, 23:37
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
lxpanel
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
howardshippin

Joined: 13 Jan 2015
Posts: 7

PostPosted: Tue 13 Jan 2015, 09:26    Post subject:  lxpanel
Subject description: lxpanel doesn't start automatically
 

Hi
On tahr using quickpet I installed lxde by first using the pet and then afterwards installing the sfs: I now know I did that backwards.

I had the problem that someone else described of obtaining a double panel (jwm + lxpanel), so I uninstalled jwm. At first I didn't know how to start lxde, but then managed to start it by typing xwin openbox.

That's where I am now. When it starts, openbox starts, which is fine, except that I don't get the panel. I can obtain the panel via the terminal (nohup lxpanel &) however it does not start automatically when I boot into Puppy.

So what should I do? Logging out and using startx lxde or xwin start lxde do not succeed in getting me into Xorg.

Thanks.
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4625
Location: World_Hub

PostPosted: Tue 13 Jan 2015, 10:11    Post subject:  

Hello Howard, Welcome.

If not a stretch, why not reinstall? If it's the eye candy you're after, maybe run run one of these.

_________________
>>>Punctuation Crash Course<<<
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 4813
Location: Gatineau (Qc), Canada

PostPosted: Tue 13 Jan 2015, 12:45    Post subject:  

Hello, Howard.

1) First mix-up I see: you should have installed either the pet archive OR the sfs,
not both... sfs and *.pet are just different packagings of the same thing in Puppy.

Solution is to remove the sfs (with the on-th-fly sfs loader), then the pet (with the
PPM un-installer). Then re-install one OR the other. See how that goes.

2) Second thing I see, is that your .xinitrc file looks wrong. Usually that file checks
for other-than-jwm window manager then it lauchnes either fbpanel or lxpanel. You
mention that both the jwm panel and lxpanel are launched, and that shouldn't happen.

But try the solution in # 1) first. It might set # 2) straight as well. If not, I may
have a few "script tricks" for you. Wink

Good luck.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
howardshippin

Joined: 13 Jan 2015
Posts: 7

PostPosted: Tue 13 Jan 2015, 13:45    Post subject: lxpanel  

thanks Semme - since I've already done quite a lot of customization, and am using puppy as my main OS, it would be better for me to find a solution without doing a re-install.

thanks musher0 - regarding the pet + sfs, what I see on page 1 of this topic is:
1. Boot a pristine frugal install of the base Puppy
2. Copy the correct SFS for your puppy into a location where it can be loaded
3. Use SFS-Load-On-The-Fly to install the SFS (Do not run any of the components)
4. Install the correct lxpupsetup PET to match the SFS
5. Click the button to activate LxPup-by-SFS
6. Reboot and create a savefile

I think I did that backwards, i.e. installed the PET and then, when nothing happened, installed the SFS.

The problem of the JWM overlap has gone away, since I've uninstalled all of JWM. The only problem I currently know about is that the panel doesn't start up automatically. I need the terminal to start it. I've tried, unsuccessfully to put lxpanel in the programs that start up automatically via "Startup control" but it doesn't seem to stick there. I will try that a second time a bit later.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1702
Location: Worcestershire, UK

PostPosted: Tue 13 Jan 2015, 13:46    Post subject:  

Hi

If this process is to load "LxPup-by-SFS" then there is an sfs and a separate pet both of which have to be loaded in the sequence sfs then pet.

The setup pet should start LxPup automatically, but the command is

xwin startlxde

I haven't looked at what 666philb has offered via his quickpet - so I may be surmising wrongly.....

Cheers
peebee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Moat

Joined: 16 Jul 2013
Posts: 281

PostPosted: Tue 13 Jan 2015, 14:59    Post subject:  

peebee wrote:
... both of which have to be loaded in the sequence sfs then pet.


I wonder if just re-installing the .pet (again) might straighten things out...?

Or alternately, create a shellscript in the /root/Startup directory with the "xwin startlxde" command...?

Bob
Back to top
View user's profile Send private message 
howardshippin

Joined: 13 Jan 2015
Posts: 7

PostPosted: Tue 13 Jan 2015, 17:07    Post subject:  

thanks everyone - it came right now. I had the command to start the desktop wrong (xwin startlxde). It was enough to log out, log in via this command, then close while saving.

Previously, because I had the initialization command wrong, I was logging in just to openbox, then adding the panel via the terminal. There was actually an advantage in that, because it left the native tahrpup desktop intact, whereas now I've lost the puppy icons. If anyone knows how to get them back will be pleased to hear. Or perhaps you can't have it all ways.

The main reason I wanted lxde was to obtain the pcman filemanager, which I find more convenient than rox.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1702
Location: Worcestershire, UK

PostPosted: Wed 14 Jan 2015, 03:34    Post subject:  

howardshippin wrote:
thanks everyone - it came right now. I had the command to start the desktop wrong (xwin startlxde). It was enough to log out, log in via this command, then close while saving.

Previously, because I had the initialization command wrong, I was logging in just to openbox, then adding the panel via the terminal. There was actually an advantage in that, because it left the native tahrpup desktop intact, whereas now I've lost the puppy icons. If anyone knows how to get them back will be pleased to hear. Or perhaps you can't have it all ways.

The main reason I wanted lxde was to obtain the pcman filemanager, which I find more convenient than rox.


Desktop -> Change appearance -> Options -> Drive icons

but you don't really need them as all drives are displayed within PcManFM

Keep a clean desktop.....

If you want program icons on the desktop - right click on any menu item and choose "Add to desktop"

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
howardshippin

Joined: 13 Jan 2015
Posts: 7

PostPosted: Wed 14 Jan 2015, 17:14    Post subject:  

thank you for your response, peebee.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0621s ][ Queries: 11 (0.0037s) ][ GZIP on ]