Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 23 Aug 2019, 07:17
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Carolina: Vanguard Edition Release 2 December 2014
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 22 of 41 [615 Posts]   Goto page: Previous 1, 2, 3, ..., 20, 21, 22, 23, 24, ..., 39, 40, 41 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 12627
Location: Stratford, Ontario

PostPosted: Tue 17 Feb 2015, 23:06    Post subject:  

Before I download 500 MB, it would be nice if any Vanguard user confirmed whether CUPS printing works.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Tue 17 Feb 2015, 23:12    Post subject:  

TBH, I'd offer to try something else, but I'm on a desktop and of the two other printers I have with any semblance of function left (I've got a ton of derelicts), one's another HP (that I should probably order ink for as it's out) and the other is an older wires-only Canon on entirely the wrong floor of my house...
_________________

Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 1185
Location: SW Wisconsin

PostPosted: Wed 18 Feb 2015, 11:01    Post subject:  

rcrsn51 wrote:
Before I download 500 MB, it would be nice if any Vanguard user confirmed whether CUPS printing works.

Printing fine to my HP4500 using a standard HPLIP 3.14.10 install accepting all of the dependencies except sane. libnetsnmp-15 had already been installed. I had a minimal minimal install using HPLIP 3.11 in the savefile I had updated but like starhawk I got the 'format not supported' error message. Probably missing GS or foomatic (shown as dependencies by the HPLIP 3.14.10 pet and installed) but I didn't sort it out, just went the 3.14.10 route. You'd know what was missing.

Edited: After reading starhawks post on the previous page. Also stripped the savefile, cleaned /var/cache/CUPS, and did a fresh HPLIP 3.11.10 install from the PPM, leaving out gutenprint and sane 'dependencies' only. HP4500 (wired ethernet network printer) is printing fine with this install.

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, LxPupBionic and upupdd for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.

Last edited by Marv on Wed 18 Feb 2015, 12:33; edited 1 time in total
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Wed 18 Feb 2015, 12:29    Post subject:  

Problem exists, actually, with both the 3.11 dotPET and the 3.14 dotPET.

When I installed the 3.14 dotPET (after uninstalling the 3.11, of course) it showed no dependencies. That said, I'll see if I can find a Ghostscript dotPET in the repo, as that might resolve this.

_________________

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Wed 18 Feb 2015, 12:35    Post subject:  

Well, that didn't work Sad

The specific error I'm getting is:

Code:
Error:
         Unsupported format 'application/postscript'!

_________________

Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 1185
Location: SW Wisconsin

PostPosted: Wed 18 Feb 2015, 12:39    Post subject:  

starhawk wrote:
Problem exists, actually, with both the 3.11 dotPET and the 3.14 dotPET.

When I installed the 3.14 dotPET (after uninstalling the 3.11, of course) it showed no dependencies. That said, I'll see if I can find a Ghostscript dotPET in the repo, as that might resolve this.


See my post above, I edited while you were posting. PPM HPLIP does show dependencies.. for me anyway. I'm pretty sure it is GS that is missing. rcrsn51 would have the final word. I usually need a reboot after the installs before everything seems to be recognized.

Cheers,

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, LxPupBionic and upupdd for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Wed 18 Feb 2015, 12:49    Post subject:  

I downloaded forum HPLIP. Hmm... okay, I'll uninstall that and try the PPM HPLIP.
_________________

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12627
Location: Stratford, Ontario

PostPosted: Wed 18 Feb 2015, 12:51    Post subject:  

Marv wrote:
rcrsn51 would have the final word.

Vanguard is a descendent of Saluki. Jemimah had little interest in printing, so she stripped out all the key CUPS components like Ghostscript and put them in an SFS along with a dog's breakfast of printer drivers.

It sounds like Starhawk has not loaded this SFS. I would assume that it contains an old copy of hplip, which may or may not work with the Vanguard upgrades like glibc.

I also don't know what happens if you install a new version of hplip_print. Does it replace the old version in the SFS?
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Wed 18 Feb 2015, 13:00    Post subject:  

Well, rc, this is kind of entertaining.

I uninstalled the forum HPLIP (3.14) and installed the one from PPM (3.11!). It showed a whole pile of dependencies, installed 'em all.

Pulled up localhost:631 in Chromium, went to Printers and clicked the 'Print Test Page' for the printer in question. A job appeared underneath that printer, page length 'unknown' -- with no action from the printer proper.

Studied the buttons, one of which said 'start printer' -- clicked it.

My printer promptly proceeded to (quite loudly, as usual) spit out the test page.

I think we've [SOLVED] this one Very Happy Woohoo!

_________________

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Wed 18 Feb 2015, 14:46    Post subject:  

[REOPENED]

eVince produces blank pages and LibreOffice won't print landscape (it comes out on the lower half of a portrait page, cropped to heck).

This is going from annoying to "after-school Christmas pageant" special...

EDIT: eVince and LibreOffice versions as built into Vanguard. (LO is ver.4341, not sure about eVince.)

_________________

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12627
Location: Stratford, Ontario

PostPosted: Wed 18 Feb 2015, 16:40    Post subject:  

starhawk wrote:
LibreOffice won't print landscape (it comes out on the lower half of a portrait page, cropped to heck).

This issue has been discussed before. It is a consequence of Carolina being stuck on CUPS 1.3.11.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Wed 18 Feb 2015, 17:48    Post subject:  

Let me guess. The fix would be to upgrade CUPS, except that CUPS can't be upgraded for one reason or another, so there is no workable fix.

Am I right?

_________________

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12627
Location: Stratford, Ontario

PostPosted: Wed 18 Feb 2015, 17:54    Post subject:  

starhawk wrote:
Am I right?

I don't know. That's for the Carolina/Vanguard team to investigate.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Wed 18 Feb 2015, 18:09    Post subject:  

Well, then. I'll assume for now that you'd have mentioned a workaround if there was one...

@battleshooter, Geoffrey, et al. -- can you see if CUPS 1.4.x works in Vanguard? I personally would think that the newer kernel would support such a move, but I really don't know enough to be sure.

EDIT: added a name or two to the above...

_________________

Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1383
Location: Australia

PostPosted: Thu 19 Feb 2015, 00:28    Post subject:  

Right, sorry Starhawk, leaving you to work this out on your own for the last few days/weeks Confused

I've not had a problem with the CUPS in Carolina/Vanguard. Advanced options like printing wireless using the share printer option is a daily thing.

This is the default Carolina SFS with the printer drivers.

starhawk wrote:
Let me guess. The fix would be to upgrade CUPS, except that CUPS can't be upgraded for one reason or another, so there is no workable fix.

Am I right?


I don't know. I only upgrade things when they're broke, so I hadn't considered CUPS till now. I can look into it. Sort of hoping Geoff will chime in about now as he's my go to man for all things Carolina.

I still need to follow the criss cross of posts and try to understand the partial solution you've posted. Been sick, still am sick, nothing serious, just common flu, but it makes it hard to think.

Sage wrote:
GetFlash v.11 in Wary64 6.99 works OK


So can you use that GetFlash in Vanguard? I think later on in the Wary 64 thread, Barry says it's actually from Slacko 64.

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 22 of 41 [615 Posts]   Goto page: Previous 1, 2, 3, ..., 20, 21, 22, 23, 24, ..., 39, 40, 41 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0998s ][ Queries: 12 (0.0368s) ][ GZIP on ]