Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 24 Sep 2017, 13:49
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
Lenovo G400 laptop Ethernet card not detected by Lucid 528
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
SunriSe

Joined: 08 Dec 2014
Posts: 1

PostPosted: Mon 08 Dec 2014, 14:11    Post subject:  Lenovo G400 laptop Ethernet card not detected by Lucid 528  

I bought a Lenovo G400 laptop today , i can run internet on lan in Windows without any problem but when i am running puppy linux on my laptop, it doesn't detect my Ethernet card. When running ifconfig command, it just shows loopback interface and nothing else. Below are results of some commands:

#lspci | grep Ether

01:00.0 Ethernet Controler: Atheros Communications Device 10a0 (rev 10)

#lspci -vm -s 01:00.0

Device: 01:00.0
class: Ethernet
vendor: Atheros Communucations
SVendor: lenovo
SDevice: Device 3804
Rev: 10

I am using Lucid Puppy 5.2.8 . I seached about this problem on google but i could not find a solution to fix this in Puppy Linux.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 11580
Location: Stratford, Ontario

PostPosted: Mon 08 Dec 2014, 14:23    Post subject:  

Lucid 528 has an old kernel. You should try a new Puppy like Tahrpup 6.0 that has better hardware support.

Please run: lspci -nn | grep Ether
Back to top
View user's profile Send private message 
ardvark


Joined: 01 Jul 2013
Posts: 1458
Location: USA

PostPosted: Mon 08 Dec 2014, 17:25    Post subject:  

rcrsn51 wrote:
Lucid 528 has an old kernel. You should try a new Puppy like Tahrpup 6.0 that has better hardware support.


I would agree. From the device number, I think the ethernet adapter is Qualcomm Atheros QCA8172 Fast Ethernet, which would require the "alx" driver. I really don't think Lucid has this module. Wink

If one of the Puppies has the 3.8.13 kernel, you could try using the alx driver listed here. You would also need to make sure that "make" and whatever else is needed is installed.

Regards...

_________________
Our Lord and Savior Jesus Christ loves and cares about you most of all!

PLEASE READ! You don't have to end up here!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0495s ][ Queries: 11 (0.0059s) ][ GZIP on ]