(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
https://forum.puppylinux.com
and continue your work there. Thank you.

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 26 Jan 2021, 04:43
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
PuppEX Tahr Linux Live CD with kernel 4.0.1-PAE-puppex
Moderators: Flash, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 4 of 4 [55 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message
James C


Joined: 26 Mar 2009
Posts: 6735
Location: Kentucky

PostPosted: Tue 10 Mar 2015, 01:05    Post subject:  

Great job as usual.

Code:
sh-4.3# report-video
VIDEO REPORT: puppex, version 6.0

Chip description:
VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750] (rev a2)

Requested by /etc/X11/xorg.conf:
  Resolution (widthxheight, in pixels): 1024x768x16
  Depth (bits, or planes):              24
  Modules requested to be loaded:       dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
  Driver loaded (and currently in use): nvidia
  Loaded modules: dbe dri2 extmod fb glx kbd mouse ramdac wfb

Actual rendering on monitor:
  Resolution:  1920x1080 pixels (513x292 millimeters)
  Depth:       24 planes

...the above also recorded in /tmp/report-video
sh-4.3#


Code:
sh-4.3# uname -a
Linux puppex 3.19.1-PAE-puppex #2 SMP Mon Mar 9 06:13:11 EDT 2015 i686 athlon i686 GNU/Linux
sh-4.3#
Puppex.jpg
 Description   
 Filesize   100.08 KB
 Viewed   826 Time(s)

Puppex.jpg

Back to top
View user's profile Send private message 
cinclus_cinclus

Joined: 22 Feb 2009
Posts: 68

PostPosted: Tue 10 Mar 2015, 07:07    Post subject: Re: News
Subject description: About the new version
 

@exton
exton wrote:
NEWS 150309
A new version of PuppEX Tahr ... changed kernel ... to 3.19.1-PAE-puppex
READ MORE...


Your kernel uses a 300HZ timer frequency. I would be glad if I could use another/same kernel with 1000HZ tick for use with the MusE MIDI/Audio sequencer with needs a tick-rate of at least 500HZ.

@stemsee
could I use one of your 1000HZ kernels?

Any hints highly appreciated.

If I myself had to build a kernel with 1000HZ tick please hint me at a suitable kernel source.

cinclus_cinclus
Back to top
View user's profile Send private message 
cinclus_cinclus

Joined: 22 Feb 2009
Posts: 68

PostPosted: Wed 11 Mar 2015, 11:15    Post subject: Re: News
Subject description: About the new version
 

cinclus_cinclus wrote:

If I myself had to build a kernel with 1000HZ tick please hint me at a suitable kernel source.


All kernel-sources are downloadable via quickpet. Sorry, did not expect that.

-cinclus_cinclus
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2572
Location: In The Way

PostPosted: Wed 11 Mar 2015, 17:56    Post subject:  

be my guest!
Back to top
View user's profile Send private message MSN Messenger 
exton


Joined: 02 Jan 2007
Posts: 87
Location: Sweden

PostPosted: Thu 30 Apr 2015, 17:28    Post subject: NEWS about PuppEX 150501
Subject description: Kernel 4.0.1-PAE-puppex
 

NEWS 150501
PuppEX Tahr build 150501 uses a PAE enabled kernel - 4.0.1-PAE-puppex. (Kernel 4.0.1 was released 150429). With PAE compiled into the kernel PuppEX can address up to 64GB of RAM. Google Chrome is now included. Just to make it possible to watch Netflix movies. I've also added Tahrpup's Service Pack 6.0.2. NVIDIA Graphics driver 346.59 is installed.

READ MORE...
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 6735
Location: Kentucky

PostPosted: Thu 30 Apr 2015, 19:04    Post subject:  

Downloaded. Works well with my GTX-750 card.

Thanks for the great work. Smile
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 6735
Location: Kentucky

PostPosted: Fri 01 May 2015, 00:53    Post subject:  

Code:
-Computer-
Processor      : 8x AMD FX(tm)-8320 Eight-Core Processor
Memory      : 8193MB (427MB used)
Machine Type      : Physical machine
Operating System      : puppex - 6.0
User Name      : root (root)
Date/Time      : Thu 30 Apr 2015 11:52:32 PM CDT
-Display-
Resolution      : 1920x1080 pixels
OpenGL Renderer      : GeForce GTX 750/PCIe/SSE2
X11 Vendor      : The X.Org Foundation
-Audio Devices-
Audio Adapter      : HDA-Intel - HDA ATI SB
Audio Adapter      : HDA-Intel - HDA NVidia
Audio Adapter      : PC-Speaker - pcsp


Code:
-Version-
Kernel      : Linux 4.0.1-PAE-puppex (i686)
Version      : #2 SMP Thu Apr 30 16:12:20 EDT 2015
C Library      : GNU C Library version 2.19 (stable)
Distribution      : puppex - 6.0
-Current Session-
Computer Name      : puppex
User Name      : root (root)
Home Directory      : /root
Desktop Environment      : Unknown (Window Manager: JWM)
-Misc-
Uptime      : 6 minutes
Load Average      : 0.85, 0.59, 0.29
Back to top
View user's profile Send private message 
exton


Joined: 02 Jan 2007
Posts: 87
Location: Sweden

PostPosted: Fri 01 May 2015, 10:57    Post subject: Thanks!  

James C,

Thanks for your report. I'm glad to hear that everything works for you.

/Arne
Back to top
View user's profile Send private message Visit poster's website 
charlie6


Joined: 30 Jun 2008
Posts: 1231
Location: Saint-Gérard / Walloon part of Belgium

PostPosted: Sun 03 May 2015, 01:26    Post subject:  

Hi exton,

Thanks for this PuppeX Tahr build 4.0.1 !
Running OOTB nicely even on an old PIV featured with intel 82845G Brookdale video chip !

Here have installed PuppeX on an USB memory key using the builtin Puppy Installer.
When booting, among the numerous boots comments and upon loading the tahrsave-XXX.4fs file, it keeps telling this:
Quote:
...Loading personal file /tahrsave-XXX.4fs ... Fat-fs (sdb1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck...


The USB key is kept plugged-in all the time. Also there is no attempt to mount/unmount it.
This although it now runs fsck as I have edited syslinux.cfg and added pfix=fsck, like this:
Code:
default vmlinuz initrd=initrd.gz pmedia=usbflash pfix=fsck


Do one have to further worry about that comment? If yes, how?
Or is it only a warning that we may ignore, as things seems to run flawlessly?

Thanks for any answer !
Best regards, Charlie.
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1231
Location: Saint-Gérard / Walloon part of Belgium

PostPosted: Mon 04 May 2015, 12:59    Post subject: [SOLVED] openGL not working on common Intel Graphic card
Subject description: ...no nvidia card present on PC
 

Hi,

[SOLVED] : see at bottom this post

here on a Dell620 laptop with an Intel video chip (no Nvidia graphic card), i get this:
Code:
sh-4.3# glxinfo
name of display: :0
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
sh-4.3#


this does not happen on Tahrpup-6.0.

I presume some GLX/DRI stuffs missing.
I have installed libgl1-mesa-glx and libgl1-mesa-dri
+ edited xorg.conf to load glx and dri.
Without success...

Thanks for any help.
Charlie

solution:
first have a look at this link:
http://ubuntuforums.org/showthread.php?t=1301433

next:
have deleted some files (here PuppeX has been frugal installed)
1. have deleted all nvidia stuffs using Pfind + «nvidia» search string (this might be not necessary ...see 2. below)
2. have deleted /usr/lib/libGL.so.346.59 (i believe this might be enough)
3. have deleted /usr/lib/xorg/modules/extensions/libglx.so.346.59 as also its symlink /usr/lib/xorg/modules/extensions/libglx.so

have downloaded using PPM and installed only (no need for extra dependencies):
1. xserver-xorg-core_1.15.1-0ubuntu2.7_i386.deb, with search string xserver-xorg-core
2. libgl1-mesa-glx_10.1.3-0ubuntu0.4_i386.deb, with search string libgl1-mesa-glx
3. move or copy /usr/lib/mesa/libGL.so.1.2.0 to /usr/lib
4. make symlinks pointing to /usr/lib/libGL.so.1.2.0:
Code:
sh-4.3# ln -s /usr/lib/libGL.so.1.2.0 /usr/lib/libGL.so.1
sh-4.3# ln -s /usr/lib/libGL.so.1.2.0 /usr/lib/libGL.so


Then have exited to prompt (---> Menu/Exit/Exit to prompt) and then
ran xorgwizard to rebuild xorg.conF
and
xwin to restart X

Then check if all OK by running «report-video» in a console:
«glx» MUST be present in the «Loaded modules» line;
Quote:
sh-4.3# report-video
VIDEO REPORT: puppex, version 6.0

Chip description:
VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)

Requested by /etc/X11/xorg.conf:
Depth (bits, or planes): 24
Modules requested to be loaded: dbe
Drivers requested to be loaded: intel

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): intel
Loaded modules: dbe dri2 extmod glx kbd mouse

Actual rendering on monitor:
Resolution: 1280x1024 pixels (338x270 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video
sh-4.3#


Then also run glxinfo to check if rendering=YES
Quote:
sh-4.3# glxinfo
name of display: :0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
...
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
...
GLX version: 1.4
...
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) 845G x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 10.1.3
OpenGL extensions:
....


that's all ..
HTH
Charlie
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 4 [55 Posts]   Goto page: Previous 1, 2, 3, 4
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 1.4701s ][ Queries: 12 (1.2455s) ][ GZIP on ]