Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 16 Sep 2019, 22:13
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Gtk 2.8 (and Gnome 2.14 for testing)
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Author Message
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Tue 25 Jul 2006, 03:33    Post subject:  Gtk 2.8 (and Gnome 2.14 for testing)  

Do not install these in Puppy 2.10 or newer !

This upgrades your Puppy to allow to use many new applications.
Do not install these in Puppy 2.10 or newer !

These Dotpups overwrites several systemfiles with new versions.

Do not install these in Puppy 2.10 or newer !

The libraries slightly differ from Grafpup-Linux, that uses Gtk 2.8, too.
I decided to use the latest versions, as they include some bugfixes.
I also used the new Caitro 1.2.0, as it has several improvements.


Normal users will need only 1 dotpup:
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gtk-2.8.20-Glib-2.9.3-Atk-1.10.3-Pango-1.10.4-Cairo-1.2.0.pup (2.8 MB)


Some more files are available here:
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/

You need the DEVEL files ONLY , if you want to compile own applications.
You need the LOCALE files ONLY, if you want some international Gtk-dialogs, like german "Ja" instead of "yes" in some buttons. Most applications have their own locale-files, so you usually will NOT need this!

First impressions:
Graveman and Geany start without problems, different to the 2.10 release I posted some days ago.

The dotpups upgrade these libraries:
atk-1.10.3
cairo-1.2.0
glib-2.9.3
gtk+-2.8.20
jpeg-6b
libpng-1.2.8
pango-1.10.4
tiff-3.7.4
libglade-2.5.0

They include everything except the manpages.

Note:
If you compile new applications after this upgrade, they only will run on older Puppys without Gtk 2.8, if on those systems a small dotpup was installed:
http://dotpups.de/dotpups/Libraries/PangoCairo.pup (170 kb)

This works only of course, if the applications do not explicitly use new functions of 2.8.
Sylpheed and Gaim work fine like this, Gimp 2.3.10 or Thunar not.

Mark

Last edited by MU on Tue 31 Jul 2007, 18:08; edited 6 times in total
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Tue 25 Jul 2006, 05:25    Post subject:  

I added a "Goffice"-dotpup.
This requires the Gtk 2.8-dotpup.
It updates Puppy to be able to run Gnumeric 1.6.3 (follows later).
In the "optional"-folder you find a "micro-icontheme", this includes only 2 icons used by the print-dialog, if you don't have the full large Gnome-icons installed.

The print-dialog can print to PDF, also with Puppys old Abiword/Gnumeric.

I could not compile the cups-module, as I would need the source.

Mark
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Tue 25 Jul 2006, 12:00    Post subject:  

I added libglade.so.2.5.0 to the Gtk dotpups, as is was requested by pygtk.
Mark
Back to top
View user's profile Send private message Visit poster's website 
klhrevolutionist


Joined: 08 Jun 2005
Posts: 1124

PostPosted: Wed 26 Jul 2006, 00:24    Post subject: reply2000  

Great job Mark. I just updated my puppy1.0.9 and everything is okay. No errors.

I have not tried compiling, i did download the needed files as mentioned though.

Now to upgrade my file-mamager rox to Thunar. Must say that it was strange of xfce to drop xffm, I rather liked it as much as I do Thunar.

_________________
Heaven is on the way, until then let's get the truth out!
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Wed 02 Aug 2006, 03:50    Post subject:  

Just tried to install Gnome 2.14 using Gtk 2.8, but it needs a newer Glib.
So I compiled Glib 2.9.3.
Different to 2.10.3 this one seems to be stable, so I think I will upgrade the Gtk-2.8 Dotpup with it tomorrow, after some more tests.
Thunar and geany have no problems with it.

test... fine, Gnome works like this Very Happy
Except nautilus, but it seems I just need to recompile it.

Mark
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Wed 02 Aug 2006, 04:55    Post subject:  

yes, needed to recompile only 3 packages, screenshot:

Gnome-panel, nautilus running in KDE Cool

http://dotpups.de/pics/puppy/KDEandGnome.jpg

Will upload a dotpup tomorrow.
Mark
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Wed 02 Aug 2006, 06:21    Post subject:  

updated:
http://www.murga.org/~puppy/viewtopic.php?p=62663#62663

Last edited by MU on Sat 12 Aug 2006, 08:08; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Fri 04 Aug 2006, 02:25    Post subject:  

--
Last edited by MU on Sat 12 Aug 2006, 08:41; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
muggins

Joined: 20 Jan 2006
Posts: 6754
Location: hobart

PostPosted: Fri 04 Aug 2006, 05:56    Post subject:  

mark,

i downloaded & ran your gnome.pup, but it seems to have messed up firefox. firefox won't run. I was getting messages, related to pango, but removed gnome & libpango & now i'm getting this:

/firefox/firefox-bin: symbol lookup error: /usr/lib/libgnomevfs-2.so.0: undefined symbol: g_thread_pool_set_sort_function

any ideas of a simple solution, rather than re-install?
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Fri 04 Aug 2006, 11:11    Post subject:  

/usr/lib/libgnomevfs-2.so.0

Is that file still there?
It should be removed togeter with Gnome.
If it was not removed cleanly, try to rename it (and reboot or run ldconfig).
Does that fix firefox?
Mark
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Fri 04 Aug 2006, 14:10    Post subject:  

I made a Dotpup for the Gnome-webbrowser epiphany.
It will need seamonkey 1, so will not work on Puppys without it.
Screenshot:
http://dotpups.de/pics/puppy/epiphany-2.14.jpg
You need dbus and startupnotification, too.
Optionally you can install locale-files to have it in your native language.

It is quite small and fast.
Has a very nice history.

Dotpups further down.

Mark

Last edited by MU on Sat 12 Aug 2006, 08:40; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Sat 12 Aug 2006, 08:03    Post subject:  

I cleaned up my server, so the links in the former messages are broken.
Here are the correct ones now.

Note that since Puppy 2.10, you must NOT install the Gtk-2.8 dotpup, as 2.10 has already Gtk 2.8.
I did not try these dotpups in Puppy 2.10 yet, except Thunar, that works fine.


To upgrade Puppy to Gtk 2.8, install these Gtk-Dotpups:
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gtk-2.8.20-Glib-2.9.3-Atk-1.10.3-Pango-1.10.4-Cairo-1.2.0.pup (2.8 MB)
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Goffice-0.21-Gsf-1.14.1-Gnomeprint-1.12.1.pup (920 kb)
If you don't want to use Gnome or Thunar, you should install these 2 icons, too:
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/optional/Goffice-0.21-Gsf-1.14.1-Gnomeprint-1.12.1-Gnome-Micro-Icontheme.pup


To install Gnome 2.14 (a small miniversion, needs ~50 MB):
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gnome-2.14/Gnome-2.14.2.pup
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/optional/Shared-mime-info-0.18.pup
It requires the Gtk-Dotpups from above Exclamation

To use the Gnome Webbrowser Epiphany in addition (works only with an installed Seamonkey like in Puppy 2.02 standard):
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gnome-2.14/Webbrowser-Epiphany/Libdbus-1-2_0.62-4.pup
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gnome-2.14/Webbrowser-Epiphany/Startupnotification-0.8.pup
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gnome-2.14/Webbrowser-Epiphany/Epiphany-2.14.2.pup
If you want to use Epiphany with another menu than english:
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gnome-2.14/Webbrowser-Epiphany/LOCALE/Epiphany-2.14.2-LOCALE.pup


If you want to use the Thunar Filemanager
This one is similar to Gnomes Nautilus, but you don't need Gnome for it.
It requires the Gtk-Dotpups from above Exclamation

http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/optional/Gamin-0.1.7.pup
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/optional/Hicolor-icon-theme-0.9.pup
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/optional/Gnome-icon-theme-2.14.2.pup (only if you don't have Gnome)
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/optional/Shared-mime-info-0.18.pup
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/optional/desktop-file-utils-0.11.pup
http://dotpups.de/dotpups/File_Managers/Thunar-Gtk-2.8/Exo-0.3.1.9svn-r22506.pup
http://dotpups.de/dotpups/File_Managers/Thunar-Gtk-2.8/LibXFCEutil-4.3.90.3svn-r22506.pup
http://dotpups.de/dotpups/File_Managers/Thunar-Gtk-2.8/Taglib-1.4.pup
http://dotpups.de/dotpups/File_Managers/Thunar-Gtk-2.8/Thunar-r22506.pup
More info:
http://www.murga.org/~puppy/viewtopic.php?t=9606


If you want to compile applications on your own, you also need the corresponding DEVEL-dotpups:
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/
http://dotpups.de/dotpups/File_Managers/Thunar-Gtk-2.8/

This picture shows Gnome with Epiphany running in JWM in a new Puppy 2.02:
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gnome-2.14/gnome214inpuppy.jpg

Mark

Last edited by MU on Sun 22 Oct 2006, 20:51; edited 3 times in total
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Sat 12 Aug 2006, 16:36    Post subject:  

there was a file missing in one of the DEVEL-dotpups, updated it:
http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gnome-2.14/DEVEL/Gnome-2.14.2-DEVEL.pup

This is only needed, if you compile your own Gnome-applications.
Mark
Back to top
View user's profile Send private message Visit poster's website 
klhrevolutionist


Joined: 08 Jun 2005
Posts: 1124

PostPosted: Sat 12 Aug 2006, 17:51    Post subject: error:  

Getting error on trying to use epiphany

epiphany.bin: error while loading shared libraries: libgtkembedmoz.so: cannot open shared object file: No such file or directory

_________________
Heaven is on the way, until then let's get the truth out!
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13647
Location: Karlsruhe, Germany

PostPosted: Sat 12 Aug 2006, 18:36    Post subject:  

klh, what Puppy do you use?
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0805s ][ Queries: 12 (0.0354s) ][ GZIP on ]