Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 20:44
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
How to install Blender 7.1 in Puppy Linux? [Solved]
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
linus.cl

Joined: 02 Apr 2014
Posts: 101
Location: Germany

PostPosted: Tue 16 Sep 2014, 06:55    Post_subject:  How to install Blender 7.1 in Puppy Linux? [Solved]  

Hello!

Can somebody create a .pet including blender for me?
I need the newest version of blender because there are many new functions and I work with blender very often.

I've tried to compile blender from source code, but I got an error:
Code:

sh-4.1# make
make: nproc: Command not found

Configuring Blender ...
# if test ! -f /root/Downloads/build_linux/CMakeCache.txt ; then \
#    cmake  -H"/root/Downloads/blender-v2.71" -B"/root/Downloads/build_linux" -DCMAKE_BUILD_TYPE:STRING=Release; \
# fi
# do this always incase of failed initial build, could be smarter here...
cmake  -H"/root/Downloads/blender-v2.71" -B"/root/Downloads/build_linux" -DCMAKE_BUILD_TYPE:STRING=Release
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:97 (MESSAGE):
  Could NOT find PythonLibsUnix (missing: PYTHON_LIBRARY PYTHON_LIBPATH
  PYTHON_INCLUDE_DIR PYTHON_INCLUDE_CONFIG_DIR)
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:288 (_FPHSA_FAILURE_MESSAGE)
  build_files/cmake/Modules/FindPythonLibsUnix.cmake:182 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:606 (find_package)


-- Configuring incomplete, errors occurred!
make: *** [all] Error 1


Thank you for help!

P.S.: I use Puppy Slacko 5.7 and I've installed the right devx.sfs

Edited_time_total
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1964
Location: wales

PostPosted: Tue 16 Sep 2014, 13:46    Post_subject:  

hi linus.cl

blender is in the slacko 5.7 PPM ... type blender into the find box
you'll also need to install the devx for it to work

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
linus.cl

Joined: 02 Apr 2014
Posts: 101
Location: Germany

PostPosted: Wed 17 Sep 2014, 07:41    Post_subject:  

Yes there is blender.

But I need blender with the new version 2.71! Mad
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1964
Location: wales

PostPosted: Wed 17 Sep 2014, 07:55    Post_subject:  

sorry i missed that....

no need to compile as there's pre compiled binaries on the blender website http://ftp.nluug.nl/pub/graphics/blender/release/Blender2.71/blender-2.71-linux-glibc211-i686.tar.bz2
just unzip and they are ready to go...

there's even a 2.72 test release to try

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
linus.cl

Joined: 02 Apr 2014
Posts: 101
Location: Germany

PostPosted: Wed 17 Sep 2014, 08:02    Post_subject:  

Thank you!
That's so easy! Very Happy Very Happy

But so I can't pack the newest blender version in a .pet package. Sad Sad
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3437
Location: Ontario

PostPosted: Wed 17 Sep 2014, 14:42    Post_subject:  

There's no need for a pet package.

You can make a desktop file which puts an entry on your start menu.

Go to /usr/share/applications/
and duplicate one of the desktop files there such as mtpaint.
Rename it to blender.desktop

Change some lines in the file such as the execute line.

--------------------------------------------------------------

Double clicking on a document file to open an application is tricky.
You can read about it on this forum.

___________________________________________________
Back to top
View user's profile Send_private_message 
gjuhasz


Joined: 29 Sep 2008
Posts: 179

PostPosted: Fri 24 Oct 2014, 20:20    Post_subject: Re: How to install Blender 7.1 in Puppy Linux?
Sub_title: sfs version of the new 2.72b release uploaded
 

linus.cl wrote:
Hello! ... I need the newest version of blender


Here you are...

Blender 2.72b was released on October 22, 2014. It is the latest stable release from the Blender Foundation.

Please find Blender-2.72b.sfs among others at

www.smokey01.com/gjuhasz/sfs

Tested in Puli.

Have fun!
Blender-2.72b.jpg
 Description   
 Filesize   27.79 KB
 Viewed   102 Time(s)

Blender-2.72b.jpg

Back to top
View user's profile Send_private_message 
linus.cl

Joined: 02 Apr 2014
Posts: 101
Location: Germany

PostPosted: Sun 02 Nov 2014, 02:59    Post_subject:  

Thank you very much!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0600s ][ Queries: 12 (0.0037s) ][ GZIP on ]