Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 28 Sep 2016, 18:21
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Business
What spreadsheet works in Slacko64? (Solved)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
gardenbod

Joined: 01 Sep 2014
Posts: 2

PostPosted: Mon 01 Sep 2014, 13:20    Post subject:  What spreadsheet works in Slacko64? (Solved)
Subject description: Gnumeric crashes when anything is entered.
 

I have Slacko64 running on a Compaq CQ58, with AMD E1. Booting from eiher DVD or Flash drive.It looks good and almost everything works; my aim is to migrate all data from Win 8.1, including spreadsheets.
Problem - Gnumeric cuts out instantly when I try to enter ANY data, by any means.
Open Office or Libreoffice would be good, but I cannot see any way to install them, or reinstall Gnumeric from another source (eg Pet).
Help?
Back to top
View user's profile Send private message 
neerajkolte


Joined: 10 Feb 2014
Posts: 517
Location: Pune, India.

PostPosted: Mon 01 Sep 2014, 13:46    Post subject:  

Hi,

Could you try out .sfs file for Libreoffice from HERE.
These sfs files are for Fatdog64 but some of them work in Slacko64.
Worth a try.

- Neeraj.

_________________
"One of my most productive days was throwing away 1000 lines of code."
- Ken Thompson

“We tend to overestimate the effect of a technology in the short run and underestimate the effect in the long run.”
- Amara’s Law.
Back to top
View user's profile Send private message 
gardenbod

Joined: 01 Sep 2014
Posts: 2

PostPosted: Mon 01 Sep 2014, 16:19    Post subject: Spreadsheets  

HI
Neeraj, thank you very much for the tip. First time lucky, I tried the version with 'amd' in the title.
It works!!
Regards.
gardenbod
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 8568
Location: qld

PostPosted: Mon 01 Sep 2014, 20:31    Post subject:  

I found the bug and the fix for gnumeric. Apparently pcre_info is deprecated and completely removed. :/
The above is a link to the patch to apply to goffice which I modded and applied.

new pets are uploaded:
http://distro.ibiblio.org/puppylinux/pet_packages-slacko6414.1/goffice-0.8.17-1-x86_64.pet
http://distro.ibiblio.org/puppylinux/pet_packages-slacko6414.1/goffice_DEV-0.8.17-1-x86_64.pet
http://distro.ibiblio.org/puppylinux/pet_packages-slacko6414.1/goffice_NLS-0.8.17-1-x86_64.pet

And the modded patch:
Code:
diff -rup goffice-0.8.17/goffice/utils/regutf8.c goffice-0.8.17-1/goffice/utils/regutf8.c
--- goffice-0.8.17/goffice/utils/regutf8.c   2009-09-06 09:52:09.000000000 +1000
+++ goffice-0.8.17-1/goffice/utils/regutf8.c   2014-09-02 08:30:02.283292332 +1000
@@ -155,7 +155,7 @@ go_regcomp (GORegexp *gor, const char *p
       default: return GO_REG_BADPAT;
       }
    } else {
-      gor->re_nsub = pcre_info (r, NULL, NULL);
+      gor->re_nsub = pcre_fullinfo (r, NULL, 0, NULL);
       gor->nosub = (cflags & GO_REG_NOSUB) != 0;
       return 0;
    }

_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
Pelo


Joined: 10 Sep 2011
Posts: 9417
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 24 Nov 2015, 10:45    Post subject: see french forum, forum francophone  

Slacko64 and gnumeric see french forum, forum francophone et postez vos remarques sur le topic de Medor ici en cliquant la zone bleue
_________________
Sprinters choose Puppy Linux as mascot, always happy, always speedy.
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo


Joined: 10 Sep 2011
Posts: 9417
Location: Mer méditerrannée (1 kms°)

PostPosted: Sat 26 Dec 2015, 00:33    Post subject: Don't fear using older versions.  

Gnumeric was working quite well in he past. I was employed for statistics in a big airline, and i can tell Gnumeric is a real clone of Excel. Don't fear using older versions.
Use older version of puppy too, to be sure they have been tested by a lot of users.
Some users feed back errors. Merci à eux.
Spread sheets in Libre Office or OOo are of lower quality than Gnumeric. Some calculation are even... wrong !

_________________
Sprinters choose Puppy Linux as mascot, always happy, always speedy.
Back to top
View user's profile Send private message Yahoo Messenger 
8Geee


Joined: 12 May 2008
Posts: 899
Location: N.E. USA

PostPosted: Sat 02 Jan 2016, 13:37    Post subject:  

Late, but FreeOffice also works well and is compatable with the "older" microsoft-office versions. I use a chopped us_eng only version. Small and functional.
_________________
Linux user #498913
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 9417
Location: Mer méditerrannée (1 kms°)

PostPosted: Sun 03 Jan 2016, 06:15    Post subject: The look is nice. and it's free  

FreeOffice is my second hand spreadsheet, when i am using Windows. The look is nice. and it's free, just some mails. Not a problem.
In the back of the debates, Puppy will exist by being different from big ones.. offering the just needed for most of users.

_________________
Sprinters choose Puppy Linux as mascot, always happy, always speedy.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Business
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0366s ][ Queries: 11 (0.0040s) ][ GZIP on ]