Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 04:51
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
EmSeeV2.2iso Full featured pup! 06 August 2014
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [39 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
nancy reagan

Joined: 22 Jan 2009
Posts: 512

PostPosted: Mon 14 Jul 2014, 14:48    Post subject:  

stemsee wrote:
1. Same partition as swap or same harddrive as swap? You shouldn't create a savefile on a swap partition!

same drive

2. You mean xorgwizard setup? Then choose kms, then let xorg guess resolution, then test, then finished then type xwin?

did that several times, also with your other sfs's, after pup ran kms and clicking finish it totally disappears etc.

I didn't burn this iso to dvd as i test it in qemu only. Also I hae never used a savefile with a dvd. But EmSeeV2 is based on Dpup Wheezy so you can search the forum for info there.

Maybe this will help. http://www.murga-linux.com/puppy/viewtopic.php?t=29356



It does not matter whether from dvd or frugal: savefile can always be made. Also with a frugal it does not see the savefile, which is very essential..

I'll give up on this for a while till more sophisticated people than me come up with their more valuable feedback.
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 4350
Location: Earth

PostPosted: Mon 14 Jul 2014, 18:06    Post subject:  

SAMBA problems using pristine EmSeeV2
Code:
sh-4.1# samba -V
samba: error while loading shared libraries: libcli_smb_common.so: cannot open shared object file: No such file or directory
sh-4.1# smbd -V
sh: smbd: command not found
sh-4.1# smbd --version
sh: smbd: command not found
sh-4.1# samba --version
samba: error while loading shared libraries: libcli_smb_common.so: cannot open shared object file: No such file or directory
sh-4.1# samba --version

sh-4.1# smblient --version
sh: smblient: command not found
sh-4.1# smblient
sh: smblient: command not found
sh-4.1# which smbd
sh-4.1# which samba
/usr/sbin/samba
Go here, to see filesystem references expected for a SAMBA installation

Here to help
Edited: Very last sentence-pointer.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile

Last edited by gcmartin on Tue 15 Jul 2014, 21:11; edited 1 time in total
Back to top
View user's profile Send private message 
stemsee


Joined: 27 Jun 2013
Posts: 442
Location: London

PostPosted: Mon 14 Jul 2014, 20:55    Post subject:  

On the desktop bottom right corner click setup > gui opens next click internet , another gui opens.... on the bottom right of that gui is the hostname, type any hostname in the field and click the big green tick! There hostname resolved!
Back to top
View user's profile Send private message MSN Messenger 
gcmartin

Joined: 14 Oct 2005
Posts: 4350
Location: Earth

PostPosted: Tue 15 Jul 2014, 00:48    Post subject:  

Barry, Shinobar and others went thru an awful lot of interaction to correct and resolve subsystem behavior such that FirstRUN resolve this and other problems for users at system's initial starts. It is discussed at length, here.

Every Puppy system which does NOT use FirstRUN has this problem and another. I only ask because users need not have the problem, considering that was solved for PUP distro development by BarryK, et al.

Picture, below to see the EmSeeV2 example of the bug. All of PUPs fields DO NOT MATCH as they should when hostname is proper. An ordinary user would never suspect the system didnt handled it nor the LAN adjustments necessary. (There is a LAN adjustment that FirstRUN also handles in background)

Test for yourself to verify. This is the reason I've been appealing to bring attention for helping.

Hope this helps understanding. If you would like to get more detail from me on this, send me a PM.
hostname.png
 Description   Notice the terminal window AFTER the Green Checkbox is clicked. I tested this before sending out the appeal to you.
 Filesize   207.13 KB
 Viewed   950 Time(s)

hostname.png


_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 4350
Location: Earth

PostPosted: Tue 15 Jul 2014, 03:43    Post subject: How to use ISOmaster to make a 64bit EmSeeV2  

Tested EmSeeV2 64bit using the ISOmaster utility to create the 64bit ISO (see below for ISOmaster procedure). When complete and the ISO booted, the following command shows the 64bit kernel in play.
Code:
sh-4.1# uname -r
3.15.5-EmSeeV2-64
Very nice!
Showhow.gif
 Description   1. Open original 32bit EmSeeV2 ISO in ISOmaster
2. Remove old VMlinux + kernel.sfs files from the ISO's contents
3. Add 64bit versions to the ISO's contents
4. Save to create new ISO
 Filesize   207.29 KB
 Viewed   716 Time(s)

Showhow.gif


_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
stemsee


Joined: 27 Jun 2013
Posts: 442
Location: London

PostPosted: Wed 16 Jul 2014, 05:13    Post subject:  

Ok! So I have a new EmSeeV2.1.iso uploading right now. It grew by 300mb somehow! Added Viacam to control cursor with head movements, requires webcam. Bleachbit aded, Espeak text to speech, cli, utility. Upgraded wine-1.7.17 to 1.7.22, upgraded xbmc-13.1 to 13.2, sorted out samba completely, added EmSeeV2savefile.sfs.tar.gz to be decompressed and copied from dvd to usb/hdd etc. Header files are now included in main sfs and removed from modules (openshot requires them to run). TestDisk-6.13 now has menu entry! Some icons fixed in menus. Cleared up status file for synaptic. Added welcome1stboot and quicksetup on first run. Removed a few small scripts, and added unattendremaster by nic007 modified by StemSee, mistakenly named 'remaster express' in menu!

I will post the links, after successful upload, at which point the previous iso links will be removed, but not deleted from the server for a day or two in case someone is in mid download!

BTW: This was remastered from a running frugal install with savefile using nic007's unattendedremaster script modified by myself to ask for path to working directory! The only thing it missed, but not its fault, was the /usr/include/ folder for headers which was mounted as sfs with modules.sfs. I recommend that method for remastering, it should be added as a standard feature in puppy.

BTW2: F2FS (full install to usb flash device) works well on my usb 3.0 stick but not on my usb 2.0 sick.

EDIT: incremental update 16/07/14

EDIT: Getting ready for EmSeeV2.2 incremental update
Back to top
View user's profile Send private message MSN Messenger 
stemsee


Joined: 27 Jun 2013
Posts: 442
Location: London

PostPosted: Wed 06 Aug 2014, 01:58    Post subject:  

I recommend users run 'shutdownconfig' from a terminal before first shutdown to create a reliably loaded savefile. Pupsaveconfig is there but....try it.

New Kernel 3.15.8-pae

EmSeeV2.2 MD5
https://drive.google.com/file/d/0B4GhZVmB2RkwZ0F5bWlKMDkzNEk/edit?usp=sharing


EmSeeV2.2.iso
capture18590.jpg
 Description   
 Filesize   32.81 KB
 Viewed   558 Time(s)

capture18590.jpg

capture6034.jpg
 Description   
 Filesize   15.23 KB
 Viewed   556 Time(s)

capture6034.jpg


Last edited by stemsee on Wed 06 Aug 2014, 11:30; edited 1 time in total
Back to top
View user's profile Send private message MSN Messenger 
stemsee


Joined: 27 Jun 2013
Posts: 442
Location: London

PostPosted: Wed 06 Aug 2014, 11:03    Post subject:  

Here is Skype-4.3.0.37.sfs specially prepared for EmSeeV2.2

https://drive.google.com/file/d/0B4GhZVmB2RkwWWU4QldRM2xicDQ/edit?usp=sharing
Back to top
View user's profile Send private message MSN Messenger 
Gobbi

Joined: 09 Mar 2012
Posts: 144

PostPosted: Tue 26 Aug 2014, 04:58    Post subject:  

Hi @stemsee ,

I tried to boot EmSeeV2.2 on an HP laptop :

Computer
Processor 4x Intel(R) Core(TM) i3-3120M CPU @ 2.50GHz
Memory 6009MB
Display
Resolution 1366x768 pixels
OpenGL Renderer Mesa DRI Intel(R) Ivybridge Mobile
X11 Vendor The X.Org Foundation
Audio Devices
Audio Adapter HDA-Intel - HDA Intel PCH

I know it has 2 RAM modules one of 2Gb and one of 4GB . Besides it shares memory with the videocard(s)...

This machine behaves in a strange way with 32bit OSes . It shows less than 800MB memory when I boot 32bit OSes on it , and I can't activate wireless even from the terminal , forget about the button from the keyboard . I can use wireless easily in Fatdog 630 and Fatdog 700.
Anyway , since it offers little RAM I thought to boot EmSee like a LiveDVD ...
I had difficulties to insert parameters at boot because it's not like : " say puppy and kernel parameters ..." works. Instead of puppy first word to write was "vmlinuz" and then everything after...
I inserted as parameters : pmedia=cd pfix=nocopy loglevel=7 . In the end it hanged out saying it doesn't find the EmSee sfs file Shocked

In september I'll be home and I shall be able to make a frugal install ... This machine has Windoze 8,1 on it and it's not mine so I'll just wait till then...
Back to top
View user's profile Send private message 
stemsee


Joined: 27 Jun 2013
Posts: 442
Location: London

PostPosted: Tue 26 Aug 2014, 08:42    Post subject:  

Hi Gobbi

Download this latest iso from17th August.
https://drive.google.com/file/d/0B4GhZVmB2RkwR0E0NGFlMWNJNVE/edit?usp=sharing


you could also do a frugal install on a usb stick/memorycard/phone and boot the pc from it.

The kernel is pae enabled and should use all the memory (my laptop has 8gb)

Alternatively you could download the 64bit kernel I provided, that might solve all issues!

https://drive.google.com/folderview?id=0B4GhZVmB2RkwVW45STZJUm4tMzQ&usp=sharing
Back to top
View user's profile Send private message MSN Messenger 
step

Joined: 04 May 2012
Posts: 196

PostPosted: Fri 29 Aug 2014, 14:48    Post subject:  

Hi StemSee, I'm writing this from EmSee 2.2, frugal install on HDD. Very nice job indeed, thank you! The icon sets are beautiful.
I selected the ATI kms video driver, went through the initial configuration and the first time wizard changing hostname and time settings and closing the wizard. Then a terminal window labelled "Espeak" popped up with a bunch of alsa / sourd driver error messages. Unfortunately it must have closed it before I could copy the error text here. But If I open another terminal now and run espeak this is what I get:
Code:

sh-4.1# espeak "hello StemSee"
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

ALSA lib pcm_dmix.c:961:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
sh-4.1#

Since this PC is 64 bit, do you recommend replacing vmlinuz with the 64bit version that you posted back in July?
And why do you prefer running FatDog over EmSee qemu when you could just run a frugal FatDog?

_________________
FatDog64 631|Blue Pup 4|DebianDog+OpenMediaVault stick
Back to top
View user's profile Send private message 
stemsee


Joined: 27 Jun 2013
Posts: 442
Location: London

PostPosted: Sat 30 Aug 2014, 05:09    Post subject:  

@step

Thanks for the feedback!

I have four puppy distros that I use for different purposes! Fatdog64 700a boots fastest and allows easiest method to edit initrd and also saves to folder, I use mostly to recover my main system and compiling 64bit apps/kernels. Studio1337 slacko 5.7 for super lowlatency and all round fastest operation for audio work, but not social media (QQ doesn't work on slacko). DebianDog for 100% debian compatibility in a puppy compatible distro which sees a lot of active development, I enjoy using this with puppy boot method as an alternative OS. Of course EmSeeV2.2 does everything I could possibly want and more, I use this 90% of the time.

I don't know why espeak has trouble with your sound card settings. Try running alsa soundcard wizard and then re-try espeak.

I recommend the 64bit kernel for all scenarios, just be careful when compiling as he system assumes full 64bit appearance even when compiling 32bit apps/kernels ... you may have to specify architecture compatibility (32bit).
Back to top
View user's profile Send private message MSN Messenger 
gcmartin

Joined: 14 Oct 2005
Posts: 4350
Location: Earth

PostPosted: Wed 03 Sep 2014, 00:42    Post subject:  

Link to EmSee ISO in the 1st post needs review.
_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
Jasper


Joined: 25 Apr 2010
Posts: 1144
Location: England

PostPosted: Wed 03 Sep 2014, 04:02    Post subject:  

gcmartin,

Enable JavaScript and report back.
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 4350
Location: Earth

PostPosted: Wed 03 Sep 2014, 21:40    Post subject:
Subject description: 6 August 2014
 

Problem occurred on Live DVD pristine boot of EmSee V2 prior to Aug17th version using Firefox. Does not seem to be browser related.

Switched horses: Used Live LH64 to download ISO on user's PC. Download is currently processing. But, the md5 link in the 1st post on this thread yields error, now. Using Chrome on LH64 downloading to default browser location

Can md5 for latest Aug17 version be posted (I think that is the version coming down from the 1st post)?

I see that the ISO link was updated today. Thanks

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [39 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0932s ][ Queries: 12 (0.0043s) ][ GZIP on ]