Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 27 Aug 2014, 08:59
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Ardour-3.5.389 for Carolina (Pulled from git 02/07/14)
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
battleshooter


Joined: 14 May 2008
Posts: 1070
Location: Australia

PostPosted: Wed 02 Jul 2014, 22:16    Post_subject:  Ardour-3.5.389 for Carolina (Pulled from git 02/07/14)
Sub_title: Recorder and Digital Audio Workstation
 



Ardour is a hard disk recorder and digital audio workstation application. It runs on Linux, OS X and FreeBSD. Its primary author is Paul Davis, who is also responsible for the JACK Audio Connection Kit. Ardour's intention is to provide digital audio workstation software suitable for professional use.

- http://en.wikipedia.org/wiki/Ardour_%28software%29


Huh. I didn't know Paul Davis also had a hand in JACK. Educational. Had to nab the little blurb/quote from Wiki instead of the main site, Ardour can't say things simply and shortly but it sure makes for impressive salesmanship. Just reading their home page makes you want to be a professional musician/producer even if you've got no idea how to go about it XD.

Ardour3


ArdourVST3

Click for fullsize as usual... those VSTs aren't included by the way... just showing they can be used.

Hmmm, looks much better than the old Ardour2 but I still give more points to LMMS for vast improvement in the eyecandy section. One thing I really like is how there are now graphical plugin analysis for the default high pass/low pass filters. Haven't played around enough to see the major difference other than graphical. While I'm griping, I will say I wish ardour3 and ardourvst3 were compatible like in Ardour2. Maybe they are but I missed the compile option but I can't combine them into one package without getting errors for one or the other. It's a shame because now I have to upload 2 SFSs with the same dependencies only difference being the version specific Ardour libraries.

Download ardour3.5.389.sfs
Size: 43.6 MB
MD5: db21c76dd4a5aa66353039c38ba7efcc

Download ardourVST3.5.389.sfs

Size: 43.3 MB
MD5: 8054a50f31fae4b072e6055aac93e86c

Download ardour_NLS-3.5.389.pet

ardour3.5.389.sfs
comes with Linux VST support, but not Windows VST support. ardourVST3.5.389.sfs comes with Linux VST support, and Windows VST support, but you'll need to install Wine to be able to run it at all. I didn't include Wine, because people might have their own Wine setup going on and I wouldn't want to mess with that.

ardour3.5.389 dependencies included in SFS
ardour3.5.389
atkmm-2.22.6
aubio-0.3.2
cairomm-1.10.0
fftw-3.3.2
glibmm-2.32.1
gtkmm-2.24.2
jack-audio-connection-kit-0.124.1
libgnomecanvasmm-2.26.0
liblo-0.26
libsamplerate-0.1.8
lilv-0.18.0
LRDF-git
lv2-1.8.0
pangomm-2.28.4
raptor2-2.0.8
serd-0.18.2
sord-0.12.0
sratom-0.4.4
suil-0.8.0

ardourVST3.5.389 dependencies included in SFS
Does not come with Wine! It was compiled with 1.5.28 but will be fine with different versions.
ardourVST3.5.389
atkmm-2.22.6
aubio-0.3.2
cairomm-1.10.0
fftw-3.3.2
glibmm-2.32.1
gtkmm-2.24.2
jack-audio-connection-kit-0.124.1
libgnomecanvasmm-2.26.0
liblo-0.26
libsamplerate-0.1.8
lilv-0.18.0
LRDF-git
lv2-1.8.0
pangomm-2.28.4
raptor2-2.0.8
serd-0.18.2
sord-0.12.0
sratom-0.4.4
suil-0.8.0

See how annoying that is? Exactly the same except for the actual Ardour package. Wink Anyway, I'll shut up now in case there really was an option I missed.

Some comments
If you need firewire support, FFADO drivers are here.

Yup, I didn't included any plugins... go forth and find them Razz

Actually here's the standard swh plugins, comes with GVerb (Reverb plugin if you couldn't have guessed Wink) and a host of other useful free plugins. People complain about Gverb's lack of presets, but I've grown quite fond of it. It's not like you can't save the presets found here.

Download swh-plugins-0.4.15.pet

I also compiled CAPS when I was looking for some good guitar distortion effects, but ended up using the Juicy VST instead, but CAPS is here if you want to give it a go.

Download caps-0.9.23.pet

If you have any plugin pets laying around, feel free to toss them my way and I'll stick them up here so we can all share and share alike Razz

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8

Edited_times_total
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2409
Location: Germany

PostPosted: Wed 02 Jul 2014, 22:40    Post_subject:  

Cool!

I will check this later.

Quote:
It's a shame because now I have to upload 2 SFSs with the same dependencies only difference being the version specific Ardour libraries.

So why not building a SFS just for the dependencies and in the Ardour SFS files including a starter-script for Ardour, that first tries to load the SFS containing the dependencies and then executing Ardour or just showing a message for the missing dependent SFS (maybe presenting a link to download).

This code will find the Ardour-Deps.sfs if it is in boot directory or at boot partition.
Code:
sfs_load --cli --skip-fixmenus --quiet "Ardour-Deps.sfs"

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1070
Location: Australia

PostPosted: Thu 03 Jul 2014, 00:18    Post_subject:  

RSH wrote:
So why not building a SFS just for the dependencies and in the Ardour SFS files including a starter-script for Ardour, that first tries to load the SFS containing the dependencies and then executing Ardour or just showing a message for the missing dependent SFS (maybe presenting a link to download).


Hah, because I'm not that clever Smile

I did kinda debate on what you're suggesting, minus the fancy scripts.

Ultimately I guess I feel it's simpler to have 2 self contained SFSs and people can just take their pick. If they were larger I would have probably only offered the VST version and uploaded the non-VST pet to install over if wanted or vice-versa .

But yes, thanks for the suggestion Smile

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1070
Location: Australia

PostPosted: Sun 13 Jul 2014, 21:52    Post_subject:  

NLS for Ardour up. Obviously compatible with both VST and normal Ardour3.

For some reason I couldn't get them to install with ./waf so I dug them out of the source and packaged them manually. Would be great if someone let me know if they work/don't work.

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0609s ][ Queries: 11 (0.0032s) ][ GZIP on ]