Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 27 Sep 2016, 08:12
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
LMMS 1.1.90 for Carolina (updated 14-04-16)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
battleshooter


Joined: 14 May 2008
Posts: 1273
Location: Australia

PostPosted: Tue 01 Jul 2014, 21:50    Post subject:  LMMS 1.1.90 for Carolina (updated 14-04-16)
Subject description: Free digital music creator
 

LMMS

LMMS is a free cross-platform software which allows you to produce music with your computer. This covers creating melodies and beats, synthesizing and mixing sounds and arranging samples. You can have fun with your MIDI keyboard and much more – all in a user-friendly and modern interface. Furthermore LMMS comes with many ready-to-use instrument and effect plugins, presets and samples.

- http://lmms.sourceforge.net




I've got to say the 1.x.x LMMS series is a vast improvement over the old 0.x.x series, at least in the looks department. The opening splash is certainly more professional than the old one.



vs.



The old one reminds me of that slightly terrifying chihuahua splash screen we used to have here on the earlier Puppy versions. Read this thread for reference (Sadly no reference pic, but I'm sure you can google it. It was pretty memorable. *shudder.)

Back to LMMS.

Download LMMS-1.1.90
Size: 21.9 MB
MD5: a5de6c44575f6df1433585988e3cf277

Where possible I used the dependencies found in the Carolina repository and if not, the same version

Dependencies included in SFS
libsamplerate-0.1.8
fftw-3.3.2
fluidsynth-1.1.6
json-c-0.11
pulseaudio-5.0
jack-audio-connection-kit-0.124.1 (recompiled with firewire driver)
fltk-1.3.2-i486

Does not come with Wine! It was compiled with 1.5.28 but it should be fine with different versions. I use it with 1.4.0 for example. You need Wine for VST support.

Compiled with:

Code:
ALSA (Advanced Linux Sound Architecture) support ON
CALF LADSPA plugins ON
C* Audio Plugin Suite (LADSPA plugins) ON
Computer Music Toolkit LADSPA plugins ON
JACK (Jack Audio Connection Kit) support ON
OGG/Vorbis support ON
PulseAudio support ON
PortAudio support OFF
SDL (Simple DirectMedia Layer) support ON
SoundFont2 player plugin ON
Stk (Synthesis Toolkit) support OFF
Steve Harris's LADSPA plugins ON
Tom's Audio Processing LADSPA plugins ON
VST support ON


If you really need the STK mallets support, I don't mind recompiling, but if not, I'll add it in the next update.

If you need firewire support, FFADO drivers are here. As the screenie shows, FFADO, JACK, and LMMS play nicely together.

Some comments:

There's such a wide variety of instruments, sounds and effects that LMMS can utilize. It's compiled with VST support so you can even use all the Windows tools and effects available to them. If there's one thing Windows has, it's a user database, So that's nice to be able to tap in to. I'd like to post some links to plugins but I got them ages ago and can't remember where I got them from! But there are really good resources all over the internet, soundfonts, VST instruments, VST effects, Calf plugins, LADSPA plugins.... so enjoy, be adventurous! Wink

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8

Last edited by battleshooter on Thu 14 Apr 2016, 06:20; edited 3 times in total
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1273
Location: Australia

PostPosted: Tue 01 Jul 2014, 22:52    Post subject:  

Some inspiration.

https://www.youtube.com/watch?v=BmrpxfmnMUs

Not me Wink

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Tue 01 Jul 2014, 23:45    Post subject: Re: LMMS 1.0.2 for Carolina (Pulled from git 1/06/14)
Subject description: Free digital music creator
 

battleshooter wrote:
[...] that slightly terrifying chihuahua splash screen we used to have here on the earlier Puppy versions.


http://www.murga-linux.com/puppy/viewtopic.php?p=137032#137032

It's the upper image, right? The one with the TV test pattern? Yeah, that's pretty creepy. (To be fair, both are kinda creepy, but the test-pattern one is definitely the worse option.) Makes me smirk, though... probably it's that funky cartoonish font. Heh.

_________________

Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1273
Location: Australia

PostPosted: Wed 02 Jul 2014, 09:06    Post subject:  

Laughing Laughing Laughing

Hahaha! Very Happy I'd say the chihuahua looks pretty terrified too looking at that pic again.

I feel like I've also seen this fellow stretched out of proportion across a screen, but I can't remember which puplet it was.
puppy_splash.png
 Description   
 Filesize   17.13 KB
 Viewed   2297 Time(s)

puppy_splash.png


_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Wed 02 Jul 2014, 19:24    Post subject:  

Hi.

That's pretty cool.

Downloaded the SFS and loaded into L.A.S.S.I.E. 003 (Precise 5.7.1 based), loaded the LP2_QT-4.8.2.sfs and installed fluid-soundfont-gm_3.1-5_all.deb for a quick test.

First time ever using LMMS.

Looks pretty cool and professional, seems to work fine.

So, what is Carolina based on?

Will Software compiled for Carolina run and work generally in Precise Puppies?

Need to check out the FFADO from Carolina, since I'm using a Phonic Helix 24 MKII Board, which is listed as 'working'.

Thanks for compiling this one.

RSH
image-1.jpg
 Description   
 Filesize   109.36 KB
 Viewed   2258 Time(s)

image-1.jpg


_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1273
Location: Australia

PostPosted: Wed 02 Jul 2014, 21:19    Post subject:  

Carolina is based off Saluki which is a "woof-build based on Racy 5.2 with Xfce". I'm also using the 3.15 kernel but that doesn't seem to affect unless dealing with kernel modules, and LMMS, FFADO, etc. aren't affected.

I don't know if Carolina software will work for Precise, I thought they used different glibcs, but it worked for you so that's great.

Just a question out of curiosity, what's LP2_QT-4.8.2?

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Wed 02 Jul 2014, 21:54    Post subject:  

Quote:
Just a question out of curiosity, what's LP2_QT-4.8.2?

It's a modified QT 4.8.2 SFS File.

The Prefix 'LP2_' means it is converted for the use with the LazY Puppy / L.A.S.S.I.E. SFS P.L.U.S. RunScripts. These RunScripts can download a SFS, store it and load it after downloading and executing the application of the SFS automatically - just by a single menu click or desktop icon click (similar to SARA-B).

Converted for the use with the LazY Puppy / L.A.S.S.I.E. SFS P.L.U.S. RunScripts doesn't mean a converted file system inside of the SFS. It means -for one part- to have added some information files to be able to load a SFS including its SFS dependencies, e.g. QT, JAVA, PYTHON, MIDI Soundfonts, Text Fonts etc.pp.

So if I'm starting LMMS 1.0.2 from its menu entry, the LMMS SFS will be loaded first, then the RunScript checks for defined SFS dependencies and will find the QT SFS and also a MIDI Soundfont SFS that will load automatically before LMMS will be executed.

This is how I do use my applications generally. To have settings available at next boot, I'm using symbolic links. E.g. /root/lmms will be sym-linked to /mnt/sda1.

No save file! Very Happy

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1273
Location: Australia

PostPosted: Thu 03 Jul 2014, 00:08    Post subject:  

Whoa, fancy... no pupsave huh?

I do something like that for all my game saves, like .zsnes so I suppose it's not that out there... but for all your applications, interesting...

But why did you need QT at all? It's not a dependency for LMMS?

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Thu 03 Jul 2014, 01:32    Post subject:  

Quote:
But why did you need QT at all? It's not a dependency for LMMS?

Oh, thanks for the info.

Tonight I was creating several SFS Modules from earlier downloaded .deb packages.

LP2_Drumstick-Tools_0.5.0-2-precise.sfs
LP2_Hexter-0.6.2-3-precise.sfs
LP2_LADSPA-PlugIns-precise.sfs
LP2_LMMS-1.0.2.sfs
LP2_SmartDeblur-1.27-fftw-3.3.2.sfs
LP2_SoundFonts-MIDI-1.0.0.sfs
LP2_VokoScreen-2.0.0-i386.sfs
LP2_WSynth-dssi-0.1.3-precise.sfs
LP2_XHippo-3.5-007.sfs
LP2_XJadeo-0.6.2-1-precise.sfs
LP2_XSynth-dssi-0.9.0-precise.sfs

Those who are marked needed QT, so I accidentally added QT to LMMS. Laughing

Maybe I should check them all. Wink

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
agar

Joined: 05 Apr 2015
Posts: 1

PostPosted: Sun 05 Apr 2015, 16:50    Post subject:  

Somebody, please compile a 2015 version of lmms in sfs.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 9409
Location: Mer méditerrannée (1 kms°)

PostPosted: Sun 03 Apr 2016, 02:55    Post subject: LMMS is not a jukebox, is it ?  

LMMS is not a jukebox, is it ?
_________________
Sprinters choose Puppy Linux as mascot, always happy, always speedy.
Back to top
View user's profile Send private message Yahoo Messenger 
backi

Joined: 27 Feb 2011
Posts: 679
Location: GERMANY

PostPosted: Mon 04 Apr 2016, 15:53    Post subject:  

Hi Battleshooter !
Your link is not working
http://puppylinuxstuff.meownplanet.net/battleshooter/Carolina/LMMS/lmms-1.0.2.sfs
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1273
Location: Australia

PostPosted: Thu 14 Apr 2016, 06:23    Post subject:  

agar wrote:
Somebody, please compile a 2015 version of lmms in sfs.


Done Wink

Well, 2016 anyway. Bit late.

Pelo wrote:
LMMS is not a jukebox, is it ?


No it's not Pelo, it's a digital music maker, as in one creates the music themselves.

backi wrote:
Hi Battleshooter !
Your link is not working
http://puppylinuxstuff.meownplanet.net/battleshooter/Carolina/LMMS/lmms-1.0.2.sfs


Thanks backi, I've uploaded a new version and a link that should hopefully work.

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1273
Location: Australia

PostPosted: Thu 14 Apr 2016, 06:29    Post subject:  

Updated 14-04-16

It's smaller than the old version... but compiled with the same dependencies hmm... I did notice the main binary itself was smaller than previous versions. Let me know if anything is missing or doesn't work as expected.

In addition to this, the developers have changed LMMS to not run under root unless the argument --allowroot is passed through. I've added that to the start up menu and created a wrapper script call "startlmms" if needed. But if you run the binary direct, don't forget to pass it as
Code:
lmms --allowroot


Other than that, clicking on the menu option should start it up no problems. If you have no sound, don't forget to change the settings in LMMS. For some reason it isn't set to ALSA or JACK by default.

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 1350
Location: Germany

PostPosted: Thu 14 Apr 2016, 22:07    Post subject:  

Quote:
"Cannot load library /usr/lib/lmms/ladspa/calf.so: (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib/lmms/ladspa/calf.so))"

Apart from this message in the Terminal it runs and works in tahr 6.0.2.

Though, it refuses to run as root.

Needed to run from terminal by lmms --allowroot to get it startetd. After setting sound to alsa and selected the default sound card/device I loaded one of its templates. Complained about the versions of lmms when created the template and used when loading the template.

However, after editing some parts I got the sounds as edited when playing the song.

_________________
RSH

T.O.P.L.E.S.S. - the Multi-Language Puppy Linux Wrapper.

Zivilcourage bringt nichts als Ärger ein!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0692s ][ Queries: 12 (0.0058s) ][ GZIP on ]