Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Sep 2014, 04:14
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
JWM panel button using script
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
fixit


Joined: 16 Mar 2013
Posts: 668
Location: El Lago, Texas

PostPosted: Mon 30 Jun 2014, 17:54    Post_subject:  JWM panel button using script  

Does a script not work as a JWM panel button ?

exec:./my-applications/bin/PowerOff.sh

The scripts works otherwise.

_________________
Andy
Slacko Puppy 5.6.0
OpenSuse 13.1 KDE
Windows XP SP3
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3907
Location: World_Hub

PostPosted: Mon 30 Jun 2014, 18:14    Post_subject:  

Since it's already in the path, your included line's optional. Oh, and >> lose the dot.
Code:
exec:PowerOff.sh

_________________
>>>Punctuation Crash Course<<<
Back to top
View user's profile Send_private_message 
fixit


Joined: 16 Mar 2013
Posts: 668
Location: El Lago, Texas

PostPosted: Mon 30 Jun 2014, 19:00    Post_subject:  

thanks.
_________________
Andy
Slacko Puppy 5.6.0
OpenSuse 13.1 KDE
Windows XP SP3
Back to top
View user's profile Send_private_message 
fixit


Joined: 16 Mar 2013
Posts: 668
Location: El Lago, Texas

PostPosted: Wed 02 Jul 2014, 17:30    Post_subject:  

It looks like there is a limit of 3 buttons. Sad

I added a forth, but it does not show up.

_________________
Andy
Slacko Puppy 5.6.0
OpenSuse 13.1 KDE
Windows XP SP3
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 3907
Location: World_Hub

PostPosted: Wed 02 Jul 2014, 17:35    Post_subject:  

Very Happy Wrong-O! My guess? You've either got a syntax error or spec'd a non-existent icon.
Code:
<!-- Additional TrayButton attribute: label -->
      <TrayButton label="Menu" icon="logo-mini.png" border="true">root:3</TrayButton>
      <TrayButton popup="Show Desktop" icon="mini-desktop.xpm" border="true">showdesktop</TrayButton>
      <TrayButton popup="Browser" icon="/usr/local/lib/X11/pixmaps/www24.png" border="true">exec:defaultbrowser</TrayButton>
      <TrayButton popup="Terminal" icon="/usr/local/lib/X11/pixmaps/console24.png" border="true">exec:urxvt</TrayButton>
      <TrayButton popup="Big FOUR" icon="/usr/local/lib/X11/mini-icons/glade-3.png" border="false">exec:anything_really</TrayButton>
jwm-tray_four.png
 Description   
 Filesize   3.71 KB
 Viewed   89 Time(s)

jwm-tray_four.png


_________________
>>>Punctuation Crash Course<<<
Back to top
View user's profile Send_private_message 
fixit


Joined: 16 Mar 2013
Posts: 668
Location: El Lago, Texas

PostPosted: Wed 02 Jul 2014, 17:57    Post_subject:  

It is working.

I had the case wrong for one letter in my icon.

_________________
Andy
Slacko Puppy 5.6.0
OpenSuse 13.1 KDE
Windows XP SP3
Back to top
View user's profile Send_private_message 
oui

Joined: 20 May 2005
Posts: 2078
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Fri 04 Jul 2014, 17:48    Post_subject:  

Related pages: see more here
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0985s ][ Queries: 12 (0.0513s) ][ GZIP on ]