Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 00:56
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
paquets virtuels manquants
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
augras

Joined: 11 Nov 2013
Posts: 695
Location: france

PostPosted: Sat 31 May 2014, 04:21    Post subject:  paquets virtuels manquants  

Bonjour,
Je viens de refaire un gros pupsave contenant un ensemble de logiciels tant graphiques que multimédia, bureautiques... que je vais utiliser pour installer puppy raring chez les copains afin qu'ils trouvent de quoi se débrouiller un peu dans tous les domaines.
Mais suite à l'installation de gnucash le PPM m'indique qu'il manque libmime-base64-perl et libnet-perl : pour toutes les indications de cette sorte j'ai réussi à contenter le toutou mais pas dans ce cas. Après recherches ces 2 paquets sont des paquets virtuels fournis normalement respectivement par perl et perl-modules : ces deux paquets sont pourtant bien installés... mais les 2 lib sont tout de même manquantes.
J'en suis donc là !
Qu'est-ce qui se passe-t-il ?
Merci pour votre aide.
Philippe
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 4464
Location: Gatineau (Qc), Canada

PostPosted: Mon 02 Jun 2014, 19:01    Post subject:  

Salut, augras.

Je suis tenté de te répondre que c'est normal qu'elles soient manquantes, vu qu'elles
sont virtuelles... Elles sont quelque part entre les deux oreilles de l'usager ?!

Mauvaise blague mise à part : des fois, le PPM, il dit n'importe quoi. (Comme moi !) Smile

La question importante est celle-ci : le logiciel fonctionne-t-il ?
Si le logiciel même te dit qu'il lui manque telle ou telle lib, là, c'est du sérieux.

Que dit le logiciel lui-même, lancé d'un terminal ?

S'il te manque vraiment des libs, http://pkgs.org est un excellent site pour les
trouver. Il suffit de choisir la biblio dans le dépôt resssemblant le plus au Puppy. Par
ex., télécharger la biblio du dépôt Ubuntu 12.04 pour un Puppy Lucid, et ainsi de suite.

À+

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 4464
Location: Gatineau (Qc), Canada

PostPosted: Mon 02 Jun 2014, 19:09    Post subject:  

Après une 2e lecture...

augras a dit :
> Après recherches ces 2 paquets sont des paquets virtuels fournis normalement
respectivement par perl et perl-modules : ces deux paquets sont pourtant bien
installés... mais les 2 lib sont tout de même manquantes.


Hum... Ça sonne comme un problème de version ou même de micro-version...
C'est pas tous les programmes perl qui aiment le perl installé par défaut sur le Toutou.

Aussi : le devx du Toutou est-il monté ? Le devx contient en général des compléments
pour les langages perl et python. Tes libs manquantes sont peut-être dans le devx ?

À tout hasard.

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
augras

Joined: 11 Nov 2013
Posts: 695
Location: france

PostPosted: Tue 03 Jun 2014, 12:16    Post subject:  

Bonjour Musher0,
Oui, c'est étonnant comme fonctionnement : des paquets virtuels qui sont réellement manquants !
Dans le terminal gnucash ne râle absolument pas. Dans son comportement il ne gère pas correctement les transactions récurrentes qui devraient apparaîtrent automatiquement environ 3 semaines avant leur échéance mais qui dans les faits n'apparaissent que le 1er du mois passé et il faut demander à ce qu'elles apparaissent.
Je ne sais pas si s'est lié. Mais comme ces dépendances sont manquantes et qu'elles ne sont apparues manquantes qu'au moment de l'installation de gnucash j'ai fait le lien.
Il n'affiche pas non plus correctement les séparations de lignes et de colonnes qui n'apparaissent que lorsque l'on clique sur une ligne et seulement pour la ligne en question : mais ça c'est très secondaire et certainement dû à un problème d'affichage.
J'ai monté le devx mais aucun changement.
Quand je cherche les lib sur le lien que tu indiques il propose de télécharger le paquet perl... déjà installé !

Après avoir installé tout ce que j'ai installé il n'y a que ces deux lib manquantes avec les dysfonctionnements ci-dessus pour le logiciel sans savoir si c'est lié. Et la lib gimphelbrowser, virtuelle également, qui implique que l'aide de gimp n'est pas gérée façon html mais étant par ailleurs bien fonctionnelle, donc sans conséquences.
Je trouve ça plutôt correct car la mule est bien chargée. Mais j'aurai bien aimé trouver comment installer les 2 lib en sujet au moins pour vérifier si les dysfonctionnements de gnucash disparaissaient.
Mais je crois qu'il va falloir faire avec !

Bon je retourne à la personalisation de wbar pour que tout ce qui est installé y soit accessible !

Merci Musher0,

Philippe
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0480s ][ Queries: 11 (0.0033s) ][ GZIP on ]