Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 13:34
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
ndiswrapper not working in PHATSlacko-5.5.02
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
B.K. Johnson

Joined: 12 Oct 2009
Posts: 141

PostPosted: Wed 28 May 2014, 14:28    Post subject:  ndiswrapper not working in PHATSlacko-5.5.02  

PHATSlacko does not have the driver for my wi-fi adapter. The driver is on my XP machine, the same one whose USB port I launch PHATSlacko from. I can connect to the Internet with the adapter from XP using the specified driver. On the puppy side (PHATSlacko), when I try to use ndiswrapper to install the driver, I get this:
[img]device_present.png[/img]
followed by this error message.
[img]ndisw-load-fail.png[/img]

At the command line, ndiswrapper -l and modprobe ndiswrapper give these results:
Code:
# ndiswrapper -l
bcmwlhigh5 : driver installed
    device (0846:9020) present

# modprobe ndiswrapper
FATAL: Module ndiswrapper not found.
#

I confirm the driver is installed in /etc/ndiswrapper/.

A search for ndiswrapper returned this list:
[img]where_ndiswrapper.png[/img]

I don't know enough to check out these files, so I hop over to the PPM. Of course, I can't update the database. Neither Internet or Network return ndiswrapper when selected. When I opt to search, the search window informs that there is one uninstalled version - version 1.5 for wary-5.
[img]ndis_w5.png[/img]

But the PPM main window also shows that version 1.57 is already installed.
[img]it_is_installed.png[/img]

So it is installed but not.working. I need to get a valid version and re-install.

Slacko versions 5.5, 5.6 and 5.7 have ndiswrapper installed OOTB and with some reservation (more on that another time) I connect with the driver set up with ndiswrapper. The Slacko-5.7/PPM lists ndiswrapper-1.57 as installed but ndiswrapper-v at the terminal shows the installed version as 1.59.

My problem is, how do I get a working ndiswrapper (1.57 or 1.59) for PHATSlacko when:
(a) I can't use PHATSlacko to connect and download the pet from PPM.
(b) accessing the PPM via Slacko-5.6 and 5.7 will only result in the existing files being overwritten.
(c) there does not appear to be a ndiswrapper-1.57 or 1.59 pet anywhere; not at the standard repositories:

http://distro.ibiblio.org/puppylinux/pet_packages-5/
http://distro.ibiblio.org/puppylinux/pet_packages-slacko14/
http://distro.ibiblio.org/puppylinux/pet_packages-slacko6414/

and the most current I could find when googling was 1.46.

I have made a request in the drivers forum for a replacement ndiswrapper 1.57. This post is for forum members like 01micko and mavrothal et al who may spot some problem.

B.K. Johnson
it_is_installed.png
 Description   
 Filesize   18.81 KB
 Viewed   119 Time(s)

it_is_installed.png

ndis_w5.png
 Description   
 Filesize   17.26 KB
 Viewed   142 Time(s)

ndis_w5.png

where_ndiswrapper.png
 Description   
 Filesize   12.83 KB
 Viewed   116 Time(s)

where_ndiswrapper.png

ndisw-load-fail.png
 Description   
 Filesize   10.28 KB
 Viewed   110 Time(s)

ndisw-load-fail.png

device_present.png
 Description   
 Filesize   6.82 KB
 Viewed   127 Time(s)

device_present.png

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0833s ][ Queries: 12 (0.0434s) ][ GZIP on ]