Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 14:46
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
histoire de packages
Moderators: Béèm, darkerror05
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
claudeh5

Joined: 06 May 2014
Posts: 12

PostPosted: Tue 20 May 2014, 20:40    Post_subject:  histoire de packages  

Bonjour.

Je suis ultra débutant linux et notamment Puppy/Toutou donc si vous pouvez m'aider...

Mon problème: je cherche à installer deux logiciels:
1/ truecrypt 7.1a
2/ softether vpn client

Concernant truecrypt 7.1a, j'ai vu qu'il y avait une conversation sur la partie anglaise. Mais franchement, pour un novice, c'est totalement abscond.

Je ne comprends rien du tout. C'est quoi un *.pet ? une archive du genre rpm ?

Quelles sont les archives que Toutou reconnait (quels sont les gestionnaires de paquets ? apt-get ? est-on toujours en mode superviseur ? (il y a besoin d'un sudo ou équivalent ou non ?)

Pour softether vpn client:

C'est un tar.gz sur http://www.softether-download.com/en.aspx?product=softether

son nom compet est

softether-vpnclient-v4.06-9437-beta-2014.04.09-linux-x86-32bit.tar.gz (4.66 MB)

(ou la version x64)

comment l'installer ?

Question subsidaire pour départager les éventuels ex-aequos :

Quelle est la différence entre un fichier.sfs, un fichier.pet, un fichier.deb et un fichier.rpm ?

Merci d'avance pour votre aide.
Back to top
View user's profile Send_private_message 
claudeh5

Joined: 06 May 2014
Posts: 12

PostPosted: Wed 21 May 2014, 03:14    Post_subject: Ca avance un peu  

Bonjour.

Je commence à comprendre quelques petites choses. l'installation des paquets *.pet c'est assez simple. Par contre la documentation semble ne pas être à jour puisqu'elle parle d'un gestionnaire de paquets, petget, qui n'est pas celui qui est installé (dans Wolx 2014 du moins).

Ce qui n'est pas évident c'est le nom des programmes ! Je viens de découvrir que le programme "gestionnaire des fichiers" est ROX-filer (que je cherchais depuis un moment).

Maintenant que j'ai vu comment on installait les *.sfs et les *.pet, voir ceux de slackware, il reste le principal pour moi:

comment (et où) installer
softether-vpnclient-v4.06-9437-beta-2014.04.09-linux-x86-32bit.tar.gz
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4258
Location: Gatineau (Qc), Canada

PostPosted: Wed 21 May 2014, 04:57    Post_subject:  

Salut, Claude.

Tout d'abord : bienvenue ! Smile J'espère que Puppy | Toutou te plaira.

Oui, l'histoire des paquets, ce peut être déroutant au début.

Il faut distinguer gestionnaire de fichiers (par exemple, ROX-Filer, Thunar) et
gestionnaire de paquets (par ex. Puppy Package Manager (alias PPM), apt-get).

Puppy utilise son propre gestionnaire de paquets (PPM), qui reconnaît bien sûr les
paquets au format *.pet, mais aussi les *.deb (familles Debian et Ubuntu), les *.rpm
(famille des mageia, CentOS et Fedora) et les *.tgz (famille des Slackware).

Au sujet de ton logiciel softether-vpnclient-machin-machin.tar.gz, vu la terminaison,
ce peut être soit une source à compiler, soit un logiciel indépendant ("self-contained";
comme opera ou firefox, si tu les télécharges du site d'origine pour ta distro).

Pour le savoir, il faut l'ouvrir. Alors, double-clique dessus. Xarchiver devrait l'ouvrir et
te montrer une liste de fichiers. En haut, il y a des icones et un menu qui te permettent
de choisir un ou tous les fichiers de l'archive, et de les déballer.

Si tu vois dans la liste des fichiers des noms de fichier comme Makefile, ou configure,
ou autogen.sh, il s'agit d'une source à compiler. Sinon, c'est un logiciel prêt à utiliser, il
suffit de le déballer.

Je vais aller voir et je te reviens. Ce sera plus simple, vu que tu débutes avec nous.
À tantôt.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
musher0


Joined: 04 Jan 2009
Posts: 4258
Location: Gatineau (Qc), Canada

PostPosted: Wed 21 May 2014, 05:32    Post_subject:  

Rebonjour !

Je viens d'enligner SoftEtherVPN-Puppy.zip à :
http://www9.zippyshare.com/v/89264979/file.html (lien valide pour 30 jours)

Je t'avoue que je ne m'y connais ni en ethernet, ni en VPN, donc j'ai compilé en
suivant les instructions données par les auteurs, mais je n'ai pas testé. J'ai compilé le
paquet "git-master", qui devrait procurer la version courante pour Linux.

Le zip ci-dessus contient et le paquet sfs et le paquet pet. Tu n'en utiliseras qu'un,
bien entendu. Commence par le pet ? S'il fonctionne, tu pourras le remplacer par le
sfs (ou non; libre à toi !). Smile

Personnes-ressources en matière de réseau, que je connais au moins un peu, sur ce
forum : "augras" (côté francophone; admin système); "Flash" (le modérateur principal
du forum Puppy, côté anglophone). Je les mentionne, parce que, si jamais le pet ne
fonctionnait pas, tu pourrais les consulter par la messagerie du forum et me revenir
pour voir s'il est possible de modifier la compilation, ou la version?

Alors, m..., comme on dit au théâtre ! Smile Tu nous tiens au courant ?
Et Bonne Route avec Puppy !

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
Médor


Joined: 26 May 2011
Posts: 1741

PostPosted: Wed 21 May 2014, 06:31    Post_subject:  

Bonjour,

Il existe dans Puppy/Toutou un client VPN PPTP : gpptp, doté d'une interface graphique simple.
Je ne suis pas sur Toutou actuellement pour vérifier l'entré du menu avec le menu simplifié mais on peut le lancer par :
Menu » Exécuter : gpptp


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4258
Location: Gatineau (Qc), Canada

PostPosted: Wed 21 May 2014, 16:17    Post_subject:  

Médor wrote:
Bonjour,

Il existe dans Puppy/Toutou un client VPN PPTP : gpptp, doté d'une interface graphique simple.
Je ne suis pas sur Toutou actuellement pour vérifier l'entré du menu avec le menu simplifié mais on peut le lancer par :
Menu » Exécuter : gpptp

Cordialement,
Médor.


Dans la section "Réseau" du menu jwm, en compagnie de "samba" et de 2 ou 3 ftp. Smile

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
claudeh5

Joined: 06 May 2014
Posts: 12

PostPosted: Sat 24 May 2014, 13:18    Post_subject:  

Bonjour.
Et merci.

Je vais tester.

Une chose qui est vraiment bien avec toutou linux: la taille. Avec tout de même une bibliothèque de logiciels conséquente

Je n'ai jamais bien compris pourquoi il faut 16 Go pour windows 7/8...

Je comprends bien que ce soit plus que les 512 ko des atari ST de 1985 parce qu'on n'avait pas d'internet ni de fichiers vidéo à cette époque mais tout de même !

Je soupçonne qu'il y a beaucoup d'optimisation à faire dans tous ces logiciels et que les compilations ne sont pas optimisées.

Un programme que j'écrirais en 50 lignes de code assembleur, je l'ai écrit en visual basic: 15.5 ko après compilation (en mode ligne de commande) !

Concernant softether vpn cette version est mieux que openvpn, elle est libre et le source est disponible pour windows, mac et linux mais pour linux il faut le compiler (makefile appelant gcc et des fichiers *.a)

autrefois (quand j'étais jeune, en 1977-1990) je programmais presque exclusivement en assembleur (6800, 8080A, 68000, 8048 et 6502) mais depuis qu'il n'y a plus que des 80x86 je ne programme plus guère.

Merci beaucoup pour vos réponses. Je viens de windows et je souffre...
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4258
Location: Gatineau (Qc), Canada

PostPosted: Sat 24 May 2014, 14:14    Post_subject:  

Salut, claudeh5.

C'est comme les scouts : "Atariste un jour, atariste toujours !" Very Happy
C'étaient de sacrées machines, les Ataris, même les 8-bits.

En résumé, t'es pas tout seul, y en a quelques autres qui hantent le forum Puppy !
(Aussi du côté anglo.) Au plaisir, confrère atariste !

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
oui

Joined: 20 May 2005
Posts: 2097
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Sat 24 May 2014, 18:42    Post_subject:  

excuse

claudeh5 wrote:
Je viens de windows et je souffre...


tu as souffert (sous windows) ou tu souffres (sous linux)?

puppy est pourtant simple (quand ça fonctionne avec ton matériel): tout le grand classique est dedans, OPTIMISÉ, c'est là l'astuce, et c'est pourquoi Puppy te confronte à des solutions pas toujours aussi fréquentes dans les autres Linux, et il n'y a pas besoin de pleurnicher!

si tu veux de l'ultra sobre, tu as d'autres solutions:

en pur assembleur pour 80x86: http://www.menuetos.net/

1 disquette simple normale de 1,5 MO

c'est exactement là que j'ai découvert en 2002-2003, je ne sais plus exactement, un certain Barry Kauler, futur papa d'un certain Puppy, sans doute en gestation à l'époque! Barry Kauler programmait encore en Windows, et a pondu un programme EXCEPTIONNEL de dessin eveWEB ne faisant que 80 kO, faut le faire (tu peux même l'utiliser dans ton puppy via Wine!)

en Linux pur, graphique
(enfin, avec
- un mode graphique,
- une collection de fonds d'écran graphiques, et
- deux applications graphiques,
-- la calculette scientifique, les signes mathématiques ne se laissant pas représenter en mode console, et
-- la présentation (MagicPoint), servant simultanément au dessin!
les autres applications,
- navigateur combiné web et de système de fichiers,
- traitement de texte super succinct servant d'éditeur aussi, et
- partie audio, étant en mode console!
mais tu peux
- te connecter en réseau et à l'internet,
- naviguer
-- sur le web et réseau,
-- naviguer dans ton système de fichier,
-- regarder tes courriels dans le navi si ton approvisionneur se contente de l'environnement, les miens le font ou le faisaient encore dernièrement, et à l'origine même ebay répondait présent, mais on ne voyait pas les images,
- calculer,
- écouter de la musique,
- régler le son,
- écrire
- imprimer en mode caractères au moins, et graphique mais en mode caractères, puisque tu as la nostalgie de l'antique, tu apprécieras
- te présenter et présenter ta carrière, tes travaux, tes ébauches et pipapo
- dessiner main levée
- copier d'une fenêtre à l'autre puisqu'en mode graphique, y compris entre applications de mode divergent, par exemple de navi vers le micro-traitement de textes, puis de la calculette vers le micro-traitement pour reprendre dans ton texte toutes les décades de pi sans risque d'erreur Wink , donc,
- multitasking de Linux
- visionner des dessins
ce sur un gestionnaire d'écran comparable à celui de Puppy, puisqu'il s'agit aussi de JWM!)

et ça, tiens toi bien, sur

1 disquette simple normale de 1,5 MO pleine à craquer (le linux proprement dit)
plus
1 disquette simple normale aux 2/3 ou 3/4 pleine (les applications)

tiens, télécharge et jette un coup d'oeil:

http://distro.ibiblio.org/baslinux/

il exista même un tuto pour Linux se basant directement sur cette mini-distro! À défaut (je ne trouve plus le lien, cette page donne des infos particulièrement utiles pour évoluer à la nostalgique en mode de commande en console !)

http://linoxide.com/guide/linux-cheat-sheet.pdf.

bon boulot!

salut
Back to top
View user's profile Send_private_message 
oui

Joined: 20 May 2005
Posts: 2097
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Sat 24 May 2014, 19:27    Post_subject:  

ah, encore qq ch.:

Puppy ne s'installe pas, mais se décomprime et se copie sur le DD. On appelle cela «en frugal».

Les nouveaux Puppys peuvent tous gérer un fichier de sauvegarde.

Ils se laissent ajouter des paquets (en l'absence de sauvegarde, il faut rajouter au coup par coup après chaque redémarrage, puisque le RAM a été totalement purgé et que Puppy fonctionne en RAM!).

Dans la sauvegarde, on peut enregistrer ces paquets ajoutés, mais, Puppy n'ayant pas de mise à jour puisque pas d'installation (on peut installer, mais alors on n'a plus qu'un linux absolument standard mais rabougri, auquel il manque des choses, par rapport aux autres linux vraiment installés, notamment les routines de mise à jour... et si on installe, il faut sacrifier une partition pour cette installation, et plus de fonctionnement en RAM, donc considérablement plus lent)...

... on met à jour en changeant purement et simplement de version!

conséquence: aux changement de version, les paquets qui avaient été ajoutés dans la sauvegarde doivent être invalidés et cela a lieu systématiquement!

pour remédier en quelque sorte à ce qui est parfois un inconvénient, dans le cas d'un puplet, et non pas de sa propre remasteurisation, et pour gagner de la place en RAM et obtenir des ISOs restant petits, on a aboutit à une troisième évolution des systèmes de paquetage propres à Puppy, qui fournit la possibilité d'adjoindre jusqu'à 6 (en standard! certaines versions spéciales non-standard peuvent entre temps admettre plus de 6) fichiers accolés, comme la sauvegarde, venant se greffer sur le système de fichiers de ce linux comme si ils en étaient partie réellement intégrante.

la 1ère génération des systèmes de paquetage propres à Puppy utilisait des paquets reconnaissable à la terminaison *.pup, paquets que l'on appelle dotputs
la 2ème génération des systèmes de paquetage propres à Puppy utilise désormais des paquets reconnaissable à la terminaison *.pet, paquets que l'on appelle dotpets

dotpets et dotpups vont dans la sauvegarde si on en crée une et c'est eux qui sont invalidés au changements de version de Puppy.

la 3ième évolution fut celle des fichiers *.sfs (squashed file systems, c'est à dire systèmes de fichiers super-comprimés).

eux ils ne vont pas dans la sauvegarde mais seulement leur index est intégré dans l'index général du système de fichiers... ils restent où ils sont. au démarrage de Puppy on est avisé d'une remise à jour du système de fichiers, si elle s'impose, c'est tout. par contre, il se peut fort bien que la nouvelle version s'avère incompatible. alors il faut en chercher d'autres en remplacement, ou complèter, quand c'est possible, le système pour les faire digérer quand même (souvent absence de dépendances, mais parfois plus graves: bibliothèques incompatibles). en outre, après changement de version, ils ne sont pas détectés automatiquement: il faut qu'ils soient dans la racine, et il peut s'en trouver, là, bien plus de 6! donc on doit choisir et enregistrer ce choix dans le système (load sfs file). avantage indirect: étant dans la racine, plusieur "puplets", c.à.d. remasteurisations de Puppy, peuvent les utiliser en commun! il suffit de les enregistrer au gré, dans chaque puplet avec lesquels ils s'avèrent compatible! on n'a pas besoin ainsi, de trimbaler le gros "wine", ou pire encore, 36 fois!

les dépôts de Puppy officiels n'offrent que très peu de dotsfs! un, presque toujours, celui de développement, puisque si Puppy est si petit, c'est parce qu'on l'a dépouillé de tout, en particulier des outils de développement que 50 % au moins des linuxiens dédaignent et n'utilisent jamais sciemment! par contre, on y trouve en général une belle batterie de dotpets, et ce, dans les dépots officiels, spécifiques, au moins en théorie, à la version! ceci donne donc un sens à l'invalidation des paquets installés aux changements de version, car il faut savoir que, quand on remasteurise, ces dotpets installés font alors partie de ta propre remasteurisation! Il n'y a aucune raison de continuer à en avoir besoin dans le fichier de sauvegarde!

mais, il y a un mais:

les puppyistes se sont enthousiasmés de pouvoir remasteuriser à gogo et de pouvoir briller dans notre communauté puppyiste en publiant leurs oeuvres d'art! et c'est là que ça se corse: les versions remasteurisées par d'autres portent les insignes d'une remasteurisation, mais sans posséder le contenu complet que, toi, tu aurais donné à l'ISO en remasteurisant pour ton propre compte! donc, ça efface dans TA sauvegarde alors que le copain, lui, n'avait pas du tout installé dans l'ISO tes paquets bien spéciaux chéris...

le système des 6 fichiers *.sfs adjoints est, là, plus souple et une bonne parade, mais comme il n'y a pas les insignes d'une version quelconque, le contrôle de compatibilité, ou, pas toujours, et il se peut qu'en cas d'incompatibilité, leur démarrage implique de graves interventions ou s'avère purement et simplement impossible, surtout quand on n'a aucune idée pour quelle version concrète ils avaient été pondus...

salut
Back to top
View user's profile Send_private_message 
Médor


Joined: 26 May 2011
Posts: 1741

PostPosted: Sun 25 May 2014, 00:55    Post_subject:  

Bonjour,

claudeh5 wrote:
Concernant softether vpn cette version est mieux que openvpn


Voici la fin du 'make' :

Code:
make[1]: Entering directory `/tmp/vpnclient'
Preparing SoftEther VPN Client...
ranlib lib/libcharset.a
ranlib lib/libcrypto.a
ranlib lib/libedit.a
ranlib lib/libiconv.a
ranlib lib/libintelaes.a
ranlib lib/libncurses.a
ranlib lib/libssl.a
ranlib lib/libz.a
ranlib code/vpnclient.a
gcc code/vpnclient.a -O2 -fsigned-char -pthread -m32 -lm -ldl -lrt -lpthread -L./ lib/libssl.a lib/libcrypto.a lib/libiconv.a lib/libcharset.a lib/libedit.a lib/libncurses.a lib/libz.a lib/libintelaes.a -o vpnclient
ranlib code/vpncmd.a
gcc code/vpncmd.a -O2 -fsigned-char -pthread -m32 -lm -ldl -lrt -lpthread -L./ lib/libssl.a lib/libcrypto.a lib/libiconv.a lib/libcharset.a lib/libedit.a lib/libncurses.a lib/libz.a lib/libintelaes.a -o vpncmd

--------------------------------------------------------------------
The preparation of SoftEther VPN Client is completed !


*** How to switch the display language of the SoftEther VPN Client Service ***
SoftEther VPN Client supports the following languages:
  - Japanese
  - English
  - Simplified Chinese

You can choose your prefered language of SoftEther VPN Client at any time.
To switch the current language, open and edit the 'lang.config' file.


*** How to start the SoftEther VPN Client Service ***

Please execute './vpnclient start' to run the SoftEther VPN Client Background Service.
And please execute './vpncmd' to run the SoftEther VPN Command-Line Utility to configure SoftEther VPN Client.
Of course, you can use the VPN Server Manager GUI Application for Windows on the other Windows PC in order to configure the SoftEther VPN Client remotely.
--------------------------------------------------------------------

make[1]: Leaving directory `/tmp/vpnclient'
#

D'après les licences incluses dans l'archive le Client VPN SoftEther utilise bien aussi openvpn : libcrypto.a, libssl.a, (fichiers intégrés dans l'archive) Exclamation
J'ignore la version exacte d'openssl utlilisée, cependant sa licence indique un Copyright 1998-2011 Exclamation

Voir sur ce fil la dernière version d'openssl-1.0.1g que j'ai compilé pour Wary-5.5/Wolx...

Concernant petget, cet utilitaire d'installation d'un paquet .pet et accessoirement d'un paquet .deb (Debian) et .tgz/.txz (Slackware) fait parti du PPM de Puppy/Toutou et il existe bien :
Code:
# whereis petget
petget: /usr/sbin/petget /usr/local/petget
#

Utilisation : petget "/chemin/fichier.pet"

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
claudeh5

Joined: 06 May 2014
Posts: 12

PostPosted: Mon 26 May 2014, 05:34    Post_subject:  

Bonjour et merci encore pour vos réponses.

Concernant softether vpn cette version est mieux que openvpn

La version de openSSL dans softether est la OpenSSL 0.9.8x.

en effet cette version intègre pour compatibilité openvpn mais aussi 5 autre protocoles:

Features of SoftEther VPN

1.2.jpgFree and open-source software.
Easy to establish both remote-access and site-to-site VPN.
SSL-VPN Tunneling on HTTPS to pass through NATs and firewalls.
Revolutionary VPN over ICMP and VPN over DNS features.
Resistance to highly-restricted firewall.
Ethernet-bridging (L2) and IP-routing (L3) over VPN.
Embedded dynamic-DNS and NAT-traversal so that no static nor fixed IP address is required.
AES 256-bit and RSA 4096-bit encryptions.
Sufficient security features such as logging and firewall inner VPN tunnel.
1Gbps-class high-speed throughput performance with low memory and CPU usage.
Windows, Linux, Mac, Android, iPhone, iPad and Windows Phone are supported.
SSL-VPN (HTTPS) and 6 major VPN protocols (OpenVPN, IPsec, L2TP, MS-SSTP, L2TPv3 and EtherIP) are all supported as VPN tunneling underlay protocols.
The OpenVPN clone function supports legacy OpenVPN clients.
IPv4 / IPv6 dual-stack.
The VPN server runs on Windows, Linux, FreeBSD, Solaris and Mac OS X.
Configure All settings on GUI.
Multi-languages (English, Japanese and Simplified-Chinese).
No memory leaks. High quality stable codes, intended for long-term runs. We always verify that there are no memory or resource leaks before releasing the build.
RADIUS / NT Domain user authentication function
RSA certificate authentication function
Deep-inspect packet logging function
Source IP address control list function
syslog transfer function

https://www.softether.org/

pour ce qui est de souffrir, le problème de linux est son installation des logiciels qui est très différente de celle de windows. On ne sait pas où s'installe le logiciel (en général windows demande dans quel dossier installer), et il y a tout un tas de bibliothèques ésotériques qui s'installent avec ... On trouve des logiciels pour linux en source. C'est à la fois rassurant et inquiétant: que fait-on de l'archive *.tar.gz qui contient un makefile appelant gcc avec tout un tas d'options ? pourquoi fournir un makefile plutôt qu'un logiciel tout prêt ? c'est quoi un fichier *.a ? A priori, gcc avec les options doit produire le même résultat dans toutes les distributions donc on ne voit pas bien l'avantage de faire soi-même sa compilation surtout quand le code faire presque 400 000 lignes de C/C++ et qu'on n'est pas le développeur de ce code ! pourquoi n'y a-t-il pas d'archives auto-extractibles qui rendraient les gestionnaires de paquets en grande partie inutiles ? Bref, on rêve d'une installation de logiciels simple et transparente pour l'utilisateur.

Edited_time_total
Back to top
View user's profile Send_private_message 
claudeh5

Joined: 06 May 2014
Posts: 12

PostPosted: Mon 26 May 2014, 05:38    Post_subject:  

Bon, j'ai encore beaucoup à apprendre mais ça ne me fait pas peur !

au fait, gcc est à installer je suppose ?

(je suis prof de mathématiques donc je m'intéresse à TeX aussi et aux logiciels de calculs formels)
Back to top
View user's profile Send_private_message 
oui

Joined: 20 May 2005
Posts: 2097
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Mon 26 May 2014, 16:36    Post_subject:  

bonsoir claude

peut-être que ce que j'ai tenté (je n'ai jamais appris l'anglais!) d'exposer dans ce message

http://www.murga-linux.com/puppy/viewtopic.php?p=779097#779097

à deux des meilleurs développeurs actuels de Puppy, stemsee et rsh, dans la langue commune, l'anglais (moi, je m'en fiche: je n'ai pas appris l'anglais, mais descend en partie d'une famille anglaise, donc ce n'est pas une catastrophe pour moi que l'anglais veuille s'imposer, uniquement, en l'utilisant, je le massacre, j'en suis conscient!) tu as un collègue sur ce forum, Emil, un allemand finissant ou ayant fini ses études de mathématiques aux USA, qui nous a fourni:

- une collection de *.sfs pour latex et lyx
- un script de construction automatique d'une copie de Puppy, le chiot, appelée "chat", et pour cause, dont rien n'est de Puppy, sur une base Debian, script modifié d'un autre script, pondu, lui, par un mathématicien français, dont Emil fait un rapport on ne peut plus élogieux

je me suis efforcé de tout traduire, ou presque, en français (mais pas en allemand, puisque Emil, allemand, aurait pu le faire lui-même sans risque d'omission ou erreur de trad!), tellement son exposé m'a enthousiasmé (mais un autre linux, francophone lui à quasi 100 %, fait quelque chose d'analogue depuis des années: http://nutyx.org, ce avec une différence magistrale, nutyx part des sources, puisque LFS (Linux from Scratch) n'existe qu'en sources Rolling Eyes . Debian, lui, fournit les deux, comme NuTyx aussi, mais les recréateurs de Debian à partir des sources sont absolument rarissimes comparé au %tage d'utilisateurs partant de la distro binaire et que la méthode Debian from Scratch n'est pas vraiment favorisée par Debian!).

en fait, Puppy, c'est pas ça du tout!

Puppy c'est une maison totalement en préfabriqué ne nécessitant même pas une plaque de béton (= partition de DD)! dès 2003..2004, Puppy offrait un environnement loisir quasi complet ne nécessitant absolument rien à rajouter et permettant de se sentir totalement à l'aise (contrairement à baslin, basic linux, qui est, lui, aussi confortable que la planche de monastarère servant de lit!)...

les premiers puppy avaient des ISOs (bien moins comprimées que maintenant) ne faisant que 20 Mo! la légendaire version 0.24, la première vraiment hautement confortable, ne faisait que 27 Mo, mais, contrairement à SliTaz, avait tout! Audio, bureau, internet, réseau etc. sans nécessiter le passage en ligne de commande, et, cette dernière particularité, c'est la grande force de Puppy (que les toutouistes tentent en permanence de remettre en question: il semble falloir "bricoler" en code et ligne de commande pour faire fonctionner Toutou et successeur, c'est pourquoi, quand je me donne de mettre en ligne des explications sur l'évolution de Puppy, du vrai Puppy, le Puppy original en langue anglaise, ce qui à moi aussi me prend un temps fou, immédiatement derrière un toutouiste vient mettre un message démontrant comment on fait ça mieux en ligne de commande et code, Médor, dont j'admire vraiment la dextérité en code et ligne de commande, même s'il l'applique sur la mauvaise distribution: il y a une distro qui se voue à ça, SliTaz, et qui était rigoureusement francophone au départ, et qui part en débandade parce que les développeurs francophones restant francophones sont de plus en plus rares. d'ailleurs SliTaz est devenu, par nécessité, anglophone officiellement depuis, et NuTyx aussi passe actuellement à l'anglophonie, quand à Mandrake, il y a des lunes que celà s'est déjà passé! Ils manquent de Médors).

en fait, donner à Puppy les outils de développement fut une gageure de Barry Kauler: il a automatiquement dilué son oeuvre en permettant à n'importe qui d'en faire n'importe quoi (la définition même du libre et sources libres). ors ce n'est pas ce qu'il voulait: pendant de longues années, ce qu'il avait le droit de copyrighter était bel et bien copyrighté (il interdisait notamment de traduire sa vaste littérature et documentation, conscient que les traducteurs ne sont que des intervenants passagers, n'ayant pas ou peu de continuité à l'ouvrage... donc les mises à jour n'ont pas lieu. Ors les versions successives de Puppy sont sa mise à jour, et les versions linguistiques ne suivent pas, les docs ne suivent pas non plus! C´est un vrai bourbier!)

tu n'as définitivement pas besoin de compilateur en Puppy! et il est vain et ridicule de développer sur des versions d'antan ayant de plus en plus d'écart avec "le" linux actuel! tu vas me dire que, «mais, les kernels, ils sont bien à jour!». bien sûr, mais le reste non. tu as des parties très anciennes (la plaie dont pourrait nous débarrasser le script d'Emil: avec le script d'Emil, Cat, qui n'est donc plus un chien Idea n'a que des bibliothèques actuelles, que ce soit en clavier Rolling Eyes , pilotes video, etc. car dans l'actuel dépôt du Debian stable, il n'y a plus que ça, il faudrait "pinner" sauvagement dans des vieilles versions pour faire remonter d'outre-tombe de vieilles bibliothèques! Et Emil a mis froidement Office et non pas Abiword dans son ISO pour cesser de bricoler: Mathématicien comme toi, il connait la difficulté du rendu de formules... Et c'est d'ailleurs pourquoi il a pondu des *.sfs de Latex et Lyx, note qu'il faut prendre des Puppy de date correspondante pour les utiliser. On peut télécharger *.sfs sur son site à l'université, mais attention, c'est de plusieurs Go qu'on parle, si on prend tout, et le site n'est pas d'un débit vraiment miraculeux!).

si donc tu veux développer modernement, prend la méthode Cat d'Emil (une méthode en fait française Wink d´origine). le script fait tout pour toi mis à part se modifier lui-même: c'est là que tu peux développer réellement. Le mini ISO est conçu et contient toutes les bibliothèques pour construite le reste en ne faisant que de télécharger automatiquement de Debian...

ou regarde d'abord SliTaz: il existe deux modes opératoires pour construire un linux from scratch du genre SliTaz, et non pas LFS (quoi que, je crois me souvenir que le nouveau ténor du développement voulait modifier les sources de LFS, c'est une indication utile, car les bash de LFS et Debian ont des petites différences dans les options, qui, malheureusement apparaissent dans certains scripts!), l'un le rel. 1.0 et l'autre le 4.0, si je me rappelle bien, et toutes les sources sont encore sur le site à http://mirror.slitaz.org (c'est ce qui est bien aussi sur slitaz: les url's sont cohérents et parlants: mirror./forum./doc./www.slitaz.org). La doc d'origine pour le SliTaz 1.0 est en français pondue par un francophone ne parlant, à cette époque, pas encore l'anglais, donc vraiment en français... La doc pour la 4.0, par contre, fut pondue en anglais, la langue ayant officiellement changé entre temps, et est éventuellement traduite, ou éventuellement pas encore (encore du boulot alors pour des âmes de bonne volonté)...

ou, comme déjà dit, NuTyx, toujours en français, mais s'anglophonisant lentement, et se basant sur Linux From Scratch LFS/BLFS et le livre publié gratuitement sur le web (et vastement traduit, la traduction ne pouvant pas toujours être à jour, car c'est un travail de titan!).

Puppy, lui, développe OFFICIELLEMENT, différemment. Les binaires officiels furent construits des sources avec T2, un générateur de distributon, puis réutilisés dans le constructeur de distribution appelé Woof et spécifique à Puppy, intégrant désormais directement des paquets Slackware, Ubuntu, Debian etc.. Ces outils sont documentés de manière excellente par Barry Kauler. Il documente aussi une méthode de construction depuis les sources. C'est au niveau de ces outils que devraient avoir lieu absolument toutes les corrections pour éviter le renouvellement des perturbations quand on reconstruit avec le constructeur de distribution Woof les prochaines versions! Ce n'est pas en bricolant du code en ligne de commande!

(Le script de Cat d'Emil fait la même chose, mais selon la méthode du mathématicien français et sans passer par une base élaborée via T2 mais en prenant directement tout de Debian).

claudeh5 wrote:
Bon, j'ai encore beaucoup à apprendre mais ça ne me fait pas peur !


Je viens de revérifier vaguement mes dires ci-dessus: la doc initiale (pondue en français) ne semble plus être directement accessible(peut-être questionner sur le forum?)! Bien dommage, car elle était relativement compacte, n'était pas traduite et aléatoire pour des raisons de traduction, et expliquait tout bonnement absolument tout Linux (pour les applications de la mixture privilégiée par SliTaz, bien sûr) ce qui permettait une mise au courant rapide. La nouvelle, pour la 5.0, que je ne connais que mal (l'autre, j'en avais traduit au moins plus de la moitié en allemand, donc je la connaissais), me semble plus vaste, moins compacte et peut-être moins systématique, et pas toujours à jour, voir donc incomplète, dans sa traduction en français, le français pouvant toujours la langue source, mais étant maintenant de plus en plus une trad de la version anglophone. mais on peut quand même la considérer comme un ouvrage fondamental sur Linux en français, et probablement de qualité, le traducteur ayant assurément en mains la doc française de la 1.0!

Salut
Back to top
View user's profile Send_private_message 
Médor


Joined: 26 May 2011
Posts: 1741

PostPosted: Mon 26 May 2014, 18:51    Post_subject:  

Bonsoir,

claudeh5 wrote:
au fait, gcc est à installer je suppose ?

Le nécessaire pour la compilation (dont gcc) se trouve dans le devx.sfs additionnel de la version de Puppy/Toutou utilisée, il existe aussi un sfs pour les sources du noyau.
Pour Toutou Wolx se servir du devx originel de Wary-5.5 : devx_wary_5.5.sfs
(Pour Toutou Rolx : devx_racy_5.5.sfs).

Les répertoires sous Linux :
Organisation courante des répertoires sous Linux

(Il existe maintenant Woof CE).


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1492s ][ Queries: 11 (0.0036s) ][ GZIP on ]