Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 07:07
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
AbiWord-3.0.0-GTK2
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 4 [47 Posts]   Goto page: 1, 2, 3, 4 Next
Author Message
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Wed 14 May 2014, 07:39    Post subject:  AbiWord-3.0.0-GTK2
Subject description: sfs pour Precise et Slacko
 

Voici le lien de abiword-3.0.0-gtk2_5.7.sfs (valide 90 jours minimum) en version complète pour Precise-5.7.1 et Slacko-5.7.0
Installer le sfs par sfs-on-the-fly puis le pet approprié : il contient la mise à jour de la libjpeg.so.62.0.0 nécessaire au bon fonctionnement de ce sfs et il permet de masquer le fichier /usr/bin/abiword d'origine.
Pour revenir à l'état antérieur, démonter le sfs puis désinstaller le pet Exclamation

Le sfs devrait fonctionner sur Raring avec le pet de Precise, ainsi que sur Slacko à partir des versions 5.5 Exclamation
Ce sfs ne fonctionne pas sur Wary/Wolx, Racy/Rolx, du moins pour l'instant car il manque des dépendances.

Cordialement,
Médor.
abiw3-install-Precise.pet
Description 
pet

 Download 
Filename  abiw3-install-Precise.pet 
Filesize  72.02 KB 
Downloaded  116 Time(s) 
abiw3-install-S14.pet
Description 
pet

 Download 
Filename  abiw3-install-S14.pet 
Filesize  71.49 KB 
Downloaded  86 Time(s) 

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 2531
Location: France

PostPosted: Wed 14 May 2014, 10:29    Post subject: Re: AbiWord-3.0.0-GTK2
Subject description: sfs pour Precise et Slacko
 

Médor wrote:
Voici le lien de abiword-3.0.0-gtk2_5.7.sfs (valide 90 jours minimum) en version complète pour Precise-5.7.1 et Slacko-5.7.0

Je viens de tester quelques fonctions basiques, cela semble fonctionnel avec Precise571.
Merci Médor !

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
augras

Joined: 11 Nov 2013
Posts: 597
Location: france

PostPosted: Wed 14 May 2014, 14:37    Post subject:  

Bonsoir,
Je ne pratique pas abiword... sauf quand l'ouverture d'un fichier coince par ailleurs !
Merci Médor.
Raring, postérieur d'un an à precise, intègre déjà la libjpeg62_6b1 : je n'ai donc pas installé le .pet.
Par contre abiword réclame alors libffi.so.5 : /usr/lib contient pourtant un lien libffi.so.5 vers libbffi.so.6 mais il pointe lui-même vers libffi.so.6.01 ; il faut supprimer le lien libffi.so.5 pour en créer un nouveau directement vers libffi..so.6.01 et tout fonctionne alors.
Par contre le .pet n'ayant pas été installé l'icône dans le menu lance l'ancienne version si l'on ne remplace pas à la main le fichier /usr/bin/abiword par le fichier abiword du sfs.
Avec ces "adaptations" ça fonctionne sous raring.
Merci encore.
Philippe
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Wed 14 May 2014, 14:51    Post subject:  

Bonsoir Philippe,

Non ce paquet sfs à besoin d'un lien pour la libffi.so.5 celui qui est inclus dans le sfs pointe sur la libffi.so.6.0.0
Donc pour Raring il faut faire un lien libffi.so.5 vers ta libffi.so.6.01 si ça ne fonctionne pas.
Si tu n'installes pas le pet il faut copier /usr/bin/abiword du sfs ou du pet dans /initrd/pup_rw/... sinon effectivement l'ancienne version se lance ou il faut désinstaller le paquet original avant de monter le sfs.
J'ai du recompiler sur Precise et sur Slacko la libjpeg.so.62.0.0, celles d'origines sur les deux versions posent des problèmes...

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1117

PostPosted: Wed 14 May 2014, 15:45    Post subject: Re: AbiWord-3.0.0-GTK2
Subject description: sfs pour Precise et Slacko
 

Médor wrote:
Voici le lien de abiword-3.0.0-gtk2_5.7.sfs (valide 90 jours minimum) en version complète pour Precise-5.7.1 et Slacko-5.7.0
Installer le sfs par sfs-on-the-fly puis le pet approprié : il contient la mise à jour de la libjpeg.so.62.0.0 nécessaire au bon fonctionnement de ce sfs et il permet de masquer le fichier /usr/bin/abiword d'origine.
Pour revenir à l'état antérieur, démonter le sfs puis désinstaller le pet Exclamation

Le sfs devrait fonctionner sur Raring avec le pet de Precise, ainsi que sur Slacko à partir des versions 5.5 Exclamation
Ce sfs ne fonctionne pas sur Wary/Wolx, Racy/Rolx, du moins pour l'instant car il manque des dépendances.


Un lien de téléchargement optionel:
http://yadi.sk/d/MA5_--vJQEbJ5

Merci Médor

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
slavvo67

Joined: 12 Oct 2012
Posts: 439
Location: The other Mr. 305

PostPosted: Wed 14 May 2014, 17:05    Post subject:  

Is ABI Word 3.0 even announced anywhere? I see no notification on ABI Source.
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Wed 14 May 2014, 17:15    Post subject:  

Hi slavvo67,

AbiWord v3.0.0 was released on October 13th 2013 Exclamation
http://abisource.com/release-notes/3.0.0.phtml

Cheers
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 597
Location: france

PostPosted: Thu 15 May 2014, 02:11    Post subject:  

Bonjour,

Médor wrote:
Donc pour Raring il faut faire un lien libffi.so.5 vers ta libffi.so.6.01 si ça ne fonctionne pas.
Si tu n'installes pas le pet il faut copier /usr/bin/abiword du sfs ou du pet dans /initrd/pup_rw/... sinon effectivement l'ancienne version se lance


C'est exactement ce que j'ai fait et essayé d'expliquer.
Mais c'est effectivement plus clair comme ça.
Bonne journée,
Philippe
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Sat 17 May 2014, 12:43    Post subject:  

Bonjour,

ASRI éducation wrote:
Je viens de tester quelques fonctions basiques, cela semble fonctionnel avec Precise571.

Il serait bien de pouvoir tester plus en profondeur les modules notamment le RDF pour les fichiers .odt et .abw

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 99

PostPosted: Sat 31 May 2014, 01:53    Post subject:  

Bonjour,

j'avais des problèmes avec Abiword sur Precise et ces deux pet et sfs ont résolu le problème.

Je n'ai pas très bien compris pourquoi l'un est un pet, et l'autre un sfs. Je les ai ntégré tous les deux dans un sfs qui regroupe une quinzaine de logiciels et ça marche très bien, à part qu'Abiword n'apparaît nul part et qu'il faut aller le chercher dans usr/bin.

Mais mon problème est résolu. Merci!

(Je suis sur le formidable Triton)

À bientôt.
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 597
Location: france

PostPosted: Sat 31 May 2014, 04:41    Post subject:  

Bonjour Dorothée,
Le .pet permet d'installer le logiciel alors que le .sfs permet de le lancer seulement quand on en a besoin. Quand on veut tester un logiciel le .sfs est très pratique puisque le système reste propre. Et dans le cas où l'on utilise rarement un logiciel c'est une bonne solution car on n'encombre pas le système.
Quelqu'un de plus au point corrigera si j'ai dis des âneries !
Dans le cas de ton .sfs qui regroupe plusieurs logiciels tu n'avais besoin que de l'un des deux : mais je ne sais pas le quel !
Bonne journée,
Philippe
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Sat 31 May 2014, 05:31    Post subject:  

Bonjour Dorothée,

En effet ni le sfs d'abiword ni le pet d'installation ne contiennent un fichier : /usr/share/applications/abiword.desktop, pour l'entré du menu car il est normalement présent d'origine dans les versions officielles de Puppy Wink
Pour la même raison, le pet d'installation permet d'écraser l'ancien fichier /usr/bin/abiword, le montage d'un sfs ne permettant pas d'écraser des fichiers existants.

Voici le contenu du fichier /usr/share/applications/abiword.desktop
Code:
[Desktop Entry]
Encoding=UTF-8
Name=Abiword word processor
Name[fr]=Traitement de textes Abiword
#Icon=/usr/share/pixmaps/puppy/write.svg #Woof CE
Icon=/usr/share/icons/hicolor/48x48/apps/abiword.png
Comment=Compose, edit, and view documents
Exec=abiword
Terminal=false
Type=Application
Categories=WordProcessor
GenericName=Abiword



Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 99

PostPosted: Sat 31 May 2014, 22:07    Post subject:  

Medor, bonjour,

merci pour l'info. En fait, je me suis très bien débrouillée en incorporant Abiword dans la wbar. Le petit A se dandine quand la souris le chatouille et Abiword s'ouvre si on clique dessus. Je le propose aussi dans le menu personnalisé quand on veut ouvrir un fichier texte (Open Office ou Abiword).

Mais le contenu du fichier /usr/share/applications/abiword.desktop me sera sûrement un jour bien utile. J'en apprend tous les jours!

À bientôt.
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Sat 31 May 2014, 23:51    Post subject:  

Bonjour Dorothée,

Les fichiers desktop apparaissent dans le menu en bas à gauche de la barre des tâches de JWM, Lxpanel, xfce, etc.
Les dernières versions de Wbar intégrent à présent un menu de configuration graphique qui permet d'ajouter/retirer facilement une application et de régler les paramètres de Wbar.

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 3220
Location: Mer méditerrannée (1 kms°)

PostPosted: Thu 12 Jun 2014, 23:54    Post subject: Abiword 2.9.4 > Abiword 3.0.0
Subject description: 2.8.6 assure, je remplace les versions 2.9.x
 

Abiword 2.9.4 > Abiword 3.0.0
Abiword 2.9.4 est installé à demeure sur certaine distros mais n'arrive pas à ouvrir les fichiers .abw
J'aime bien Abiword. Il me suffit. Mais faudrait qu'ils n'accumulent pas les bugs non résolus.
Version gtk3 : d'autres testeurs vont bien s'y coller.

_________________
Puppy, il ne lui manque que la parole !

Last edited by Pelo on Thu 26 Jun 2014, 12:06; edited 5 times in total
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 4 [47 Posts]   Goto page: 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0865s ][ Queries: 12 (0.0049s) ][ GZIP on ]