Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 17 Aug 2018, 19:26
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
DebianDog Utilities
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 6 [76 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
dancytron

Joined: 18 Jul 2012
Posts: 1102

PostPosted: Mon 20 Jul 2015, 02:31    Post subject:  

Tried DogRadio in Openbox Jessie. Worked well. No problem adding Custom Stations (local NPR Stations) or Stations from off the list (BBC World News).

Very nice.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3214
Location: holland

PostPosted: Tue 21 Jul 2015, 17:03    Post subject:  

Thanks for the feedback, Dan!
Glad you like it.
For a more polished version, 0.0.3, see my previous post (Edit2)

http://www.murga-linux.com/puppy/viewtopic.php?p=854507#854507

Fred
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3214
Location: holland

PostPosted: Tue 08 Sep 2015, 12:36    Post subject:  

**** DogRadio new version ****

Edited my post (Edit3 and Edit4) in this thread, here:
http://www.murga-linux.com/puppy/viewtopic.php?p=854507#854507

Fred
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3214
Location: holland

PostPosted: Mon 16 Nov 2015, 18:17    Post subject:  

Hi All,

*** Conky-Clock ***

Choose analog clock to display on the desktop, using yad GUI.

Perhaps a bit overdone to make a special app for choosing a clock display, but it was fun for me to make and to explore more of the 'yad' options.
Partly taken from here:
http://murga-linux.com/puppy/viewtopic.php?t=72815
Thanks very much to battleshooter and the one(s) who created the clock.lua script and the beautiful "clock_face" images, there's lots to choose from. Smile

Note: Requires yad version 0.26 or higher.
Other dependencies: wmctrl , hsetroot (wmctrl to check which window manager is active, e.g. JWM, special treatment using hsetroot for transparency) , liblua and conky-all.

Download:
Removed conkyclock_0.0.1_all.deb, see Edit below for newer (fixed) version 0.0.2

Install from terminal in directory from where inside is the downloaded file: conkyclock_0.0.2_all.deb:
Code:
dpkg -i conkyclock_0.0.2_all.deb
apt-get -f install # force installing extra required dependencies


Run from Menu> Utility (JWM) or Menu> Accessories (Openbox-xfce)

Edit: New version 0.0.2, fixed checking for the right yad version number, see next post from Stemsee
https://googledrive.com/host/0ByBgCDlZZ8K5NlYzQmM2cTh1Uk0/conkyclock_0.0.2_all.deb

Fred
conkyclock.jpg
 Description   Conky-Clock preview
 Filesize   94.38 KB
 Viewed   1007 Time(s)

conkyclock.jpg


Last edited by fredx181 on Sun 14 Feb 2016, 04:58; edited 3 times in total
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2260
Location: In The Way

PostPosted: Tue 17 Nov 2015, 06:48    Post subject:  

I tried installing your deb on wheezy and this
capture7463.jpg
 Description   "to old" != "too old"
 Filesize   10.25 KB
 Viewed   1022 Time(s)

capture7463.jpg

capture11757.jpg
 Description   
 Filesize   14.08 KB
 Viewed   1006 Time(s)

capture11757.jpg

Back to top
View user's profile Send private message MSN Messenger 
fredx181


Joined: 11 Dec 2013
Posts: 3214
Location: holland

PostPosted: Tue 17 Nov 2015, 12:43    Post subject:  

Hi Stemsee,

Quote:
I tried installing your deb on wheezy and this
...


Yes, thanks for reporting, the point is that I had never seen the yad version output like that (2 columns)

Fixed by changing line 11 in /usr/local/bin/conkyclock:
Code:
VERSION=`yad --version`

to:
Code:
VERSION=`yad --version | awk '{ print $1 }'`


Which will output the version number only and should work well this way.

So fixed in version 0.0.2, see Edit and download link in above Conky-Clock post

Edit: Btw, on which wheezy you were trying to install it? Dpup Wheezy perhaps or simillar puppy?
Note that this thread is for DebianDog utilities, not for any puppy (although the .deb packages can be installed with some modifying of course)

Fred
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2260
Location: In The Way

PostPosted: Tue 17 Nov 2015, 20:08    Post subject:  

Thanks Fred

On puppy Dpup wheezy, working fine now.

Might have been even nicer with a pseudo/transparent background.

This yad version I compiled with html enabled, maybe that has something to do with the two column string.
Back to top
View user's profile Send private message MSN Messenger 
fredx181


Joined: 11 Dec 2013
Posts: 3214
Location: holland

PostPosted: Wed 18 Nov 2015, 05:49    Post subject:  

stemsee wrote:
On puppy Dpup wheezy, working fine now.

Might have been even nicer with a pseudo/transparent background.


On DD Jwm it has transparency.
The script needs to know which wallpaper is active, on DD it finds it in ~/.config/rox.sourceforge.net/ROX-Filer/pinbd (<backdrop style=.........)

Just creating a symlink works, but only if wmctrl and hsetroot is installed:
Code:
ln -s ~/Choices/ROX-Filer/PuppyPin ~/.config/rox.sourceforge.net/ROX-Filer/pinbd


Fred
clock.png
Description  transparent clock on dpup wheezy
png

 Download 
Filename  clock.png 
Filesize  171.87 KB 
Downloaded  290 Time(s) 
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3214
Location: holland

PostPosted: Fri 20 Nov 2015, 15:06    Post subject:  

Hi All,

*** Conky-Clock v2 "deLuxe Edition" ***

Warning: For real Clock Maniacs only!!! Very Happy

Changes compared to the more simple Conky-Clock from earlier posted in this thread:
- Choice from 300 clock images with all different appropriate hands
- Option to display the date on the clock (requires imagemagick installed)
- Option to set the size of the clock
- Much larger size of the package (almost 14MB uncompressed)

Images and shell scripts taken from here:
http://jbaseb.deviantart.com/art/Conky-Analog-Clock-V6-4-6-themes-286955767
But very much modified for use with yad GUI

Download:
https://googledrive.com/host/0ByBgCDlZZ8K5NlYzQmM2cTh1Uk0/conkyclock2_1.0.1_all.deb

Install from terminal in directory from where inside is the downloaded file: conkyclock2_1.0.1_all.deb:

Code:
dpkg -i conkyclock2_1.0.1_all.deb
apt-get -f install # force installing extra required dependencies


Run 'Conky Clock v2' from Menu> Utility (JWM) or Menu> Accessories (Openbox-xfce)

Fred
conkyclock-v2-preview.jpg
 Description   Conky-Clock v2 on Jwm
 Filesize   89.27 KB
 Viewed   859 Time(s)

conkyclock-v2-preview.jpg

Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 5122
Location: Republic of Novo Zelande

PostPosted: Mon 15 Feb 2016, 15:19    Post subject:  

fredx181 wrote:
*** Dog-Radio ***
Yet another internet radio stream program, this one uses yad with icons GUI and tray-icon.
Hi, does this require a particular version of yad? I have not succeeded with getting it running correctly on Slacko 5.6.
It appears to start but has no gui - just a tray icon that does nothing so I thought maybe it required a certain version of yad. Thread here
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3214
Location: holland

PostPosted: Wed 17 Feb 2016, 19:02    Post subject:  

greengeek wrote:
fredx181 wrote:
*** Dog-Radio ***
Yet another internet radio stream program, this one uses yad with icons GUI and tray-icon.
Hi, does this require a particular version of yad? I have not succeeded with getting it running correctly on Slacko 5.6.
It appears to start but has no gui - just a tray icon that does nothing so I thought maybe it required a certain version of yad. Thread here


Yes, probably it won't work with old yad version 0.12 that some puppies still have included.
For me v0.20 and above works well.

from pet.specs:
dogradio-_0.0.6_all|dogradio|_0.0.6_all||Multimedia|3748K||dogradio_0.0.6_all.pet|+libc6, +gtk2-engines-murrine, +yad, +sed, +conky, +mplayer, +file, +streamripper|DogRadio||||

gtk2-engines-murrine is not really required but makes it look more smooth.
streamripper: also optional, for ripping streams (right-click tray-icon menu> Rip stream)

Fred
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3214
Location: holland

PostPosted: Thu 18 Feb 2016, 17:13    Post subject:  

*** New DogRadio v 0.0.6 ***

See for more info and .deb download, Edit6 here:

http://www.murga-linux.com/puppy/viewtopic.php?p=854507#854507

Topic by Stemsee and .pet download, see here:

http://murga-linux.com/puppy/viewtopic.php?t=105384

Fred
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2260
Location: In The Way

PostPosted: Sat 20 Feb 2016, 05:57    Post subject:  

Hi Fred

I have 2 feature requests for DogRadio!

One is a toggle switch to change from btheadset to default output and back.
two is a button to select bt speaker from an hcitool scan and write its mac address to /etc/asound.conf or export the mac address as a variable.

asound.conf entry for two bluetooth speaker devices ... replace mac addresses with variable or write directly the mac address to the config.
Code:
defaults.pcm.device 0
defaults.pcm.card 0
pcm.btheadset {
   type plug
   slave {
       pcm {
           type bluetooth
           device 13:28:36:00:BB:EF
           profile "auto"
       }
   }
   hint {
       show on
       description "BTHeadset"
   }
}
ctl.btheadset {
  type bluetooth
}

pcm.btheadset1 {
   type plug
   slave {
       pcm {
           type bluetooth
           device CC:C5:0A:67:D7:39
           profile "auto"
       }
   }
   hint {
       show on
       description "Headset"
   }
}
ctl.btheadset1 {
  type bluetooth
}
Back to top
View user's profile Send private message MSN Messenger 
stemsee

Joined: 27 Jun 2013
Posts: 2260
Location: In The Way

PostPosted: Tue 23 Feb 2016, 07:01    Post subject:  

I wrapped the addition to func script thusly
Code:
btcon=`hcitool con | rev | cut -f1 -d ':'`
if [ ! -z "$btcon" ]; then
shopt -s expand_aliases
alias mplayer='mplayer -ao alsa:device=btheadset "$@"'
fi


Now auto-switches to configured sound card if no bluetooth connection is found. This is very general and will not differentiate between a speaker and keyboard bluetooth connection, at the moment.
Back to top
View user's profile Send private message MSN Messenger 
wiak

Joined: 11 Dec 2007
Posts: 934
Location: not Bulgaria

PostPosted: Sat 15 Jul 2017, 12:32    Post subject: using xhplay/xhippo combination as universal file viewer  

mcewanw wrote:
Description

xhippo is a very resource-efficient versatile and extensible media player both in terms of its tiny installation size and in its RAM usage.
...
xhippo is a generic playlist manager program/process control program (source in C).

With the included backends: xhplay, and xhrecord, it can play all sorts of audio and video media (the playlist can contain a mix of audio and video types) and also record audio (mp3, wav, ogg, aac, and flac) via the included xhrecord


Just discovered that xhplay/xhippo combination is even more flexible/powerful than I realised - can work with mixed playlists of AV media and image files (e.g. gif, animated gifs, png, jpeg) and even pdf, doc, and html files if you like! Just needed adding extra copies of existing mcewanw code snippets into xhplay but in these altering program file extensions and viewer program names as per here:

http://www.murga-linux.com/puppy/viewtopic.php?p=960816#960816

xhplay with xhippo turns out to be an amazing efficient universal file type player/viewer combination.

wiak
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 6 [76 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0804s ][ Queries: 12 (0.0206s) ][ GZIP on ]