Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 17 Apr 2014, 02:46
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
How to get musicplayer to play .asx radio stn bookmark file?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Author Message
ruuatl

Joined: 06 Apr 2014
Posts: 18

PostPosted: Tue 08 Apr 2014, 13:01    Post subject:  How to get musicplayer to play .asx radio stn bookmark file?
Subject description: Internet radio stations file WinAmp
 

In Windows XP, my radio station bookmark file was a notepad file with .3mu bookmarks.
It downloaded into Linux as an .asx file.
I tried setting the "run action", but couldn't get GNOME MPlayer to play it.

Is there a way to play it?
Is there another player, like WinAmp, which worked in Windows and which was faster at playing bookmarks and sounded better than GNOME MPlayer?
For downloading, I think I can use only SFS files, since I am using a live CD.
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 749
Location: London, England

PostPosted: Tue 08 Apr 2014, 16:51    Post subject:  

These types of files such as .m3u and .pls and .asx are playlist metafiles. They are just small text files which contain instructions to launch a player and connect it to the true stream URL.

The .asx file type is more usually designed to work with Windows Media Player but some Linux audio or media players will be able to open it. Check the webpage of the radio station for alternative "Listen Now" buttons or links which might give you a .m3u or .pls file instead though, as these are slightly less problematic.

MPlayer (or Gnome MPlayer) will open the .asx file if you enter -playlist /path/to/asxfile

Alternatively you can right-click and save the .asx file in your usual download location and then right-click on it and open it as text to reveal the real stream URL which you can then enter into your player as a bookmark instead.

Here is an .asx file opened as text:-

Code:
<ASX VERSION="3.0">
   <!--Windows Media Player Metafile-->
   <!--File Stream-->
   <title>Radio Jackie</title>
   <ENTRY>
      <AUTHOR>Radio Jackie 107.8</AUTHOR>
      <REF HREF="http://radiojackie.com:12614" />
   </ENTRY>
   <ENTRY>
      <AUTHOR>Radio Jackie 107.8</AUTHOR>
      <REF HREF="http://port80.radiojackie.com:80" />
   </ENTRY>
</ASX>

Note the stream URL with port number http://radiojackie.com:12614
You can just enter that and the stream will play.

_________________
Oscar in England

Back to top
View user's profile Send private message 
ruuatl

Joined: 06 Apr 2014
Posts: 18

PostPosted: Tue 08 Apr 2014, 22:05    Post subject:  

Where do I put: -playlist /path/to/asxfile ?

I tried putting it in GNOME MPlayer Edit>Preferences>Extra Options to MPlayer.
I also inserted the filename as executable.
Neither worked.
The AbiWord file doesn't have anyplace to put it.

I entered it into the terminal and got this error message:
# -playlist /path/to/asxfile
bash: -playlist: command not found
# touch -playlist /path/to/asxfile
touch: invalid option -- 'p'
Try `touch --help' for more information.

I tried putting http://radiojackie.com:12614 into the file that I got working as a file of playlist metafiles, but it wanted to put it into another playlist metafile and wouldn't put it into the file of playlist metafiles as another playlist metafile.

How can I get the MPlayer Executable to be blank again?
The file of metafiles was working before, but now it wants some file in there.
It says:
Use this option to specify an MPlayer application that is not in the path.
The metafiles appeared with headphones icons, but now they just appear as black text if open or as blue text if open as folder.
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 749
Location: London, England

PostPosted: Tue 08 Apr 2014, 23:47    Post subject:  

Actually I tested that .asx file I downloaded in Gnome MPlayer in Slacko 5.6 and it played without needing -playilst in front. I just clicked File>Open and navigated to the .asx file and it played, but these things vary sometimes depending on the stream format (mp3 or aacplus for example) and other factors.

If you are playing a stream which you are connecting the player to via http (like the link extracted from the .asx file) then you need to do that by using File>Open Location.

If you have downloaded your .asx file the best idea might be to open it as text, grab the http link and enter that in "Open Location" or "Open URL" or whatever.

When I say /path/to/asxfile you do not literally enter those words. You must use your own paths and file names. For example if you have downloaded your .asx file (and it is named "listen.asx") and you have saved it in /root/Downloads then it will play if you open a terminal and type:-
Code:
mplayer -playlist /root/Downloads/listen.asx

and press Enter.

_________________
Oscar in England

Back to top
View user's profile Send private message 
ruuatl

Joined: 06 Apr 2014
Posts: 18

PostPosted: Wed 09 Apr 2014, 09:35    Post subject:  

When I navigate to the .asx file through GNOME and do File>Open, GNOME remains grey and says "stopped"; nothing happens.

I tried Open Location with mms and http radio station metafiles.
The mms says "loading" for a long time.
The http one doesn't do anything.

When I navigated to the .asx file, I noticed that it only has one URL in it, one with mms, which was the first in the list. Somehow it didn't load all the other metafiles.

The terminal command worked.
# mplayer -playlist /root/Radio2.asx
MPlayer svn r34540 (Ubuntu), built with gcc-4.6 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing mms://beotelmedia.beotel.net/rtvpink.
STREAM_ASF, URL: mms://beotelmedia.beotel.net/rtvpink
Resolving beotelmedia.beotel.net for AF_INET...
Connecting to server beotelmedia.beotel.net[195.252.114.172]: 1755...

Connected
read error:: Resource temporarily unavailable
pre-header read failed
Resolving beotelmedia.beotel.net for AF_INET...
Connecting to server beotelmedia.beotel.net[195.252.114.172]: 80...

connection timeout
Failed, exiting.
Resolving beotelmedia.beotel.net for AF_INET...
Connecting to server beotelmedia.beotel.net[195.252.114.172]: 80...

connection timeout
No stream found to handle url mms://beotelmedia.beotel.net/rtvpink


Exiting... (End of file)
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5561
Location: Valåmoen, Norway

PostPosted: Wed 09 Apr 2014, 10:28    Post subject:  

Thank you Oscar for your knowledge.
I will add this to the pmusic todo-list

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
rokytnji


Joined: 20 Jan 2009
Posts: 1122
Location: Pecos/ Texas

PostPosted: Wed 09 Apr 2014, 10:29    Post subject:  

Quote:
I tried putting http://radiojackie.com:12614 into the file


I went to that link. Hit the listen on toolbar. Downloaded in Xine the .pls offered. I will upload the .pls I recieved.

Just unzip. Rename to radiojackie.pls. Open with gnome-mplayer. I use xmms myself for pls or mocp,cmus.

Happy Trails, Rok
listen.pls.zip
Description 
zip

 Download 
Filename  listen.pls.zip 
Filesize  183 Bytes 
Downloaded  4 Time(s) 

Last edited by rokytnji on Wed 09 Apr 2014, 10:53; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks

Joined: 05 Feb 2012
Posts: 749
Location: London, England

PostPosted: Wed 09 Apr 2014, 10:38    Post subject:  

That tells us that your "Radio2.asx" file is trying to connect your player to the URL "mms://beotelmedia.beotel.net/rtvpink" but the stream is down, off-line or can not be accessed for some reason. If that is the case then nothing will make it work. Sometimes streams are blocked to force you to listen via their website so they can insert advertising, but I really don't know what is happening here.

Perhaps it would help if you could give the radio station website that you are trying to listen to.

The mms:// protocol is really a Windows Media Player thing although some players including MPlayer should be able to handle it. If the stream is mp3 you may be able to substitute http:// in place of mms:// but not if the stream is wma (windows media audio).

Sometimes it may be better to launch the player via a link on the webpage rather than using a local copy of the .asx file because the stream URL may change and your local copy would not reflect the update.

If you want to have a number of radio streams bookmarked I suggest you try PupRadio (which is in the menu). With this it is very easy to enter radio station names and web URL's and save these as bookmarks which you access whenever you want from the drop-down bookmarks list. If you select mplayer as the player in PupRadio you can then enter either direct stream URL's or weblinks to playlist files (such as .asx or .m3u or .pls). If you are entering a weblink to a playlist file you can experiment with putting -playlist in front.

Press the play button to see if it plays and if it does, click the button to save it as a bookmark.

_________________
Oscar in England

Back to top
View user's profile Send private message 
ruuatl

Joined: 06 Apr 2014
Posts: 18

PostPosted: Wed 09 Apr 2014, 21:44    Post subject:  

I couldn't get pupRadio presets or Mike's stations to work.
I tried it every which way (except going to the homepage of the station).

Using the presets:
GNOME says loading or stopped or playing.
There was a bubble window saying the station was playing, "OK".

Creating a new preset:
I put in what I think was the correct URL and it registered with the name I put in.
I can't hear anything.
Volume is 61%, not muted.
My speakers are on.
Back to top
View user's profile Send private message 
rokytnji


Joined: 20 Jan 2009
Posts: 1122
Location: Pecos/ Texas

PostPosted: Wed 09 Apr 2014, 22:09    Post subject:  

Playing OK for me in terminal using moc.

Code:
chronix_aggression.pls                ││1 ://radiojackie.com:12614/[     |NET]│
│chronix_grit.pls                      ││                                      │
│chronix_metal_masters.pls             ││                                      │
│chronix_metal.pls                     ││                                      │
│classic_gator_rock.pls                ││                                      │
│Dangerous.pls                         ││                                      │
│digital_gunfire.pls                   ││                                      │
│dronezone.pls                         ││                                      │
│FMRokket.pls                          ││                                      │
│Futura_911.pls                        ││                                      │
│gamer_radio.pls                       ││                                      │
│GotRadio.pls                          ││                                      │
│IcyGold_Radio.pls                     ││                                      │
│indiepop.pls                          ││                                      │
│jackieradio.pls                       ││                                      │
│kpop.pls                              ││                                      │
│NIN.pls                               ││                                      │
│No_Boundries_rock.pls                 ││                                      │
│NoiseFM.pls                           ││                                      │
├────┤Playing...               ├──────────┤       Master  97%  ├───┤>000:00:00├┤
│ > http://radiojackie.com:12614/                                              │
│00:13       [00:00]   44kHz  128kbps [STEREO] [NET] [SHUFFLE] [REPEAT] [NEXT


Back to top
View user's profile Send private message Visit poster's website 
dejan555


Joined: 30 Nov 2008
Posts: 2588
Location: Montenegro

PostPosted: Thu 10 Apr 2014, 02:06    Post subject:  

ruuatl, try with this pls
Also, check out this mplayer frontend for radio
http://murga-linux.com/puppy/viewtopic.php?t=90842

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
OscarTalks

Joined: 05 Feb 2012
Posts: 749
Location: London, England

PostPosted: Thu 10 Apr 2014, 10:10    Post subject:  

If the preset button stations in PupRadio are playing but you don't hear any audio then you need to check your volume settings first before trying to connect to other streams. Open Retrovol and check all the controls, especially look for the one labelled "PCM".

To launch a stream by connecting to a .asx file over the web (rather than by downloading a local copy to your machine) you can just use the web link. Hover your cursor over the link on the page to see it or right-click and copy the link to clipboard and paste it in. For example, in terminal:-
Code:
mplayer -playlist http://www.radiojackie.com/listenhigh.asx

should connect and play.

I notice that with Gnome MPlayer you should use two dashes like this --playlist although it will play without using the argument at all. The strange thing is though that it refuses to stop or close. It just buffers and starts playing again !!
Code:
gnome-mplayer --playlist http://www.radiojackie.com/listenhigh.asx

You may have to kill it to stop it.

With PupRadio I suggest you stick to MPlayer and enter the -playlist argument and web link in the URL field if it is a playlist file you are linking to. If it is a direct stream URL then you only need the URL and no -playlist argument. In addition to storing your favourite stations on the buttons you can also store them (more than eight of them) in the drop-down list of bookmarks near the bottom.

_________________
Oscar in England

Back to top
View user's profile Send private message 
ruuatl

Joined: 06 Apr 2014
Posts: 18

PostPosted: Thu 10 Apr 2014, 10:43    Post subject:  

dejan555, I clicked on "pls" and saw the player, but it said "stopped" and I didn't hear anything.
I am using a live CD with Puppy Precise and read that I need SFS for download.

OscarTalks, I pasted the first code into rxvt and I hear it.
mplayer -playlist http://www.radiojackie.com/listenhigh.asx
PupRadio still isn't working for me.

rokytnji, what is moc?
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 749
Location: London, England

PostPosted: Thu 10 Apr 2014, 11:32    Post subject:  

OK, so MPlayer and the system are working.

Now open PupRadio
Select Preferred Player = mplayer
Type Name = RadioJackie
Type URL = -playlist http://www.radiojackie.com/listenhigh.asx
Click the Play Now button

Stream should play. It does for me.

If it plays, click the Save Bookmark button. Stream stops but bookmark is saved. To play it again at any time, select it in the Bookmarks drop-down list and click the Play Bookmark button.

Alternatively, you can save up to 8 favourite bookmarks as the Preset buttons.
pupradio-asx.jpg
 Description   Playing a stream via a .asx playlist link over the web
 Filesize   60.9 KB
 Viewed   46 Time(s)

pupradio-asx.jpg


_________________
Oscar in England

Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2588
Location: Montenegro

PostPosted: Thu 10 Apr 2014, 13:24    Post subject:  

It's not the problem with .asx, like you said in some previous post OscarTalks, mms://beotelmedia.beotel.net/rtvpink just isn't valid url, while this one is http://pink.exyuserver.com/listen.pls (ruuatl, I'm assuming you want to play "Radio Pink" )

In simple gtk radio:
mms://beotelmedia.beotel.net/rtvpink doesn't work for me
http://pink.exyuserver.com/listen.pls does work
http://www.radiojackie.com/listenhigh.asx works for me
(without -playlist, this is detected automatically in SGR, just paste url in "Open URL" window)

moc is a music player for console (Music-On-Console)
sgr-radiojackie.jpg
 Description   
 Filesize   41.66 KB
 Viewed   32 Time(s)

sgr-radiojackie.jpg


_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Display posts from previous:   Sort by:   
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0972s ][ Queries: 12 (0.0063s) ][ GZIP on ]