Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 30 Jul 2014, 13:15
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
[Résolu] Subtitleeditor et la galère des libraries
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Author Message
Dorothée


Joined: 27 Nov 2012
Posts: 99

PostPosted: Tue 25 Feb 2014, 01:20    Post subject:  [Résolu] Subtitleeditor et la galère des libraries  

Bonsoir tout le monde,

quelqu'un aurait-il dans sa besace un subtitleeditor qui marcherait sur Lupu 528? Parce que je galère avec un paquet Debian et des tas de libraries qui manquent. Et je ne veux pas revenir sur windows! (ça marche très bien sur windows, hélas!)

À bientôt, et merci d'avance,

Last edited by Dorothée on Thu 20 Mar 2014, 00:11; edited 1 time in total
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1803
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 25 Feb 2014, 07:32    Post subject:  

Bonjour Dorothée,
As-tu essayé Puppy "Precise" avec laquelle tu aurais peut-être plus de chance d'y arriver, vu qu'elle est construite pour l'utilisation des deb du dépôt Ubuntu?
C'est loin d'être parfait mais c'est tout de même moins galère dès que, sorti des programmes "standard", on essaie d'en installer des plus spécialisés.

PPM propose subtitleeditor_0.39.0-2 et libsubtitleeditor0_0.39.0-2, un paquet contenant les lib et runtime...

Note: C'est pour cette raison en particulier que j'ai choisi Puppy "Precise" comme base de travail pour ToOpPy (qui embarque libgstreamer d'origine).

Voici la liste complète des dépendances manquantes, telle que la donne PPM:
Quote:
HIÉRARCHIE DES DÉPENDANCES MANQUANTES DU PAQUET subtitleeditor_0.39.0-2
Format de chaque ligne: 'paquet-dépendant-manquant: dépendances manquantes d'un paquet-dépendant-manquant'

libgstreamer-plugins-base0.10-0: libgstreamer0.10-0 iso-codes
libgstreamer0.10-0:
libgstreamermm-0.10-2: libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libxml++2.6-2
libsubtitleeditor0: libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgstreamermm-0.10-2 libxml++2.6-2
gstreamer0.10-x: libgstreamer0.10-0 libgstreamer-plugins-base0.10-0
gstreamer0.10-plugins-good: libavc1394-0 libcairo-gobject2 libdv4 libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libiec61883-0 libjack-jackd2-0 libshout3 libsoup-gnome2.4-1 libv4l-0 libwavpack1 gstreamer0.10-plugins-base
gstreamer0.10-plugins-base: libgstreamer0.10-0 libvisual-0.4-0 libgstreamer-plugins-base0.10-0

gstreamer0.10-plugins-base:
libavc1394-0:
libcairo-gobject2:
libdv4:
libgstreamer0.10-0:
libgstreamermm-0.10-2:
libgstreamer-plugins-base0.10-0:
libiec61883-0:
libjack-jackd2-0:
libshout3:
libsoup-gnome2.4-1:
libv4l-0: libv4lconvert0
libvisual-0.4-0:
libwavpack1:
libxml++2.6-2:
libv4lconvert0:

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
Médor


Joined: 26 May 2011
Posts: 1659

PostPosted: Tue 25 Feb 2014, 08:41    Post subject:  

Bonjour,

Pas simple, subtitleeditor nécessite effectivement de nombreuses dépendances Exclamation

Pour Lucid-528, Asri-300, voir ces paquets :
subtitleeditor_0.40.0-1~webupd8~lucid_i386.deb
libsubtitleeditor0_0.40.0-1~webupd8~lucid_i386.deb
Plus les dépendences dont gstreamer, gstreamermm, libxml++, etc. depuis le PPM...

Pour Precise il existe :
subtitleeditor_0.41.0-1~webupd8~precise_i386.deb
libsubtitleeditor0_0.41.0-1~webupd8~precise_i386.deb
...


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1803
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 25 Feb 2014, 10:23    Post subject:  

Bonjour,
Même en installant toutes les lib indiquées comme "manquantes", je n'arrive pas à faire fonctionner subtitleeditor. L'application s'ouvre Very Happy
...
mais plante lamentablement dès que j'essaie de charger un fichier vidéo. Embarassed
Ce que la console renvoie:
Quote:
# subtitleeditor

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(subtitleeditor:18096): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
Config::Config > No such file or directory
Segmentation fault
#

(il faut bien le dire, ces p... de libs, c'est la plaie de LINUX et cette blessure toujours ouverte en décourage plus d'un, car même si au bout du compte, moyennent quelques recherches sur le net, on arrive à faire fonctionner la bête, bien peu se donnent cette peine, ou même peuvent se la donner!).
Embarassed Crying or Very sad
Si d'aventure on y arrive, alors il faudra faire un paquet prêt à l'emploi.

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
Médor


Joined: 26 May 2011
Posts: 1659

PostPosted: Tue 25 Feb 2014, 11:38    Post subject:  

J'ai essayé de compiler le tout (ou presque...) sur Precise-5.7 mais j'ai encore au moins deux problèmes lors du make :
Quote:
collect2: ld returned 1 exit status
make[4]: *** [libadjusttime.la] Error 1
make[4]: Leaving directory `/tmp/subtitleeditor-0.41.0/plugins/actions/adjusttime'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/subtitleeditor-0.41.0/plugins/actions'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/subtitleeditor-0.41.0/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/subtitleeditor-0.41.0'
make: *** [all] Error 2
#

Ce ne doit pas être impossible, mais ça reste une usine à gaz Wink

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1803
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 25 Feb 2014, 12:42    Post subject:  

Pour ce qui est de la compilation, j'ai beaucoup, sinon tout à apprendre. Mes excuses Médor si je dis des conneries, mais il semblerait qu'il manque quelque chose dans les sources elles-mêmes, non?
Liste des fichiers:
Quote:
/install/
/install/doinst.sh
/install/slack-desc
/usr/
/usr/bin/
/usr/bin/subtitleeditor
/usr/doc/
/usr/doc/subtitleeditor-0.41.0/
/usr/doc/subtitleeditor-0.41.0/ABOUT-NLS
/usr/doc/subtitleeditor-0.41.0/AUTHORS
/usr/doc/subtitleeditor-0.41.0/COPYING
/usr/doc/subtitleeditor-0.41.0/ChangeLog
/usr/doc/subtitleeditor-0.41.0/INSTALL
/usr/doc/subtitleeditor-0.41.0/NEWS
/usr/doc/subtitleeditor-0.41.0/README
/usr/doc/subtitleeditor-0.41.0/TODO
/usr/doc/subtitleeditor-0.41.0/subtitleeditor.SlackBuild
/usr/lib/
/usr/lib/libsubtitleeditor.la
/usr/lib/libsubtitleeditor.so.0.0.0
/usr/lib/subtitleeditor/
/usr/lib/subtitleeditor/plugins/
/usr/lib/subtitleeditor/plugins/actions/
/usr/lib/subtitleeditor/plugins/actions/libabout.la
/usr/lib/subtitleeditor/plugins/actions/libabout.so
/usr/lib/subtitleeditor/plugins/actions/libadjusttime.la
/usr/lib/subtitleeditor/plugins/actions/libadjusttime.so

/usr/lib/subtitleeditor/plugins/actions/libapplytranslation.la
/usr/lib/subtitleeditor/plugins/actions/libapplytranslation.so
/usr/lib/subtitleeditor/plugins/actions/libbestfit.la
/usr/lib/subtitleeditor/plugins/actions/libbestfit.so
/usr/lib/subtitleeditor/plugins/actions/libchangeframerate.la
/usr/lib/subtitleeditor/plugins/actions/libchangeframerate.so
/usr/lib/subtitleeditor/plugins/actions/libclipboard.la
/usr/lib/subtitleeditor/plugins/actions/libclipboard.so
/usr/lib/subtitleeditor/plugins/actions/libcombinesubtitles.la
/usr/lib/subtitleeditor/plugins/actions/libcombinesubtitles.so
/usr/lib/subtitleeditor/plugins/actions/libcommand.la
/usr/lib/subtitleeditor/plugins/actions/libcommand.so
/usr/lib/subtitleeditor/plugins/actions/libconfigurekeyboardshortcuts.la
/usr/lib/subtitleeditor/plugins/actions/libconfigurekeyboardshortcuts.so
/usr/lib/subtitleeditor/plugins/actions/libdialoguize.la
/usr/lib/subtitleeditor/plugins/actions/libdialoguize.so
/usr/lib/subtitleeditor/plugins/actions/libdocumentmanagement.la
/usr/lib/subtitleeditor/plugins/actions/libdocumentmanagement.so
/usr/lib/subtitleeditor/plugins/actions/libdocumentsnavigation.la
/usr/lib/subtitleeditor/plugins/actions/libdocumentsnavigation.so
/usr/lib/subtitleeditor/plugins/actions/libduplicatesubtitle.la
/usr/lib/subtitleeditor/plugins/actions/libduplicatesubtitle.so
/usr/lib/subtitleeditor/plugins/actions/libeditcell.la
/usr/lib/subtitleeditor/plugins/actions/libeditcell.so
/usr/lib/subtitleeditor/plugins/actions/liberrorchecking.la
/usr/lib/subtitleeditor/plugins/actions/liberrorchecking.so
/usr/lib/subtitleeditor/plugins/actions/libextendlength.la
/usr/lib/subtitleeditor/plugins/actions/libextendlength.so
/usr/lib/subtitleeditor/plugins/actions/libexternalvideoplayer.la
/usr/lib/subtitleeditor/plugins/actions/libexternalvideoplayer.so
/usr/lib/subtitleeditor/plugins/actions/libfindandreplace.la
/usr/lib/subtitleeditor/plugins/actions/libfindandreplace.so
/usr/lib/subtitleeditor/plugins/actions/libinsertsubtitle.la
/usr/lib/subtitleeditor/plugins/actions/libinsertsubtitle.so
/usr/lib/subtitleeditor/plugins/actions/libinsertsubtitlefromkeyframe.la
/usr/lib/subtitleeditor/plugins/actions/libinsertsubtitlefromkeyframe.so
/usr/lib/subtitleeditor/plugins/actions/libitalicize.la
/usr/lib/subtitleeditor/plugins/actions/libitalicize.so
/usr/lib/subtitleeditor/plugins/actions/libjoindocument.la
/usr/lib/subtitleeditor/plugins/actions/libjoindocument.so
/usr/lib/subtitleeditor/plugins/actions/libkeyframesmanagement.la
/usr/lib/subtitleeditor/plugins/actions/libkeyframesmanagement.so
/usr/lib/subtitleeditor/plugins/actions/libminimizeduration.la
/usr/lib/subtitleeditor/plugins/actions/libminimizeduration.so
/usr/lib/subtitleeditor/plugins/actions/libmoveafterprecedingsubtitle.la
/usr/lib/subtitleeditor/plugins/actions/libmoveafterprecedingsubtitle.so
/usr/lib/subtitleeditor/plugins/actions/libmovesubtitles.la
/usr/lib/subtitleeditor/plugins/actions/libmovesubtitles.so
/usr/lib/subtitleeditor/plugins/actions/libplaintext.la
/usr/lib/subtitleeditor/plugins/actions/libplaintext.so
/usr/lib/subtitleeditor/plugins/actions/libpreferences.la
/usr/lib/subtitleeditor/plugins/actions/libpreferences.so
/usr/lib/subtitleeditor/plugins/actions/libremovesubtitle.la
/usr/lib/subtitleeditor/plugins/actions/libremovesubtitle.so
/usr/lib/subtitleeditor/plugins/actions/libreversetextandtranslation.la
/usr/lib/subtitleeditor/plugins/actions/libreversetextandtranslation.so
/usr/lib/subtitleeditor/plugins/actions/libscalesubtitles.la
/usr/lib/subtitleeditor/plugins/actions/libscalesubtitles.so
/usr/lib/subtitleeditor/plugins/actions/libselection.la
/usr/lib/subtitleeditor/plugins/actions/libselection.so
/usr/lib/subtitleeditor/plugins/actions/libsortsubtitles.la
/usr/lib/subtitleeditor/plugins/actions/libsortsubtitles.so
/usr/lib/subtitleeditor/plugins/actions/libspellchecking.la
/usr/lib/subtitleeditor/plugins/actions/libspellchecking.so
/usr/lib/subtitleeditor/plugins/actions/libsplitdocument.la
/usr/lib/subtitleeditor/plugins/actions/libsplitdocument.so
/usr/lib/subtitleeditor/plugins/actions/libsplitsubtitle.la
/usr/lib/subtitleeditor/plugins/actions/libsplitsubtitle.so
/usr/lib/subtitleeditor/plugins/actions/libstacksubtitles.la
/usr/lib/subtitleeditor/plugins/actions/libstacksubtitles.so
/usr/lib/subtitleeditor/plugins/actions/libstyleeditor.la
/usr/lib/subtitleeditor/plugins/actions/libstyleeditor.so
/usr/lib/subtitleeditor/plugins/actions/libtextcorrection.la
/usr/lib/subtitleeditor/plugins/actions/libtextcorrection.so
/usr/lib/subtitleeditor/plugins/actions/libtimemodemanagement.la
/usr/lib/subtitleeditor/plugins/actions/libtimemodemanagement.so
/usr/lib/subtitleeditor/plugins/actions/libtimingfromplayer.la
/usr/lib/subtitleeditor/plugins/actions/libtimingfromplayer.so
/usr/lib/subtitleeditor/plugins/actions/libtypewriter.la
/usr/lib/subtitleeditor/plugins/actions/libtypewriter.so
/usr/lib/subtitleeditor/plugins/actions/libvideoplayermanagement.la
/usr/lib/subtitleeditor/plugins/actions/libvideoplayermanagement.so
/usr/lib/subtitleeditor/plugins/actions/libviewmanager.la
/usr/lib/subtitleeditor/plugins/actions/libviewmanager.so
/usr/lib/subtitleeditor/plugins/actions/libwaveformmanagement.la
/usr/lib/subtitleeditor/plugins/actions/libwaveformmanagement.so
/usr/lib/subtitleeditor/plugins/subtitleformats/
/usr/lib/subtitleeditor/plugins/subtitleformats/libadobeencoredvdntsc.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libadobeencoredvdntsc.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libadobeencoredvdpal.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libadobeencoredvdpal.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libadvancedsubstationalpha.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libadvancedsubstationalpha.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libbitc.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libbitc.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libdcsubtitle.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libdcsubtitle.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libmicrodvd.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libmicrodvd.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libmpl2.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libmpl2.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libmpsub.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libmpsub.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libplaintextformat.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libplaintextformat.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libsami.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libsami.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libsbv.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libsbv.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libsprucestl.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libsprucestl.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libsubrip.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libsubrip.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libsubstationalpha.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libsubstationalpha.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libsubtitleeditorproject.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libsubtitleeditorproject.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libsubviewer2.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libsubviewer2.so
/usr/lib/subtitleeditor/plugins/subtitleformats/libtimedtextauthoringformat1.la
/usr/lib/subtitleeditor/plugins/subtitleformats/libtimedtextauthoringformat1.so
/usr/man/
/usr/man/man1/

Ces 2 fichiers (en gras) sont-il bien présents dans tes sources?
=> Voir ici?

Cordialement

_________________

Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 1803
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 25 Feb 2014, 12:48    Post subject:  

Note:
Dorothée wrote:
(ça marche très bien sur windows, hélas!)
En dernier recours, ce programme fonctionne peut-être bien avec W.I.N.E!
[EDIT] Je ne trouve pas subtitleeditor pour windose sur le net, ou alors il porte un autre nom?

Cordialement.

_________________


Last edited by Argolance on Tue 25 Feb 2014, 13:16; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Médor


Joined: 26 May 2011
Posts: 1659

PostPosted: Tue 25 Feb 2014, 13:15    Post subject:  

La libadjusttime est un plugin dans le paquet des sources de subtitleeditor (0.41.0) ...

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 99

PostPosted: Tue 25 Feb 2014, 21:31    Post subject:  

Vraiment, je vous remercie beaucoup de vous être penchés sur ce problème avec tant d'acuité.

Comme je n'ai pas eu le temps aujourd'hui de me remettre à ma cuisine informatique, je vais recommencer (sur une copie de fichier de sauvegarde toute neuve, pour pouvoir faire toutes les expériences, y compris les plus foireuses) et je vous tiens au courant.

D'ores et déjà, voici la liste des librairies présentes et manquantes que mon Lulu me communique (sachant que j'ai installé auparavant gstreamer, qui a dû installer des librairies):

# ldd /usr/bin/subtitleeditor
/usr/bin/subtitleeditor: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/bin/subtitleeditor)
linux-gate.so.1 => (0xffffe000)
libgstreamer-0.10.so.0 => /usr/lib/libgstreamer-0.10.so.0 (0xb766d000)
libgstinterfaces-0.10.so.0 => /usr/lib/libgstinterfaces-0.10.so.0 (0xb7665000)
libgstpbutils-0.10.so.0 => not found
libsubtitleeditor.so.0 => not found
libglademm-2.4.so.1 => not found
libgtkmm-2.4.so.1 => /usr/lib/libgtkmm-2.4.so.1 (0xb7305000)
libatkmm-1.6.so.1 => /usr/lib/libatkmm-1.6.so.1 (0xb72c1000)
libgdkmm-2.4.so.1 => /usr/lib/libgdkmm-2.4.so.1 (0xb7279000)
libpangomm-1.4.so.1 => /usr/lib/libpangomm-1.4.so.1 (0xb724c000)
libcairomm-1.0.so.1 => /usr/lib/libcairomm-1.0.so.1 (0xb722b000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb6e55000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb6dbf000)
libglibmm-2.4.so.1 => /usr/lib/libglibmm-2.4.so.1 (0xb6d67000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb6d28000)
libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0xb6d21000)
libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xb6c56000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb6b60000)
libm.so.6 => /lib/libm.so.6 (0xb6b3a000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb6b1b000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb6b02000)
libc.so.6 => /lib/libc.so.6 (0xb69a8000)
libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb69a1000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb699c000)
libdl.so.2 => /lib/libdl.so.2 (0xb6998000)
libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb686e000)
libz.so.1 => /lib/libz.so.1 (0xb6859000)
libgiomm-2.4.so.1 => /usr/lib/libgiomm-2.4.so.1 (0xb67b8000)
libpng12.so.0 => /lib/libpng12.so.0 (0xb6793000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb6789000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb666c000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb6650000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb6628000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb660e000)
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb6602000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb6588000)
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb64ea000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb64a7000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6430000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb6400000)
librt.so.1 => /lib/librt.so.1 (0xb63f7000)
libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb63f3000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb63ee000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb63e8000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xb63d8000)
libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb63d4000)
libXi.so.6 => /usr/lib/libXi.so.6 (0xb63c6000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb63bd000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb63b3000)
libpcre.so.3 => /lib/libpcre.so.3 (0xb6382000)
/lib/ld-linux.so.2 (0xb7711000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6368000)
libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb630d000)
libdirectfb-1.2.so.0 => /usr/lib/libdirectfb-1.2.so.0 (0xb6296000)
libfusion-1.2.so.0 => /usr/lib/libfusion-1.2.so.0 (0xb628c000)
libdirect-1.2.so.0 => /usr/lib/libdirect-1.2.so.0 (0xb6276000)
libxcb-render-util.so.0 => /usr/lib/libxcb-render-util.so.0 (0xb6271000)
libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0xb6268000)
libresolv.so.2 => /lib/libresolv.so.2 (0xb6254000)
libselinux.so.1 => /lib/libselinux.so.1 (0xb6239000)
libexpat.so.1 => /lib/libexpat.so.1 (0xb6212000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb620d000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6207000)
#
Il y a d'abord ce ibstdc++.so.6: version `GLIBCXX_3.4.15 que j'ai cherché partout sur internet et que je n'ai pas trouvé.

J'ai aussi téléchargé et mis libgstpbutils-0.10.so.0 dans /usr/lib/ mais il me dit qu'il n'est pas là! Comment se fait-ce?

À propos de Precise, j'aurais préféré rester sur Lulu parce que c'est celui qui a le plus répondu à mes besoins jusqu'à maintenant (des logiciels de base et des tas de sfs pris chez LazyuPup le magnifique). D'autant qu'il y a eu récemment une actualisation.

Quant à subtitleeditor sur windows, je me suis trompée, c'est subtitle workshop qui marche. Qui sait si ce logiciel-là peut mieux fonctionner avec mon Lulu?

Je vais de ce pas essayer avec les deux:
subtitleeditor_0.40.0-1~webupd8~lucid_i386.deb
libsubtitleeditor0_0.40.0-1~webupd8~lucid_i386.deb

C'est drôle que ce soit chez ASRI, parce que c'est là où j'avais cherché en premier, et je n'avais pas trouvé.

Bon, je recommence et je vous tiens au courant.

Et merci encore!
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 99

PostPosted: Wed 26 Feb 2014, 01:25    Post subject:  

Voici le résultat des courses:

après avoir essayé subtitle workshop sous wine, mais dont la prévisualisation vidéo ne marche pas (chez moi en tout cas) et tenté de trouver des librairies sur internet, j'ai fini par découvrir le logiciel JUBLER, qui a l'air du tonnerre, grâce à robwoj44:

http://www.murga-linux.com/puppy/viewtopic.php?search_id=773402591&t=45991

et que l'on peut trouver là:

http://dotpups.de/puppy4/dotpups/Multimedia/

Donc j'en reste là. Mais cette recherche m'a permis d'apprendre des tas de choses, et aussi grâce à vous!

Merci encore, et à bientôt pour de nouvelles aventures,
Back to top
View user's profile Send private message 
Jejy69


Joined: 20 Jan 2011
Posts: 705
Location: Perpignan

PostPosted: Wed 26 Feb 2014, 04:51    Post subject:  

Bonjour Dorothée,

J'ai créé un paquet .pet de SubtitleEditor, si vous le souhaitez, vous pouvez le télécharger ici https://e-nautia.com/disk/download.php?id=5418098, la recherche de librairies n'étant pas franchement une partie de plaisir.
Je l'ai compilé sous lucid, il devrait donc correspondre à vos attentes, du moins je l'espère.
S'il est défectueux, faites le moi savoir. Smile

Cordialement,
Jérôme,
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1659

PostPosted: Wed 26 Feb 2014, 06:59    Post subject:  

Bonjour,

@ Jérôme,
Bien ancienne la version 0.30 de subtitleeditor Exclamation
Les libs complémentaires notamment gstreamer en version 0.10 ne devraient pas se trouver dans le pet.
Il est fort possible que ça écrase une version installée de gstreamer plus récentes (>= 0.10.35)...
As-tu oublié de tout stripper Question

@ Dorothée,
La libstdc++ est d'origine en version 6.0.13 sur Lucid-528, Asri-300, et en version 6.0.16 sur Precise.
Celle de Precise fonctionne sur Lucid-528, on peut installer le deb : http://packages.ubuntu.com/precise/i386/libstdc++6/download


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL

Last edited by Médor on Wed 26 Feb 2014, 09:30; edited 1 time in total
Back to top
View user's profile Send private message 
Jejy69


Joined: 20 Jan 2011
Posts: 705
Location: Perpignan

PostPosted: Wed 26 Feb 2014, 07:27    Post subject:  

Bonjour Médor,

Quote:
Bien ancienne la version 0.30 de subtitleeditor

Lucid est bien ancienne également. Ne pas s'étonner s'il y a des problèmes de libs si vous installez des versions beaucoup plus récentes. Je reste en accord avec la distribution de base. Lucid propose SubtitleEditor dans sa version 0.30.

Quote:
Il est fort possible que ça écrase une version installée de gstreamer plus récentes (>= 0.10.35)...

Lucid n'intègre pas gstreamer, et si on respecte un peu l’obsolescence de cette distribution, alors, ce paquet écrasera un gstreamer d'une même version.

Quote:
As-tu oublié de tout stripper

Non, je souhaite simplement offrir un peu de simplicité. Après Dorothée n'est pas dans l'obligation d'installer ce paquet, et pourra reprendre les différentes mélanges de Precise avec Lucid, comme vous semblez lui indiquer...

Sinon, il est possible de faire un SFS qui n'écrasera rien.

Cordialement,
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1659

PostPosted: Wed 26 Feb 2014, 07:45    Post subject:  

@ Jérôme,:

Il existe un paquet subtitleeditor 0.40.0 Ubuntu Lucid Update Exclamation
Donc c'est possible Wink

Il n'y a pas que subtitleeditor que se sert de libstreamer, libxml++, ... Exclamation
Ces paquets doivent être séparés Exclamation
Barry K recommande aussi de diviser un paquet en : EXE, DOC, NLS, DEV Exclamation

À part les modules du noyau, on peut stripper les libs et les exécutables.

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 99

PostPosted: Wed 26 Feb 2014, 18:32    Post subject:  

Décidément, vous êtes formidables!

à Jejy69, je vais essayer tout de suite ton Pet, et même essayer de le transformer en sfs (j'aime bien fonctionner en sfs).

Je n'ai pas tout saisi des subtilités informatiques auxquelles vous faites allusion, mais je vous tiens au courant du résultat.

Et merci encore!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1382s ][ Queries: 12 (0.0040s) ][ GZIP on ]