Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 03:31
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
[Résolu] Openoffice : Accents sur nom de fichiers non gérés
Moderators: Béèm, darkerror05
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
crestey


Joined: 22 Jan 2014
Posts: 19

PostPosted: Thu 23 Jan 2014, 14:07    Post_subject:  [Résolu] Openoffice : Accents sur nom de fichiers non gérés  

Bonjour à tous,

Tout est dans le titre.
Les accents sont bien gérés dans rox, aussi dans writter et calc(dans les feuilles elles-mêmes).
Mais quand je veux sauver un fichier openoffice avec un accent dans le nom, ooo ne veut pas.
(De même si j'ouvre un répertoire avec des noms de fichiers avec accent, openoffice me les présente avec des hiéroglyphes)

Bref, toutoulinux gère partout bien les accents, mais openoffice n'y arrive pas (pour les noms de fichiers uniquement).

une idée ?

Edited_time_total
Back to top
View user's profile Send_private_message 
ASRI éducation


Joined: 09 May 2009
Posts: 2544
Location: France

PostPosted: Thu 23 Jan 2014, 14:21    Post_subject:  

Peux-tu préciser la version du paquet utilisé ?
Cordialement,

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send_private_message Visit_website 
Médor


Joined: 26 May 2011
Posts: 1737

PostPosted: Thu 23 Jan 2014, 14:25    Post_subject:  

L'option UTF-8 pour la locale est-t-elle active ?

Voir dans l'Assistant de Toutou » Administration » Localisation.
Voir aussi dans les préférences du programme si l'UTF-8 est bien configuré.

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
crestey


Joined: 22 Jan 2014
Posts: 19

PostPosted: Thu 23 Jan 2014, 15:41    Post_subject:  

Quote:
Peux-tu préciser la version du paquet utilisé ?

C'est celui-là : http://toutoulinux.free.fr/pet.php (openoffice3.2 allégé)
Quote:
L'option UTF-8 pour la locale est-t-elle active ?

Non
Donc je l'ai activé, mais c'est sans effet.
Quote:
Voir aussi dans les préférences du programme si l'UTF-8 est bien configuré.

Je suis allé voir dans Calc/Outils/Option....
Et je n'ai rien trouvé concernant la configuration de l'UTF-8
... Confused ... Crying or Very sad ...
Back to top
View user's profile Send_private_message 
Médor


Joined: 26 May 2011
Posts: 1737

PostPosted: Thu 23 Jan 2014, 15:55    Post_subject:  

Il faut absolument mettre la locale du système en UTF-8 Exclamation
Les fichiers déjà enregistrés sont en iso-8859, les accents sont incompatibles entre les deux modes.
Dans une partition Windows, les caractères accentués dans les nom de fichiers et les doc. sont aussi en UTF-8.
En UTF-8 un caractère accentué est codé sur deux bits pas en iso-8859-1x

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
crestey


Joined: 22 Jan 2014
Posts: 19

PostPosted: Thu 23 Jan 2014, 16:23    Post_subject:  

C'est résolu.
Le même problème est là : http://forum.ubuntu-fr.org/viewtopic.php?pid=43991#p43991
Ici, ça se passe dans le fichier /etc/profile que j'ai modifié comme ça
Code:
#this line gets edited by chooselocale script...
#LANG=fr_FR.utf8.utf8 w004 going back to non-utf8...
LANG=fr_FR.utf8
export LANG
#LC_ALL=fr_FR
LC_ALL=fr_FR.utf8
export LC_ALL
#LANGUAGE=fr_FR
LANGUAGE=fr_FR.utf8
export LANGUAGE

Et maintenant, tout baigne.
Back to top
View user's profile Send_private_message 
Médor


Joined: 26 May 2011
Posts: 1737

PostPosted: Thu 23 Jan 2014, 16:34    Post_subject:  

Oui, ça revient au même en cochant l'option UTF-8 dans l'interface ça modifie ensuite /etc/profile Wink

D'origine sous Wolx la locale est bien réglée en UTF-8.
Code:
# locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
# locale --all
C
en_US.utf8
fr_FR.utf8
POSIX
#


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
crestey


Joined: 22 Jan 2014
Posts: 19

PostPosted: Thu 23 Jan 2014, 17:16    Post_subject:  

C'est bizarre, car j'avais bien coché l'option et ça n'avais rien arrangé.
Du coup, juste pour tester, je l'ai décoché, j'ai rebooté, et mon problème reste résolu suite à la manip manuelle de /etc/profile.
Donc vu de mon PC, ce que tu suggères est sans rapport avec mon problème. Question
Back to top
View user's profile Send_private_message 
Médor


Joined: 26 May 2011
Posts: 1737

PostPosted: Thu 23 Jan 2014, 17:39    Post_subject:  

Bien ce n'est pas normal, je viens de passer par l'interface en fr_FR, après redémarrage de la session X, j'ai maintenant :
Code:
# locale
LANG=fr_FR
LC_CTYPE="fr_FR"
LC_NUMERIC="fr_FR"
LC_TIME="fr_FR"
LC_COLLATE="fr_FR"
LC_MONETARY="fr_FR"
LC_MESSAGES="fr_FR"
LC_PAPER="fr_FR"
LC_NAME="fr_FR"
LC_ADDRESS="fr_FR"
LC_TELEPHONE="fr_FR"
LC_MEASUREMENT="fr_FR"
LC_IDENTIFICATION="fr_FR"
LC_ALL=
# locale --all
C
en_US.utf8
fr_FR
fr_FR.utf8
POSIX
#

Ça a bien installé en plus les fichiers pour la locale fr_FR, inexistants par défaut lors du premier boot en LiveCD Exclamation

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
crestey


Joined: 22 Jan 2014
Posts: 19

PostPosted: Thu 23 Jan 2014, 18:17    Post_subject:  

Je viens de tester plusieurs fois.
Pour moi l'option de Assistant de Toutou » Administration » Localisation. modifie uniquement LANG (le premier paramètre listé pas la commande locale)
Pour modifier les autres paramètres (tous ceux en LC_... ), il faut écrire directement dans /etc/profile.
Sinon ils ne bougent pas.
Je pense que mon problème venait de là.
Back to top
View user's profile Send_private_message 
Médor


Joined: 26 May 2011
Posts: 1737

PostPosted: Thu 23 Jan 2014, 18:28    Post_subject:  

Pas d'accord Wink

Je viens de repasser en fr_FR.UTF-8 en cochant la case UTF-8, validé, redémarré la session X et je suis actuellement avec le mêmes valeurs du premier code (et fr_FR en plus dans locale -all).

Je n'ai pas modifié manuellement /etc/profile Wink

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
crestey


Joined: 22 Jan 2014
Posts: 19

PostPosted: Thu 23 Jan 2014, 18:39    Post_subject:  

Bon.

Il est l'heure de conclure. Cette histoire m'inspire.
Je vais donc improviser quelques proverbes shadocks :

"L'important c'est de pomper, peu importe à quoi ça sert !"

Plus à propos

"Il vaut mieux que ça marche sans qu'on sache pourquoi, plutôt que ça ne marche pas sans qu'on n'y puisse rien"

Bonne nuit à toi Wink
Back to top
View user's profile Send_private_message 
Médor


Joined: 26 May 2011
Posts: 1737

PostPosted: Thu 23 Jan 2014, 18:53    Post_subject:  

Ouai Wink

D'ailleurs j'ai le même fonctionnement dans Rolx, voir les captures sur le fil concernant cinelerra.

Bonne nuit
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0717s ][ Queries: 11 (0.0066s) ][ GZIP on ]