Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 21 Nov 2014, 20:41
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
Icons drives from Desktop disappears when unplug USB device
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
marcos90

Joined: 07 Sep 2011
Posts: 78

PostPosted: Sun 29 Dec 2013, 11:53    Post_subject:  Icons drives from Desktop disappears when unplug USB device  

Puppy Linux Precise latest version

This problem only happens when I unplug USB External Drive like dvd drive .
Other devices like USB pen drive won't happen any problem .

I've tried all the methods like using Pmount to mount optical drive and before unplug I unmount . But even after this steps , it still disappearing with the desktop itens . Also I've tried " Refresh Desktop" option , it work for some seconds , but disappears again .

To retrieve the icons , I need to reboot the system .

I'm start to think that the problem may reside in the USB external device , its one of that IDE-SATA-USB converter cable .
icon disappear before after.png
Description 
png

 Download 
Filename  icon disappear before after.png 
Filesize  196.22 KB 
Downloaded  512 Time(s) 
Back to top
View user's profile Send_private_message 
metastasis69

Joined: 28 Aug 2013
Posts: 9
Location: Philippines

PostPosted: Thu 17 Apr 2014, 09:17    Post_subject:  

I experience same things on the latest Slacko 5.7. I end up on restarting my machine or find it on my /mnt folder. I can't find all the active drive on the directory.
Back to top
View user's profile Send_private_message Visit_website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11150
Location: Arizona USA

PostPosted: Thu 17 Apr 2014, 09:43    Post_subject:  

I'm not sure why Puppy even shows the device if it doesn't have a CD or DVD in it. As I understand it, Linux only "sees" filesystems. So I'd assume that a device such as a CD or DVD drive, that doesn't have a disk in it that has a recognizable file-system on it, won't be seen.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9256
Location: Stratford, Ontario

PostPosted: Thu 17 Apr 2014, 10:43    Post_subject:  

I have also seen this disappearing icon bug with a USB optical drive in Slacko 56. But it only happens on one machine and it doesn't always happen.

Sometimes if I wait a while before unplugging the optical drive, the other device icons will stay.

Strange.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0422s ][ Queries: 12 (0.0034s) ][ GZIP on ]