Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 21:56
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Running Chromium-27.0.1421.0 in Racy-5.5
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
jrb


Joined: 11 Dec 2007
Posts: 1040
Location: Smithers, BC, Canada

PostPosted: Sat 28 Dec 2013, 12:11    Post subject:  Running Chromium-27.0.1421.0 in Racy-5.5
Subject description: Modify Racy to run newer Chromium
 

Knowing that a few people, including myself, have been frustrated by not being able to run recent Chromiums in Racy or Wary, I have continued to play with the problem. I believe I may have cracked it now.

Initially I tried Oscartalk's Chromium-31 but had no success. Then I tried JamesTheAwesomeDude's Chromium Version 27.0.1421.0 . I'm posting from it now. Here's how I did it.

I installed gcc_lib-4.7.3 and glibc-2.17 from Quirky-6.0 and libgconf-2.so.4.1.5, libgcrypt.so.11.7.0, libgnome-keyring.so.0.2.0 and libgpg-error.so.0.8.0 from Slacko-14. See below for the unlinked dotpets.

After getting it running I modified /usr/bin/chromium to:

Code:
#!/bin/sh
exec /opt/chromium/chrome-wrapper -user-data-dir=/root/.config/chromium --allow-outdated-plugins "$@"
to get rid of the warnings about flashplayer being out of date.

It also places two entries on the Internet Menu, one of which says "Chromium can't be run as root". The other one works fine. I haven't figured this one out yet.

I haven't tried any of the other Chromium versions out there. Some of the them may work equally well. I'll leave the testing up to all of you eager Chromium fans. Cool

I also haven't tried it in Wary but it should work equally well (where is the crossed fingers Emoticon?) EDIT: I just tried it in Wary-5.5 and I could get it to open after adding dbus but it wouldn't bring back any web pages, just that "Snap" message saying it had failed. Crying or Very sad

So far so good, but WARNING!!! Shocked many people feel upgrading glibc is a bad (risky) idea. So back up your pupsave, or start with a new one before you follow this procedure. Anyone who wants to do it differently, Please Do and let us know how it turns out.

Enjoy, J
libgcrypt-1.5.0-1.pet
Description 
pet

 Download 
Filename  libgcrypt-1.5.0-1.pet 
Filesize  249.29 KB 
Downloaded  79 Time(s) 
libgpg-error-1.10-1.pet
Description 
pet

 Download 
Filename  libgpg-error-1.10-1.pet 
Filesize  6.13 KB 
Downloaded  86 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0434s ][ Queries: 12 (0.0063s) ][ GZIP on ]