Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 28 Nov 2014, 00:14
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Light-Debian-Core-Live-CD-Wheezy + Porteus-Wheezy
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 224 of 262 [3926 Posts]   Goto page: Previous 1, 2, 3, ..., 222, 223, 224, 225, 226, ..., 260, 261, 262 Next
Author Message
saintless


Joined: 11 Jun 2011
Posts: 2663
Location: Bulgaria

PostPosted: Thu 24 Jul 2014, 03:09    Post subject:  

I think this is the problem:

pavrecord line 116:
Code:
Select Target Directory: /root

precord line 132:
Code:
Select Target Directory (for example): /root


Edit: Changing manually in GUI /root to /home/puppy works so I guess it is not real bug for multiuser. Just the default folder is /root and without changing this the program errors.

Edit2: No, changing /root to $HOME/ (or any other folder inside binary files) does not work. I always get /root as default in GUI. Only manually changing from GUI works.
ls -l $HOME/ gives the correct /home/puppy output so I can't tell what exactly has to be changed yet.

Toni
Back to top
View user's profile Send private message MSN Messenger 
mcewanw

Joined: 16 Aug 2007
Posts: 2349
Location: New Zealand

PostPosted: Thu 24 Jul 2014, 03:52    Post subject:  

saintless wrote:
I think this is the problem:

pavrecord line 116:
Code:
Select Target Directory: /root

precord line 132:
Code:
Select Target Directory (for example): /root


Edit: Changing manually in GUI /root to /home/puppy works so I guess it is not real bug for multiuser. Just the default folder is /root and without changing this the program errors.

Edit2: No, changing /root to $HOME/ (or any other folder inside binary files) does not work. I always get /root as default in GUI. Only manually changing from GUI works.
ls -l $HOME/ gives the correct /home/puppy output so I can't tell what exactly has to be changed yet.

Toni


I fixed that multiuser bug in previous released pavrecord for debiandog I think, but must have reintroduced it by accident. It isn't a bug in the program itself, just in the config files where I had /root as a default rather that ${HOME}, which is the fix I had made for the previous version. Changing it manually in the GUI should work, however, but only if you close the program with the close button, not the window x button. The window x button causes the default config to be reloaded on restart. However, manually changing dir to a user writable one in the GUI should again work fine, so it isn't really a bug, just an inconvenience that I will address in next versions. Your edit2 above seems to suggest manually selecting correct wished for save dir doesn't work - it should... EDIT: oh, I see, it does work as expected according to my rereading what you wrote.

The fix, by the way, is therefore to edit the /etc/precord/.precordrc (and /etc/pavrecord/.pavrecordrc), in which you should replace /root with ${HOME}.

William

_________________
Non enim propter gloriam, diuicias aut honores pugnamus set propter libertatem solummodo quam Nemo bonus nisi simul cum vita amittit.
Back to top
View user's profile Send private message Visit poster's website 
saintless


Joined: 11 Jun 2011
Posts: 2663
Location: Bulgaria

PostPosted: Thu 24 Jul 2014, 03:59    Post subject:  

mcewanw wrote:
Changing it manually in the GUI should work, however, but only if you close the program with the close button, not the window x button.

Yes, I confirm selecting from GUI different folder than /root and using Close button works and saves the new selected folder. I also think we can't call this program bug. I will test more later tonight.

Toni
Back to top
View user's profile Send private message MSN Messenger 
mcewanw

Joined: 16 Aug 2007
Posts: 2349
Location: New Zealand

PostPosted: Thu 24 Jul 2014, 04:02    Post subject:  

Toni and Fred,

I have attached the test.mp3 file that I find plays fine with gnome-mplayer in my openbox install, but produces no audio when played with mplayer in that same install. Wonder if you could try it for me and let me know if you have the same result. If not, I am confused, why on earth does gnome-mplayer play it but not mplayer (which says it can't find the hw) on my system?

It plays with either in my jwm install (for the retry I reinstalled openbox version on yet another usb stick by the way)

Cheers, William

EDIT:
Code:
Playing test.mp3.
Detected file format: MP2/3 (MPEG audio layer 2/3) (libavformat)
[mp3 @ 0x871d240]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: audio (mp3), -aid 0
Load subtitles in .
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Selected audio codec: MP3 (MPEG audio layer 3) [libavcodec]
AUDIO: 22050 Hz, 1 ch, floatle, 32.0 kbit/4.54% (ratio: 4000->88200)
[AO_ALSA] Unable to set hw-parameters: Invalid argument
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [null] 22050Hz 1ch floatle (4 bytes per sample)
Video: no video
Starting playback...
A:   2.8 (02.8) of 3.1 (03.0)  0.5%                                             
[mp3float @ 0x8793600]incomplete frame

A: 3.0 (03.0) of 3.1 (03.0) 0.5%

Audio output truncated at end.
test.tar
Description  Just change extension from .tar to .mp3
tar

 Download 
Filename  test.tar 
Filesize  12 KB 
Downloaded  38 Time(s) 

_________________
Non enim propter gloriam, diuicias aut honores pugnamus set propter libertatem solummodo quam Nemo bonus nisi simul cum vita amittit.
Back to top
View user's profile Send private message Visit poster's website 
mcewanw

Joined: 16 Aug 2007
Posts: 2349
Location: New Zealand

PostPosted: Thu 24 Jul 2014, 04:35    Post subject:  

Fred and Toni,

Here is something else to try.

Code:
arecord -V stereo /root/arecord_temp & { sleep 1; rm -f /root/arecord_temp; }


Just enter that odd-looking, but generally working, single line of code into a console. It should produce a simple single-line ascii vu meter detecting your microphone (assuming alsamixer set up to capture from the mic and mic boost has been activated in alsamixer).

SFR provided me with this code extract to fix arecord VU meter operating in Puppy Precise, and Puppy Slacko. It also works in DebianDog jwm, but for some reason, it doesn't work on my machine using DebianDog openbox version, which suggests some issue with alsa. It is as if alsa isn't initialised correctly.

Not surprisingly to me, xrecord doesn't seem to function in openbox debiandog on my computer either, and I haven't changed any of the recording code in that at all from previous versions (though I only probably ever tested it on jwm version).

William

Note that I'm doing all these tests on the same computer.

EDIT2: I should probably mention that if this line doesn't work you might need to do a killall arecord after that to clean the process up (or probably just closing the terminal you ran it from should do the job).

_________________
Non enim propter gloriam, diuicias aut honores pugnamus set propter libertatem solummodo quam Nemo bonus nisi simul cum vita amittit.
Back to top
View user's profile Send private message Visit poster's website 
saintless


Joined: 11 Jun 2011
Posts: 2663
Location: Bulgaria

PostPosted: Thu 24 Jul 2014, 11:48    Post subject:  

Hi, William, Fred.

Tests from OpenBox version:

1. arecord -V stereo command works:



2. Xrecord works for me (I get /root/Loremipsum.mp3 file and I can play it with xhplay and gnome-mplayer).
Code:
root@dog:~# xrecord
Recording WAVE 'stdin' : Signed 16 bit Little Endian, Rate 44100 Hz, Mono
LAME 3.99.5 32bits (http://lame.sf.net)
CPU features: MMX (ASM used), SSE (ASM used)
Resampling:  input 44.1 kHz  output 22.05 kHz
Using polyphase lowpass filter, transition band:  8269 Hz -  8535 Hz
Encoding <stdin> to /root/Loremipsum.mp3#
Encoding as 22.05 kHz single-ch MPEG-2 Layer III (11x)  32 kbps qval=2


3. However I also can't play test.mp3 and new recorded /root/Loremipsum.mp3 directly with mplayer. Here is the output:
Code:
root@dog:~# mplayer /live/image/test.mp3
MPlayer2 9d6b188 (C) 2000-2012 MPlayer Team
Cannot open file '/root/.mplayer/input.conf': No such file or directory
Failed to open /root/.mplayer/input.conf.
Cannot open file '/usr/local/etc/mplayer/input.conf': No such file or directory
Failed to open /usr/local/etc/mplayer/input.conf.

Playing /live/image/test.mp3.
Detected file format: MP2/3 (MPEG audio layer 2/3) (libavformat)
[mp3 @ 0x871d240]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: audio (mp3), -aid 0
Load subtitles in /live/image/
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Selected audio codec: MP3 (MPEG audio layer 3) [libavcodec]
AUDIO: 22050 Hz, 1 ch, floatle, 32.0 kbit/4.54% (ratio: 4000->88200)
[AO_ALSA] Unable to set hw-parameters: Invalid argument
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [null] 22050Hz 1ch floatle (4 bytes per sample)
Video: no video
Starting playback...
A:   2.7 (02.7) of 3.1 (03.0)  0.8%                                             
[mp3float @ 0x8793600]incomplete frame
A:   3.0 (03.0) of 3.1 (03.0)  0.8%                                             

Audio output truncated at end.

Exiting... (End of file)

Code:
root@dog:~# mplayer /root/Loremipsum.mp3
MPlayer2 9d6b188 (C) 2000-2012 MPlayer Team
Cannot open file '/root/.mplayer/input.conf': No such file or directory
Failed to open /root/.mplayer/input.conf.
Cannot open file '/usr/local/etc/mplayer/input.conf': No such file or directory
Failed to open /usr/local/etc/mplayer/input.conf.

Playing /root/Loremipsum.mp3.
Detected file format: MP2/3 (MPEG audio layer 2/3) (libavformat)
[mp3 @ 0x871d240]max_analyze_duration reached
[mp3 @ 0x871d240]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: audio (mp3), -aid 0
Load subtitles in /root/
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Selected audio codec: MP3 (MPEG audio layer 3) [libavcodec]
AUDIO: 22050 Hz, 1 ch, floatle, 32.0 kbit/4.54% (ratio: 4000->88200)
[AO_ALSA] Unable to set hw-parameters: Invalid argument
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [null] 22050Hz 1ch floatle (4 bytes per sample)
Video: no video
Starting playback...
A:  10.0 (10.0) of 10.1 (10.0)  0.8%                                           

Audio output truncated at end.

Exiting... (End of file)
root@dog:~#

Reinstalling alsa-base and alsa-utils does not change this problem for me.
For now we can mark direct playing from terminal with mplayer some mp3 files on OpenBox version as a bug (not critical in my opinion since we can play them with xhippo (xhplay) and gnome-mplayer).
I guess we will find a fix for this as usual.

Edit: I'm not sure if it is a real bug but here is the fix for OpenBox version:
mplayer -srate 48000 /path-to-file-name
Code:
root@dog:~# mplayer -srate 48000 /live/image/test.mp3
MPlayer2 9d6b188 (C) 2000-2012 MPlayer Team
Cannot open file '/root/.mplayer/input.conf': No such file or directory
Failed to open /root/.mplayer/input.conf.
Cannot open file '/usr/local/etc/mplayer/input.conf': No such file or directory
Failed to open /usr/local/etc/mplayer/input.conf.

Playing /live/image/test.mp3.
Detected file format: MP2/3 (MPEG audio layer 2/3) (libavformat)
[mp3 @ 0x871d240]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: audio (mp3), -aid 0
Load subtitles in /live/image/
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Selected audio codec: MP3 (MPEG audio layer 3) [libavcodec]
AUDIO: 22050 Hz, 1 ch, floatle, 32.0 kbit/4.54% (ratio: 4000->88200)
AO: [alsa] 48000Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   2.7 (02.6) of 3.1 (03.0)  2.1%                                             
[mp3float @ 0x8793600]incomplete frame
A:   3.0 (03.0) of 3.1 (03.0)  2.1%                                             


Exiting... (End of file)
root@dog:~#


No bugs to mark yet in my opinion.
It looks more like different setup to me and maybe AlsaEqualizer that is missing in Jwm version has something to do with this?

Toni

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
fredx181

Joined: 11 Dec 2013
Posts: 883
Location: holland

PostPosted: Thu 24 Jul 2014, 13:44    Post subject:  

Hi Toni , William,
Quote:
It looks more like different setup to me and maybe AlsaEqualizer that is missing in Jwm version has something to do with this?


Yes, AlsaEqualizer should have to do with it, try renaming /etc/asound.conf and the problem is gone.(also equalizer is disabled then)
I got the exact same results as you both had trying the test.mp3
Not sure if we can call this a bug and from what then; alsaequal or mplayer?.
Looks like it's only a problem with mono recordings btw.
xhippo plays the test.mp3 fine but I think it uses lame for it.

This command works well for me:
Code:
arecord -V stereo /root/arecord_temp & { sleep 1; rm -f /root/arecord_temp; }


Edit:
William wrote:
Wonder if you could try it for me and let me know if you have the same result. If not, I am confused, why on earth does gnome-mplayer play it but not mplayer (which says it can't find the hw) on my system?

Yes, that's a mystery to me also, maybe because gnome-mplayer detects the "default soundcard" (which is setup in /etc/asound.conf as "plughw:0,0" in openbox version) and mplayer doesn't.

Fred
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 294

PostPosted: Thu 24 Jul 2014, 18:35    Post subject: bug in Desktop file editor  

It seems a little discombobulated.

To demonstrate, I had it create a desktop file with the information in the 1st attachment.

What it created was:

Code:
[Desktop Entry]
Encoding=UTF-8
Terminal=Application
NoDisplay=false
Comment=false
Categories=this is the comment
Name=this is a category
GenericName=the name
Exec=the generic name
Icon=exec here


As you'll see, stuff ended up in the wrong spot.

I've also attached a copy of the .desktop itself.

Dan
testdesktopfileeditor.desktop.gz
Description  remove gz added to spoof forum
gz

 Download 
Filename  testdesktopfileeditor.desktop.gz 
Filesize  195 Bytes 
Downloaded  30 Time(s) 
2014-07-24-173002_888x359_scrot.png
Description 
png

 Download 
Filename  2014-07-24-173002_888x359_scrot.png 
Filesize  68.97 KB 
Downloaded  45 Time(s) 
Back to top
View user's profile Send private message 
mcewanw

Joined: 16 Aug 2007
Posts: 2349
Location: New Zealand

PostPosted: Thu 24 Jul 2014, 19:22    Post subject: mplayer not playing mono mp3 or ogg files in openbox DD  

Hi Fred,

The previous test.mp3 file I uploaded works also on Win7 in either Windows Media Player or VLC.

As you have identified, mplayer in openbox debiandog is not playing mp3 or ogg mono files (it does seem to correctly play wav mono files interestingly enough, unless I'm mistaken).

The bug seems to be at alsa system level and, from what you say, may be caused by AlsaEqualizer. Hopefully the bug can be resolved via some extra AlsaEqualiser-related configuration, but I haven't myself found the solution as yet.

The test.mp3 file I uploaded works also on Win7 in either Windows Media Player or VLC.

I also downloaded some test mono files from the Internet, which confirm the issue. These are also true mono files (rather than dual mono - which is mono track but on both channels of a stereo record I believe):

http://en.wikipedia.org/wiki/File:Free_as_a_Bird_%28Beatles_song_-_sample%29.ogg (307KB)

http://www.mediacollege.com/audio/tone/download/

http://www.mediacollege.com/audio/tone/files/100Hz_44100Hz_16bit_05sec.mp3 (78.8KB)

http://www.kozco.com/tech/32.mp3 (504KB)

Cheers, William

_________________
Non enim propter gloriam, diuicias aut honores pugnamus set propter libertatem solummodo quam Nemo bonus nisi simul cum vita amittit.
Back to top
View user's profile Send private message Visit poster's website 
mcewanw

Joined: 16 Aug 2007
Posts: 2349
Location: New Zealand

PostPosted: Fri 25 Jul 2014, 00:57    Post subject: new precord and pavrecord debs uploaded  

Hi Fred and Toni,

I've uploaded new deb for precord (now version number 9.0.2). Fixes the single lame1 mistake that was in precord, which I would never have noticed had it not been for the DD openbox mplayer issue, since precord uses mplayer for playback by default when it can't find lame! So it would be an irrelevant fix really were it not for that DD openbox alsa issue. For user's convenience, I also modified its default config file so ${HOME} will be default save folder. Hopefully, I've not introduced any major bug to it in the process :-) Download at its main thread and remember, as usual, to delete ~/.precord and ~/.pavrecord before installing new one:

http://www.murga-linux.com/puppy/viewtopic.php?t=49907

Also uploaded new deb for pavrecord to also provide the ${HOME} default save location and took the opportunity to make x11grab screencast use video bitrate of 1000k by default:

http://www.murga-linux.com/puppy/viewtopic.php?t=81332

With the above precord, the mplayer not playing mono mp3 or mono ogg won't matter since precord uses lame|aplay for playback as first choice. Still would be nice to solve that alsa issue.

Cheers, William

_________________
Non enim propter gloriam, diuicias aut honores pugnamus set propter libertatem solummodo quam Nemo bonus nisi simul cum vita amittit.

Last edited by mcewanw on Fri 25 Jul 2014, 01:54; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
saintless


Joined: 11 Jun 2011
Posts: 2663
Location: Bulgaria

PostPosted: Fri 25 Jul 2014, 01:43    Post subject: Re: bug in Desktop file editor  

Hi, Dan.
dancytron wrote:
To demonstrate, I had it create a desktop file with the information in the 1st attachment.

Yes, I also confirm this problem testing now. I have older version that behaves better but also has issues. I will write Terry later today if he can fix desktop-editor. Unfortuantely for me he uses Bacon and I can't edit the binary myself.
I will search for alternative solution also.

Edit: I wrote to Terry but anyway here is alternative Desktop-editor written for Porteus by Joe:
https://forum.porteus.org/viewtopic.php?f=75&t=1131
And deb package for us (the menu entry is in Utility):
http://smokey01.com/saintless/Fredx181/desktop-editor_1.0_i386.deb

William,
I will update the first post with link for new packages and new bug fixes later.

Toni

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
fredx181

Joined: 11 Dec 2013
Posts: 883
Location: holland

PostPosted: Fri 25 Jul 2014, 06:16    Post subject:  

Hi William,
Quote:
As you have identified, mplayer in openbox debiandog is not playing mp3 or ogg mono files (it does seem to correctly play wav mono files interestingly enough, unless I'm mistaken).

The bug seems to be at alsa system level and, from what you say, may be caused by AlsaEqualizer. Hopefully the bug can be resolved via some extra AlsaEqualiser-related configuration, but I haven't myself found the solution as yet.


I've tried editing /etc/asound.conf but nothing worked.
The only possible workaround I found that solves it was setting the frequency in ~/.mplayer/config like this:
Code:
# Uncomment one of the two frequency settings:
# srate=44100
srate=48000

I may be wrong but it looks like the frequency is resampled by default always to 48000Hz.
With empty ~/.mplayer/config and renamed /etc/asound.conf (equalizer disabled) I always get 48000:
Code:
root@dog:~# cat /proc/asound/card0/pcm0p/sub0/hw_params
access: MMAP_INTERLEAVED
format: S32_LE
subformat: STD
channels: 2
rate: 48000 (48000/1)
period_size: 1024
buffer_size: 8192


Btw, just for info, installing the Wheezy mplayer solves the problem also, without having to edit mplayer config.

Fred
Back to top
View user's profile Send private message 
mcewanw

Joined: 16 Aug 2007
Posts: 2349
Location: New Zealand

PostPosted: Fri 25 Jul 2014, 19:32    Post subject:  

fredx181 wrote:
Hi William,

The only possible workaround I found that solves it was setting the frequency in ~/.mplayer/config like this:
Code:
# Uncomment one of the two frequency settings:
# srate=44100
srate=48000

I may be wrong but it looks like the frequency is resampled by default always to 48000Hz.
...

Btw, just for info, installing the Wheezy mplayer solves the problem also, without having to edit mplayer config.

Fred


Hi Fred,

Your last comment makes me wonder if that mplayer2 doesn't auto-detect srate. Funny thing is, you can put srate=1000 (or pretty much anything above that) and it plays the mono test file without any noticeable change in what you hear. In Precord, arecord using -f cd, which should result in sampling rate of 44100. I've also played around with lame settings, but makes no difference to what mplayer will accept - mono always coming out at half of 44100 = 22050. And the test files from the Internet would also still need that srate value in mplayer config.

Oh well, putting srate=48000 or whatever... seems to be effective enough anyway - don't know if that has any negative effects in terms of potential sound quality - doesn't seem to.

William

_________________
Non enim propter gloriam, diuicias aut honores pugnamus set propter libertatem solummodo quam Nemo bonus nisi simul cum vita amittit.
Back to top
View user's profile Send private message Visit poster's website 
mcewanw

Joined: 16 Aug 2007
Posts: 2349
Location: New Zealand

PostPosted: Fri 25 Jul 2014, 19:39    Post subject:  

Fred

One thing I've noticed that is very different between openbox DD and jwm DD is that, like Puppy, jwm DD includes the likes of defaultbrowser, defaulttexteditor etc (or somethings like that) whereas openbox DD doesn't I think. Without these, some Puppy gtkdialogs won't completely function I'd think, since these default names are often used or referred to in Puppy scripts.

Also, Rox right-click and mime handling functionality is very limited in the openbox version, which I understand since you focus on Thunor, but still, Puppy users will miss the extra Rox functionality (even, for example, clicking on iso within Rox to open it, or as in jwm DD to extract/install debs etc). Overall, I think it would be a big improvement if these extras, which on the whole are incorporated in jwm DD, were eventually mirrored in the openbox version, but it is just my opinion, and Thunor does it all anyway I know.

William

_________________
Non enim propter gloriam, diuicias aut honores pugnamus set propter libertatem solummodo quam Nemo bonus nisi simul cum vita amittit.
Back to top
View user's profile Send private message Visit poster's website 
mcewanw

Joined: 16 Aug 2007
Posts: 2349
Location: New Zealand

PostPosted: Sat 26 Jul 2014, 03:05    Post subject: just to keep you on your toes  

I managed playing the attached test2 mp3 file with mplayer on openbox DD too, but try it...

EDIT: Ignore this post. The attached test2 mp3 file played fine in mplayer with srate=48000 after I rebooted system. Prior to that I had to set srate greater than 48000 for it to work. The test file itself was resampled to 48000 when I created it.

EDIT2: On second thoughts, maybe I was correct first of all and needs srate greater than 48000 in mplayer config for this one. I can't test at the moment because my alsa system has been broken somehow and I'll have to start again from clean changes dir.
test2.tar
Description  Just replace tar with mp3
tar

 Download 
Filename  test2.tar 
Filesize  12 KB 
Downloaded  22 Time(s) 

_________________
Non enim propter gloriam, diuicias aut honores pugnamus set propter libertatem solummodo quam Nemo bonus nisi simul cum vita amittit.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 224 of 262 [3926 Posts]   Goto page: Previous 1, 2, 3, ..., 222, 223, 224, 225, 226, ..., 260, 261, 262 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1814s ][ Queries: 12 (0.0482s) ][ GZIP on ]