Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 15:32
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Light-Debian-Core-Live-CD-Wheezy + Porteus-Wheezy
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 216 of 257 [3854 Posts]   Goto page: Previous 1, 2, 3, ..., 214, 215, 216, 217, 218, ..., 255, 256, 257 Next
Author Message
fredx181

Joined: 11 Dec 2013
Posts: 863
Location: holland

PostPosted: Tue 08 Jul 2014, 11:28    Post subject:  

Toni wrote:
Tested portable DebianDog-Installer in Lupu-528 and Fluppy.
Lupu-528 - Frugal and Full install failed.
Fluppy - Full failed Frugal success.


That's not a very good score Smile
Thanks for testing and the details.
I thought already that there could be missing libraries but there are probably also other factors that make it fail.

Anyway here's new portable folder with missing libraries added .
Can you test again when you have time?, it's not very important so absolutely no hurry.

https://drive.google.com/file/d/0ByBgCDlZZ8K5YnppQ21pb3pkbGM/edit?usp=sharing
(Extract and run AppRun inside folder)

Fred
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 2613
Location: Bulgaria

PostPosted: Tue 08 Jul 2014, 13:28    Post subject:  

Hi, Fred.
Unfortunately I get segmentation fault:
Code:
# /mnt/home/downloadspuppy/debdoginstall/AppRun
SCRIPTDIR=/mnt/home/downloadspuppy/debdoginstall
library_path=/mnt/home/downloadspuppy/debdoginstall/usr/lib:/mnt/home/downloadspuppy/debdoginstall/usr/lib/i386-linux-gnu:/lib:/usr/lib:/usr/X11R7/lib:/root/my-applications/lib:/opt/qt4/lib:/usr/lib/seamonkey:/opt/samba/lib
/mnt/home/downloadspuppy/debdoginstall/AppRun: line 18:  5448 Segmentation fault      Xdialog --title "DebianDog Installer" --clear --radiolist "Please select what type install you would like to do:         " 13 110 3 "frugal-install" "bootloaders grub4dos, syslinux and extlinux are supported." off "full-install" "bootloader grub4dos is supported (works with ext2,3,4, NTFS and FAT)." off 2>$tempfile

Can you confirm md5sum is the same?
Code:
87f21ad743afc7618aff7cbf5d245189 debdoginstall.tar.gz


Toni

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
fredx181

Joined: 11 Dec 2013
Posts: 863
Location: holland

PostPosted: Tue 08 Jul 2014, 13:46    Post subject:  

Hi Toni,
Quote:
Unfortunately I get segmentation fault:
Code:
# /mnt/home/downloadspuppy/debdoginstall/AppRun
SCRIPTDIR=/mnt/home/downloadspuppy/debdoginstall
library_path=/mnt/home/downloadspuppy/debdoginstall/usr/lib:/mnt/home/downloadspuppy/debdoginstall/usr/lib/i386-linux-gnu:/lib:/usr/lib:/usr/X11R7/lib:/root/my-applications/lib:/opt/qt4/lib:/usr/lib/seamonkey:/opt/samba/lib
/mnt/home/downloadspuppy/debdoginstall/AppRun: line 18: 5448 Segmentation fault


Yes, sorry, added one library to much that's apparently conflicting. I just noticed the same while testing on Puppy Exprimo
Uploaded again (same link in above post) (it's now running well on Exprimo btw), also I tested on Saluki but it gave GLIB wrong version error. I realize it's probably to much to ask to make it work on most puppy's.
Maybe if it doesn't depend on parted there's better chance.

Fred
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 2613
Location: Bulgaria

PostPosted: Tue 08 Jul 2014, 14:38    Post subject:  

Hi, Fred.

Full failed, Frugal Success on both Lupu-528 and Fluppy:
http://smokey01.com/saintless/Fredx181/Temp-stuff/test2.txt

I don't think you can make it work on all puppy versions and no need to try. Even pet packages and puppy-sfs files can't work on all.

Toni
Back to top
View user's profile Send private message MSN Messenger 
fredx181

Joined: 11 Dec 2013
Posts: 863
Location: holland

PostPosted: Tue 08 Jul 2014, 16:09    Post subject:  

Toni wrote:
Full failed, Frugal Success on both Lupu-528 and Fluppy:
http://smokey01.com/saintless/Fredx181/Temp-stuff/test2.txt

I don't think you can make it work on all puppy versions and no need to try. Even pet packages and puppy-sfs files can't work on all.

Toni


There's improvement! Yes!
Thanks again for trying.
Yes, I agree it can't work on all puppy versions but looking at your output I think it's just one thing that fails: mounting 01-filesystem.squashfs on /media/target. So it's close to working.
Also I could remove the parted dependency (it was just for setting the boot flag only, which can be done with fdisk also)
If you don't mind I'll bother you within the next few days to test again Smile
Going to install Lupu myself to test on it.

Fred
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 2613
Location: Bulgaria

PostPosted: Tue 08 Jul 2014, 16:37    Post subject:  

No problem testing, Fred Smile
_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
fredx181

Joined: 11 Dec 2013
Posts: 863
Location: holland

PostPosted: Tue 08 Jul 2014, 18:13    Post subject:  

Hi Toni,
Fred wrote:
Yes, I agree it can't work on all puppy versions but looking at your output I think it's just one thing that fails: mounting 01-filesystem.squashfs on /media/target. So it's close to working.


Not even close but impossible I think on distro's with older kernel version than 2.6.38 (not supporting xz compression).
As far as I can see that's the reason why xz compressed .squashfs cannot be mounted on Lupu and the install fails.

Fred
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 2613
Location: Bulgaria

PostPosted: Wed 09 Jul 2014, 02:20    Post subject:  

Hi, Fred.

Yes, I agree xz compression and old kernel is the problem after testing unsquashfs and mount -o loop command.

Suggestions:

1. Full install - we loose most DebianDog advantages like sfs options and small size. And still no one reported DebianDog Full install test or use. I suggest removing Full install option from portable installer.

2. Make (Frugal-only or both with red text warning for Full install about old kernel) portable installer executable with chmod +x permissions and include it in the iso outside /live directory. It will be easy to extract it from puppy or other linux and make frugal install for testing. Full install can be made from DebianDog later if needed.

Toni

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
fredx181

Joined: 11 Dec 2013
Posts: 863
Location: holland

PostPosted: Wed 09 Jul 2014, 04:47    Post subject:  

Hi Toni,
Quote:
portable installer executable with chmod +x permissions and include it in the iso outside /live directory. It will be easy to extract it from puppy or other linux and make frugal install for testing. Full install can be made from DebianDog later if needed.


Good idea!
I''l make tonight appimage with frugal install only and removed parted dependency.


Tip for Jwm version for more advanced terminal: roxterm from squeeze (the one from wheezy needs gtk3).
Tested on Jwm by only installing the .deb from here:
https://packages.debian.org/en/squeeze/roxterm

A big advantage IMHO is support for drag 'n drop and tabs.
Only around 600 Kb and you can clean a bit maybe.

Fred
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 2613
Location: Bulgaria

PostPosted: Wed 09 Jul 2014, 07:29    Post subject:  

fredx181 wrote:
Tip for Jwm version for more advanced terminal: roxterm from squeeze (the one from wheezy needs gtk3).
Tested on Jwm by only installing the .deb from here:
https://packages.debian.org/en/squeeze/roxterm

Thanks, Fred.
I will add it as optional terminal. But after some playing with Wheezy alternative roxterm-gtk2 package I got this wheezy version with edited Control and added what is needed to work from dependencies.
http://smokey01.com/saintless/Fredx181/roxterm-gtk2_2.6.5-1_i386.deb
Seems to work the same way and adding almost the same size.

Toni
Back to top
View user's profile Send private message MSN Messenger 
saintless


Joined: 11 Jun 2011
Posts: 2613
Location: Bulgaria

PostPosted: Wed 09 Jul 2014, 09:13    Post subject:  

Hi, Fred.

New /opt/bin/mount-swap with option to mount swap file instead partition. Works for swap file named pupswap.swp in /live/image (or /mnt/home for OpenBox version).
This way we can automount already existing puppy swap file.

And Make-Swap-File GUI if you like to add it in OpenBox version:
http://smokey01.com/saintless/Fredx181/make-swap-mount-swap.tar.gz



Toni
Back to top
View user's profile Send private message MSN Messenger 
fredx181

Joined: 11 Dec 2013
Posts: 863
Location: holland

PostPosted: Wed 09 Jul 2014, 14:19    Post subject:  

Hi Toni,
Quote:
I will add it as optional terminal. But after some playing with Wheezy alternative roxterm-gtk2 package I got this wheezy version with edited Control and added what is needed to work from dependencies.

Even better, didn't know about existing roxterm-gtk2 package.

Quote:
And Make-Swap-File GUI if you like to add it in OpenBox version:

I will add it.

New DebianDog-Installer appimage without needing parted (frugal install only).
Tested and working for me on: dpup Exprimo, Lupu-528, Saluki, Puppy Precise.
https://drive.google.com/file/d/0ByBgCDlZZ8K5bnAzYzFqRlhJT1E/edit?usp=sharing
Edited post on page 214:
http://murga-linux.com/puppy/viewtopic.php?p=787249#787249

Fred
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 2613
Location: Bulgaria

PostPosted: Thu 10 Jul 2014, 01:56    Post subject:  

fredx181 wrote:
New DebianDog-Installer appimage without needing parted (frugal install only).
Tested and working for me on: dpup Exprimo, Lupu-528, Saluki, Puppy Precise.
https://drive.google.com/file/d/0ByBgCDlZZ8K5bnAzYzFqRlhJT1E/edit?usp=sharing

Thank you, Fred!
I will test it later today.

Toni

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
fredx181

Joined: 11 Dec 2013
Posts: 863
Location: holland

PostPosted: Thu 10 Jul 2014, 11:33    Post subject:  

Hi Toni,
Bugfix for portable DebianDog installer.
After some more testing I found it seems installing right but doesn't boot because of boot flag not set.
See Edit4 on page 214 for more info:
http://murga-linux.com/puppy/viewtopic.php?p=787249#787249
DebianDog-Installer appimage:
Edit 10 min later Uploaded again because of mistake.
https://drive.google.com/file/d/0ByBgCDlZZ8K5bnAzYzFqRlhJT1E/edit?usp=sharing

Fred
Back to top
View user's profile Send private message 
saintless


Joined: 11 Jun 2011
Posts: 2613
Location: Bulgaria

PostPosted: Thu 10 Jul 2014, 11:53    Post subject:  

OK, Fred.
New versions replaced on the site also.

Toni

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send private message MSN Messenger 
Display posts from previous:   Sort by:   
Page 216 of 257 [3854 Posts]   Goto page: Previous 1, 2, 3, ..., 214, 215, 216, 217, 218, ..., 255, 256, 257 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1276s ][ Queries: 12 (0.0447s) ][ GZIP on ]