Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 01:26
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid Puppy Revitalized as 5.2.8.6!
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 17 [243 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 15, 16, 17 Next
Author Message
Moose On The Loose


Joined: 24 Feb 2011
Posts: 534

PostPosted: Sat 30 Nov 2013, 20:35    Post subject:  

RSH wrote:
Quote:
I think I may have an even smarter smarter idea

That's how things usually do evolve. Laughing

Quote:
Instead why not mount the SFS via a loopback use the ldconfig and then dismount. It never needs to be pulled into the normal file system just to run it once at start up.

That's just where the expert is split from the newbie. Wink

A hint, though: what about a temp file to be created after it has been executed once (to avoid re-running/-loading when just X is restarted for another reason)?


I could put it in init.d so it only happens on boot. To make it only happen if really needed seems a bit harder. The user may add the SFS to the boot list, remove it and then add it again. If ldconfig was run with it unplugged, it needs to run again with it plugged in.

Perhaps I can just live with it happening more than needed. Putting it in Startup is nice because I can ask permission which I always want to do in such a case.

Code:

if ! ( ldconfig -p | grep -q THENAME ) ; then
  do the stuff
else
  don't do the stuff
  fi


Looks like a way to avoid unneeded actual runs of ldconfig. I think that goes into the script in any case.
Back to top
View user's profile Send private message 
simon1482

Joined: 15 Jul 2010
Posts: 18

PostPosted: Sat 30 Nov 2013, 20:36    Post subject: trackpad click won't die!  

Hi,
Long-term Puppy user here (puppeee 4.1, then Lucid 528 which has worked like a charm for the past few years) popping back in now that I've got a new laptop and trying to get the latest Lucid tuned to my taste. Sorry if this isn't the right place for my troubleshooting, let me know if it should be somewhere else.

The problem is, despite TouchPad Tapping being disabled in Setup > Mouse/Keyboard > Choose Type of Mouse, the trackpad is still acting as the primary mouse button. (By the way, it's installed on a Lenovo X130e which has a synaptic trackpad. Clicking when I press hard enough to click the physical button under the trackpad is fine, but the "soft clicking" of the trackpad when I'm trying to move the mouse is driving me insane!)

The synaptic device is showing up:
Code:
grep Synaptics /proc/bus/input/devices:
Name="PS/2 Synaptics TouchPad"

But when I tried
Code:
synclient TapButton1=0

It brought up the message "Restart X-server to control from synclient". Restarting didn't help.

Another observations is that synaptics appears to be working, because right-clicking on the trackpad (which only has one physical button) works fine.

Can someone please help work out how to disable my trackpad clicking?

Thanks,
Simon
Back to top
View user's profile Send private message 
Atle

Joined: 19 Nov 2008
Posts: 290
Location: Oslo, Norway

PostPosted: Mon 02 Dec 2013, 16:29    Post subject:  

Some small issues with LupuLibre latest on a Asus U36SD

PDFViewer fails to start. Kust shows a "blink" of the PDF and then gone

Video will not play on Mplayer. Just says "stopped"

Gnome alsamixer and alsamixer does not work. Usually works on other Lucid out of box on same PC.

Its not bugs but some issues that normal users might disagree with.

1) Default package manager GUI is set to "Classic", while "Ziggy" is cleary the best as for new users.

2) It looks like many of the downloads STILL points to slow slow ibiblio, while the other mirrors are rocket fast.

Just some fast input.

Best

atle
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
wboz

Joined: 20 Nov 2013
Posts: 70

PostPosted: Mon 02 Dec 2013, 16:40    Post subject:  

playdayz wrote:
You want the new browsers, try the Puppy I mentioned that is just beginning 5.7 development--and have your own input into how it works for you--that's much of the fun.


Thanks, your posts help clear things up. Well Puppy 5.2.8 is working great for me, and honestly Chromium is running just fine ... so I do not feel any need for change Smile
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1536
Location: Maine, USA

PostPosted: Mon 02 Dec 2013, 17:49    Post subject:  

Atle wrote:
Some small issues with LupuLibre latest on a Asus U36SD

PDFViewer fails to start. Just shows a "blink" of the PDF and then gone

Video will not play on Mplayer. Just says "stopped"

Gnome alsamixer and alsamixer does not work. Usually works on other Lucid out of box on same PC.
Thanks for your report. To give us a starting point, could you try running all 3 of these (one at a time) and then run pdiag to get a diagnostic file. Either post it or PM it to me.

The PDF viewer works on my P4 system, so I need to see if something prevents it for you. For mplayer and the alsamixers, we need help from someone knowledgeable in those areas. I, too, have seen similar mplayer behavior but do not know what to do about it.
Richard
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2668
Location: New Zealand

PostPosted: Wed 04 Dec 2013, 02:13    Post subject: Re: trackpad click won't die!  

simon1482 wrote:
Another observations is that synaptics appears to be working, because right-clicking on the trackpad (which only has one physical button) works fine.
Can someone please help work out how to disable my trackpad clicking?
Thanks, Simon
The fact that it has only a single button makes me wonder if it is the same sort of 'clickpad' that npierce referred to in this thread:
http://www.murga-linux.com/puppy/viewtopic.php?t=85069&start=30
if so it might be worth PMing npierce to see if he may be able to offer some suggestions.

If you look in /root and click the eye icon at the top to display hidden files do you see a /.flsynclient file?
Back to top
View user's profile Send private message 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1529

PostPosted: Wed 04 Dec 2013, 18:36    Post subject:  

I've been giving LupuLibre a try recently and it's been working well. I'm particularly impressed with the fact that Fluxbox autoconfigures its menu when it starts up and lists all the applications I've installed as well as the ones already supplied with LupuLibre (some much more prominent distros should take note).
_________________
Stone Pentium IV (2.4 GHz), 2 GB of RAM, 160 GB hard drive running Puppy Classic 214X GTK3, Fire Hydrant 3.0.0 Inferno, Precise Puppy 573-L, Puppy Tahr 6.0 Exton, Puppy 4.20 Deeper Thought v2.
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 05 Dec 2013, 01:41    Post subject:  

To Playdays and other users. Whenyou guys mention things like this
Quote:
it does bug me that current browser choice is limited.


I use Firefox 25.0.1 are there later browser than that?

Sorry if I come through as stupid as I secretly appear to be Smile

Chrome I would use a SFS what else exist that works better on Slacko
than on old trusty 528-005 or 5.2.8.6?

Not that I have anything against Slacko
I have it installed but only use it for the program MakeHuman.

In case this is way too far from base just smile and skip responding.

I trust I will use old 528 until it fail

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
Moose On The Loose


Joined: 24 Feb 2011
Posts: 534

PostPosted: Thu 05 Dec 2013, 11:21    Post subject:  

nooby wrote:

Chrome I would use a SFS what else exist that works better on Slacko
than on old trusty 528-005 or 5.2.8.6?


Over in another thread, we have beat to death the issue of an added SFS not replacing an existing file. This means that an SFS from Chrome would have to use a script or other method to change the /usr/local/deaultbrowser to make it work for you.
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 05 Dec 2013, 17:25    Post subject:  

Moose On The Loose thanks for explanation.
oh okay.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
Roy

Joined: 31 Dec 2008
Posts: 442

PostPosted: Fri 06 Dec 2013, 21:32    Post subject:  

Using lupuplus-5.2.8.6-20131120, I'm having trouble with Pdvdrsab authoring a shrank.vob file. I select the file, select "author", and a screen momentarily blinks onto the screen before immediately disappearing.

Perhaps I am doing something wrong... too small of a save file? The 3Gb file is on a separate partition with 100Gb of free space.

Quote:
OscarTalks also has two versions of Skype 4.2.0.11 for Lucid If a few could test I could put it in the repo.
http://www.murga-linux.com/puppy/viewtopic.php?search_id=1968871940&t=86808


These two Skype builds work great with lupuplus!

-Roy

Edit: It appears that I need to manually re-run/reset the DHCP in Dougal's network wizard at each bootup. All of the information to connect is retained, but it does not automatically connect to wireless without personal action.
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1536
Location: Maine, USA

PostPosted: Sat 07 Dec 2013, 17:37    Post subject:  

Roy wrote:
Using lupuplus-5.2.8.6-20131120, I'm having trouble with Pdvdrsab authoring a shrank.vob file. I select the file, select "author", and a screen momentarily blinks onto the screen before immediately disappearing.

Perhaps I am doing something wrong... too small of a save file? The 3Gb file is on a separate partition with 100Gb of free space.
. . .
Edit: It appears that I need to manually re-run/reset the DHCP in Dougal's network wizard at each bootup. All of the information to connect is retained, but it does not automatically connect to wireless without personal action.
For both of these issues, could you obtain a pdiag file so we can see what is happening? When you boot up, do not attempt to connect until after you get the pdiag file (if at all). Before you get the file, try Pdvdrsab, then get the file. Just enter 'pdiag' without the ticks and attach the pdiag...tar.gz file it creates in the /root directory, to a posting here. That way, we can check for error messages and any Pdvdrsab "specialist" might find it useful.

Thanks for reporting your experience.
Richard
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Sat 07 Dec 2013, 20:46    Post subject:  

OscarTalks also has two versions of Skype 4.2.0.11 for Lucid If a few could test I could put it in the repo.
http://www.murga-linux.com/puppy/viewtopic.php?search_id=1968871940&t=86808

Roy, believe it or not just today I was thinking of asking for a couple of testers since I don't skype. Anyone else? With a couple of tests I can put it in the repo. Thanks.

Last edited by playdayz on Mon 09 Dec 2013, 20:26; edited 1 time in total
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8645

PostPosted: Sun 08 Dec 2013, 09:00    Post subject:  

I don't use skype now but some recent posts from users have shown that there may be a need to change to version 4 to handle a protocol or server change that affects video which is annoying as the version 2 I had from lucid worked well but sometimes we have to bend with the wind.

mike
Back to top
View user's profile Send private message 
Roy

Joined: 31 Dec 2008
Posts: 442

PostPosted: Wed 11 Dec 2013, 18:12    Post subject:  

Here is the pdiag from lupu-5.2.8.6-20131120, dealing with the manual reset of DHCP at every boot.

The computer with lupuplus and the shrank.vob file is not available until next week sometime.

-Roy

(Edited to delete attachment)

Last edited by Roy on Tue 17 Dec 2013, 12:29; edited 1 time in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 17 [243 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 15, 16, 17 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1006s ][ Queries: 12 (0.0061s) ][ GZIP on ]