Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 13:25
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
Trust Flex graphics tablet - Puppy Precise 6.1
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
David Andrew

Joined: 15 Nov 2013
Posts: 11

PostPosted: Fri 15 Nov 2013, 18:57    Post subject:  Trust Flex graphics tablet - Puppy Precise 6.1
Subject description: No pressure sensitivity
 

Hello,

I’m desperately trying to get my Trust Flex graphics tablet working with Puppy Precise 6.1, but it’s been a long battle over the course of several months now, and one I’m really losing.

The tablet in question seems to be re-branded and recognized as a Waltop tablet by the likes of lsusb and Hard info. Under Puppy Precise (and all other 32-bit puppy variants) it’s only recognized and functional as a mouse with GIMP and MTPaint. There is no pressure sensitivity.

Another important thing to note, is that it has worked with every Linux distro I’ve tried out of the box. It also seems to work out of the box just fine with the 64-bit puppy variants. But no such luck with any of the 32-bit puppies. The fact that it worked with the 64-bit puppy variants is the reason I’m not giving up hope. I’ll list the things that have been tried:

Aiptek driver: A google search lead me to try this one first. I don’t remember the xorg configurations I tried at the time, but the results have ranged from a dead xorgserver to a dead mouse. It may be noteworthy to mention that when I installed the driver on Windows, I noticed the name Aiptek during the installation process.

xf86-input_k.3.2.44-precise-wacom-mod-0.21.0.pet: This is one I had high hopes for, because it matches my Puppys kernel, and the script automatically configures xorg.conf. The only result was a change of behaviour with my touchpad. The tablet continued to function as a mouse.

wizardpen: This one lists various Trust tablet as supported, as well as Waltop. I’ve tooth-combed the SourceForge.net Wizardpen website on how to configure the 70-wizardpen file, but without success.

Here is the readout of my “/proc/bus/input/devices” file:

    I: Bus=0003 Vendor=172f Product=0037 Version=0110
    N: Name=" WALTOP Tablet "
    P: Phys=usb-0000:00:1d.0-2/input0
    S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb5/5-2/5-2:1.0/input/input12
    U: Uniq=
    H: Handlers=mouse1 event12
    B: PROP=0
    B: EV=1f
    B: KEY=c03 0 1f0001 0 0 0 0 0 0 0 0
    B: REL=143
    B: ABS=1000003
    B: MSC=10


The event number is 12 most of the time, but sometimes shows up as 3.

Currently I have the wizardpen driver with my 70-wizardpen file configured as below:


    Section "InputClass"
    Identifier "Waltop pen"
    # MatchIsPointer "on"
    MatchProduct "WALTOP|0037"
    MatchDevicePath "/dev/input/event12"
    # MatchVendor "WALTOP|172f"
    Driver "wizardpen"
    Option "TopX" "2199"
    Option "TopY" "3598"
    Option "BottomX" "30325"
    Option "BottomY" "29278"
    Option "TopZ" "10"
    Option "BottomZ" "1023"
    EndSection

    Section "InputClass"
    Identifier "wizardpen ignore mouse dev"
    # MatchIsPointer "on"
    MatchDevicePath "/dev/input/mouse1"
    # MatchVendor "WALTOP|172f"
    Driver ""
    EndSection


When that failed, I then copied these configurations to a custom 52-tablet file, also without success.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0369s ][ Queries: 11 (0.0033s) ][ GZIP on ]