Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 02 Sep 2015, 11:06
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Problem using Broadcom BCM43xx wifi in Fatdog 630
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
Schpankme


Joined: 09 Nov 2013
Posts: 51

PostPosted: Mon 11 Nov 2013, 02:30    Post subject:  Problem using Broadcom BCM43xx wifi in Fatdog 630  

Hello all,

I'm having issues configuring 'Broadcom Wifi adapter'; used information from this discussion (pg 1-2) without resolution:
http://208.109.22.214/puppy/viewtopic.php?t=82611&sid=71f33fc4a503ab91f43def62cd0588a4

Problem:
Not showing up in Network Wizard
Onboard LAN disabled (P5Q SE/R mobo)

Steps taken:
Fatdog64-630rc1, installed to Hard drive.

Installed - Broadcom-wl.pet
http://208.109.22.214/puppy/viewtopic.php?mode=attach&id=62063&sid=1782e582336a4cfc18547c6e0cb06c44

verified wl enabled

reboot
g fatdog Savefile=none
depmod
modprobe lib80211
modprobe cfg80211
insmod /usr/share/broadcom/wl.ko

insmod: error inserting '/usr/share/broadcom/wl.ko': -1 Unknown symbol in module
no wifi shown in network wizard

I've spent four (4) days researching this issue, your assistance would be greatly appreciated.

Thank you
Back to top
View user's profile Send private message 
ardvark


Joined: 01 Jul 2013
Posts: 1458
Location: USA

PostPosted: Mon 11 Nov 2013, 07:58    Post subject:  

Hi...

Unless I missed it, can you provide the chipset number?

Thanks...

_________________
Our Lord and Savior Jesus Christ loves and cares about you most of all!

PLEASE READ! You don't have to end up here!
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 4027
Location: Kiel,Germany

PostPosted: Mon 11 Nov 2013, 10:44    Post subject:  

Don't know much about fatdog, but am assuming that the kernel is different in version 611 and 630, so 99,9999999% sure it would not load .

/usr/share/broadcom/wl.ko is an unusual path, would drop it into /lib/modules/*/Broadcom/ directory .

Then insmod is a bit different than modprobe, modprobe might work better .

And it is always needed to run depmod ( likely with path to drivers ) to rule out missing symbols errors while loading .

Otherwise I would suggest to post where you got the driver from .

_________________
«Give me GUI or Death» -- I give you [[Xx]term[inal]] [[Cc]on[s][ole]] .
Macpup user since 2010 on full installations.
People who want problems with Puppy boot frugal Razz
Back to top
View user's profile Send private message 
Schpankme


Joined: 09 Nov 2013
Posts: 51

PostPosted: Mon 11 Nov 2013, 13:27    Post subject:  

Karl Godt wrote:

/usr/share/broadcom/wl.ko


Fatdog64-630rc1

Netgear WNA3100
Broadcom BCM43231

After 'following' the original bootup procedure correctly: savefile=none

wl enabled

depmod
modprobe lib80211
modprobe cfg80211
insmod /usr/share/broadcom/wl.ko

OK

Still no usb, wifi (Broadcom) device found within network wizard.

Last edited by Schpankme on Mon 11 Nov 2013, 13:31; edited 3 times in total
Back to top
View user's profile Send private message 
Schpankme


Joined: 09 Nov 2013
Posts: 51

PostPosted: Mon 11 Nov 2013, 13:28    Post subject:  

ardvark wrote:
provide the chipset number?


Netgear WNA3100 .. Broadcom BCM43231
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 11071

PostPosted: Mon 11 Nov 2013, 14:03    Post subject:  

Recent info suggests ndswrapper is the only way for this device
http://askubuntu.com/questions/276321/getting-ubuntu-to-recognize-a-bcm43231-network-card-what-is-up-with-terminal

mike
Back to top
View user's profile Send private message 
peterw

Joined: 19 Jul 2006
Posts: 103
Location: UK

PostPosted: Mon 11 Nov 2013, 20:03    Post subject: Wifi and Fatdog
Subject description: Some wifi devices work some don't
 

Hi Schpankme

I also have a frugal install of Fatdog64-630rc1. Whilst I don't have a Broadcom wifi card my problems have been similar. The laptop has a r8180 card and this has never been satisfactory with the Fatdog and Lighthouse 64 bit systems (On very rare occasions it has worked). I have to use a usb wireless device rt73usb which works fine.

Interestingly, my r8180 works well on 32bit Puppies. Years ago I have had Broadcom cards and they worked fine in 32 bit Puppies as well. What I am getting at is that the Broadcom driver may not be compatible with the 64 bit Puppies. You could try ndiswrapper but it did not work for me.

Best of luck. I will follow your progress.

peterw
Back to top
View user's profile Send private message 
Schpankme


Joined: 09 Nov 2013
Posts: 51

PostPosted: Thu 14 Nov 2013, 21:42    Post subject: Re: Wifi and Fatdog
Subject description: Some wifi devices work some don't
 

peterw wrote:
frugal install of Fatdog64-630rc1.
You could try ndiswrapper but it did not work for me.


I gave up and used a different Wifi Adapter.

Now, we need to install Enlightenment. >Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1190s ][ Queries: 11 (0.0113s) ][ GZIP on ]