Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Aug 2014, 04:21
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
glib 2.18 Compile fail.
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
Scotchialoo

Joined: 25 Oct 2013
Posts: 54
Location: Poland

PostPosted: Fri 08 Nov 2013, 04:49    Post subject:  glib 2.18 Compile fail.
Subject description: I want compile for Chromium Browser Library
 

[UPDATED in a Second Post]

I want compile for "Chromium browser library" Because waterfall will be writing: 'glibc_2.14' not found and 'glibc_2.15 not found' for /lib/libc.so.6

Last edited by Scotchialoo on Mon 11 Nov 2013, 07:29; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Scotchialoo

Joined: 25 Oct 2013
Posts: 54
Location: Poland

PostPosted: Mon 11 Nov 2013, 07:21    Post subject: GLIBC 2.16 - Compile Full Completed.
Subject description: in /opt/glibc-2.18: Compile works. but Chromium runtime is broke...
 

Oh... That's same as a t2 build...
I don't know what is happened with a glibc 2.18 package...
I Compiled now with a Folder /glibc-2.18/glibc instead of: /glibc-2.18 and /glibc-build
Yea. Segmention faul with glibc...
But If I compile with glibc 2.16 is completed but it's not added shorcut for libc... But FatDog64 Haves 2.13

When:

GCC 4.6.2 + binutils 2.20:
"/usr/lib64/gcc/x86_64-t2-linux-gnu/4.6.2/../../../../x86_64-t2-linux-gnu/bin/ld: Please report this bug."
GCC 4.6.2 + binutils 2.24 [Dev] (with a Copy and Paste - Fail as a with Old binutils/With Full-Install: Works around.):
Compile completed. ["/glibc-2.18 with /glibc-2.18/glibc" instead of "/glibc-2.18" and "/glibc-build" {Frozen build}]

Command for Compile:

~/glibc[-2.18,Created empty folder]/glibc[-2.18,Downloaded]/configure --prefix=/usr --libdir=/usr/lib64 --build=x86_64-t2-linux-gnu --disable-profile --enable-kernel=2.6.32 --with-headers=/usr/include libc_cv_forced_unwind=yes libc_cv_cleanup=yes libc_cv_ctors_header=yes

libcurl 7.24 [Standard for FatDog64-630rc1] + glibc Versions Compile (2.15 - 2.18 ) with Newest binutils Snapshot + fd64-devx_630.sfs [GCC 4.6.2]:

Completed:

2.16: Compile completed,but That's doesn't add shortcut for libc.so [GCC 4.6.2] - in FatDog64-631 [Not planned,or Can be imagined.] will be fit as a Development (alpha) versions.
Error in a Compile Process: http://comments.gmane.org/gmane.linux.lfs.support/36059 [Posix]

Failed:
2.15: [/root/glibc-2.15/sunrpc/xbootparam_prot.stmp] Segmentation fault -> make
Should be doesn't start anymore: (Resolve: fatdog savefile=none)
2.17: Compile 100% Fail. -> new2dir make install [Segmentation fault]
2.18: as a glibc 2.17


UPDATED [15/11/2013]: I know what is Reason... That's Curl...
Curl will be works only on 7.24 in Glib 2.13

On FatDog64-630rc1:
curl --version:

curl 7.24.0 (x86_64-t2-linux-gnu) libcurl/7.24.0 OpenSSL/1.0.0g zlib/1.2.5 libidn/1.24

More info for Resolve -> https://bbs.archlinux.org/viewtopic.php?id=146308

UPDATE [25/11/2013]: Now with /opt/glibc-2.18 is works around. But that's same about a Chromium waterfall runtime... Still doesn't works...

UPDATE #2 [4/1/2014]: glibc Compile is will be completed with T2-SDE... When I can't compile or Running with highest glibc (Becuase that's not possible... 2.17 from 2.13)
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0463s ][ Queries: 11 (0.0074s) ][ GZIP on ]