Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 20:43
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
HPlip in Lupu_526?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
Old Codger

Joined: 14 May 2009
Posts: 24

PostPosted: Tue 05 Nov 2013, 17:15    Post subject:  HPlip in Lupu_526?  

This is really two questions rolled into one.

I would like to install HPlip => 3.11.10 to support an HP 5510e all-in-one. Search as I may, there is no reference to it in QuickPets or PPM. There is the option of downloading either the automatic or manual package from HP site but can find no way of checking whether dependencies are satisfied or available (and, anyway, Puppy is not listed as supported)? I've searched this site and googled but can find nothing that offers sufficient (or any) guidance.

The corollary to this dilemma is how to effectively use PPM (QuickPets is less problematical and will succeed where PPM does not - perhaps because PPM needs regular reloading?) Most distros use Synaptic (sometimes supplemented by a more user-friendly manager equivalent to QuickPets) which lists all available packages, libraries and depends - and won't install anything unless all dependencies are available. To be fair, I haven't had any difficulties 'til now and even if HPlip/HPlipLite were located there is still the paradox that dependencies can only be checked retrospectively. According to PH101 -

"Once you know what dependencies are missing you can go searching for them"

- but where since PPM only list "meta" packages?

On a similar note, I also need to install the driver for a Brother DCP115C which is normally straightforward using the their installer - which downloads and installs the specified drivers - but it requires csh/tcsh (bash isn't enough).

[PS Using Puppy 526_Lupu with the Puppy-lucid-official repo checked]
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9202
Location: Stratford, Ontario

PostPosted: Tue 05 Nov 2013, 17:39    Post subject:  

Your best source for information about installing printers in Puppy is here.

It is two posts above this thread.

Immediately underneath your post is a thread about Brother printers that addresses the csh issue.
Back to top
View user's profile Send private message 
Old Codger

Joined: 14 May 2009
Posts: 24

PostPosted: Tue 05 Nov 2013, 20:25    Post subject:  

For the Brother, all I need to know is how to get hold of tcsh - which is related to second question about libs etc in PPM or any other method (but perhaps it is buried somewhere in the 9 pages of that thread).

The main issue is with HPLip (or HPLipLie).
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9202
Location: Stratford, Ontario

PostPosted: Tue 05 Nov 2013, 21:09    Post subject:  

Old Codger wrote:
For the Brother, all I need to know is how to get hold of tcsh

A quick forum search got me this.
Back to top
View user's profile Send private message 
Old Codger

Joined: 14 May 2009
Posts: 24

PostPosted: Wed 06 Nov 2013, 10:26    Post subject:  

Thanks - tcsh now installed. Unfortunately my simplistic approach of using linux-brprinter-installer-1.0.4-1 failed - presumably because Puppy is so esoteric (compared to other distros where it has always been successful)! In fact dpkg didn't understand the switches thrown at it nor do the target folders exist. At least it pulled down the two required deb packages.

Clearly I need to study http://www.murga-linux.com/puppy/viewtopic.php?t=42533

Still need pointing in the right direction to get hplip/hpliplite...
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9202
Location: Stratford, Ontario

PostPosted: Wed 06 Nov 2013, 12:35    Post subject:  

Old Codger wrote:
Clearly I need to study http://www.murga-linux.com/puppy/viewtopic.php?t=42533

According to Brother, your DCP-115C should be installed as an MFC-210C. At the end of the main post is a ready-made PET for this model.

Quote:
Still need pointing in the right direction to get hplip/hpliplite...

You already have it. The How to Install Your Printer/Scanner in Puppy has a link to a ready-made PET for the HPLIP package.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0591s ][ Queries: 11 (0.0106s) ][ GZIP on ]