Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Dec 2014, 10:30
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
remastered precise forces xorgconfig wizard at boot [solved]
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
ashes

Joined: 22 Aug 2011
Posts: 46

PostPosted: Sun 03 Nov 2013, 04:41    Post subject:  remastered precise forces xorgconfig wizard at boot [solved]  

Hi,

I have remastered Puppy Precise 5.7.1 to have live boot CD suited for my needs.

Now, every time I boot, I have to go through xorg config wizard before before x starts. That's unnecessary since I'm using the remastered puppy on just one machine

I have tried several changes like pfix=nox, then an approach described here, http://www.murga-linux.com/puppy/viewtopic.php?t=67393, which I tried manually, I hardened xorg.conf co it cant't be changed, deleted /root/.XLOOADED etc, etc

None of that helped and by now I have run the RemasterPuppyLive-CD-script several times, which consumes a bit of time.

Does anybody of you know of a possibility to remaster Precise without xorg config wizard bothering after boot?

Thank you in advance

Last edited by ashes on Sun 03 Nov 2013, 12:09; edited 1 time in total
Back to top
View user's profile Send private message 
ashes

Joined: 22 Aug 2011
Posts: 46

PostPosted: Sun 03 Nov 2013, 12:08    Post subject:  

due to my poor linux skills I solved the problem the hard way.

since I got tired about remastering after every configuration I opened the precise-sfs file and changed and experimented this way.
I recommend this way of editing a remastered puppy.

first I deleted .XLOADED which in Precise is in /root so that there's no complain about an unclean shutdown

then I went to /usr/sbin
there I focussed on xorgwizard, xorgwizard-cli and and xorgwizard-automatic

I renamed xorgwizard to xorgwizard1 and xorgxizard-cli to xorgwizard-cli1

I renamed xorgwizard-automatic to xorgwizard-cli, because the boot-script of which I don't know where it can be found, wants to run xorgwizard-cli.
I decided to have xorgwizard-automatic run instead, that's why I did the rename.

in the /root/Startup folder I placed a script to reverse all this renaming after X has started.

and now xorg config wizard doesn't bother me anymore when I load my custom Precise


if there's a more elegant way to solve the issue, I welcome suggestions
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0380s ][ Queries: 11 (0.0036s) ][ GZIP on ]