Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 09:52
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
LxPup : a Puppy with LXDE as its desktop environment
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 24 of 27 Posts_count   Goto page: Previous 1, 2, 3, ..., 22, 23, 24, 25, 26, 27 Next
Author Message
simes

Joined: 29 Sep 2007
Posts: 45
Location: Cheshire, UK

PostPosted: Fri 29 Aug 2014, 08:55    Post_subject: Re: LxPup fix pet  

peebee wrote:

Could you download 14.08.01 and verify the md5 is correct and test on that please?

evince, zathura and mtpaint are all running correctly in my tests....

Can you run them all in a terminal and pm me any diagnostic messages produced?

Thanks


Hello again
Done! I have downloaded 14.08.01 and verified the md5, and saved the new install to a folder. Now my system behaves like yours; evince, zathura and mtpaint all run correctly, LXTerminal does not start. Also (very minor point) the Simple Network Setup tool fails to load my RT61 network card driver on second and subsequent boots but Network Wizard does it correctly. (SNS works fine on other puppies.) By the way I did not install the 'mime settings' PET on 14.08.01 - no need, it seems. I have not sent a PM - no diagnostic messages.

I like these LXpups very much, many thanks.
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1459
Location: Malvern, Worcs, UK

PostPosted: Fri 29 Aug 2014, 13:15    Post_subject: Re: LxPup fix pet  

simes wrote:
Hello again
Done! I have downloaded 14.08.01 and verified the md5, and saved the new install to a folder. Now my system behaves like yours; evince, zathura and mtpaint all run correctly, LXTerminal does not start. Also (very minor point) the Simple Network Setup tool fails to load my RT61 network card driver on second and subsequent boots but Network Wizard does it correctly. (SNS works fine on other puppies.) By the way I did not install the 'mime settings' PET on 14.08.01 - no need, it seems. I have not sent a PM - no diagnostic messages.

I like these LXpups very much, many thanks.


Great! Just what I was hoping to hear. The fix pet does do a few useful things - it makes pdf files clickable to open them, and it makes urxvt the terminal program in pcmanfm avoiding lxterminal and it makes mtpaint compatible with the right-clicks option add-on.

So all useful results which will appear in 14.08.02 edition.....where lxterminal will work!

Cheers & thanks
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
peebee


Joined: 21 Sep 2008
Posts: 1459
Location: Malvern, Worcs, UK

PostPosted: Sun 07 Sep 2014, 02:43    Post_subject: Add a different desktop environment to LxPup
Sub_title: Only applies to LxPup14.08 (Slacko flavour)
 

ONLY APPLY TO LxPup14.08 Slacko flavour or later

Download and install the sfs for the Desktop Environment from:
http://lx-pup.weebly.com/desktop-environments.html

then install the switch pet below (the jwm switch of course needs no sfs)

To revert back to LXDE just uninstall the switch pet.

The "plan" is to include the switch pets is the next iso with a Desktop Environment switcher in the options.

The difficult part of switching DE is to get the menu right - particularly to make sure that only the desktop appearance menu items appropriate to the DE appear - I haven't done that for this exercise other than to a limited extent so the menus will have some inappropriate items.

Note that Compiz requires a reboot after installation for the Beryl window manager to work properly.

and LxQt needs a reboot after installation of the Qt4 sfs and before the switch pet is installed otherwise Qt doesn't work and the switch won't work.

Thanks go to Jejy69 for some of the sfs's.

Cheers
peebee
lx_jwm_switch-1.pet
Description  no sfs needed for this one
pet

 Download 
Filename  lx_jwm_switch-1.pet 
Filesize  1.47 KB 
Downloaded  58 Time(s) 
lx_mate_switch-1.pet
Description 
pet

 Download 
Filename  lx_mate_switch-1.pet 
Filesize  10.3 KB 
Downloaded  61 Time(s) 
lx_kde_switch-1.pet
Description 
pet

 Download 
Filename  lx_kde_switch-1.pet 
Filesize  4.58 KB 
Downloaded  55 Time(s) 
lx_xfce_switch-1.pet
Description 
pet

 Download 
Filename  lx_xfce_switch-1.pet 
Filesize  64.66 KB 
Downloaded  65 Time(s) 
lx_lxqt_switch-1.pet
Description 
pet

 Download 
Filename  lx_lxqt_switch-1.pet 
Filesize  216.19 KB 
Downloaded  59 Time(s) 
lx_compiz_switch-1.pet
Description 
pet

 Download 
Filename  lx_compiz_switch-1.pet 
Filesize  170.25 KB 
Downloaded  61 Time(s) 

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
peebee


Joined: 21 Sep 2008
Posts: 1459
Location: Malvern, Worcs, UK

PostPosted: Mon 08 Sep 2014, 02:05    Post_subject: LxPupTahr 14.09  

LxPupTahr 14.09 is now available from SF.net.
md5 from SF.net - click on little "i"

Based on TahrPup 5.8.3.rc1 from 666philb with kernel 3.14.11 including the ydrv update from shinobar.

PcManFM (and libfm) is updated to version 1.2.2

OpenSSL is updated to version 1.0.1i

Broadcom STA wifi driver is added.

MtPaint is also added so that graphic right-clicks work (and there seems to be problems with AZPainter).

The browser included in TahrPup is PaleMoon but Chromium37 can be added.

Cheers
peebee

_________________
LxPup-14.10 = Puppy + LXDE

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
Marv


Joined: 04 May 2005
Posts: 349
Location: SW Wisconsin

PostPosted: Tue 09 Sep 2014, 13:10    Post_subject: Re: LxPupTahr 14.09  

peebee wrote:
LxPupTahr 14.09 is now available from SF.net.


Downloaded and running well on my Fujitsu S6230 Pentium M ipw2200 laptop. The only things I had to do to get running were to swap in the 3.15.4 kernel to allow forcepae as a kernel parameter for the Pentium M and add acpid to the Startup Apps using the control panel to get lidsuspend working. Sound, video, connection all good. My personal theme and tray prefs, external Opera .desktop, Gvolwheel, PWF 2.9 using a static IP tweaks and voila!

Edit: Couple of days steady use now. Vattery added, printing set up, not much else changed. Seems even more robust than the Slacko based 14.07 if that's possible. Miss the Slacko repos a bit but all in all this seems 'better' to me.
puppy_lxtahr_14.09.jpg
 Description   
 Filesize   43.75 KB
 Viewed   1328 Time(s)

puppy_lxtahr_14.09.jpg


_________________
tweaked 412 based boxpup, well honed 'lina-lite-005, alphaOS 321 Wink , X-slacko 2.2n, Lxpup-Tahr, and not to forget trusty Carolina/Carolite (now with 3.17 kernel). All lean and steady pups.
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1459
Location: Malvern, Worcs, UK

PostPosted: Sat 13 Sep 2014, 12:10    Post_subject: Slacko flavours of LxPup14.09  

Slacko flavours of LxPup14.09 are now available from:

https://sourceforge.net/projects/lxpup/files/LxPup14.09/

Click on the little "i" to see the md5 checksum

Pre-release versions

LxPup-14.09.00-s-nopae.iso - based on Slacko6-beta2 with kernel 3.4.94 (nonpae)

LxPup-14.09.00-s-pae.iso - again based on Slacko6-beta but with kernel 3.14.11 (pae)

New features ( compared to 14.08 ) =
- version 1.2.2 of pcmanfm
- new LXPup Desktop Environment Switcher (Menu: Desktop - Change appearance - Options - DE Switcher)
- OpenSSL version 1.0.1i
- Broadcom STA wifi driver included for both new Slacko versions

Slight warning - I'm not sure that the Slacko pae version with kernel 3.14.11 from TahrPup thanks to 666philb works 100% correctly on Intel graphics. On my laptop I have to press the screen brightness key to get a display. Works ok on my desktop with nvidia graphics though.

Cheers
peebee
Screenshot.png
 Description   
 Filesize   195.09 KB
 Viewed   1155 Time(s)

Screenshot.png


_________________
LxPup-14.10 = Puppy + LXDE

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
simes

Joined: 29 Sep 2007
Posts: 45
Location: Cheshire, UK

PostPosted: Tue 16 Sep 2014, 17:13    Post_subject: Re: LxPupTahr 14.09  

peebee wrote:
LxPupTahr 14.09 is now available from SF.net.


Just to add that I have installed LxPupTahr-14.09 too. Very easy frugal install to folder and so far all seems rock solid. 'Quickpet tahr' is nice to see and it downloaded and installed the big LibreOffice SFS at the first attempt, very satisfactory. No glitches so far - what a great operating system.

I always install my Puppies by mounting the ISO (one click in Puppy, of course), copy the files from the ISO to a new folder, then run GRUB4DOS to find the new Puppy and make it bootable. Total time to install a brand new operating system from scratch, under 5 minutes. Even if there were no other clever features in Puppy, this would be a huge productivity improvement over Windows. I still find this mind-boggling after many years of using Puppy. Thanks everyone, especially peebee for the LxPup series.
Back to top
View user's profile Send_private_message 
Gooplusplus


Joined: 04 Sep 2013
Posts: 21
Location: Las Vegas

PostPosted: Wed 17 Sep 2014, 05:59    Post_subject: LxPup Tahr 14.09 - good impressions - will not start X in VM
Sub_title: LxPup Tahr added to 2014 Kudos USB Multiboot Linux collection.
 

I had a very good first impression of Lx Pup Tahr 14.09. I especially like your choice of Pale Moon as default web browser for the distro.

In fact, I decided to also install Pale Moon 64-bit on my Windows machine as a replacement for Firefox (for various reasons, Chrome is still my preferred Windows browser.)

I noted that unlike many other Linux distros, several lesser (and conflicting) media plugins were replaced by the superior VLC web plugin for Pale Moon.

The browser worked great for on-the-fly media transcoding tested via VLC-enabled http://www.homenetvideo.com/demo/index-v.php?/Test%20Files (a free home network media server demo).

One negative note: LX Pup Tahr would not start X as a virtual machine in VMware's free Player.
This did not happen for any other recent Linux distro release including other Puppy distros.

Not working in VM prevented me from considering making a quick YouTube review of LX Pup Tahr.

I recently released two new 2014 4GB "Kudos" USB Multiboot Linux collections (32 bit and 64 bit). The first one includes the new LX Pup Tahr distro.

http://www.gooplusplus.com/multiboot-collections/



I plan to also release an 850MB Kudos "mini" USB Multiboot collection soon that "features" Lx Pup Tahr.


Edited_time_total
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1459
Location: Malvern, Worcs, UK

PostPosted: Wed 17 Sep 2014, 07:28    Post_subject:  

@Marv, @Simes & @GooPlusPlus

Thank you all for your comments.

All the features you mention arise from the base TahrPup5.8.3-rc1 produced by 666philb so he deserves your thanks more than me..... QuickpetTahr, PaleMoon, VLC plugin...

@GooPlusPlus - if you get the chance can you see if your VMWare problem also applies to vanilla TahrPup5.8.3 ?

Thanks
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 831
Location: USA

PostPosted: Wed 17 Sep 2014, 08:22    Post_subject:  

Downloading LxPupTahr now.
_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 500GB WD HDD, Windows 7
(Slacko) Puppy Arcade 11 on USB Stick
Back to top
View user's profile Send_private_message 
Gooplusplus


Joined: 04 Sep 2013
Posts: 21
Location: Las Vegas

PostPosted: Wed 17 Sep 2014, 08:23    Post_subject:  

@peebee: unfortunately, TahrPup 5.8.3.rc1 failed starting X at the same point in the same way after creating and running a new VMware VM.

I also tried the suggested xwin jwm and xwin fvwm95 (and xwin lxde and xwin openbox) without success.

Whether it is relevant of not, my Lenovo i7 notebook with 8GB RAM has 1366x768 resolution with both Intel and Nvidia graphics.

Edited_time_total
Back to top
View user's profile Send_private_message 
Gobbi

Joined: 09 Mar 2012
Posts: 144

PostPosted: Wed 17 Sep 2014, 08:51    Post_subject:  

On my PC with a Radeon HD 7870XT - LxPupTahr 14.09 didn't start X either . I tried to see if it works in Qemu but it fails too... Sad
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1459
Location: Malvern, Worcs, UK

PostPosted: Wed 17 Sep 2014, 11:30    Post_subject:  

Gooplusplus wrote:
@peebee: unfortunately, TahrPup 5.8.3.rc1 failed starting X at the same point in the same way after creating and running a new VMware VM.

I also tried the suggested xwin jwm and xwin fvwm95 (and xwin lxde and xwin openbox) without success.

Whether it is relevant of not, my Lenovo i7 notebook with 8GB RAM has 1366x768 resolution with both Intel and Nvidia graphics.


Thanks for testing - could you report the problem over on the TahrPup thread providing as much diagnostic info as is possible - i.e. your hardware configuration, how Puppy is installed, the point in the boot sequence it fails and any error messages displayed.

One thing to try if it is booting but to a black desktop is to press whatever keys are needed on your laptop to increase screen brightness as I've had to do this with the k3.14.11 kernel on my HP laptop.

Thanks
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1770
Location: wales

PostPosted: Wed 17 Sep 2014, 12:58    Post_subject:  

Gooplusplus wrote:
@peebee: unfortunately, TahrPup 5.8.3.rc1 failed starting X at the same point in the same way after creating and running a new VMware VM.

I also tried the suggested xwin jwm and xwin fvwm95 (and xwin lxde and xwin openbox) without success.

Whether it is relevant of not, my Lenovo i7 notebook with 8GB RAM has 1366x768 resolution with both Intel and Nvidia graphics.

hi Gooplusplus,

i just tried tahrpup in vmware player and as you say it doesn't boot to desktop.
at the prompt type xorgwizard and select the modesetting driver, the desktop should then fire up

cheers

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=93998
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
Gooplusplus


Joined: 04 Sep 2013
Posts: 21
Location: Las Vegas

PostPosted: Thu 18 Sep 2014, 06:19    Post_subject:  

@666philb: Thanks, xorgwizard followed by xwin did get me to the desktop.

I then had to change video resolution again in the initial desktop quick wizard to make it stick during the session.

I also had to run the Alsa Sound Wizard because there was no sound. Any PCM setting under 50% was silent.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 24 of 27 Posts_count   Goto page: Previous 1, 2, 3, ..., 22, 23, 24, 25, 26, 27 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1334s ][ Queries: 12 (0.0367s) ][ GZIP on ]