Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 13:06
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Using New HPLIP Drivers in Puppy 4.3.x
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [36 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
jakfish

Joined: 18 Jul 2008
Posts: 754

PostPosted: Thu 10 Oct 2013, 14:47    Post subject:  

Would you suggest that I try the Canon driver? Or try everything once more with CUPS 1.1.23 and stick to HP?

Edit: wait, I think I understand what you're really saying. Maybe switch printers? But wireless is working w/ the family laptop, etc... Hmm...

Interesting,
Jake
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8919
Location: Stratford, Ontario

PostPosted: Thu 10 Oct 2013, 15:54    Post subject:  

I was just curious about whether any modern printers are still compatible with Series-4 Puppies. It looks like some Canons are (assuming you resolve the libjpeg7 issue). But I doubt if any HP printer that needs a recent HPLIP driver will work.
Back to top
View user's profile Send private message 
jakfish

Joined: 18 Jul 2008
Posts: 754

PostPosted: Thu 10 Oct 2013, 16:09    Post subject:  

Seems a shame that there isn't a generic HP driver for basic printing. I guess the printers outfoxed themselves as they got more and more complicated.

Jake
Back to top
View user's profile Send private message 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Fri 11 Oct 2013, 02:49    Post subject:  

jakfish wrote:
Seems a shame that there isn't a generic HP driver for basic printing. I guess the printers outfoxed themselves as they got more and more complicated.

Jake


Maybe Google could include a linux app for Google Cloud printing. I think it already works with the Chrome Browser.

Edit: Just tried it. Worked with my new HP 6100
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 2046
Location: The Blue Marble

PostPosted: Fri 11 Oct 2013, 05:54    Post subject:  

.
_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13
Back to top
View user's profile Send private message 
jakfish

Joined: 18 Jul 2008
Posts: 754

PostPosted: Fri 11 Oct 2013, 09:27    Post subject:  

The rub is, any Puppy derivative that can run a current Chrome or use a Google Linux app can probably install a current HPLIP.

Jake
Back to top
View user's profile Send private message 
jakfish

Joined: 18 Jul 2008
Posts: 754

PostPosted: Fri 11 Oct 2013, 16:37    Post subject:  

An interesting turn, perhaps. In Windows, using the 3520's own printer ip--10.0.0.3:9100, I found that the old HP 990c driver works.

With my 4.3 machines, what pets would you recommend to see if this works with Puppy?

I prefer to be as basic as possible, so CUPS 1.1.23 is fine with me--as long as 1.1.23 will accept the ip address (1.3.11 actually found the 3520 in its network section)

Jake
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8919
Location: Stratford, Ontario

PostPosted: Fri 11 Oct 2013, 18:59    Post subject:  

Are you sure that you are running Puppy 432 and not 431? My copy of 432 has libjpeg.so.7 and yours does not.

The CUPS wizard in 432 is broken, making it difficult to get a printer installed. But the version of Gutenprint in 432 has a Deskjet 990C driver.

Are you using any swap? Is it possible that your problems are due to lack of memory and not drivers?
Back to top
View user's profile Send private message 
jakfish

Joined: 18 Jul 2008
Posts: 754

PostPosted: Sat 12 Oct 2013, 15:33    Post subject:  

Hi, rcrsn51,

Since Puppeee 1.0 runs so much faster on the eee 900 than 432 (on the Vaio, I'm using 4.32 v3, whose CUPS seems in good shape), I'm testing on the eee.

Driver: HP 990c on both XP SP3 and Puppeee
Samba: smb://10.0.0.10/990c
Printer IP: http:/10.0.0.3:9100
CUPS: 1.1.23

The printer is shared, and when I print in puppeee, I get no error message, and I see the document is received by XP/990c, I see the printer come to life, but I get no print out at all.

If I print directly to 3520 printer, I get "Unable to get printer status (client-error-bad-request)!" Printer does not turn on.

When I install CUPS 1.3.11, and print directly to printer, I get error "Unable to get printer status (Bad Request)!" Printer does not turn on.

With 1.3.11 and samba, I get the error: "Can't load /etc/opt/samba/smb.conf - run testparm to debug it"

Jake
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8919
Location: Stratford, Ontario

PostPosted: Sat 12 Oct 2013, 16:51    Post subject:  

1. Are you using swap?

2. Are you talking about the Gutenprint HP990C driver?

3. You appear to have gone from a scenario where printing partially worked to a new one where nothing works.

4. Jemimah had no interest in printers and there were numerous problems with printing in her builds. I have no way of testing puppeee, so I cannot comment on your problems.

5. However, I now have a procedure in place for running new HPLIP driver packages in Puppy 4.3.1. I got tired of the wonky behaviour in 4.3.2 and scrapped it. If you want to continue with this, you will need a clean install of 431 on some machine. We need to be on the same page to get this working.
Back to top
View user's profile Send private message 
jakfish

Joined: 18 Jul 2008
Posts: 754

PostPosted: Sat 12 Oct 2013, 20:42    Post subject:  

1. Are you using swap? >> No, the eee 900 has 2GB RAM

2. Are you talking about the Gutenprint HP990C driver? >> Yes

3. You appear to have gone from a scenario where printing partially worked to a new one where nothing works. >> Correct, but the HP 990c prints fine XP-to-3520

4. Jemimah had no interest in printers and there were numerous problems with printing in her builds. I have no way of testing puppeee, so I cannot comment on your problems. >> Okay

5. However, I now have a procedure in place for running new HPLIP driver packages in Puppy 4.3.1. I got tired on the wonky behaviour in 4.3.2 and scrapped it. If you want to continue with this, you will need a clean install of 431 on some machine. We need to be on the same page to get this working. >> In light of this, I now have fresh install of 4.31 on 1 GB SD card that I can use on the eee 900

Many thanks,
Jake
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8919
Location: Stratford, Ontario

PostPosted: Sat 12 Oct 2013, 20:56    Post subject:  

How to install recent HPLIP printer drivers in Puppy 4.3.1

1. Go here and install CUPS 1.3.11.

2. From the same page, install the setdefprn-1.0.pet.

3. Go here. Install the hplip_print-3.13.9.pet and hplip_print_legacy_cups_patch-1.3.11.pet.

4. Go here and install the libusb_4xx-1.0.pet.

5. Download and install the ghostscript_puppy431-8.64.pet.

6. Restart CUPS with: /etc/init.d/cups restart

7. Run the CUPS setup wizard and install your printer. Declare it as the default printer. THIS IS IMPORTANT.
Back to top
View user's profile Send private message 
jakfish

Joined: 18 Jul 2008
Posts: 754

PostPosted: Sun 13 Oct 2013, 08:25    Post subject:  

Success. You did it. W/ a fresh 4.31, a test page prints and so does Abiword. This is a CUPS setup that prints directly to the 3520.

I'm going to see if your setup works with my existing OSs and will post back.

Your determination and assistance really are things for the ages.

Jake
Back to top
View user's profile Send private message 
jakfish

Joined: 18 Jul 2008
Posts: 754

PostPosted: Sun 13 Oct 2013, 11:00    Post subject:  

W/ Puppeee 1.0/eee 900, everything worked as well, using the same steps. I successfully printed a test page and MS Word doc in Wine

But upon reboot, I got this error:

Unable to open file "/var/spool/cups/d00004-001 Permission Denied"

I realize that Puppeee may be problematic, but I was wondering if there is a workaround to this, considering that it did print.

Jake
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8919
Location: Stratford, Ontario

PostPosted: Sun 13 Oct 2013, 11:16    Post subject:  

This permissions problem also occurred with other users when upgrading to CUPS 1.3.11, particularly with USB installs. It has something to do with the special layered filesystem for PUPMODE=13 messing with the permissions of CUPS folders. It is discussed (at length) starting here.

The eventual solution was to create a script in /root/Startup named "cups-fix"
Code:
/etc/init.d/cups stop
rm -rf /var/spool/cups
rm -rf /var/run/cups
(and maybe) rm -rf /var/cache/cups
/etc/init.d/cups start

This lets CUPS rebuild its folders with the right permissions.

BTW, it is also possible to upgrade the HPLIP scanner driver for Puppy 4.3.x. Once you have your printer installs done, we can look at this.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [36 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0785s ][ Queries: 11 (0.0109s) ][ GZIP on ]