Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 27 Aug 2014, 09:01
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Tastaturbelegung "de"
Moderators: MU
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
edpuppy

Joined: 08 Oct 2013
Posts: 12

PostPosted: Tue 08 Oct 2013, 05:23    Post_subject:  Tastaturbelegung "de"
Sub_title: Belegung wird nach Neustart nicht übernommen
 

Hi liebe Puppy-Users,

Kleines aber nerviges Problem mit Precise Puppy.

Im Setup hab ich alles auf deutsch gestellt und das klappt auch wunderbar. Nur die Tastaturbelegung ist nach jedem Neustart immer wieder Englisch.

Selbst wenn ich unter Setup>>Xorg-Tastaturbelegung>>Belegung auf de umstelle, übernehme und dann Puppy speichere ist es nach dem Neustart immer Englisch.

Wie kann ich das ändern ?

Danke für die HIlfe im Vorraus!
Back to top
View user's profile Send_private_message 
antilet

Joined: 17 Aug 2012
Posts: 169

PostPosted: Tue 08 Oct 2013, 06:47    Post_subject:  

Mit oder ohne Speicherdatei?
Mit oder ohne Grubeintrag?

man kann es beim Start mitgeben:
PKEYS=de

_________________
Toshiba Satallite M30X-124 | ATI Mobility Radeon 9700 | Intel PRO/Wireless 2200BG
Most Linux need special boot options to boot on this laptop: i8042.nomux=1 highres=off nohz=off irqpoll

Back to top
View user's profile Send_private_message 
edpuppy

Joined: 08 Oct 2013
Posts: 12

PostPosted: Tue 08 Oct 2013, 07:13    Post_subject:  

Mit Speicherdatei.

Ich starte einfach, bei erscheinen des Menüs mit der Entertaste das System. Also ohne EInträge.

Werd ich mal probieren..Danke
Back to top
View user's profile Send_private_message 
antilet

Joined: 17 Aug 2012
Posts: 169

PostPosted: Tue 08 Oct 2013, 08:03    Post_subject:  

Mit Speicherdatei sollte er es sich aber merken. Komisch....
_________________
Toshiba Satallite M30X-124 | ATI Mobility Radeon 9700 | Intel PRO/Wireless 2200BG
Most Linux need special boot options to boot on this laptop: i8042.nomux=1 highres=off nohz=off irqpoll

Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2505
Location: Burghaslach, Germany somewhere also known as "Hosla"

PostPosted: Tue 08 Oct 2013, 14:12    Post_subject: Tastaturbelegung "de"  

Hallo ed,

Antworten auf
antilet wrote:
Mit oder ohne Speicherdatei?
Mit oder ohne Grubeintrag?
sind ganz bestimmt hilfreich.

Kopiere bitte auch mal
Code:
cat /etc/rc.d/PUPSTATE
in eine Konsole und schick es her.

Das hilft helfen Very Happy
Back to top
View user's profile Send_private_message 
oui

Joined: 20 May 2005
Posts: 2062
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Tue 08 Oct 2013, 18:40    Post_subject:  

geh in /etc/X11/xorg.conf und ändere dort die Tastatur! Dann Datei abspeichern, und X wieder starten... So kann man JEDE Tastatur einstellen (inklusiv der schrecklichen Devanagari-Tastatur für indische Sprachen in Puppy einstellen (nur man braucht auch noch, dazu, einen passenden Zeichensatz! Für viele Sonder-Sprachen ist er in Puppy NICHT von vornherein vorhanden! Aber FÜR DEUTSCH, schon...!!!)

wer ohne Speicherdatei arbeitet, sollte remasteurisieren!

beide können vorübergehend sich mit dem Befehl

Code:
setxkbmap de


in der Konsole aushelfen! So kann man den Text in einer völlig anderen Sprache auch mitte in einer Zeile ausgeben und zurückumstellen

Code:
setxkbmap tr

... dann weiterschreiben ...

setxkbmap de


und weiter mit deutscher Tastatur nach dem türkischen Texteinschluß!

Statt de nehmen Schweizerdeutsche ch eben...

Die Cursor-Taste oben hilft zum schnellen Wechsel da die Konsole sich solche Befehle merkt!

Ist absolut praktisch!

Man kann die Konsole stark verkleinern, falls dieses Fensterchen sonst stört!!!
Back to top
View user's profile Send_private_message 
edpuppy

Joined: 08 Oct 2013
Posts: 12

PostPosted: Wed 09 Oct 2013, 05:56    Post_subject:  

Uhh, rege Beteiligung hier. Danke dafür erstmal Smile

@antilet
hab es beim Startmenü eingegeben. Während des Ladevorgang wurde auch bestätigt, das "DE"-Belegung geladen wird. Im PUppy hab ich aber keider wieder nur die englische, da ja im Savefile diese gespeichert ist, wieso auch immer...

@L18L

Code:
# cat /etc/rc.d/PUPSTATE
PUPMODE=13
PDEV1=''
DEV1FS=''
PUPSFS='sdb1,vfat,/puppy_precise_5.7.sfs'
PUPSAVE='sdb1,vfat,/precisesave.2fs'
PMEDIA='cd'
#ATADRIVES is all internal ide/pata/sata setxkb dedrives, excluding optical, excluding usb...
ATADRIVES='sda '
#ATAOPTICALDRIVES is list of non-usb optical drives...
ATAOPTICALDRIVES='sr0 '
#these directories are unionfs/aufs layers in /initrd...
SAVE_LAYER='/pup_ro1'
PUP_LAYER='/pup_ro2'
#The partition that has the precisesave file is mounted here...
PUP_HOME='/mnt/dev_save'
#(in /initrd) ...note, /mnt/home is a link to it.
#this file has extra kernel drivers and firmware...
ZDRV=''
#complete set of modules in the initrd (moved to main f.s.)...
ZDRVINIT='no'
#Partition no. override on boot drive to which session is (or will be) saved...
PSAVEMARK=''
PSUBDIR=''
#



@oui

meine Xorg.conf sieht wohl so aus. Wenn ich das richtig sehe, ist dort "de" eingestellt, oder?

Den Rest deiner Erklärung führe jetzt mal einfach aus wie du es beschrieben hast.

Code:
Special base config file used in Puppy Linux.

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"     # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

# This loads the font modules
#    Load        "type1"
#    Load        "freetype"

# This loads xtrap extension, used by xrandr
#    Load       "xtrap"

# This loads the GLX module (if present). xorg 7.4/5 need explicit disable to disable...
#    Disable    "glx" #LOADGLX

# This loads dri module (if present). 7.4 loads it by default, have to disable...
#    Load       "dri" #LOADDRI
#    Disable "dri"

EndSection

# **********************************************************************
# Files section.  This allows default font paths to be set
# **********************************************************************

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

    FontPath   "/usr/share/X11/fonts/misc/"
    FontPath   "/usr/share/X11/fonts/Type1/"
    FontPath   "/usr/share/X11/fonts/TTF/"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12).  This allows clients to receive these key
# events.

#    Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

    Option "RandR" "on"

# With this, Xorg won't talk to HAL to add evdev devices and you'll be back
# with the old Xorg behavior (pre-7.4)...

    Option "AutoAddDevices" "false"

# For no-Hal, kirk also suggests this...

#    Option "AllowMouseOpenFail" "true"

# Xorg 7.4, Ubuntu Jaunty, CTRL-ALT-BACKSPACE is disabled by default...

    Option "DontZap" "false"

EndSection

#everything past here is auto-generated by Puppy's Xorg Wizard...

Section "ServerLayout"
   Identifier "Default Layout"
   Screen "Screen0" 0 0
   InputDevice "Keyboard0" "CoreKeyboard"
   InputDevice "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "XkbRules" "xorg"
   Option      "XkbModel" "pc102"
   Option      "XkbLayout" "de" #xkeymap0
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Device" "/dev/input/mice"
   Option       "Protocol" "IMPS/2" #mouse0protocol
   #Option      "Emulate3Buttons"
   #Option      "Emulate3Timeout" "50"
   Option      "ZAxisMapping" "4 5" #scrollwheel
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
   #HorizSync    31-50
   VertRefresh  59-76
   #UseModes     "Modes0" #monitor0usemodes
   Option      "PreferredMode" "1920x1080"
EndSection

Section "Modes"
   Identifier "Modes0"
   #modes0modeline0
EndSection

Section "Device"
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "kmsdev"                # <str>
        #Option     "ShadowFB"              # [<bool>]
   Identifier  "card0"
   Driver      "modesetting" #card0driver
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
   #Option         "metamodes" "1920x1080_60 +0+0" #METAMODES_0
   Subsection "Display"
      Depth       24
      Modes       "1920x1080"
   EndSubsection
EndSection

#PuppyHardwareProfile=NVIDIA


EDIT:

Nach Eingabe von setxkbmap de und einem Neustart scheint es nun zu funktionieren..

Vielen Dank Smile
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2505
Location: Burghaslach, Germany somewhere also known as "Hosla"

PostPosted: Thu 10 Oct 2013, 04:47    Post_subject: Tastaturbelegung "de"
Sub_title: nicht ganz aktuelle Version
 

edpuppy wrote:
...
Code:
# cat /etc/rc.d/PUPSTATE
PUPMODE=13
PDEV1=''
DEV1FS=''
PUPSFS='sdb1,vfat,/puppy_precise_5.7.sfs'
....
#
...

Dieser Non-US keyboards bug in puppy_precise_5.7 ist beseitigt in puppy_precise_5.7.1

Warum Neustart nach setxkbmap bzw. was startest du neu?
Back to top
View user's profile Send_private_message 
edpuppy

Joined: 08 Oct 2013
Posts: 12

PostPosted: Thu 10 Oct 2013, 07:58    Post_subject:  

Mit neustarten meint ich das komplette Puppy, um zu sehen, ob ich beim nächsten Start sofort die DEkeys habe. Seltsamerweise, wenn ich direkt nach dem Start Thunderbird öffne, habe ich wieder die USKeys. MAch ich das Gleiche mit FF oder dem Editoren ZB, hab ich deKeys. Und danach dann auch im Thunderbird... Neutral

Wie sieht es denn mit einem update auf 5.7.1 aus?

Das Ganze läuft über einen USB-Stick. Kann ich den mit dem aktuellen ISO neu machen und einfach meine jetzige Savedatei nutzen?
Back to top
View user's profile Send_private_message 
antilet

Joined: 17 Aug 2012
Posts: 169

PostPosted: Thu 10 Oct 2013, 09:08    Post_subject:  

edpuppy wrote:
Wie sieht es denn mit einem update auf 5.7.1 aus?

Das Ganze läuft über einen USB-Stick. Kann ich den mit dem aktuellen ISO neu machen und einfach meine jetzige Savedatei nutzen?

Kann man. Allerdings funktioniert das Updaten der Save-Datei nicht immer - also vorher sichern...

_________________
Toshiba Satallite M30X-124 | ATI Mobility Radeon 9700 | Intel PRO/Wireless 2200BG
Most Linux need special boot options to boot on this laptop: i8042.nomux=1 highres=off nohz=off irqpoll

Back to top
View user's profile Send_private_message 
edpuppy

Joined: 08 Oct 2013
Posts: 12

PostPosted: Fri 11 Oct 2013, 03:48    Post_subject:  

OK Danke.

Nochmal zur Vervollständigung: Die deutsche Tastatur wird erst ohne irgendwelche manuellen EInstellungen übernommen wenn ich den Firefox öffne. Vorher sind alle Programmme in US Keys..

Naja...ich werd so schnell wie möglich die neue Version testen. Bis dahin...
Back to top
View user's profile Send_private_message 
antilet

Joined: 17 Aug 2012
Posts: 169

PostPosted: Fri 11 Oct 2013, 05:06    Post_subject:  

edpuppy wrote:
Nochmal zur Vervollständigung: Die deutsche Tastatur wird erst ohne irgendwelche manuellen EInstellungen übernommen wenn ich den Firefox öffne. Vorher sind alle Programmme in US Keys..

Wie L18L schrieb, ist das ein bekannter Bug, der mit 5.7.1 gefixed wurde...

_________________
Toshiba Satallite M30X-124 | ATI Mobility Radeon 9700 | Intel PRO/Wireless 2200BG
Most Linux need special boot options to boot on this laptop: i8042.nomux=1 highres=off nohz=off irqpoll

Back to top
View user's profile Send_private_message 
edpuppy

Joined: 08 Oct 2013
Posts: 12

PostPosted: Sat 12 Oct 2013, 06:52    Post_subject:  

Aktuelle Version 5.7.1 mit Unetbootin auf den Stick geschrieben (alle verhanden Dateien überschrieben), Savefile der alten Version übernommen hat bestens geklappt.

Und der NonUS-Keys-Bug ist gefixt

Bestens Dank für die Hilfe und besonders für den Hionweis auf die aktuelle Version

Thema erledigt Smile

Gruß
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0922s ][ Queries: 11 (0.0040s) ][ GZIP on ]