Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Sep 2014, 10:04
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Wine - run Windows programs in Linux
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 5 [72 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
FeodorF


Joined: 07 Jul 2010
Posts: 173
Location: Heidelberg, Germany

PostPosted: Fri 18 Apr 2014, 07:38    Post subject: CAD running on Wine
Subject description: PCB designer: Eagle 6.5.0 -freeware licence-
 

This CAD program can be used to develop professional PCB's (boards).

You can download it here: http://www.cadsoftusa.com/download-eagle/?language=en&lang=en

Limitations: With 'freeware' licensing you can only use a board size of 10 cm x 8 cm.

Read here: http://www.cadsoftusa.com/download-eagle/freeware/?language=en

This board is within the limits. Developed by: http://elmicro.com/en/kit12.html




Back to top
View user's profile Send private message 
FeodorF


Joined: 07 Jul 2010
Posts: 173
Location: Heidelberg, Germany

PostPosted: Fri 18 Apr 2014, 20:31    Post subject: Stellarium running on Wine
Subject description: You need something faster/equal XP 3000+ to make it work
 

Stellarium is a free GPL software which renders realistic skies in real time with OpenGL. With Stellarium, you really see what you can see with your eyes, binoculars or a small telescope. Stellarium is also used in real planetariums.

Homepage: http://stellarium.sourceforge.net/

Download (win32) here: http://sourceforge.net/projects/stellarium/files/Stellarium-win32/0.12.4/stellarium-0.12.4-win32.exe/download

Little help: F1-Help , F2-Configuration Window , F6-Location Window , z-Azimuthal grid , CTRL+Q-Quit , Mouse: Left-Info on , Right-Info off



Stellarium FAQ's & bug reports: https://launchpad.net/stellarium
Back to top
View user's profile Send private message 
FeodorF


Joined: 07 Jul 2010
Posts: 173
Location: Heidelberg, Germany

PostPosted: Sat 19 Apr 2014, 08:04    Post subject: Wine emulating Windows 7
Subject description: How to setup Wine for Win7 programs
 

I would strongly suggest not to mix up Win/XP and Win7 applications while running Wine.

How to do a Windows 7 setup for Wine?
=========================

Follow the same steps as described on page 3 of this post.
At 'Menu->Utility->Wine Config' choose Windows 7 and click Ok. From there on you follow the same steps.

How to swap from Wine Win/XP to Wine Windows 7 ?
================================

If you already have Wine installed on '/mnt/home/ wine' (f.e. sda1) rename the folder to wine-XP or wine_XP.
Now go to '/root' and delete the link '.wine'. Click on 'Menu->Utility->Wine Config' and choose Windows 7.
Go to '/root' rename '.wine' to 'wine-Win7 or wine_Win7' and move it to '/mnt/home'.
At last step you provide a link from your '/mnt/home/ wine-Win7' folder to '/root' calling it '/root .wine'.

To revert everything just delete your .wine link and discard the .wine file being produced by your new 'Menu->Utility->Wine Config' setup.
Now pick the folder you need from '/mnt/home ...' as your '/root .wine' link.
Back to top
View user's profile Send private message 
FeodorF


Joined: 07 Jul 2010
Posts: 173
Location: Heidelberg, Germany

PostPosted: Sat 19 Apr 2014, 08:45    Post subject: A bit more than the name tells 'Soundcard Oscilloscope'
Subject description: This one needs a 'Wine Windows 7' setup!
 

This one needs a 'Wine Windows 7' setup!

Project 'Soundcard Oscilloscope': http://www.zeitnitz.de/Christian/scope_en?mid=4.01

Download from here Windows 7 (32-bit): http://www.zeitnitz.eu/scope/scope_141.exe

English pdf manual: http://www.zeitnitz.eu/scope/manual_scope_v141.pdf Please have a look at the manual first!

Homepage: http://www.zeitnitz.de/Christian/scope


Back to top
View user's profile Send private message 
FeodorF


Joined: 07 Jul 2010
Posts: 173
Location: Heidelberg, Germany

PostPosted: Tue 22 Apr 2014, 16:40    Post subject: How to intall the Adobe Flash Player to Wine 1.7.16
Subject description: Version 13.0.0.182
 

Yes, you are right - I had missed the Adobe Flash Player part. There we go now.

How to install the Adobe Flash Player 13.0.0.182 for Wine version 1.7.16?
==============================================
1) start your Puppy Linux SeaMonkey/Firefox browser and download the Flash Player Installer for Windows from here:
--> http://fpdownload.macromedia.com/get/flashplayer/pdc/13.0.0.182/install_flash_player.exe File size: 17.1 MB
2) save this file to drive c: of your Wine installation
3) install your windows browser to Wine
4) click on the Flash Player Installer.exe to execute the install process
5) go to 'Menu->Utility->Wine Control Panel' - the Flash Player icon will tell you that the installation went well
6) start your Wine internet browser and check if Flash works on youtube
7) please don't forget to power off your PC to restart

How to check if your Flash Player works?
=========================
go right there and check: http://www.youtube.com/watch?v=glfgb3vWP3g#aid=P8mLjI4ofhA


How to check what version is installed?
========================
check right here: http://www.adobe.com/software/flash/about/

That's it.
Have fun!
Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 80

PostPosted: Wed 23 Apr 2014, 23:06    Post subject: Wine 1.7.17  

my attempt at compiling wine-1.7.17

wine-1.7.17-i486_v1.1.pet _______ puppy 431 | stripped=true | mirrors
wine-1.7.17-i486_v1.2.pet _______ puppy 431 | stripped=false | mirrors
wine-1.7.17-i486_v2.1.pet _______ racy puppy 5.5 | stripped=true | mirrors
wine-1.7.17-i486_v2.2.pet _______ racy puppy 5.5 | stripped=false | mirrors
wine_DEV-1.7.17-i486_v1.pet ____ puppy 431 | mirrors
wine_DEV-1.7.17-i486_v2.pet ____ racy puppy 5.5 | mirrors
wine_DOC-1.7.17-i486.pet _______ mirrors
wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ mirrors


If you are not going to submit bug reports to WineHQ, I recommend packages that are 'stripped=true'
If you are going to submit bug reports to WineHQ, I recommend packages that are 'stripped=false'
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine. [references]

The first post [>] has links to:
sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------
puppy 431 ->

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
_________ mirrors _________
/distro/4.3__1/puppies-431.1-main-Xserver.iso
/distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet
/fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet
/libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/libusb/1.0.9/libusb-1.0.9-i486_v2.pet
/libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet
/xorg/7.3/xorg_xorg_full_dri-7.3.pet
/xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


When compiling, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- puppy 431
----------------------------------------------------------------------------------------------------------
racy puppy 5.5 ->

I compiled using Racy 5.5
_________ mirrors _________
/distro/racy5.5/racy-5.5.iso
/distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
/fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet


When compiling in racy puppy 5.5, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- racy puppy 5.5
----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
FeodorF


Joined: 07 Jul 2010
Posts: 173
Location: Heidelberg, Germany

PostPosted: Sat 26 Apr 2014, 08:33    Post subject: Important note about the 'frugal' installation of 'Wine'
Subject description: You have to change some 'symlinks'
 

If you run 'Wine' in 'frugal' mode you will have to do some manual changes.

In the folder '/mnt/home/wine/drive_c/users/root' you'll find 5 symlinked folders. These folders should be regular folders but not symlinks.

You will see 'Desktop', 'My Documents', 'My Music', 'My Pictures' and 'My Videos' as symlinks to /root. This will upset Puppy Linux and Wine. Therefore you have to delete the symlinks and create regular folders with the same names instead.
Back to top
View user's profile Send private message 
FeodorF


Joined: 07 Jul 2010
Posts: 173
Location: Heidelberg, Germany

PostPosted: Sun 27 Apr 2014, 08:45    Post subject: Scribus running on Slacko 5.7.0 and Wine-1.7.17
Subject description: Open Source Desktop Publishing
 

"Scribus is an Open Source program that brings professional page layout to Linux, BSD UNIX, Solaris, OpenIndiana, GNU/Hurd, Mac OS X, OS/2 Warp 4, eComStation, and Windows desktops with a combination of press-ready output and new approaches to page design."

Puppy Linux version used: 'Slacko 5.7.0 PAE'

Home: http://www.scribus.net/canvas/Scribus

Possible downloads: http://wiki.scribus.net/canvas/Download

Download for Wine-1.7.17: -> http://sourceforge.net/projects/scribus/files/scribus/1.4.3/scribus-1.4.3-windows.exe/download

Scribus screenshots: -> http://sourceforge.net/projects/scribus/?source=directory#screenshots

Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 80

PostPosted: Mon 05 May 2014, 21:15    Post subject: Wine 1.7.18  

my attempt at compiling wine-1.7.18

wine-1.7.18-i486_v1.1.pet _______ puppy 431 | stripped=true | mirrors
wine-1.7.18-i486_v1.2.pet _______ puppy 431 | stripped=false | mirrors
wine-1.7.18-i486_v2.1.pet _______ racy puppy 5.5 | stripped=true | mirrors
wine-1.7.18-i486_v2.2.pet _______ racy puppy 5.5 | stripped=false | mirrors
wine_DEV-1.7.18-i486_v1.pet ____ puppy 431 | mirrors
wine_DEV-1.7.18-i486_v2.pet ____ racy puppy 5.5 | mirrors
wine_DOC-1.7.18-i486.pet _______ mirrors
wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ mirrors


If you are not going to submit bug reports to WineHQ, I recommend packages that are 'stripped=true'
If you are going to submit bug reports to WineHQ, I recommend packages that are 'stripped=false'
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine. [references]

The first post [>] has links to:
sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------
puppy 431 ->

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
_________ mirrors _________
/distro/4.3__1/puppies-431.1-main-Xserver.iso
/distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet
/fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet
/libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/libusb/1.0.9/libusb-1.0.9-i486_v2.pet
/libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet
/xorg/7.3/xorg_xorg_full_dri-7.3.pet
/xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


When compiling, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- puppy 431
----------------------------------------------------------------------------------------------------------
racy puppy 5.5 ->

I compiled using Racy 5.5
_________ mirrors _________
/distro/racy5.5/racy-5.5.iso
/distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
/fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet


When compiling in racy puppy 5.5, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- racy puppy 5.5
----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 80

PostPosted: Mon 19 May 2014, 16:56    Post subject: Wine 1.7.19  

my attempt at compiling wine-1.7.19

wine-1.7.19-i486_v1.1.pet _______ puppy 431 | stripped=true | mirrors
wine-1.7.19-i486_v1.2.pet _______ puppy 431 | stripped=false | mirrors
wine-1.7.19-i486_v2.1.pet _______ racy puppy 5.5 | stripped=true | mirrors
wine-1.7.19-i486_v2.2.pet _______ racy puppy 5.5 | stripped=false | mirrors
wine_DEV-1.7.19-i486_v1.pet ____ puppy 431 | mirrors
wine_DEV-1.7.19-i486_v2.pet ____ racy puppy 5.5 | mirrors
wine_DOC-1.7.19-i486.pet _______ mirrors
wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt _________ mirrors


If you are not going to submit bug reports to WineHQ, I recommend packages that are 'stripped=true'
If you are going to submit bug reports to WineHQ, I recommend packages that are 'stripped=false'
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------
puppy 431 ->

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
_________ mirrors _________
/distro/4.3__1/puppies-431.1-main-Xserver.iso
/distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet
/fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet
/libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/libusb/1.0.9/libusb-1.0.9-i486_v2.pet
/libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet
/xorg/7.3/xorg_xorg_full_dri-7.3.pet
/xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


When compiling, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- puppy 431
----------------------------------------------------------------------------------------------------------
racy puppy 5.5 ->

I compiled using Racy 5.5
_________ mirrors _________
/distro/racy5.5/racy-5.5.iso
/distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
/fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet


When compiling in racy puppy 5.5, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- racy puppy 5.5
----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 80

PostPosted: Tue 17 Jun 2014, 21:13    Post subject: Wine 1.7.20  

my attempt at compiling wine-1.7.20

wine-1.7.20-i486_v1.1.pet _______ puppy 431 | stripped=true | mirrors
wine-1.7.20-i486_v1.2.pet _______ puppy 431 | stripped=false | mirrors
wine-1.7.20-i486_v2.1.pet _______ racy puppy 5.5 | stripped=true | mirrors
wine-1.7.20-i486_v2.2.pet _______ racy puppy 5.5 | stripped=false | mirrors
wine_DEV-1.7.20-i486_v1.pet ____ puppy 431 | mirrors
wine_DEV-1.7.20-i486_v2.pet ____ racy puppy 5.5 | mirrors
wine_DOC-1.7.20-i486.pet _______ mirrors
wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt _________ mirrors



If you are not going to submit bug reports to WineHQ, I recommend packages that are 'stripped=true'
If you are going to submit bug reports to WineHQ, I recommend packages that are 'stripped=false'
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------
puppy 431 ->

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
_________ mirrors _________
/distro/4.3__1/puppies-431.1-main-Xserver.iso
/distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet
/fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet
/libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/libusb/1.0.9/libusb-1.0.9-i486_v2.pet
/libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet
/xorg/7.3/xorg_xorg_full_dri-7.3.pet
/xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


When compiling, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- puppy 431
----------------------------------------------------------------------------------------------------------
racy puppy 5.5 ->

I compiled using Racy 5.5
_________ mirrors _________
/distro/racy5.5/racy-5.5.iso
/distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
/fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet


When compiling in racy puppy 5.5, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- racy puppy 5.5
----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Sun 22 Jun 2014, 20:47; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
FeodorF


Joined: 07 Jul 2010
Posts: 173
Location: Heidelberg, Germany

PostPosted: Sat 21 Jun 2014, 22:34    Post subject: Open Office 4.1.0 running on Wine 1.7.20
Subject description: Add up: language support, desktop icons
 

You can download from there: http://www.openoffice.org/product/index.html

If You need an other language like: Chinese (simplified), Chinese (traditional), Hindi, Japanese, Khmer, Korean, Tamil, Thai, Vietnamese

You can go there: http://www.openoffice.org/download/other.html#aoo to download your 'Windows Intel EXE' file.

Guess you'd like to have some desktop icons to start your wine applications.
It's very easy to do:

- download and install your wine application
- look at /root/Desktop for your '.desktop' file and open it as text file
- change, if needed the 'Exec=env WINEPREFIX=' line so that it reads like this:

Exec=env WINEPREFIX="/root/.wine" wine C:\\\\windows\\\\command\\\\start.exe /Unix /root/.wine/dosdevices/c:/users/Public/Desktop/OpenOffice4.1.0.lnk

- copy your '.lnk' file from /root/Desktop to: '/mnt/home/wine/drive_c/users/Public/Desktop' and rename it to 'OpenOffice4.1.0.lnk'

Rem: If you give 'SeaMonkeySetup2.26.1.exe' a try, you'll see that 'SeaMonkey.desktop' works 'out of the box'.
Wine-Desktop-Icons.jpg
 Description   
 Filesize   16.45 KB
 Viewed   275 Time(s)

Wine-Desktop-Icons.jpg

Back to top
View user's profile Send private message 
FeodorF


Joined: 07 Jul 2010
Posts: 173
Location: Heidelberg, Germany

PostPosted: Sat 28 Jun 2014, 21:11    Post subject: Open Office 4.1.0 running on Wine 1.7.20
Subject description: How to enlarge in full screen mode
 

How to give OpenOffice a professional look in full screen mode in 'Writer, Calc, Draw, ...'

- start OpenOffice 4.1.0
- click on 'Tools'
- click on 'Options...'
- click on 'View'
- set 'User Interface Scaling' to 130%
- set 'User Interface Icon size and style' to Large
- close the window with 'OK'
Open Office 4.1.0.jpg
 Description   
 Filesize   15.69 KB
 Viewed   270 Time(s)

Open Office 4.1.0.jpg

Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 80

PostPosted: Mon 30 Jun 2014, 15:18    Post subject: Wine 1.7.21  

my attempt at compiling wine-1.7.21

wine-1.7.21-i486_v1.1.pet _______ puppy 431 | stripped=true | mirrors
wine-1.7.21-i486_v1.2.pet _______ puppy 431 | stripped=false | mirrors
wine-1.7.21-i486_v2.1.pet _______ racy puppy 5.5 | stripped=true | mirrors
wine-1.7.21-i486_v2.2.pet _______ racy puppy 5.5 | stripped=false | mirrors
wine_DEV-1.7.21-i486_v1.pet ____ puppy 431 | mirrors
wine_DEV-1.7.21-i486_v2.pet ____ racy puppy 5.5 | mirrors
wine_DOC-1.7.21-i486.pet _______ mirrors
wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt _________ mirrors



If you are not going to submit bug reports to WineHQ, I recommend packages that are 'stripped=true'
If you are going to submit bug reports to WineHQ, I recommend packages that are 'stripped=false'
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------
puppy 431 ->

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
_________ mirrors _________
/distro/4.3__1/puppies-431.1-main-Xserver.iso
/distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet
/fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet
/libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/libusb/1.0.9/libusb-1.0.9-i486_v2.pet
/libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet
/xorg/7.3/xorg_xorg_full_dri-7.3.pet
/xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


When compiling, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- puppy 431
----------------------------------------------------------------------------------------------------------
racy puppy 5.5 ->

I compiled using Racy 5.5
_________ mirrors _________
/distro/racy5.5/racy-5.5.iso
/distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
/fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet


When compiling in racy puppy 5.5, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- racy puppy 5.5
----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Tue 01 Jul 2014, 14:41; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
jlst

Joined: 23 Nov 2012
Posts: 15

PostPosted: Tue 01 Jul 2014, 11:16    Post subject:  

Thanks
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 5 [72 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1694s ][ Queries: 12 (0.0033s) ][ GZIP on ]