(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
https://forum.puppylinux.com
and continue your work there. Thank you.

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Sep 2020, 14:29
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Wine - run Windows programs in Linux
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 30 of 31 [451 Posts]   Goto page: Previous 1, 2, 3, ..., 28, 29, 30, 31 Next
Author Message
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Fri 24 Apr 2020, 00:01    Post subject: wine-5.6  

My attempt at compiling wine-5.6

[wine-5.6 mirrors]

1.x and 2.x failed to compile because of a bug

wine-5.6_v3.1.pet _________ tahrpup 6.0.5 PAE [stripped=true]
wine-5.6_v3.2.pet _________ tahrpup 6.0.5 PAE [stripped=false]
wine_DEV-5.6_v3.1.pet ____ tahrpup 6.0.5 PAE
wine_DEV-5.6_v3.2.pet ____ tahrpup 6.0.5 PAE

wine_DOC-5.6.pet

wine_extras-v2.1.pet __________ menu entries | mirrors
md5.txt and hashdeep.txt ____ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character points to a directory of download links, or an individual download link.
example:
> __ wine/5.6/
> _____wine-5.6_v1.1.pet

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------

----------------------------
tahrpup 6.0.5 PAE
----------------------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.
They still need to be installed in puppy for wine to use their features.
The dev files are only needed when compiling.

[mirrors]
mpg123/1.25.10/mpg123-1.25.10_v1.1.pet
mpg123/1.25.10/mpg123_DEV-1.25.10.pet

[mirrors]
openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

Puppy Package Manager > mingw-w64_3.1.0-1
binutils-mingw-w64-i686_2.23.52.20130620-1ubuntu1
binutils-mingw-w64-x86-64_2.23.52.20130620-1ubuntu1
gcc-mingw-w64_4.8.2-10ubuntu2+12
gcc-mingw-w64-base_4.8.2-10ubuntu2+12
gcc-mingw-w64-i686_4.8.2-10ubuntu2+12
gcc-mingw-w64-x86-64_4.8.2-10ubuntu2+12
mingw-w64_3.1.0-1
mingw-w64-common_3.1.0-1
mingw-w64-i686-dev_3.1.0-1
mingw-w64-x86-64-dev_3.1.0-1

----------------------------------------

When compiling in tahrpup 6.0.5 PAE, I used:
v3.1
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --libdir=/usr/lib32 CFLAGS="-O2 -march=i486 -mtune=i686"

v3.2
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --libdir=/usr/lib32 CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline -march=i486 -mtune=i686"


----------------------------------------------------------------------------------------------------------

Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Fri 24 Apr 2020, 00:02    Post subject: wine64-5.6  

My attempt at compiling wine64
This is a WOW64 build.
https://wiki.winehq.org/Building_Wine#Shared_WoW64

[wine-5.6 mirrors]

wine64-5.6_v4.1.pet _________ tahrpup64 6.0.5 [stripped=true]
wine64_DEV-5.6.pet __________ tahrpup64 6.0.5
wine64_DOC-5.6.pet __________ tahrpup64 6.0.5

----------------------------
tahrpup64 6.0.5
----------------------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.

Puppy Package Manager > mingw-w64_3.1.0-1
binutils-mingw-w64-i686_2.23.52.20130620-1ubuntu1
binutils-mingw-w64-x86-64_2.23.52.20130620-1ubuntu1
gcc-mingw-w64_4.8.2-10ubuntu2+12
gcc-mingw-w64-base_4.8.2-10ubuntu2+12
gcc-mingw-w64-i686_4.8.2-10ubuntu2+12
gcc-mingw-w64-x86-64_4.8.2-10ubuntu2+12
mingw-w64_3.1.0-1
mingw-w64-common_3.1.0-1
mingw-w64-i686-dev_3.1.0-1
mingw-w64-x86-64-dev_3.1.0-1

----------------------------------------

When compiling in tahrpup64 6.0.5, I used:
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --enable-win64 --libdir=/usr/lib64 CFLAGS="-O2"


https://wiki.winehq.org/Packaging#WoW64_Workarounds
For the 32-bit wine build, I used files from 'wine-5.6_v3.1.pet' from the previous forum post.
----------------------------------------------------------------------------------------------------------
The 32-bit wineserver is included, just in case it is needed.
It is a hidden file ".wineserver"

I do not have any 64-bit applications to test.
I can only do minimal testing because my AMD graphics driver is not functioning properly.
I may have to learn to compile Mesa to do any more detailed testing of 32-bit applications with this wine build.
I am relying on others to test this wine version.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Thu 07 May 2020, 00:57    Post subject: wine-5.7  

My attempt at compiling wine-5.7

[wine-5.7 mirrors]

2.x failed to compile because of a bug
I am assuming bug 47907 still applies, just that bug 49106 caused crash first.

1.x and 2.x failed to compile because of a bug

wine-5.7_v3.1.pet _________ tahrpup 6.0.5 PAE [stripped=true]
wine-5.7_v3.2.pet _________ tahrpup 6.0.5 PAE [stripped=false]
wine_DEV-5.7_v3.1.pet ____ tahrpup 6.0.5 PAE
wine_DEV-5.7_v3.2.pet ____ tahrpup 6.0.5 PAE

wine_DOC-5.7.pet

wine_extras-v2.1.pet __________ menu entries | mirrors
md5.txt and hashdeep.txt ____ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character points to a directory of download links, or an individual download link.
example:
> __ wine/5.7/
> _____wine-5.7_v1.1.pet

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------

----------------------------
tahrpup 6.0.5 PAE
----------------------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.
They still need to be installed in puppy for wine to use their features.
The dev files are only needed when compiling.

[mirrors]
mpg123/1.25.10/mpg123-1.25.10_v1.1.pet
mpg123/1.25.10/mpg123_DEV-1.25.10.pet

[mirrors]
openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

Puppy Package Manager > mingw-w64_3.1.0-1
binutils-mingw-w64-i686_2.23.52.20130620-1ubuntu1
binutils-mingw-w64-x86-64_2.23.52.20130620-1ubuntu1
gcc-mingw-w64_4.8.2-10ubuntu2+12
gcc-mingw-w64-base_4.8.2-10ubuntu2+12
gcc-mingw-w64-i686_4.8.2-10ubuntu2+12
gcc-mingw-w64-x86-64_4.8.2-10ubuntu2+12
mingw-w64_3.1.0-1
mingw-w64-common_3.1.0-1
mingw-w64-i686-dev_3.1.0-1
mingw-w64-x86-64-dev_3.1.0-1

----------------------------------------

When compiling in tahrpup 6.0.5 PAE, I used:
v3.1
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --libdir=/usr/lib32 CFLAGS="-O2 -march=i486 -mtune=i686"

v3.2
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --libdir=/usr/lib32 CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline -march=i486 -mtune=i686"


----------------------------------------------------------------------------------------------------------

Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Thu 07 May 2020, 01:03; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Thu 07 May 2020, 00:58    Post subject: wine64-5.7  

My attempt at compiling wine64
This is a WOW64 build.
https://wiki.winehq.org/Building_Wine#Shared_WoW64

[wine-5.7 mirrors]

wine64-5.7_v4.1.pet _________ tahrpup64 6.0.5 [stripped=true]
wine64_DEV-5.7.pet __________ tahrpup64 6.0.5
wine64_DOC-5.7.pet __________ tahrpup64 6.0.5

----------------------------
tahrpup64 6.0.5
----------------------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.

Puppy Package Manager > mingw-w64_3.1.0-1
binutils-mingw-w64-i686_2.23.52.20130620-1ubuntu1
binutils-mingw-w64-x86-64_2.23.52.20130620-1ubuntu1
gcc-mingw-w64_4.8.2-10ubuntu2+12
gcc-mingw-w64-base_4.8.2-10ubuntu2+12
gcc-mingw-w64-i686_4.8.2-10ubuntu2+12
gcc-mingw-w64-x86-64_4.8.2-10ubuntu2+12
mingw-w64_3.1.0-1
mingw-w64-common_3.1.0-1
mingw-w64-i686-dev_3.1.0-1
mingw-w64-x86-64-dev_3.1.0-1

----------------------------------------

When compiling in tahrpup64 6.0.5, I used:
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --enable-win64 --libdir=/usr/lib64 CFLAGS="-O2"


https://wiki.winehq.org/Packaging#WoW64_Workarounds
For the 32-bit wine build, I used files from 'wine-5.7_v3.1.pet' from the previous forum post.
----------------------------------------------------------------------------------------------------------
The 32-bit wineserver is included, just in case it is needed.
It is a hidden file ".wineserver"

I do not have any 64-bit applications to test.
I can only do minimal testing because my AMD graphics driver is not functioning properly.
I may have to learn to compile Mesa to do any more detailed testing of 32-bit applications with this wine build.
I am relying on others to test this wine version.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Tue 26 May 2020, 14:17    Post subject: wine-5.8  

My attempt at compiling wine-5.8

[wine-5.8 mirrors]

2.x failed to compile because of a bug
I am assuming bug 47907 still applies, just that bug 49106 caused crash first.

1.x and 2.x failed to compile because of a bug

wine-5.8_v3.1.pet _________ tahrpup 6.0.5 PAE [stripped=true]
wine-5.8_v3.2.pet _________ tahrpup 6.0.5 PAE [stripped=false]
wine_DEV-5.8_v3.1.pet ____ tahrpup 6.0.5 PAE
wine_DEV-5.8_v3.2.pet ____ tahrpup 6.0.5 PAE

wine_DOC-5.8.pet

wine_extras-v2.1.pet __________ menu entries | mirrors
md5.txt and hashdeep.txt ____ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character points to a directory of download links, or an individual download link.
example:
> __ wine/5.8/
> _____wine-5.8_v1.1.pet

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------

----------------------------
tahrpup 6.0.5 PAE
----------------------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.
They still need to be installed in puppy for wine to use their features.
The dev files are only needed when compiling.

[mirrors]
mpg123/1.25.10/mpg123-1.25.10_v1.1.pet
mpg123/1.25.10/mpg123_DEV-1.25.10.pet

[mirrors]
openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

Puppy Package Manager (update database) > mingw-w64_3.1.0-1
binutils-mingw-w64-i686_2.23.52.20130620-1ubuntu1+3build1_i386.deb
binutils-mingw-w64-x86-64_2.23.52.20130620-1ubuntu1+3build1_i386.deb
gcc-mingw-w64_4.8.2-10ubuntu2+12_all.deb
gcc-mingw-w64-base_4.8.2-10ubuntu2+12_i386.deb
gcc-mingw-w64-i686_4.8.2-10ubuntu2+12_i386.deb
gcc-mingw-w64-x86-64_4.8.2-10ubuntu2+12_i386.deb
g++-mingw-w64_4.8.2-10ubuntu2+12_all.deb
g++-mingw-w64-i686_4.8.2-10ubuntu2+12_i386.deb
g++-mingw-w64-x86-64_4.8.2-10ubuntu2+12_i386.deb
mingw-w64_3.1.0-1_all.deb
mingw-w64-common_3.1.0-1_all.deb
mingw-w64-i686-dev_3.1.0-1_all.deb
mingw-w64-x86-64-dev_3.1.0-1_all.deb

----------------------------------------

When compiling in tahrpup 6.0.5 PAE, I used:
v3.1
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --libdir=/usr/lib32 CFLAGS="-O2 -march=i486 -mtune=i686"

v3.2
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --libdir=/usr/lib32 CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline -march=i486 -mtune=i686"


----------------------------------------------------------------------------------------------------------

Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Fri 19 Jun 2020, 01:58; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Tue 26 May 2020, 14:17    Post subject: wine64-5.8  

My attempt at compiling wine64
This is a WOW64 build.
https://wiki.winehq.org/Building_Wine#Shared_WoW64

[wine-5.8 mirrors]

wine64-5.8_v4.1.pet _________ tahrpup64 6.0.5 [stripped=true]
wine64_DEV-5.8.pet __________ tahrpup64 6.0.5
wine64_DOC-5.8.pet __________ tahrpup64 6.0.5

----------------------------
tahrpup64 6.0.5
----------------------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.

Puppy Package Manager > mingw-w64_3.1.0-1
binutils-mingw-w64-i686_2.23.52.20130620-1ubuntu1
binutils-mingw-w64-x86-64_2.23.52.20130620-1ubuntu1
gcc-mingw-w64_4.8.2-10ubuntu2+12
gcc-mingw-w64-base_4.8.2-10ubuntu2+12
gcc-mingw-w64-i686_4.8.2-10ubuntu2+12
gcc-mingw-w64-x86-64_4.8.2-10ubuntu2+12
mingw-w64_3.1.0-1
mingw-w64-common_3.1.0-1
mingw-w64-i686-dev_3.1.0-1
mingw-w64-x86-64-dev_3.1.0-1

----------------------------------------

When compiling in tahrpup64 6.0.5, I used:
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --enable-win64 --libdir=/usr/lib64 CFLAGS="-O2"


https://wiki.winehq.org/Packaging#WoW64_Workarounds
For the 32-bit wine build, I used files from 'wine-5.8_v3.1.pet' from the previous forum post.
----------------------------------------------------------------------------------------------------------
The 32-bit wineserver is included, just in case it is needed.
It is a hidden file ".wineserver"

I do not have any 64-bit applications to test.
I can only do minimal testing because my AMD graphics driver is not functioning properly.
I may have to learn to compile Mesa to do any more detailed testing of 32-bit applications with this wine build.
I am relying on others to test this wine version.
Back to top
View user's profile Send private message Visit poster's website 
Smithy


Joined: 12 Dec 2011
Posts: 1157

PostPosted: Thu 04 Jun 2020, 10:04    Post subject:  

Hi Version 2013.

Is Wine 4.9 on page 25 the best version to use for 32 bit?

I ask because of those bugs you mention onwards, which affect Vulkan DirectX D3D replacement thing according to comments on that wine forum.
Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Fri 05 Jun 2020, 01:17    Post subject:  

Smithy wrote:
Hi Version 2013.

Is Wine 4.9 on page 25 the best version to use for 32 bit?

I ask because of those bugs you mention onwards, which affect Vulkan DirectX D3D replacement thing according to comments on that wine forum.

Which wine forum threads are you referring to?

Which wine 32 bit to use, depends on which puppy distro you want to use wine with.
Wine compiled on a newer puppy distro may fail to work with an older puppy distro.
Meaning, it partially depends on what glibc version the distro you are using has, compared to what glibc version the distro that wine was compiled in.

I have been compiling 32 bit wine on three different puppy distros. Tahr 32 bit being the latest, for now.
Back to top
View user's profile Send private message Visit poster's website 
Smithy


Joined: 12 Dec 2011
Posts: 1157

PostPosted: Fri 05 Jun 2020, 08:09    Post subject:  

The Wine HQ Bug Forum:

https://bugs.winehq.org/show_bug.cgi?id=47907

https://bugs.winehq.org/show_bug.cgi?id=49106

Ok I need to use your Tahr versions as they are probably the most appropriate. I use GLIB 226.

Your Version 3 was as far as I tried, which was not as straightforward as previously, (i.e install pet, winecfg in the terminal, bosh, bosh done).
Possibly because of changes like usr/lib/wine to usr/lib32/wine and other stuff. But it works well.

So I thought it might be interesting to try a 5 version to see if it goes faster, has new noticeable features or runs some old windows games.
Back to top
View user's profile Send private message 
fabrice_035


Joined: 28 Apr 2014
Posts: 768
Location: Bretagne / France

PostPosted: Sun 07 Jun 2020, 11:48    Post subject:  

Thanks, I'm currently trying version 5.0_v3.1, I didn't need to install .pet, just extract the files and associate .exe with the wine program.
It's still nice to be able to play StarCraft 1 again under Puppy Linux Smile
Nothing to say it's perfect.

edit: for info ... http://www.murga-linux.com/puppy/viewtopic.php?t=117957

_________________
Bionicpup64-8.0 _ Kernel 5.4.27-64oz _ Asus Rog GL752
Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Fri 19 Jun 2020, 01:39    Post subject: wine-5.9  

My attempt at compiling wine-5.9

[wine-5.9 mirrors]

2.x failed to compile because of a bug
I am assuming bug 47907 still applies, just that bug 49106 caused crash first.

1.x and 2.x failed to compile because of a bug

wine-5.9_v3.1.pet _________ tahrpup 6.0.5 PAE [stripped=true]
wine-5.9_v3.2.pet _________ tahrpup 6.0.5 PAE [stripped=false]
wine_DEV-5.9_v3.1.pet ____ tahrpup 6.0.5 PAE
wine_DEV-5.9_v3.2.pet ____ tahrpup 6.0.5 PAE

wine_DOC-5.9.pet

wine_extras-v2.1.pet __________ menu entries | mirrors
md5.txt and hashdeep.txt ____ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character points to a directory of download links, or an individual download link.
example:
> __ wine/5.9/
> _____wine-5.9_v1.1.pet

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------

----------------------------
tahrpup 6.0.5 PAE
----------------------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.
They still need to be installed in puppy for wine to use their features.
The dev files are only needed when compiling.

[mirrors]
mpg123/1.25.10/mpg123-1.25.10_v1.1.pet
mpg123/1.25.10/mpg123_DEV-1.25.10.pet

[mirrors]
openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

Puppy Package Manager (update database) > mingw-w64_3.1.0-1
binutils-mingw-w64-i686_2.23.52.20130620-1ubuntu1+3build1_i386.deb
binutils-mingw-w64-x86-64_2.23.52.20130620-1ubuntu1+3build1_i386.deb
gcc-mingw-w64_4.8.2-10ubuntu2+12_all.deb
gcc-mingw-w64-base_4.8.2-10ubuntu2+12_i386.deb
gcc-mingw-w64-i686_4.8.2-10ubuntu2+12_i386.deb
gcc-mingw-w64-x86-64_4.8.2-10ubuntu2+12_i386.deb
g++-mingw-w64_4.8.2-10ubuntu2+12_all.deb
g++-mingw-w64-i686_4.8.2-10ubuntu2+12_i386.deb
g++-mingw-w64-x86-64_4.8.2-10ubuntu2+12_i386.deb
mingw-w64_3.1.0-1_all.deb
mingw-w64-common_3.1.0-1_all.deb
mingw-w64-i686-dev_3.1.0-1_all.deb
mingw-w64-x86-64-dev_3.1.0-1_all.deb

----------------------------------------

When compiling in tahrpup 6.0.5 PAE, I used:
v3.1
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --libdir=/usr/lib32 CFLAGS="-O2 -march=i486 -mtune=i686"

v3.2
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --libdir=/usr/lib32 CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline -march=i486 -mtune=i686"


----------------------------------------------------------------------------------------------------------

Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Fri 19 Jun 2020, 02:01; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Fri 19 Jun 2020, 01:40    Post subject: wine64-5.9  

My attempt at compiling wine64
This is a WOW64 build.
https://wiki.winehq.org/Building_Wine#Shared_WoW64

[wine-5.9 mirrors]

wine64-5.9_v4.1.pet _________ tahrpup64 6.0.5 [stripped=true]
wine64_DEV-5.9.pet __________ tahrpup64 6.0.5
wine64_DOC-5.9.pet __________ tahrpup64 6.0.5

----------------------------
tahrpup64 6.0.5
----------------------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.

Puppy Package Manager > mingw-w64_3.1.0-1
binutils-mingw-w64-i686_2.23.52.20130620-1ubuntu1
binutils-mingw-w64-x86-64_2.23.52.20130620-1ubuntu1
gcc-mingw-w64_4.8.2-10ubuntu2+12
gcc-mingw-w64-base_4.8.2-10ubuntu2+12
gcc-mingw-w64-i686_4.8.2-10ubuntu2+12
gcc-mingw-w64-x86-64_4.8.2-10ubuntu2+12
mingw-w64_3.1.0-1
mingw-w64-common_3.1.0-1
mingw-w64-i686-dev_3.1.0-1
mingw-w64-x86-64-dev_3.1.0-1

----------------------------------------

When compiling in tahrpup64 6.0.5, I used:
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --enable-win64 --libdir=/usr/lib64 CFLAGS="-O2"


https://wiki.winehq.org/Packaging#WoW64_Workarounds
For the 32-bit wine build, I used files from 'wine-5.9_v3.1.pet' from the previous forum post.
----------------------------------------------------------------------------------------------------------
The 32-bit wineserver is included, just in case it is needed.
It is a hidden file ".wineserver"

I do not have any 64-bit applications to test.
I can only do minimal testing because my AMD graphics driver is not functioning properly.
I may have to learn to compile Mesa to do any more detailed testing of 32-bit applications with this wine build.
I am relying on others to test this wine version.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Thu 25 Jun 2020, 01:17    Post subject: wine-5.0.1  

My attempt at compiling wine-5.0.1

[wine-5.0.1 mirrors]

applied patch from https://bugs.winehq.org/show_bug.cgi?id=47907#c12
2.x compiled successfully

wine-5.0.1_v2.1.pet ________ racy puppy 5.5 (stripped=true)
wine-5.0.1_v2.2.pet ________ racy puppy 5.5 (stripped=false)
wine_DEV-5.0.1_v2.1.pet ____ racy puppy 5.5
wine_DEV-5.0.1_v2.2.pet ____ racy puppy 5.5

wine-5.0.1_v3.1.pet _________ tahrpup 6.0.5 PAE [stripped=true]
wine-5.0.1_v3.2.pet _________ tahrpup 6.0.5 PAE [stripped=false]
wine_DEV-5.0.1_v3.1.pet ____ tahrpup 6.0.5 PAE
wine_DEV-5.0.1_v3.2.pet ____ tahrpup 6.0.5 PAE

wine_DOC-5.0.1.pet

wine_extras-v2.1.pet __________ menu entries | mirrors
md5.txt and hashdeep.txt ____ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character points to a directory of download links, or an individual download link.
example:
> __ wine/5.0.1/
> _____wine-5.0.1_v1.1.pet

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------

------------
racy 5.5
------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.
They still need to be installed in puppy for wine to use their features.
The dev files are only needed when compiling.

[mirrors]
bison/3.3/bison-3.3_v1.2.pet
bison/3.3/bison_DEV-3.3_v1.2.pet

[mirrors]
fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

[mirrors]
gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

[mirrors]
gnutls/3.5.2/gnutls-3.5.2_v1.2.pet
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

[mirrors]
lcms2/2.8/lcms2-2.8_v2.pet
lcms2/2.8/lcms2_DEV-2.8_v2.pet

[mirrors]
libelf/0.8.13/libelf-0.8.13-i486_v2.pet
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

[mirrors]
libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

[mirrors]
libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

[mirrors]
libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

[mirrors]
mpg123/1.25.10/mpg123-1.25.10_v1.2.pet
mpg123/1.25.10/mpg123_DEV-1.25.10.pet

[mirrors]
nettle/3.2/nettle-3.2_v1.2.pet
nettle/3.2/nettle_DEV-3.2_v1.2.pet

[mirrors]
openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

[mirrors]
openldap/2.4.13/openldap-2.4.13-i486.pet
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

[mirrors]
prelink/20130503/prelink-20130503-i486_v2.pet

----------------------------------------

When compiling in racy 5.5, I used:
v2.1
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x --libdir=/usr/lib32 CFLAGS="-O2 -march=i486 -mtune=i686"

v2.2
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x --libdir=/usr/lib32 CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline -march=i486 -mtune=i686"


----------------------------------------------------------------------------------------------------------

----------------------------
tahrpup 6.0.5 PAE
----------------------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.
They still need to be installed in puppy for wine to use their features.
The dev files are only needed when compiling.

[mirrors]
mpg123/1.25.10/mpg123-1.25.10_v1.1.pet
mpg123/1.25.10/mpg123_DEV-1.25.10.pet

[mirrors]
openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

Puppy Package Manager (update database) > mingw-w64_3.1.0-1
binutils-mingw-w64-i686_2.23.52.20130620-1ubuntu1+3build1_i386.deb
binutils-mingw-w64-x86-64_2.23.52.20130620-1ubuntu1+3build1_i386.deb
gcc-mingw-w64_4.8.2-10ubuntu2+12_all.deb
gcc-mingw-w64-base_4.8.2-10ubuntu2+12_i386.deb
gcc-mingw-w64-i686_4.8.2-10ubuntu2+12_i386.deb
gcc-mingw-w64-x86-64_4.8.2-10ubuntu2+12_i386.deb
g++-mingw-w64_4.8.2-10ubuntu2+12_all.deb
g++-mingw-w64-i686_4.8.2-10ubuntu2+12_i386.deb
g++-mingw-w64-x86-64_4.8.2-10ubuntu2+12_i386.deb
mingw-w64_3.1.0-1_all.deb
mingw-w64-common_3.1.0-1_all.deb
mingw-w64-i686-dev_3.1.0-1_all.deb
mingw-w64-x86-64-dev_3.1.0-1_all.deb

----------------------------------------

When compiling in tahrpup 6.0.5 PAE, I used:
v3.1
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --libdir=/usr/lib32 CFLAGS="-O2 -march=i486 -mtune=i686"

v3.2
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --libdir=/usr/lib32 CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline -march=i486 -mtune=i686"


----------------------------------------------------------------------------------------------------------

Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Thu 25 Jun 2020, 01:17    Post subject: wine64-5.0.1  

My attempt at compiling wine64
This is a WOW64 build.
https://wiki.winehq.org/Building_Wine#Shared_WoW64

[wine-5.0.1 mirrors]

wine64-5.0.1_v4.1.pet _________ tahrpup64 6.0.5 [stripped=true]
wine64_DEV-5.0.1.pet __________ tahrpup64 6.0.5
wine64_DOC-5.0.1.pet __________ tahrpup64 6.0.5

----------------------------
tahrpup64 6.0.5
----------------------------

I installed the following files before compiling.
Support for these files (dependencies) are compiled into wine.
The files are not included in the wine .pet.

Puppy Package Manager > mingw-w64_3.1.0-1
binutils-mingw-w64-i686_2.23.52.20130620-1ubuntu1
binutils-mingw-w64-x86-64_2.23.52.20130620-1ubuntu1
gcc-mingw-w64_4.8.2-10ubuntu2+12
gcc-mingw-w64-base_4.8.2-10ubuntu2+12
gcc-mingw-w64-i686_4.8.2-10ubuntu2+12
gcc-mingw-w64-x86-64_4.8.2-10ubuntu2+12
mingw-w64_3.1.0-1
mingw-w64-common_3.1.0-1
mingw-w64-i686-dev_3.1.0-1
mingw-w64-x86-64-dev_3.1.0-1

----------------------------------------

When compiling in tahrpup64 6.0.5, I used:
Code:
configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-x --enable-win64 --libdir=/usr/lib64 CFLAGS="-O2"


https://wiki.winehq.org/Packaging#WoW64_Workarounds
For the 32-bit wine build, I used files from 'wine-5.0.1_v3.1.pet' from the previous forum post.
----------------------------------------------------------------------------------------------------------
The 32-bit wineserver is included, just in case it is needed.
It is a hidden file ".wineserver"

I do not have any 64-bit applications to test.
I can only do minimal testing because my AMD graphics driver is not functioning properly.
I may have to learn to compile Mesa to do any more detailed testing of 32-bit applications with this wine build.
I am relying on others to test this wine version.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 504
Location: Florida, USA

PostPosted: Thu 02 Jul 2020, 00:32    Post subject: wine-5.10  

2.x failed to compile because of a bug *
https://bugs.winehq.org/show_bug.cgi?id=49106

* bug caused crash first, assuming next bug is still there:
1.x and 2.x failed to compile because of a bug
https://bugs.winehq.org/show_bug.cgi?id=47907

3.x crashes with mention of gnutls.
not sure what version gnutls is installed by default in tahr.
tried the version I compiled.
installed gnutls with dependencies:
gnutls
gmp
libtasn
nettle
attempting compile again, and now a crash with a new error:
undefined reference to `InterlockedCompareExchange64'

wine-5.11 fixes this error and compilation is successful.
my guess is this commit fixed it:
https://source.winehq.org/git/wine.git/commit/0c14b1a962573ee125940f2008c646befe597226
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 30 of 31 [451 Posts]   Goto page: Previous 1, 2, 3, ..., 28, 29, 30, 31 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.3281s ][ Queries: 12 (0.2171s) ][ GZIP on ]