Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 19 Oct 2017, 16:30
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
LazPaint : une alternative à Paint.Net
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 5 [74 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
circular

Joined: 01 Aug 2014
Posts: 23

PostPosted: Wed 06 Aug 2014, 09:00    Post subject:  

Je suis content que mon logiciel soit utile.

J'ai trouve un petit bug dans la version 6 avec le deplacement des calques, alors je vais faire une version 6.1 rapidement pour y remedier.

Cordialement.
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Wed 06 Aug 2014, 09:34    Post subject:  

circular wrote:
J'ai trouve un petit bug dans la version 6 avec le deplacement des calques, alors je vais faire une version 6.1 rapidement pour y remedier.

Merci pour l'info.
Cordialement,

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
circular

Joined: 01 Aug 2014
Posts: 23

PostPosted: Sun 10 Aug 2014, 16:45    Post subject:  

Bonjour, voila une nouvelle version (6.2). Elle semble bien fonctionner sous Puppy Slacko et sous Linux Mint.

(en) Hello, here is a new version (6.2). It seems to work fine on Puppy Slacko and Linux Mint.

32-bit:
http://sourceforge.net/projects/lazpaint/files/bin/lazpaint6.2_i386-linux_gtk2.tar.gz/download

Je n'ai pas d'ordinateur 64 bit, alors je ne sais pas comment compiler pour 64 bit.

(en) I don't have a 64-bit computer, so I don't know how to compile for 64 bits.

Cordialement / Cheers
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Sun 10 Aug 2014, 18:23    Post subject:  

circular wrote:
Bonjour, voila une nouvelle version (6.2). Elle semble bien fonctionner sous Puppy Slacko et sous Linux Mint.

Bonjour,
La version 6.2 est également compatible avec Precise 5.7.1
J'en ai profité pour créer des paquets pet et sfs http://sourceforge.net/projects/asriedu/files/asriedu_packages/asriedu_packages_31x_base_puppyprecise5xx
Cordialement,

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
circular

Joined: 01 Aug 2014
Posts: 23

PostPosted: Sun 10 Aug 2014, 19:13    Post subject:  

Bonjour,

Voila une reaction rapide !

J'avais oublie de m'occuper de la question du redemarrage de l'application quand on change de langue. Je l'ai corrige et j'ai remplace le fichier lazpaint6.2_i386-linux_gtk2.tar.gz . La seule chose qui change dans l'archive est le fichier executable.

Excusez le desagrement de refaire les fichiers

Cordialement
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Sun 10 Aug 2014, 20:03    Post subject:  

circular wrote:
J'avais oublie de m'occuper de la question du redemarrage de l'application quand on change de langue. Je l'ai corrige et j'ai remplace le fichier lazpaint6.2_i386-linux_gtk2.tar.gz . La seule chose qui change dans l'archive est le fichier executable.

J'ai enligné les paquets mis à jour à partir de la dernière archive.
Cordialement,

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
circular

Joined: 01 Aug 2014
Posts: 23

PostPosted: Mon 11 Aug 2014, 04:26    Post subject:  

Merci.

J'ai installe le paquet SFS sur puppy slacko et cela fonctionne nickel, avec l'item dans le menu Graphic et tout.

Cordialement
lazpaint_puppy_2014-08-11_131400.png
 Description   
 Filesize   127.73 KB
 Viewed   210 Time(s)

lazpaint_puppy_2014-08-11_131400.png

Back to top
View user's profile Send private message 
jopervasco

Joined: 25 Mar 2011
Posts: 571
Location: France

PostPosted: Sat 16 Aug 2014, 06:04    Post subject:  

circular wrote:
Pour comprendre, j'aurais besoin de plus d'information sur le crash:
- combien de secondes cela arrive apres l'affichage de la fenetre principale?
- est-ce que cela arrive quand vous cliquez quelque chose, ou bien cela arrive sans rien faire?


Bonjour
ce qui m'étonne c'est que j'utilise Lazarus et Fpc et que je n'ai pas de soucis pour les applis que j'ai créées.

il faudrait que je je compile tes sources voir si ça fait pareil et si j'ai un plantage ?

Je viens d'essayer avec lazpaint6.2_i386-linux_qt.tar.gz
Quote:

./lazpaint: error while loading shared libraries: libQt4Pas.so.5: cannot open shared object file: No such file or directory

mais là il doit me manquer une lib linux et je ne suis pas très calé dans ce domaine pour installer cela

_________________
Visitez mon site http://joreveur.info
Back to top
View user's profile Send private message 
augras

Joined: 11 Nov 2013
Posts: 1446
Location: france

PostPosted: Sat 16 Aug 2014, 10:08    Post subject:  

Bonjour,
Lazpaint 6.2 fonctionne sous raring3.9.9.2.
Pour japervasco : il y a un paquet libqt4pas.deb dans les dépôts ubuntu pour raring et on peut supposer pour les autres. Par contre ce paquet n'est pas installé chez moi, je viens de vérifier, et il n'est pas réclamé !
Philippe
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Sat 16 Aug 2014, 12:17    Post subject:  

augras wrote:
Bonjour,
Lazpaint 6.2 fonctionne sous raring3.9.9.2.
Pour japervasco : il y a un paquet libqt4pas.deb dans les dépôts ubuntu pour raring et on peut supposer pour les autres. Par contre ce paquet n'est pas installé chez moi, je viens de vérifier, et il n'est pas réclamé !
Philippe

Je ne savais pas que Lazpaint avait besoin de Qt.

@ circular
Ton avis ? les bibliothèques Qt sont-elles nécessaires ?
Cordialement,

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
circular

Joined: 01 Aug 2014
Posts: 23

PostPosted: Sat 16 Aug 2014, 20:24    Post subject:  

Non LazPaint n'a pas besoin de Qt. Il y a une version Gtk et une version Qt. C'est une question de choix. Certains préfèrent utiliser des applications nativement Qt avec KDE par exemple pour des raisons d'utilisation de la mémoire. Cela dit, cela semble nécessiter une librairie supplémentaire. Elle est facile a installer avec synaptic.
Back to top
View user's profile Send private message 
circular

Joined: 01 Aug 2014
Posts: 23

PostPosted: Mon 06 Apr 2015, 21:51    Post subject:  

Bonjour,

Une nouvelle version de LazPaint 6.4.1 est a compiler, tester et mettre dans des paquets.

Fichiers binaires pour le moment:
https://sourceforge.net/projects/lazpaint/files/bin/

Quelqu'un m'a dit qu'il ferait des binaires linux64 bientot. Il n'y a pas de paquet pour le moment, si vous pouvez en faire ce sera la bienvenue.

Nouvelles fonctionalites :

- Chargement de modeles 3d avec textures
- Ajout de l'outil "pinceau" different de l'outil "crayon" : on peut choisir la forme du pinceau
- Ajout de l'outil de clonage : clic droit pour definir la source, clic gauche maintenu pour dupliquer
- Ajout d'une palette de couleur : on peut charger/sauvegarder dans divers formats, posteriser ou faire un tramage (dithering) avec la palette
- La boite a outil est ancree a l'interieur de la fenetre principale
- Quand on sauvegarde PNG/JPG/BMP : choix de la qualite
- Ajout du filtre "pluie" (menu Rendu)
lazpaint6.4_brush.png
Description  Outil "pinceau" different de "crayon"
png

 Download 
Filename  lazpaint6.4_brush.png 
Filesize  151.29 KB 
Downloaded  86 Time(s) 

Last edited by circular on Tue 07 Apr 2015, 04:58; edited 1 time in total
Back to top
View user's profile Send private message 
Médor

Joined: 26 May 2011
Posts: 2822

PostPosted: Mon 06 Apr 2015, 22:41    Post subject:  

Bonsoir circular,

La dernière version 6.4.1 fonctionne bien Very Happy

J'ai eu cependant lors du premier lancement une fenêtre indiquant que la dernière version disponible était la 6.2 ...
(je n'avais pas de fichier de config. précédent sur ma version actuelle de Toutou Slaxen 6.0).
Le message n'est plus réapparu après réouverture.


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
circular

Joined: 01 Aug 2014
Posts: 23

PostPosted: Tue 07 Apr 2015, 04:19    Post subject:  

Bonjour Medor,

Ah cool que la version fonctionne ! Cool

Le message a propos de la version est normal, puisque le numero de version "officiel" est 6.2 pour le moment, puisque c'est encore en test.

Cela dit, je pense que je vais officiellement passer a la 6.4.1, meme si la version linux64 n'est pas encore disponible, ni la version macOs.
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Tue 07 Apr 2015, 13:06    Post subject:  

circular wrote:
Ah cool que la version fonctionne ! Cool

Le message a propos de la version est normal, puisque le numero de version "officiel" est 6.2 pour le moment, puisque c'est encore en test.

Cela dit, je pense que je vais officiellement passer a la 6.4.1, meme si la version linux64 n'est pas encore disponible, ni la version macOs.

Content de savoir que cette application continue de s'améliorer tout en restant compatible avec notre mini-distro favorite.
Concernant la mise à disposition de la version 6.4.x, pas de problème. Lorsque tu seras prêt (et que tu nous préviendras), nous enlignerons un paquet compatible avec les bases Puppy Linux.

Cordialement,

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 3 of 5 [74 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1170s ][ Queries: 14 (0.0076s) ][ GZIP on ]