Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 07:26
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
chromium browser
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 27 Aug 2012
Posts: 3

PostPosted: Thu 29 Aug 2013, 08:46    Post_subject:  chromium browser
Sub_title: dialogue box - you can't use chromium as root

After downloading chromium and dependencies, was told you cant use Chromium as root. Tried to use it as spot. Was met with the same, you cant use Chromium as root. What a waste! Question
Back to top
View user's profile Send_private_message 

Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Thu 29 Aug 2013, 09:51    Post_subject:  

Easily fixed to run as root. Smile
What Puppy are you using. If Precise do this:

Change permissions:

#chmod 4755 /usr/lib/chromium-browser/chromium-browser-sandbox

Amend exec line in /usr/share/applications/chromium-browser.desktop as follows

Exec=/usr/lib/chromium=browser/chromium-browser --user-data-dir=/root/.config/chromium --disk-cache-size=2000000 --media-cache-size=2000000

If you are using a different Puppy version the relevant directories and files may be named differently. Compare your directory structure and file names with the above and amend instructions accordingly if necessary.

Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send_private_message Visit_website 

Joined: 17 Sep 2009
Posts: 232
Location: Calicut, Kerala, India

PostPosted: Thu 29 Aug 2013, 10:55    Post_subject: Chromium Browser
Sub_title: Running in Root

I will get ride of root problem by adding few words in the execution file i.e like --user-data-dir. It is working for me.
Back to top
View user's profile Send_private_message YIM MSNM 

Joined: 21 Sep 2008
Posts: 1551
Location: Worcestershire, UK

PostPosted: Thu 29 Aug 2013, 12:18    Post_subject:  

This is not a bug - it is a feature of Puppy always running as root....

Have you looked in Browsers & Internet section of the forum - there you will find a number of pre-packaged versions of Chromium with the fixes applied.


LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 

Joined: 26 Jan 2011
Posts: 509
Location: Japan

PostPosted: Tue 10 Sep 2013, 00:22    Post_subject:  

It appeared to be fixed now.

I just downloaded google-chrome-stable_current_i386.deb and used undeb to dump the files to a USB stick. I then tried to run opt/google/chrome/google-chrome but received the usual can't run as root error message.

I then installed the deb file normally (no menu entry though), found the file /usr/bin/google-chrome and ran it. Bingo! This file was present in the undebbed folders, but only as a corrupted symlink. Changed it with the "real" file from the installed folder, and now also my undebbed version works.

File contents:
exec /opt/google/chrome/google-chrome --user-data-dir=/root/.config/chrome --disk-cache-size=10000000 --media-cache-size=10000000 "$@"

P.S.: Ups.. I just noticed that the thread is about Chromium, not Google Chrome, but hopefully above applies to Chromium as well
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0605s ][ Queries: 11 (0.0157s) ][ GZIP on ]