Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 28 Jul 2014, 00:39
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Macpup 550
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 8 [110 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Author Message
backi

Joined: 27 Feb 2011
Posts: 433
Location: GERMANY

PostPosted: Sat 24 Aug 2013, 10:11    Post subject:  

Hallo RSH !

Zum Keybord problem ..benutze " Advanced Xorg keyboard configuration "

Did help !

There is a "keyzbordFixxer-1.pet .

Try this
http://macpup.org/runtt21/
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 433
Location: GERMANY

PostPosted: Sat 24 Aug 2013, 13:42    Post subject:  

Hi !

I have to differentiate the issue with my german keyboard settings .

What i have done ? Used " advanced Xorg Keyboard configurations "and installed KeyboardFixxer-1.pet .

Works ....so far .Settings are saved after restart .

But... when restarting desktop Xorgserver settings are gone .
I have to go to >Menue> Desktop > E17 Keyboard recovery (KeyzboardFixxer )
then everything is fixed again .

Just want to report .
Back to top
View user's profile Send private message 
oldyeller


Joined: 15 Nov 2011
Posts: 772
Location: Mishawaka IN

PostPosted: Sat 24 Aug 2013, 14:09    Post subject:  

Hi runtt21,

This looks and runs great. Nice themes as well Very Happy

Keep up the great job that you have been doing.


Cheers
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3956
Location: Kiel,Germany

PostPosted: Sat 24 Aug 2013, 14:26    Post subject:  

backi wrote:
Hi !
I have to differentiate the issue with my german keyboard settings .
What i have done ? Used " advanced Xorg Keyboard configurations "and installed KeyboardFixxer-1.pet .
Works ....so far .Settings are saved after restart .
But... when restarting desktop Xorgserver settings are gone .
I have to go to >Menue> Desktop > E17 Keyboard recovery (KeyzboardFixxer )
then everything is fixed again .
Just want to report .

Problem is that e17 runs the external setxkbmap command everytime it starts from xwin or the X Xorg server is restarted .
The Advanced Keyboard Configuration has added few lines of code to create a file in /root/Startup .
That file is executed everytime e17 gets started new from prompt shell .

Unfortunately e17 does not know /root/Startup , so just restarting e17 by the e17 menu panel or the need for the F1-recover-Key when e17 chokes mainly while fiddling with shelf-settings, makes e17 also run the setxkbmap command with this rather unsatisfying option line again .

That call to setxkbmap can be viewed in /tmp/xerrs.log . It is somewhat recommended to check the xerrs.log , but e17 puts in a bunch of info there, so easy to scroll over it . Me I am using US keyboard, since that stupid layout is even less stupid than the german DE layout , so was not that much affected in MP529 .
Back to top
View user's profile Send private message Visit poster's website 
backi

Joined: 27 Feb 2011
Posts: 433
Location: GERMANY

PostPosted: Sat 24 Aug 2013, 16:27    Post subject:  

Hi !

Used glxgears to check Framerates .

Macpup 5.5 (Precise ) gives me about 200 .
In Macpup 5.2.8 (Dpupexprimo also ) i got 2000 and more on my toshiba labtop .
Why Precise (Raring too ) only gives 10 time less framerates ?

How to accomplish higher framerates ( if possible ) ?
Is it possible to transfer drivers from those mentioned to Macpup 5.5 ?

How to ?
I have to admit that i dont have any videoproblems so far .
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3956
Location: Kiel,Germany

PostPosted: Sun 25 Aug 2013, 05:16    Post subject:  

# glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate
.
303 frames in 5.0 seconds = 60.459 FPS
301 frames in 5.0 seconds = 60.122 FPS

# grep fresh /var/log/Xorg.0.log
[ 13.985] (II) intel(0): Using vrefresh ranges from config file

xorg.conf :
VertRefresh 59-76

§
http://stackoverflow.com/questions/17196117/disable-vertical-sync-for-glxgears
Code:
vblank_mode=0 glxgears

ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
5055 frames in 5.0 seconds = 1010.368 FPS
5074 frames in 5.0 seconds = 1014.658 FPS
5153 frames in 5.0 seconds = 1030.583 FPS
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 1369
Location: Malvern, Worcs, UK

PostPosted: Sun 25 Aug 2013, 05:40    Post subject: Usability feedback  

Hi

Just tried MacPup550 on my HP550 laptop using a pristine manual frugal install.

Initial bootup and first impressions were all good, however I quickly stumbled across some usability issues which I thought I'd mention if I can be so bold:

- no usb device hot-plugging detection - wondering whether pup-volume-monitor could be included and integrated with the Enlightenment file manager??

- no (well very few anyway) meaningful icons displayed in Enlightenment file manager + a bit of confusion between Root and root

- some rather strange descriptors between each section of the menu items

- dragging a folder (e.g. /mnt/home) from Rox to the desktop so that it can be accessed easily produces a ? icon and associates the icon with the Enlightenment file manager

Cheers!
peebee

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 433
Location: GERMANY

PostPosted: Sun 25 Aug 2013, 06:04    Post subject:  

Hi Karl Godt !
Thanks for your answer .But your response is quite a bit enigmatic .
I am an absolute beginner .

What i did ....put " vblank_mode=0 glxgears " in terminal ... it gaves me a quite high glxgear frame rate ....

But where to place this "vblank_mode=0 glxgears " to make it persistent ?
How to ? If possible Step by step .

Thanks in advance .
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 433
Location: GERMANY

PostPosted: Sun 25 Aug 2013, 06:04    Post subject:  

Hi Karl Godt !
Thanks for your answer .But your response is quite a bit enigmatic .
I am an absolute beginner .

What i did ....put " vblank_mode=0 glxgears " in terminal ... it gaves me a quite high glxgear frame rate ....

But where to place this "vblank_mode=0 glxgears " to make it persistent ?
How to ? If possible Step by step .

Thanks in advance .
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3956
Location: Kiel,Germany

PostPosted: Sun 25 Aug 2013, 06:31    Post subject:  

Quote:
- no usb device hot-plugging detection

Switch to the Jwm windowmanager then .
Hot plug should work, put would not produce anything on the desktop .
Use pmount in the shelf for that .

e17 can be configured with its own hotplug support but that relies heavily on complete HAL and DBUS .

In my compiles it even did not show any hotplug events. Just the partitions that were known at e17 start showed on the desktop .

backi wrote:
How to ? If possible Step by step .

Not here . Have no clue about it anywayz . Must be a compile option for glxgears . Source is 11MB and i am throttled to analog speed for the rest of the month, could not even dl the official release yet due to connection interrupt after 700KB .
Back to top
View user's profile Send private message Visit poster's website 
runtt21


Joined: 07 Jun 2008
Posts: 1643
Location: BigD Texas

PostPosted: Sun 25 Aug 2013, 07:33    Post subject:  

peebee please read back through the first few post I made in this thread.I explained about EFM and desktop icons.
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 2057
Location: Ontario Canada

PostPosted: Sun 25 Aug 2013, 08:37    Post subject: Macpup 550  

Manual frugal install to a 32gb SDHC card, running on a Gateway
desktop pc.
video-info-glx 1.5.3 Sun 25 Aug 2013 on macpup 550 Linux 3.2.29 i686
0.0 VGA compatible controller:
NVIDIA Corporation GF114 [GeForce GTX 560 Ti] (rev a1)
oem: NVIDIA
product: GF110 Board - 12630002 Chip Rev
X Server: Xorg Driver: nvidia
X.Org version: 1.11.3
dimensions: 1920x1080 pixels (513x292 millimeters)
depth of root window: 24 planes
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 560 Ti/PCIe/SSE2
OpenGL version string: 4.3.0 NVIDIA 325.15
Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
Core 0: @1600 1: @1600 2: @1600 3: @1600 4: @1600 5: @1600 6: @1600
7: @1600 MHz

I had a problem with downloading the devx file, first attempt was a
32mb file so deleted that and tried again,next one seemed closer to
what I thought it should be but it wouldn't load with sfs-load
on-the-fly, I downloaded the devx for precise 5.5 and that one worked.
I found the kernel source sfs elsewhere and installed the proprietary
nvidia driver.
Firefox updated itself to the latest version.
I'm not too familiar with e17 but I am finding my way around without
much trouble, I will keep testing, lots left to try out Smile

EDIT:I had a problem with puppy package manager, it seemed to be
working okay but it would stop after downloading a large file and not
get to the next file to download.
The htop screen showed a sleep2 message flashing on and off every so
often so maybe something to do with using an SDHC card?
I moved Macpup to the hard drive and no problems with ppm now.
screenshot.jpg
 Description   
 Filesize   45.78 KB
 Viewed   610 Time(s)

screenshot.jpg


Last edited by Billtoo on Sun 25 Aug 2013, 10:51; edited 1 time in total
Back to top
View user's profile Send private message 
russoodle


Joined: 12 Sep 2008
Posts: 657
Location: Down-Under in South Oz

PostPosted: Sun 25 Aug 2013, 09:59    Post subject: Re: Download links
Subject description: do not work or too slow
 

ikaros262 wrote:
Er, guys... Embarassed
Please consider hosting your files in a faster site. Besides why FileFactory having superb sites such as Dropbox, Box, MEGA, etc etc etc.... that do not limit downloads ? Or why not asking russoodle to host them ? Sorry I am being childish Rolling Eyes Laughing

Yoo-hoo...runtt... Very Happy

Whether or not there are d/l or speed issues on your server, i'm more than happy to host MP550 as an alternative location if you like, just let me know..

cheers and congrats, matey!

'dudette'
Laughing

_________________
This aging business really bugs me - it didn't bother me years ago, so why is it happening now??
meownplanet - puppylinuxstuff
Back to top
View user's profile Send private message 
Senza Vega

Joined: 13 Aug 2013
Posts: 46

PostPosted: Sun 25 Aug 2013, 11:03    Post subject: Hooray !  

FINALLY! my favorite puppy with a French keyboard!
Thank you very much for this work!
Back to top
View user's profile Send private message 
kros54

Joined: 17 May 2009
Posts: 103
Location: member of Hungarian Puppy Linux Community

PostPosted: Sun 25 Aug 2013, 11:40    Post subject:  

It seems that the Hungarian language is a difficult ...
In fact, the same error as the macpup529 at: Hungarian language can not be changed.
All previous versions Macpup, and many puplet worked is all very well.
The localization process worked for each one. These are not.
I'm sorry... Sad
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 8 [110 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0885s ][ Queries: 12 (0.0046s) ][ GZIP on ]