Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 12:52
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
USB sticks are not detected!
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
seras

Joined: 19 Jul 2013
Posts: 2

PostPosted: Fri 19 Jul 2013, 14:27    Post_subject:  USB sticks are not detected!
Sub_title: USB sticks are not detected when they are plugged after power on!
 

Hi,

I use the precise puppy - 5.6.1. The problem is that puppy cannot detect my usb stick when I plug it after the power on of the laptop. I cannot see the USB stick neither at the desktop nor at the Pmount. However there is no problem when the stick is plugged before the boot. This problem applies to all usb sticks that I have tested. My laptop is an old Fujitsu Siemens Amilo (L7310W). Thank you in advance.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Fri 19 Jul 2013, 16:04    Post_subject:  

I once saw the same problem with an IBM desktop machine. Other than trying to update the BIOS, I don't think that there is anything you can do about this.
Back to top
View user's profile Send_private_message 
greengeek

Joined: 20 Jul 2010
Posts: 2606
Location: New Zealand

PostPosted: Fri 19 Jul 2013, 19:24    Post_subject:  

If you get desperate and find no other answers you could try the following:

Make this script and put it somewhere like /usr/bin. (The script says to put it in /root/startup but that was only for my particular problem). The script resets the internal usb hub then redetects and mounts all attached drives/partitions. I would suggest trying this when system is idle and not in the middle of transferring data. Try inserting the usb stick, waiting for 15 seconds to let the system settle, then clicking on the script:

Code:
#!/bin/sh
#########   This script unmounts all disks, reboots the usb driver then reloads it then mounts all partitions found.
#(Thanks sunburnt for the mnt-all code, rcrsn51 for the ehci_hcd idea and musher0 for the unmount code)
###      Use at your own risk... No warranty!


# For auto. mounting at bootup, put this script in Puppy folder: /root/Startup

# After bootup, if other drives are plugged in, run mnt-all again to mount them.
#PREPARATION - unmount devices already mountd during boot
sleep 2
# ~/my-applications/bin/umount-only-disks.sh
####Musher0 code to unmount only disks
df -H -T -x squashfs -x tmpfs -x rootfs -x aufs -P | grep "/mnt/s" | cut -f2 -d'm' > spc_dsq.txt
while read line
do
umount /m$line
done < spc_dsq.txt
rm -f spc_dsq.txt
sleep 5

#SECTION 1 - remove the usb driver, then reload it
rmmod ehci_hcd
sleep 2
modprobe ehci_hcd
sleep 10

#SECTION 2 -  automount all drives and partitions
# This gets a list of all partition info. except swap and optical drives.
List=`probepart |egrep -v '(swap|sr|none)'`


# This "for" loop steps through the list one partition at a time.
for Line in $List
do
   Part=${Line%%\|*}                     # Get only partition.
   Part=${Part##*/}

   [ "`df |grep $Part`" ]&& continue         # Don`t mount, if done already.

   Type=${Line%\|*}                     # Get file system type.
   Type=${Type##*\|}

   [ -d /mnt/$Part ]|| mkdir /mnt/$Part      # Make the mount dir., if none.
   mount -t $Type /dev/$Part /mnt/$Part            # Mount the partition.
   echo "# Mount Partition:  $Part    Type:  $Type"   # Display mount info.
done 
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 612

PostPosted: Sat 20 Jul 2013, 01:19    Post_subject:  

Try to delete the hidden dir /root/.pup_event (Ctr-H to show hidden files and dirs) and restart X. It's only a desperate attempt. Give feedback if it works.
Back to top
View user's profile Send_private_message 
cthisbear

Joined: 29 Jan 2006
Posts: 3442
Location: Sydney Australia

PostPosted: Sat 20 Jul 2013, 06:17    Post_subject:  

Specs:

http://www.dealtime.co.uk/Fujitsu-Siemens-Fujitsu-Siemens-AMILO-L7310W-14-1-Widescreen-Celeron-M-360-256MB-40GB-DVDRW-DL-XP-Home/info?tab=specs

3 x USB 2.0, VGA out, RJ-11 (modem), RJ-45 (NIC)

:::::::::

Check bios.

F12 boots some.

Other bios need you to nominate the hard drive
to boot from.

Usually under Advanced Options...Hard drive Boot Order.

Others want you to nominate USB or USB hard drive.

First hard drive not set as your usb.

but Boot and LBA are crical....none of that
but all of the other posted options = failure.

Try a different port.

Boot another PC to see if it works.

The Flags might not be set to

Boot and LBA

They are the usual for USB booting.

If you could boot Puppy from your USB
and run >> GParted >> manage flags...it may fix it.


sometimes after selecting boot order....
pressing F10 ( to save it) makes it work better.

""""""""

"
Re: Boot to USB Memory stick

Postby sabrex on Thu Jun 28, 2012 9:07

In the bios area under advanced you may have something
called Legacy USB support.

This should be enabled

https://forum.ts.fujitsu.com/forum/viewtopic.php?f=59&t=45551&sid=b32bcaacb423cdac8480808a4ca73cf9

Chris.
Back to top
View user's profile Send_private_message 
seras

Joined: 19 Jul 2013
Posts: 2

PostPosted: Sat 20 Jul 2013, 07:19    Post_subject:  

Thank you all of you for the support. I ran the scrip that greengeek suggested by using the terminal. The message that I received was: "ERROR: Module ehci_hcd does not exist in /proc/modules
FATAL: Module ehci_hcd does not found". I also tried to delete .pup_event and restart X but nothing happened. So the problem has not been solved!
Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Sat 20 Jul 2013, 08:23    Post_subject:  

Somewhere between kernel 2.6.39 and 3.0 Puppy kernel's began to build the main usb drivers ( [eou[x?]]hci_hcd and usb-storage ) into the kernel . Therefore they are not load- and removable anymore . Probably try an older Puppy 4 or Lupu 5 series to see if their's configuration work better with your hardware .
_________________
«Give me GUI or Death» -- I give you [[Xx]term[inal]] [[Cc]on[s][ole]] .
Macpup user since 2010 on full installations.
People who want problems with Puppy boot frugal Razz
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0640s ][ Queries: 11 (0.0077s) ][ GZIP on ]