Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 03:08
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to install Ntop and dependencies?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [26 Posts]   Goto page: 1, 2 Next
Author Message
wirwav

Joined: 14 Jul 2013
Posts: 33

PostPosted: Sun 14 Jul 2013, 10:48    Post subject:  How to install Ntop and dependencies?  

Has anyone figured out how to install Ntop using Linux Puppy.

Is there a Pet?

Where to get all the dependancies?

Thanks
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3964
Location: Kiel,Germany

PostPosted: Sun 14 Jul 2013, 13:08    Post subject:  

http://packages.debian.org/wheezy/ntop
_________________
«Give me GUI or Death» -- I give you [[Xx]term[inal]] [[Cc]on[s][ole]] .
Macpup user since 2010 on full installations.
People who want problems with Puppy boot frugal Razz
Back to top
View user's profile Send private message Visit poster's website 
wirwav

Joined: 14 Jul 2013
Posts: 33

PostPosted: Mon 15 Jul 2013, 01:56    Post subject:  

Thanks, looks useful... But, I am a Linux user for just a few days now and since my machine has only 4GB or SSD and limited to Puppy only, I am totally lost as to how to get those Debian listed dependancies onto Puppy.

Sorry, any more help with that!!
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3808
Location: World_Hub

PostPosted: Mon 15 Jul 2013, 05:18    Post subject:  

Wirwav- you didn't mention the pup you're on.. For me, along with deps- it's in the pkg mngr.
Back to top
View user's profile Send private message 
wirwav

Joined: 14 Jul 2013
Posts: 33

PostPosted: Mon 15 Jul 2013, 05:35    Post subject:  

Hi

I installed lupu_528.sfs

I dont see it at all under package manager.

What ver do you have?

I tried to use NtopXtra and run it under wine, OpenXtra commander just says that the Ntop service is Not installed.
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3428
Location: West Lothian, Scotland, UK

PostPosted: Mon 15 Jul 2013, 05:37    Post subject:  

Here in "Precise-5.6.1"...
I opened the "Puppy Package Manager" [PPM]...
Searched for ntop...
"ntop_4.1.0+dfsg1-1" = "display network usage in web browser" was found...
Clicked it and a dialog window opened that allowed me to "examine dependencies".
See screenshot below of the result of choosing to do that.
i.e. 8 dependencies [plus 2 in the 2nd tab not displayed].
I didn't bother to complete the install.
00.jpg
 Description   
 Filesize   74.13 KB
 Viewed   300 Time(s)

00.jpg

Back to top
View user's profile Send private message 
wirwav

Joined: 14 Jul 2013
Posts: 33

PostPosted: Mon 15 Jul 2013, 05:44    Post subject:  

thanks, I am downloading Precise-5.6.1.iso as we speak.
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3808
Location: World_Hub

PostPosted: Mon 15 Jul 2013, 05:48    Post subject:  

All you had to do was tick your repos'n update PPM.
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3428
Location: West Lothian, Scotland, UK

PostPosted: Mon 15 Jul 2013, 07:06    Post subject:  

Yes...
I had probably updated my Precise-5.6.1 PPM during some previous session.
Back to top
View user's profile Send private message 
wirwav

Joined: 14 Jul 2013
Posts: 33

PostPosted: Mon 15 Jul 2013, 07:53    Post subject:  

Hi.

I tried to update package manager in 5.28, it updated, but Ntop was never found.

So now I am on 5.6.1 Precise.. Sure I searched for Ntop and found it, I checked all the dependancies (default) and sat back and waited.

It does not seem to load properly and there is no icon etc.

Shame, looked like it was almost there!
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3808
Location: World_Hub

PostPosted: Mon 15 Jul 2013, 08:01    Post subject:  

Think you missed the 'tick' bit..

@ any rate, type this into a console: which ntop

Then: ldd /path/from/above/output

No (L)ldd? Do this: /lib/ld-linux.so.2 --list /path/to/ntop
tick_repos.jpg
 Description   
 Filesize   19.95 KB
 Viewed   252 Time(s)

tick_repos.jpg

Back to top
View user's profile Send private message 
wirwav

Joined: 14 Jul 2013
Posts: 33

PostPosted: Mon 15 Jul 2013, 08:39    Post subject:  

hi,

nop sorry..

I get a bash report that says No such file or directory

And again the Puppy package manager seems to be frozen 10 minutes now, just a white screen with Puppy Package manager at the top.

Did you go through to installing it?

Maybe there is something wrong with the installation packages.

Are you familiar with the program?

The NtopXtra works fine on my windows machine, but this is a little Dell FX170 with 4GB SSD and 2GB ram, I wanted to leave it running 24/7 !!

Also not sure if Ntop runs with SeaMonkey as a browser.

Maybe thats the problem?
Back to top
View user's profile Send private message 
wirwav

Joined: 14 Jul 2013
Posts: 33

PostPosted: Mon 15 Jul 2013, 08:50    Post subject:  

ok I didnt spot this "No (L)ldd? Do this: /lib/ld-linux.so.2 --list /path/to/ntop"

Finally the blank window closed.

I have done the above and I get,

--list/path/to/ntop: error while loading shared libraries: --list/path/to/ntop:
cannot open shared object file: No such file or directory
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3808
Location: World_Hub

PostPosted: Mon 15 Jul 2013, 09:10    Post subject:  

Case and spacing- both critical. While not perfect- +intristin..

For you, try again: /lib/ld-linux.so.2 --list /usr/sbin/ntop
ntop_528-004.jpg
 Description   
 Filesize   42.92 KB
 Viewed   254 Time(s)

ntop_528-004.jpg

ntop_config-1.jpg
 Description   
 Filesize   177.73 KB
 Viewed   228 Time(s)

ntop_config-1.jpg


Last edited by Semme on Mon 15 Jul 2013, 09:35; edited 3 times in total
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3428
Location: West Lothian, Scotland, UK

PostPosted: Mon 15 Jul 2013, 09:13    Post subject:  

wirwav wrote:
It does not seem to load properly and there is no icon etc.

I just now tried to complete the installation of ntop, but PPM froze, with no sign of ntop having been successfully installed.

Also got this:
Code:
# /lib/ld-linux.so.2 --list /usr/sbin/ntop
/usr/sbin/ntop: error while loading shared libraries: /usr/sbin/ntop: cannot open shared object file: No such file or directory
#


I'll reboot without saving the session changes, and make a 2nd attempt after the reboot.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [26 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0673s ][ Queries: 12 (0.0044s) ][ GZIP on ]