Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Oct 2018, 13:58
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Upup Raring with kernel 3.9.8 non-PAE
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 4 [59 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message

Joined: 22 May 2010
Posts: 79

PostPosted: Tue 09 Jul 2013, 20:23    Post subject:  


I tried installing Raring 3981 on a headless system, using an iso on a rewrite CD. The install succeeded with X auto-installing to the max resolution. Resizing using the startup window offered option does not work (it never has), so I ticked the restart X option. The auto-install X system does permit reset to other resolutions, but instead of restarting only X, the system wants to fully restart, shutting down and making a save-file. This can't be done with no head (HDD), which means shutdown no-save and restart bringing the auto-install of X at max resolution. Is this a newest-woof feature, or newest-woof bug?

I tried to work around by saving to disk, since my media was a rewrite CD and not closed. I assumed I could make a machine-specific remaster and so dodge around the problem. But the save-to-disk blanked my media... I'll have to re-install the iso on my Cd befoe I can try installing "nox" and installing X by qizard at the desired resolution. I assume that will work, but I wonder if it is possible to revert to, or option in, the old non-auto X, so one CD can be used to install to different headless machine?
Back to top
View user's profile Send private message 

Joined: 08 Jul 2009
Posts: 5484
Location: Finland

PostPosted: Wed 10 Jul 2013, 02:13    Post subject:  

CLAM01. I am afraid the changed xorgwizard through woof creates your problem. The fix should go through Barry Kauler and the improvement implemented to the woof. I believe there would be solution.

Meanwhile, you could try: ppower tray app, right click it > Hardware control > Screen > Change resolution and select from the availabe list.
Does that work.
Back to top
View user's profile Send private message 

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Wed 10 Jul 2013, 03:36    Post subject:  

Hi @CLAM01

I saw you comments on your system's issue.

On a different note, though, am I reading you correctly; are you booted and running on a Live CD system (meaning booting and running in RAM from CD)?

If so, at reboot/shutdown time, your system should be giving the option to save to the very same CD/DVD you booted from.

But, for this to work, you MUST have created your CD/DVD in multisession mode from the ISO. Both PBurn and Burn2CD will, each, provide the option to create the disc in multisession mode so that it will allow Puppy, when needed, to write your saved session. Thereby, ALL system changes during its running will be saved on the Live media disc on any subsequent reboot. Your HDD/USB is never needed in this case for anything to do with system operations.

Hope this helps

Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 

Joined: 11 Feb 2013
Posts: 572

PostPosted: Wed 10 Jul 2013, 14:16    Post subject:  

Last edited by simargl on Sun 01 Sep 2013, 11:19; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 

Joined: 13 Aug 2011
Posts: 21

PostPosted: Wed 10 Jul 2013, 14:51    Post subject: Upup Raring with kernel 3.9.8 non-PAE  

hi all
just to let you know Raring is working fine for me . Frugel install on sdb1 second reboot got firefox from upup repo works fine good work as always. Hope you enjoy you summer.

thank you
Back to top
View user's profile Send private message 

Joined: 22 May 2010
Posts: 79

PostPosted: Wed 10 Jul 2013, 19:49    Post subject:  

pemasu, Thanks, I'll try the ppower workaround and post how it works. I have to return to a computer on which I can re-CD the iso to try again. If I can't find an anybody-can-do workaround I will query Barry re the over-automated auto-X (when X-at-install was upgraded to default to 24-planes, so it black-screened 16-plane machines [most business-laptops are 16, for battery-life being more important than aesthetic beauty in the business world] there was still vesa to get started and the 16-plane option in xorgwizard; perhaps vesa-and-then-upgrade can be returned as an option).

gcmartin, My headless units are total-security kiosk-type setup: new install from read-only CD each startup, install to and run in ram, scan to new net-setup each time, everything goes at shutdown, next start as clean (or dirty) as th CD image.
Downloads are restricted to ram personal storage limit (unless a stick or card is added and link-targeted), and if not so, or transferred to a stick or card at end of session, are vaporized with shutdown.
I multi-session (I called it leaving open in my post) the CDs and fill the extra with SFSs of extras (libreoffice, etc) for on-the-fly access (they also work for normal puppy installations). When I am checking out latest puppies I copy the iso to a rewrite cd, also multisession. If I like the puppy I make CDR disks for normal use. Since the machine I was experimenting with has a writing CD player, I thought to try saving to CD to get a restart at the desired resolution. I thought to then remaster for the specific machine (it having enough ram), then write the new master iso back to the rewritable CD. Then I could restart the machine at the desired resolution.
But the save-to-CD process, rather than going to the next track, wrote over the iso.
These things happen in experimenting, and it was my first attempt to use the save-to-CD option, so I may have done something wrong.
Back to top
View user's profile Send private message 

Joined: 30 Jun 2008
Posts: 1210
Location: Saint-Gérard / Walloon part of Belgium

PostPosted: Fri 12 Jul 2013, 09:00    Post subject:  

Dear Pemasu,
hope Finland +yourself... are enjoying somewhat better weather conditions. Here i got sunburned (nek + nose... Embarassed ) at doing outdoor jobs.

I made a comparison between raring and wheezy-3.5.2.x relevant to mesa stuffs:
- In upup raring /usr/lib/dri/swrast_dri.so is ca. 385K sized; whereas it is 14M in wheezy-3.5.2.x;
- In wheezy-3.5.2.x, /usr/lib/dri/ is only populated with swrast_dri.so; not any i915_dri.so r others;
- In Wheezy-3.5.2.x i noticed these comments coming upon launching gCAD3D im a terminal:
GL_RENDERER: Gallium 0.4 on llvmpipe (LLVM 0x209)
GL_VERSION: 2.1 Mesa 8.0.5
GLU_EXTENSIONS: GLU_EXT_nurbs_tessellator GLU_EXT_object_space_tess
AP_Get_Setup /root/gCAD3D/cfg/gCAD3D.rc |TEXTURE_ON|

...GL_renderer is reported as Gallium

As gCAD3D runs nice on wheezy using swrast_dri.so, i wonder how to reproduce the same working conditions on raring- ? I believe it could run OK with a similar dri modules configuration.

I got mesa-9.1.2 compiled on raring- using the same options as these (got i915_dir.so, i965...r300 r600 ...swrast_dri.so).
but with a resulting very slow frame-per-secong rate using swrast_dri.so.
(swrast_dri.so about 20M sized).

In whezy, I did not found any gallium file nor folder ...?

So do you use different configure options ..or what else?

Thanks for any answer
Back to top
View user's profile Send private message 

Joined: 08 Jul 2009
Posts: 5484
Location: Finland

PostPosted: Fri 12 Jul 2013, 09:53    Post subject:  

Since introducing ( I believe ) llvm support for radeon drivers, gallium has been compiled as shared library. Previously, as in in wheezy mesa, it has been compiled statically in dri drivers, which makes those dri drivers bigger. Of course you can compile mesa as you which, ie compile gallium statically or as shared lib. That makes the big difference in dri driver size. As you have noticed. Ubuntu Raring and even Precise has libllvm for radeon drivers. The change how to include gallium lib for dri happened at that time, I think. The reason why libgallium shared versus static is important is unknown for me.

With mesa 9.1.4 there isnt anymore choice for disabling libllvm. So there is no future sense to try to compile mesa without libllvm support. Mesa 9.1.4 is now already in proposed state. You can download Raring mesa 9.1.4 already and try it. I have even made one big pet of mesa 9.1.4 and tested it. Worked fine.
Back to top
View user's profile Send private message 

Joined: 08 Jul 2009
Posts: 5484
Location: Finland

PostPosted: Fri 12 Jul 2013, 11:14    Post subject:  

With 3.9.8 kernel I noticed that sometimes huawei 3g modem connection interrupts.

I have followed what dmesg says:
hub 2-1:1.0: unable to enumerate USB device on port 2
Might be problem with hardware or it can be harmless.

3.9.9 kernel has fix for:
USB: fix port probing
and a lot other usb fixes. It seems 3.9.9 is mainly usb fix update.

Also I wasnt satisfied of the responsiveness of this kernel. I think that I know what influenced into it and that is another reason to recompile kernel. It means recompile of the proprietary drivers but...then I am going to let 3.9.X series to be. 3.10.X is another story.....

I have other fixes. Libiculess build, some other unneeded stuff removed, makes iso about 6 Mb smaller.

Mesa-9.1.4 will be soon ready to be included in database ( it is already ready for download as splitted .debs in launchpad ) and I will see if I get that one to the build also. Better support for f2fs usb full install is under the work and that woof upgrade i will sure use.
Back to top
View user's profile Send private message 

Joined: 10 May 2012
Posts: 1020

PostPosted: Fri 12 Jul 2013, 18:05    Post subject:  

Hi pemasu,
please, consider removing Wayland libs:


I maybe wrong, but without them, switching between keyboard layouts seems to work more reliably. Observed this both in BK's and this Raring. And you'll also free up about 258K?, don't remember exactly.
Back to top
View user's profile Send private message 

Joined: 08 Jul 2009
Posts: 5484
Location: Finland

PostPosted: Fri 12 Jul 2013, 18:10    Post subject:  

Anikin. Cant remove them.
# abiword
abiword: error while loading shared libraries: libwayland-client.so.0: cannot open shared object file: No such file or directory

Libwayland is dependency for gtk-3.
Back to top
View user's profile Send private message 

Joined: 30 Jun 2008
Posts: 1210
Location: Saint-Gérard / Walloon part of Belgium

PostPosted: Sat 13 Jul 2013, 11:38    Post subject: mesa-9.1.4 compile trial  

Hi Pemasu,
i do not know which debian packages are to install to get mesa-9.1.4 and to get gCAD3D running OK with TEXTURE displayed together with an acceptable rendering speed. I got a try resulting in a very very slooow running gCAD3D.

Then i managed to try compiling Mesa-9.1.4 ... Confused ;

i got a first set of swrast_dri.so + i915_dri.so, without error message; just a warning telling llwm was missing;
Here are the used configure options;
+ launching ./autogen.sh (to get m4 stuffs + launch of /usr/bin/autoconf)

sh-4.1# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-dri --enable-glx --with-gallium-drivers="i915,swrast" --with-dri-drivers="i915,swrast"

gcad3d runs with TEXTURE display , BUT very slowly.

Doing a new Mesa-9.1.4 compile showed some deps were missing in the first trial - i.e. llvm3.4-dev was missing.
I also had to symlink all files in /usr/lib/llvm-3.4/bin/ to /usr/bin.

here is the list of installed deps:

dri2proto-2.8-i486.pet: 9453 bytes
gCAD3D-2.00.pet: 1818 K
libdrm2_2.4.45-3_i386.deb: 459 K
libdrm-dev_2.4.45-3_i386.deb: 636 K
libdrm-intel1_2.4.45-3_i386.deb: 496 K
libdrm-nouveau2_2.4.45-3_i386.deb: 449 K
libffi6_3.0.13-4_i386.deb: 18 K
libffi-dev_3.0.13-4_i386.deb: 106 K
libgl1-mesa-dev_9.1.4-1_i386.deb: 34 K
libgl1-mesa-dri_9.1.4-1_i386.deb: 5756 K
libgl1-mesa-glx_9.1.4-1_i386.deb: 130 K
libgl1-mesa-swx11_9.1.4-1_i386.deb: 1030 K
libglapi-mesa_9.1.4-1_i386.deb: 49 K
libglu1-mesa_9.0.0-1_i386.deb: 217 K
libllvm3.4_3.4~svn183914-1_i386.deb: 8837 K
libturbojpeg1_1.3.0-2_i386.deb: 170 K
libx11-xcb1_1.6.0-1_i386.deb: 150 K
libx11-xcb-dev_1.6.0-1_i386.deb: 152 K
libxcb1-dev_1.9.1-3_i386.deb: 102 K
libxcb-dri2-0_1.9.1-3_i386.deb: 13 K
libxcb-dri2-0-dev_1.9.1-3_i386.deb: 16 K
libxcb-glx0_1.9.1-3_i386.deb: 33 K
libxcb-render0_1.9.1-3_i386.deb: 20 K
libxcb-render0-dev_1.9.1-3_i386.deb: 26 K
libxcb-xfixes0_1.9.1-3_i386.deb: 15 K
libxcb-xfixes0-dev_1.9.1-3_i386.deb: 19 K
libxdmcp6_1.1.1-1_i386.deb: 27 K
libxdmcp-dev_1.1.1-1_i386.deb: 42 K
libxfixes3_5.0.1-1_i386.deb: 22 K
libxfixes-dev_5.0.1-1_i386.deb: 25 K
libxxf86vm1_1.1.2-1+deb7u1_i386.deb: 20 K
llvm-3.4_3.4~svn183914-1_i386.deb: 1555 K
llvm-3.4-dev_3.4~svn183914-1_i386.deb: 16 M
llvm-3.4-runtime_3.4~svn183914-1_i386.deb: 39 K
mesa-common-dev_9.1.4-1_i386.deb: 292 K
multiarch-support_2.17-7_i386.deb: 157 K
x11proto-core-dev_7.0.24-1_all.deb: 761 K
x11proto-dri2-dev_2.8-2_all.deb: 18 K
x11proto-fixes-dev_5.0-2_all.deb: 19 K
x11proto-gl-dev_1.4.16-2_all.deb: 32 K

Total: 39 M (40 files)

I then got the following error message in the "make" step :

CXX gallivm/lp_bld_debug.lo
gallivm/lp_bld_debug.cpp: In member function 'virtual void raw_debug_ostream::write_impl(const char*, size_t)':
gallivm/lp_bld_debug.cpp:110:40: warning: cast from type 'const char*' to type 'char*' casts away qualifiers [-Wcast-qual]
gallivm/lp_bld_debug.cpp: In function 'void lp_disassemble(const void*)':
gallivm/lp_bld_debug.cpp:210:64: error: no matching function for call to 'llvm::Target::createMCAsmInfo(std::string&) const'
gallivm/lp_bld_debug.cpp:210:64: note: candidate is:
/usr/lib/llvm-3.4/include/llvm/Support/TargetRegistry.h:298:16: note: llvm::MCAsmInfo* llvm::Target::createMCAsmInfo(const llvm::MCRegisterInfo&, llvm::StringRef) const
/usr/lib/llvm-3.4/include/llvm/Support/TargetRegistry.h:298:16: note: candidate expects 2 arguments, 1 provided

Also, at this point, i believe it is above my knowledges ... sniff! Crying or Very sad

I would be interested which results you get with the mesa pet you mentionned in an above post ... Rolling Eyes ?

Thanks for any answer !
Back to top
View user's profile Send private message 

Joined: 08 Jul 2009
Posts: 5484
Location: Finland

PostPosted: Sat 13 Jul 2013, 14:35    Post subject:  

Charlie6. Here is link to the Ubuntu Raring proposed mesa-9.1.4. I created pet from it. It is debian full mesa package. There is more stuff than Puppies include, but I didnt start to strip it down. I wait for official update.

Back to top
View user's profile Send private message 

Joined: 22 May 2010
Posts: 79

PostPosted: Fri 19 Jul 2013, 18:28    Post subject:  

Pemasu, Getting back to you in regard to resetting screen resolutions in X in 3981 and 399. I’ve done some experimenting, these are the results: Using the power-applet to change resolution solution you suggested does change the screen resolution. It does not resize the screen to fit the new resolution to the frame. Going to a larger-image resolution (to 1200x768 from 1600x1200) leaves the right and bottom of the desktop image 'off-camera' and the usual mechanisms to pan to the off-screen areas do not work. The on-screen advice is to restart (after a save), when X will fit the new resolution to the screen-space. This cannot be done using read-only media and no HDD.

But the problem occurred installing using defaults, letting X probe and select, both at install and at resize. The machine has ATI graphics and X was selecting ATI, which is “no KMS” and requires the machine to restart. User-selecting “Radeon, (requires KMS)” for the restart brought X restart only and solved the problem.

I tried 3981 and 399 headless install on an Intel machine, too, whose graphics start vesa on only half the screen, requiring an X reset which brings the correct resolution for the screen. On this machine the Intel driver messages the same “no KMS" and "requires restart", but only X restarts, and works normally.

So the problem is the ATI graphics option, with the cure being to use the Radeon driver.

Frisbee, however, could not find my wireless. Frisbee wanted to auto-connect to a strongest signal in the test area, which is not the correct one. I may wrestle with this someday. Meanwhile, I will use 387 and previous, which work in these set-ups out of the box, with the old network wizard allowing step-by-step directing of wireless set-up, allowing choice of cards and networks nodes.
Automation is great when you don't need versatility.

gcmartin, My save-to-CD failure I found to have been due to incompatibilities. I use old 4x RWCDs for my OS install experiments. Modern Super-Drives can write 4x for DVDs still writing that slow. CD writing that slow, with modern processors,uses so little resources it can be backgrounded, so it is convenient. Most high-speed CD-only writers, and CD-writer-DVD-reader units, cannot run slow enough spindle speeds to write 4x. My session-write attempt failed for the writer in the machine being one of the unable to slow enough. With a faster writable CD the modify and save-modified-X work around would probably have worked.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 4 [59 Posts]   Goto page: Previous 1, 2, 3, 4
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1362s ][ Queries: 14 (0.0289s) ][ GZIP on ]