Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 04:13
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Where's the latest stable version of Inkscape for PL528?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Author Message
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Mon 24 Jun 2013, 14:23    Post subject:  Where's the latest stable version of Inkscape for PL528?
Subject description: What I've is the Lite version that comes bundled with my OS...
 

...but I would like to have a few days to try different things with it, including reading/following some tutorials that I've stumbled upon in the last days.

So, there's (apparently) a complete version in the repositories that one encounters when using Quickpet, but is it the latest one?

If someone knows where it is & shares that info it would be great because I don't like d/l things from not-habitual places. Thanks!

_________________
Sony VAIO VGN AR250G Notebook + 512MB RAM.
Need color of cables of 2 connectors at top & down side of Dell monitor 1704FPTt (look through vents at right side at the back)

Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3937
Location: World_Hub

PostPosted: Mon 24 Jun 2013, 16:03    Post subject:  

Hi Benny.. 0.48.1 for Lucid here, 0.48.2 here, and 0.48.4 <the latest & greatest> here.

You may be short a few deps to make the full version run, so >> open from a shell.

Keep in mind Lucid's based on Wink 10.04.4 LTS. Dwnld accordingly..
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Mon 24 Jun 2013, 17:31    Post subject:  

Thanks, Semme, for replying!

I went to one of the links supplied by you & d/l the 0.48.4 version. After extracting the first relevant file & reading it (INSTALL) decided to extract all because didn't understand it.

Now I've a doubt before proceeding to try to install & use it: what do I have to do with the other "Inkscape Lite" software that I have already installed?

I d/l & extracted to sda5, a partition different from the one PL528 is installed at.

Thanks in advance!

Edit: After issuing './configure' an important number of issues surfaced. In relation to this I'm including the ./config command's output below:

"sh-4.1# ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... no
checking how to create a pax tar archive... gnutar
checking for style of include used by make... none
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether the C++ compiler works... no
configure: error: in `/mnt/sda5/inkscape-0.48.4':
configure: error: C++ compiler cannot create executables
See `config.log' for more details
sh-4.1#


In this edition of this post I've removed the config.log & substituted it by the above, as suggested by Semme.

_________________
Sony VAIO VGN AR250G Notebook + 512MB RAM.
Need color of cables of 2 connectors at top & down side of Dell monitor 1704FPTt (look through vents at right side at the back)


Last edited by benny7440 on Wed 26 Jun 2013, 11:33; edited 1 time in total
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3937
Location: World_Hub

PostPosted: Mon 24 Jun 2013, 20:36    Post subject:  

There's NOTHING to configure. They're all links to binaries! Unless you're amd64- THIS is YOUR pkg!

As for the 'light' version you questioned about.. I'm not sure. Perhaps toy around during a live boot?
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Wed 26 Jun 2013, 11:47    Post subject:  

Thanks Semme for replying!

In your last post you suggest that I d/l a different software? I've d/l <inkscape_0.48.4.orig.tar.gz> from http://security.ubuntu.com/ubuntu/pool/main/i/inkscape/inkscape_0.48.4.orig.tar.gz.

I'll proceed to d/l the one you last suggested but will wait until your next reply....

_________________
Sony VAIO VGN AR250G Notebook + 512MB RAM.
Need color of cables of 2 connectors at top & down side of Dell monitor 1704FPTt (look through vents at right side at the back)

Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3937
Location: World_Hub

PostPosted: Wed 26 Jun 2013, 15:48    Post subject:  

Toss inkscape_0.48.4.orig.tar.gz and anything else you may have unpacked.

Install the dwnld I left and fire 'inkscape' from a shell to see what's missing.

Feel free to paste the terminal output here with your next reply..

PS- Incase you were unaware, 528 installs *deb's* by default.
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Wed 26 Jun 2013, 21:16    Post subject:  

I'm sorry Semme to admit that even thou the installation process went without a glitch I've found 2 extra icons for inkscape at the Menu > Graphic tab, nothing at the Utility tab as reported by my system after installation process.

I tried to have it run from the shell but have not a clue as to its location. I used Searchmonkey file finder & it found 281 matches; I introduced in Advance search a condition by date & received ~25 matches then. Nonetheless, this exercise didn't give me the location of the executable file, so I tried the icons that appear under the menu: nothing happenned...

I didn't delete the files obtained by extracting from the first package but they're isolated within a unique folder & not installed.

How to proceed from here?

Thanks in advance!

Edit: I found the appropriate file at /usr/bin but when trying to run it from the shell:

"sh-4.1# inkscape
inkscape: error while loading shared libraries: libgsl.so.0: cannot open shared object file: No such file or directory
sh-4.1#
"

After this I think I'm missing something. I once had the devx for gcc but can't find it anywhere in my disk. Do you know from where I can d/l it?

Thanks again!
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3937
Location: World_Hub

PostPosted: Thu 27 Jun 2013, 06:29    Post subject:  

Dump the output here:
Code:
/lib/ld-linux.so.2 --list /usr/bin/inkscape
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Thu 27 Jun 2013, 10:44    Post subject:  

Thanks, Semme, for replying!

The output for the command is shown below (same as I already posted):

"sh-4.1# /lib/ld-linux.so.2 --list /usr/bin/inkscape
/usr/bin/inkscape: error while loading shared libraries: libgsl.so.0: cannot open shared object file: No such file or directory
sh-4.1#
"

PS. When I talked before about devx (around gcc) I was thinking on something else; the missing lib here seems to be libgsl.so.0.
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3937
Location: World_Hub

PostPosted: Thu 27 Jun 2013, 13:06    Post subject:  

Copy, paste and execute the line below. If it says no (L)ldd, install this one click pkg and rerun.
Code:
ldd /usr/bin/inkscape

We're doing things the way we are so I can get a handle on *all* the deps you're missing.

Having libgsl0ldbl_1.13+dfsg-1 installed merely scratches the surface..
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Fri 28 Jun 2013, 08:36    Post subject:  

Thanks Semme!

The code produced a lot of output. After reading it line by line I noticed that there were some interesting entries (don't know if they're relevant or not) that I'm including below:

"libgsl.so.0 => not found libgslcblas.so.0 => not found
ldd /usr/bin/inkscape libMagick++.so.2 => not found
libMagickCore.so.2 => not found
"

I'm not proceeding to install the pkg you suggested because I understand that it's for the case that the code you provided didn't run... waiting for more instructions!
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3937
Location: World_Hub

PostPosted: Fri 28 Jun 2013, 16:46    Post subject:  

Guessing I've got more libs than you, install these >> libaspell, libgsl0ldbl and libmagick++2.

Rerun 'ldd /usr/bin/inkscape' as you may need this above and beyond what was missing.

So long as there aren't any not founds, do a menu launch & TELL ME WHAT I WANNA HEAR!
inkscape_0.48.4.jpg
 Description   
 Filesize   85.17 KB
 Viewed   269 Time(s)

inkscape_0.48.4.jpg

Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Sun 30 Jun 2013, 12:27    Post subject:  

Thanks Semme for the links! I d/l the 3 lib files, installed them (without receiving any contradictory messages from the system) & tried 2 of the icons inserted in my Meny>Graphics entry but nothing seemed to happenned...

The result from running the command you provided resulted in just the following interesting entries:

"sh-4.1# ldd /usr/bin/inkscape
...libMagickWand.so.2 => not found
libMagickCore.so.2 => not found...
sh-4.1#
"

The ellipsis above mean that there were more data as the commands' output both at before them and after. If you want the whole thing I can rerun it later and paste it in another post. Right now I think is wise to shutdown due to an approaching thunderstorm.

Thanks; I'm sorry for the rush!
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3937
Location: World_Hub

PostPosted: Sun 30 Jun 2013, 15:32    Post subject:  

This >> libMagickCore.so.2 is from my *fourth* link. In addition, grab and install this.

If she still doesn't fire, run these- one @ a time:
Code:
ldd /usr/bin/inkscape > inkscape_libs.txt
gzip inkscape_libs.txt

.. then *attach* the newly created inkscape_libs.txt.gz file that's now in your /root folder.
Back to top
View user's profile Send private message 
benny7440


Joined: 20 Apr 2009
Posts: 416

PostPosted: Sun 30 Jun 2013, 20:40    Post subject:  

Thanks, Semme, for replying with yje needed libs!

I installed the libs (I missed that one:
Quote:
"you may need this above and..."
from 28 June). When I clicked on the first icon within Menu>Graphics it took so long to do something, & a short message stating that a file was missing, that I had enough time for going there again & clicking the second icon. Sorry to tell you that the little window didn't stated the name of the file.

Nevertheless, after closing both little message windows two instances of the new inkscape opened. I closed one of them & played with the other for about 1 hr. Looks great & powerful.

Still, (interruption for running from shell - just for checking) I'm concerned of what this message really means (or might mean). After ./inkscape plus ENTER it might have put around a thousand times the following:

"(inkscape:22894): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed"

but the application ran...

Any ideas? Thanks in advance, Semme!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0879s ][ Queries: 12 (0.0068s) ][ GZIP on ]